source: projects/specs/trunk/a/audit/audit-vl.spec @ 12121

Revision 12121, 24.6 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3%{!?__python3: %global __python3 /usr/bin/python3}
4%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print (get_python_lib())")}
5%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
6
7%define sca_version 0.4.10
8%define sca_release 4
9
10Summary: User space tools for 2.6 kernel auditing
11Name: audit
12Version: 2.8.5
13Release: 1%{?_dist_release}
14License: GPLv2+
15Group: System Environment/Daemons
16URL: http://people.redhat.com/sgrubb/audit/
17Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
18Patch1: audit-2.8.6-memleak.patch
19
20Distribution: Vine Linux
21Vendor: Project Vine
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24BuildRequires: gettext intltool libtool swig
25BuildRequires: python-devel python3-devel
26BuildRequires: openldap-devel
27BuildRequires: tcp_wrappers
28BuildRequires: krb5-devel
29BuildRequires: kernel-headers >= 2.6.18
30BuildRequires: libcap-ng-devel
31BuildRequires: automake >= 1.9
32BuildRequires: autoconf >= 2.59
33Requires: %{name}-libs = %{version}-%{release}
34Requires: chkconfig
35Requires(pre): coreutils
36
37%description
38The audit package contains the user space utilities for
39storing and searching the audit records generate by
40the audit subsystem in the Linux 2.6 kernel.
41
42%package libs
43Summary: Dynamic library for libaudit
44License: LGPLv2+
45Group: Development/Libraries
46
47%description libs
48The audit-libs package contains the dynamic libraries needed for
49applications to use the audit framework.
50
51%package libs-devel
52Summary: Header files and static library for libaudit
53License: LGPLv2+
54Group: Development/Libraries
55Requires: %{name}-libs = %{version}-%{release}
56Requires: kernel-headers >= 2.6.18
57
58%description libs-devel
59The audit-libs-devel package contains the static libraries and header
60files needed for developing applications that need to use the audit
61framework libraries.
62
63%package libs-python
64Summary: Python2 bindings for libaudit
65License: LGPLv2+
66Group: Development/Libraries
67Requires: %{name}-libs = %{version}-%{release}
68
69%description libs-python
70The audit-libs-python package contains the bindings so that libaudit
71and libauparse can be used by python2.
72
73%package libs-python3
74Summary: Python3 bindings for libaudit
75License: LGPLv2+
76Group: Development/Libraries
77Provides: python-audit = %{version}-%{release}
78Requires: %{name}-libs = %{version}-%{release}
79
80%description libs-python3
81The audit-libs-python3 package contains the bindings so that libaudit
82and libauparse can be used by python3.
83
84%package -n audispd-plugins
85Summary: Plugins for the audit event dispatcher
86License: GPLv2+
87Group: System Environment/Daemons
88Provides: python3-audit = %{version}-%{release}
89Requires: %{name} = %{version}-%{release}
90Requires: %{name}-libs = %{version}-%{release}
91Requires: openldap
92
93%description -n audispd-plugins
94The audispd-plugins package provides plugins for the real-time
95interface to the audit system, audispd. These plugins can do things
96like relay events to remote machines or analyze events for suspicious
97behavior.
98
99%package -n compat32-%{name}-libs
100Summary: Dynamic library for libaudit
101License: LGPLv2+
102Group: Development/Libraries
103
104%description -n compat32-%{name}-libs
105The audit-libs package contains the dynamic libraries needed for
106applications to use the audit framework.
107
108%prep
109%setup -q
110%patch1 -p1
111
112%build
113%configure --sbindir=/sbin --libdir=/%{_lib} \
114    --with-python=yes --with-python3=yes \
115    --with-libcap-ng=yes --with-libwrap --enable-gssapi-krb5=yes
116make CFLAGS="%{optflags}" %{?_smp_mflags}
117
118%install
119rm -rf $RPM_BUILD_ROOT
120mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d,audit/rules.d}}
121mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
122mkdir -p $RPM_BUILD_ROOT/%{_lib}
123mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
124mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
125make DESTDIR=$RPM_BUILD_ROOT install
126
127mkdir -p $RPM_BUILD_ROOT/%{_libdir}
128# This winds up in the wrong place when libtool is involved
129mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
130mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
131curdir=`pwd`
132cd $RPM_BUILD_ROOT/%{_libdir}
133LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
134ln -s ../../%{_lib}/$LIBNAME libaudit.so
135LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
136ln -s ../../%{_lib}/$LIBNAME libauparse.so
137cd $curdir
138# Remove these items so they don't get picked up.
139rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
140rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
141
142find $RPM_BUILD_ROOT -name '*.la' -delete
143find $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages -name '*.a' -delete
144
145# Move the pkgconfig file
146mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
147
148# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
149touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
150touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
151
152#% check
153#make check
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157rm -rf zos-remote-policy
158
159%post libs -p /sbin/ldconfig
160
161%post
162/sbin/chkconfig --add auditd
163# This is to migrate users from audit-1.0.x installations
164if [ -f /etc/auditd.conf ]; then
165   mv /etc/auditd.conf /etc/audit/auditd.conf
166fi
167if [ -f /etc/audit.rules ]; then
168   mv /etc/audit.rules /etc/audit/audit.rules
169fi
170# This is to enable the dispatcher option which was commented out
171if [ -f /etc/audit/auditd.conf ]; then
172   grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
173   if [ $? -eq 1 ] ; then
174      tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
175      if [ -n $tmp ]; then
176         sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
177         cat $tmp > /etc/audit/auditd.conf
178         rm -f $tmp
179      fi
180   fi
181fi
182
183%post -n compat32-%{name}-libs -p /sbin/ldconfig
184
185%preun
186if [ $1 -eq 0 ]; then
187   /sbin/service auditd stop > /dev/null 2>&1
188   /sbin/chkconfig --del auditd
189fi
190
191%postun libs -p /sbin/ldconfig
192
193%postun
194if [ $1 -ge 1 ]; then
195   /sbin/service auditd condrestart > /dev/null 2>&1 || :
196fi
197
198%postun -n compat32-%{name}-libs -p /sbin/ldconfig
199
200%files libs
201%defattr(-,root,root)
202%{!?_licensedir:%global license %%doc}
203%license COPYING.LIB
204/%{_lib}/libaudit.*
205/%{_lib}/libauparse.*
206%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
207%{_mandir}/man5/libaudit.conf.5.gz
208
209%files libs-devel
210%defattr(-,root,root)
211%{!?_licensedir:%global license %%doc}
212%license COPYING.LIB
213%doc contrib/skeleton.c contrib/plugin
214%{_libdir}/libaudit.a
215%{_libdir}/libauparse.a
216%{_libdir}/libaudit.so
217%{_libdir}/libauparse.so
218%{_includedir}/libaudit.h
219%{_includedir}/auparse.h
220%{_includedir}/auparse-defs.h
221%{_datadir}/aclocal/audit.m4
222%{_libdir}/pkgconfig/audit.pc
223%{_libdir}/pkgconfig/auparse.pc
224%{_mandir}/man3/*
225
226%files libs-python
227%defattr(-,root,root)
228%attr(755,root,root) %{python_sitearch}/_audit.so
229%attr(755,root,root) %{python_sitearch}/auparse.so
230%{python_sitearch}/audit.py*
231
232%files libs-python3
233%defattr(-,root,root,-)
234%attr(755,root,root) %{python3_sitearch}/*
235
236%files
237%defattr(-,root,root,-)
238%doc README ChangeLog rules init.d/auditd.cron
239%{!?_licensedir:%global license %%doc}
240%license COPYING
241%attr(644,root,root) %{_mandir}/man8/audispd.8.gz
242%attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
243%attr(644,root,root) %{_mandir}/man8/auditd.8.gz
244%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
245%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
246%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
247%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
248%attr(644,root,root) %{_mandir}/man8/aulast.8.gz
249%attr(644,root,root) %{_mandir}/man8/auvirt.8.gz
250%attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
251%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
252%attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
253%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
254%attr(644,root,root) %{_mandir}/man5/audispd.conf.5.gz
255%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
256%attr(750,root,root) /sbin/auditctl
257%attr(750,root,root) /sbin/auditd
258%attr(755,root,root) /sbin/ausearch
259%attr(755,root,root) /sbin/aureport
260%attr(750,root,root) /sbin/autrace
261%attr(750,root,root) /sbin/audispd
262%attr(750,root,root) /sbin/augenrules
263%attr(750,root,root) %{_bindir}/aulastlog
264%attr(750,root,root) %{_bindir}/aulast
265%attr(755,root,root) %{_bindir}/ausyscall
266%attr(755,root,root) %{_bindir}/auvirt
267%attr(755,root,root) /etc/rc.d/init.d/auditd
268%attr(750,root,root) %dir %{_var}/log/audit
269%attr(750,root,root) %dir /etc/audit
270%attr(750,root,root) %dir /etc/audit/rules.d
271%attr(750,root,root) %dir /etc/audisp
272%attr(750,root,root) %dir /etc/audisp/plugins.d
273%config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
274%ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
275%ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
276%config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
277%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
278%config(noreplace) %attr(640,root,root) /etc/audisp/audispd.conf
279%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/af_unix.conf
280%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
281
282%files -n audispd-plugins
283%defattr(-,root,root,-)
284%attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
285%attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
286%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
287%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
288%config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
289%attr(750,root,root) /sbin/audispd-zos-remote
290%config(noreplace) %attr(640,root,root) /etc/audisp/audisp-remote.conf
291%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-remote.conf
292%attr(750,root,root) /sbin/audisp-remote
293%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
294%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
295
296
297%if %{build_compat32}
298%files -n compat32-%{name}-libs
299%{!?_licensedir:%global license %%doc}
300%license COPYING.LIB
301%defattr(-,root,root)
302%attr(755,root,root) /%{_lib}/libaudit.*
303%attr(755,root,root) /%{_lib}/libauparse.*
304%endif
305
306%changelog
307* Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-1
308- new upstream release.
309- imported Patch1 from rawhide.
310
311* Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
312- new upstream release.
313- dropped all patches.
314- dropped system-config-audit.
315- added python3 bindings.
316
317* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
318- fix sca_release
319
320* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
321- create compat32-audit-libs subpackage
322
323* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
324- rebuild with python-2.7.2
325- add Patch12 (audit-1.7.18-libaudit.patch)
326
327* Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
328- new upstream release
329- rebuild with krb5-1.8.2
330
331* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
332- forgot to increment sca_release macro (why on earth is sca_release
333  individually defined from main package's release number anyway?)
334
335* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
336- rebuilt with gcc-4.4.3-3 on ppc
337
338* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
339- rebuilt with rpm-4.8.0-3 (on ppc)
340
341* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
342- rebuild with python-2.6
343
344* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
345- rebuild with openldap-2.4.11
346
347* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
348- initial build for Vine Linux
349- disable krb5, prelude and selinux
350- add ja.po (XXX: minimal)
351
352* Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
353- Add subject to audit daemon events (Chu Li)
354- Add tcp_wrappers support for auditd
355- Updated syscall tables for 2.6.27 kernel
356- Audit connect/disconnect of remote clients
357- Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
358
359* Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
360- Update system-config-audit to 0.4.8
361- Whole lot of bug fixes - see ChangeLog for details
362- Reimplement auditd main loop using libev
363- Add TCP listener to auditd to receive remote events
364- Fix scheduler problem (#457061)
365
366* Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
367- Move ausearch-expression to main package (#453437)
368
369* Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
370- Fix interpreting of keys in syscall records
371- Don't error on name=(null) PATH records in ausearch/report
372- Add key report to aureport
373- Update system-config-audit to 0.4.7 (Miloslav Trmac)
374- Add support for the filetype field option in auditctl new to 2.6.26 kernels
375
376* Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
377- Fix output of keys in ausearch interpretted mode
378- Fix ausearch/report --start now to not be reset to midnight
379- audispd now has a priority boost config option
380- Look for laddr in avcs reported via prelude
381- Detect page 0 mmaps and alert via prelude
382
383* Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
384- Fix overflow in audit_log_user_command, better (#438840)
385- ausearch was not matching path in avc records
386- audisp-prelude attempt to reposition index after examining each type
387- correct building of mls policy
388- Fix auparse iterating in auparse_find_field and next_field
389- Don't alert on USER_AVC's - they are not quite right
390
391* Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
392- Fix buffer overflow in audit_log_user_command, again (#438840)
393- Fix memory leak in EOE code in auditd (#440075)
394- In auditctl, don't use new operators in legacy rule format
395- Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
396
397* Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
398- Fix memleak in auditd eoe code
399
400* Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
401- Remove LSB headers from init scripts
402- Fix buffer overflow in audit_log_user_command again
403
404* Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
405- Handle user space avcs in prelude plugin
406- Fix watched account login detection for some failed login attempts
407- Couple fixups in audit logging functions (Miloslav Trmac)
408- Add support in auditctl for virtual keys
409- auparse_find_field_next was not iterating correctly, fixed it
410- Add idmef alerts for access or execution of watched file
411- Fix buffer overflow in audit_log_user_command
412- Add basic remote logging plugin - only sends & no flow control
413- Update ausearch with interpret fixes from auparse
414
415* Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
416- Apply hidden attribute cleanup patch (Miloslav Trmac)
417- Apply auparse expression interface patch (Miloslav Trmac)
418- Fix potential memleak in audit event dispatcher
419- Update system-config-audit to version 0.4.6 (Miloslav Trmac)
420- audisp-prelude alerts now controlled by config file
421- Updated syscall table for 2.6.25 kernel
422- Apply patch correcting acct field being misencoded (Miloslav Trmac)
423- Added watched account login detection for prelude plugin
424
425* Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
426- Update for gcc 4.3
427- Cleanup descriptors in audispd before running plugin
428- Fix 'recent' keyword for aureport/search
429- Fix SE Linux policy for zos_remote plugin
430- Add event type for group password authentication attempts
431- Couple of updates to the translation tables
432- Add detection of failed group authentication to audisp-prelude
433
434* Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
435- In ausearch/report, prefer -if to stdin
436- In ausearch/report, add new command line option --input-logs (#428860)
437- Updated audisp-prelude based on feedback from prelude-devel
438- Added prelude alert for promiscuous socket being opened
439- Added prelude alert for SE Linux policy enforcement changes
440- Added prelude alerts for Forbidden Login Locations and Time
441- Applied patch to auparse fixing error handling of searching by
442  interpreted value (Miloslav Trmac)
443
444* Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
445- Add prelude IDS plugin for IDMEF alerts
446- Add --user option to aulastlog command
447- Use desktop-file-install for system-config-audit
448- Avoid touching auditd.conf most of the time (#408501)
449
450* Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
451- Updates for spec file review
452- Adjust permission on selinux policy file
453
454* Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
455- Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
456- Check for audit log being writable by owner in auditd
457- If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
458- Updated CAPP, LSPP, and NISPOM rules for new capabilities
459- Added aulastlog utility
460
461* Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
462- Allow 0600 file perms for audit logs
463
464* Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
465- fchmod of log file was on wrong variable (#426934)
466- Allow use of errno strings for exit codes in audit rules
467
468* Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
469- Don't fchmod() /dev/null to mode 0400 (#426934)
470
471* Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
472- Add kernel release string to DEAMON_START events
473- Fix keep_logs when num_logs option disabled (#325561)
474- Fix auparse to handle node fields for syscall records
475- Update system-config-audit to version 0.4.5 (Miloslav Trmac)
476- Add keyword week-ago to aureport & ausearch start/end times
477- Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
478- Add RACF zos remote audispd plugin (Klaus Kiwi)
479- Add event queue overflow action to audispd
480
481* Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
482- Don't retry if the rt queue is full.
483
484* Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
485- Add support for searching by posix regular expressions in auparse
486- Route DEAMON events into rt interface
487- If event pipe is full, try again after doing local logging
488- Optionally add node/machine name to records in audit daemon
489- Update ausearch/aureport to specify nodes to search on
490- Fix segfault interpretting saddr fields in avcs
491
492* Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
493- Fix uninitialized variable in auparse (John Dennis)
494
495* Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
496- External plugin support in place
497- Fix reference counting in auparse python bindings (#263961)
498- Moved default af_unix plugin socket to /var/run/audispd_events
499
500* Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
501- Add newline to audispd string formatted events
502
503* Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
504- spec file cleanups
505- Update to s-c-audit 0.4.3
506
507* Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
508- Update Licence tags
509- Adding perm field should not set syscall added flag in auditctl
510- Fix segfault when aureport -if option is used
511- Fix auditctl to better check keys on rule lines
512- Add support for audit by TTY and other new event types
513- Auditd config option for group permission of audit logs
514- Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
515- New audit event dispatcher
516- Update syscall tables for 2.6.23 kernel
517
518* Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
519- Fix potential buffer overflow in print clone flags of auparse
520- Fix python traceback parsing watches without perm statement (Miloslav Trmac)
521- Update auditctl to handle legacy kernels when putting a watch on a dir
522- Fix acct interpretation in auparse
523
524* Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
525- Fix a double free when auditd receives SIGHUP
526- Move the system-config-audit menu entry to the Administration menu
527
528* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
529- Add system-config-audit (Miloslav Trmac)
530- Correct bug in audit_make_equivalent function (Al Viro)
531
532* Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
533- Add feed interface to auparse library (John Dennis)
534- Apply patch to libauparse for unresolved symbols (#241178)
535- Apply patch to add line numbers for file events in libauparse (John Dennis)
536- Change seresults to seresult in libauparse (John Dennis)
537- Add unit32_t definition to swig (#244210)
538- Add support for directory auditing
539- Update acct field to be escaped
540
541* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
542- Change buffer size to prevent truncation of DAEMON events with large labels
543- Fix memory leaks in auparse (John Dennis)
544- Update syscall tables for 2.6.21 kernel
545- Update capp & lspp rules
546- New python bindings for libauparse (John Dennis)
547
548* Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
549- New event dispatcher (James Antill)
550- Apply patches fixing man pages and Makefile.am (Philipp Hahn)
551- Apply patch correcting python libs permissions (Philipp Hahn)
552- Fix auditd segfault on reload
553- Fix bug in auparse library for file pointers and descriptors
554- Extract subject information out of daemon events for ausearch
555
556* Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
557- Remove requires kernel-headers for python-libs
558- Apply patch to prevent segfaults on auditd reload
559
560* Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
561- Updated autrace to monitor *at syscalls
562- Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
563- Finish reworking auditd config parser
564- In auparse, interpret open, fcntl, and clone flags
565- In auparse, when interpreting execve record types, run args through unencode
566- Add support for OBJ_PID message type
567- Event dispatcher updates
568
569* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
570- rebuild
571
572* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
573- NEW audit dispatcher program & plugin framework
574- Correct hidden variables in libauparse
575- Added NISPOM sample rules
576- Verify accessibility of files passed in auparse_init
577- Fix bug in parser library interpreting socketcalls
578- Add support for stdio FILE pointer in auparse_init
579- Adjust init script to allow anyone to status auditd (#230626)
580
581* Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
582- Add man pages
583- Reduce text relocations in parser library
584- Add -n option to auditd for no fork
585- Add exec option to space_left, admin_space_left, disk_full,
586  and disk_error - eg EXEC /usr/local/script
587
588* Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
589- updated audit_rule_fieldpair_data to handle perm correctly (#226780)
590- Finished search options for audit parsing library
591- Fix ausearch -se to work correctly
592- Fix auditd init script for /usr on netdev (#228528)
593- Parse avc seperms better when there are more than one
594
595* Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
596- New report about authentication attempts
597- Updates for python 2.5
598- update autrace to have resource usage mode
599- update auditctl to support immutable config
600- added audit_log_user_command function to libaudit api
601- interpret capabilities
602- added audit event parsing library
603- updates for 2.6.20 kernel
604
605* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
606- Make more adjustments for python 2.5
607
608* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
609- Fix a couple parsing problems (#217952)
610- Add tgkill to S390* syscall tables (#218484)
611- Fix error messages in ausearch/aureport
612
613* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
614- rebuild against python 2.5
615
616* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
617- Fix timestamp for libaudit.conf (#218053)
618
619* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
620- Fix minor parsing problem and add new msg types
621
622* Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
623- ausearch & aureport implement uid/gid caching
624- In ausearch & aureport, extract addr when hostname is unknown
625- In ausearch & aureport, test audit log presence O_RDONLY
626- New ausearch/aureport time keywords: recent, this-week, this-month, this-year
627- Added --add & --delete option to aureport
628- Update res parsing in config change events
629- Increase the size on audit daemon buffers
630- Parse avc_path records in ausearch/aureport
631- ausearch has new output mode, raw, for extracting events
632- ausearch/aureport can now read stdin
633- Rework AVC processing in ausearch/aureport
634- Added long options to ausearch and aureport
635
636* Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
637- In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
638- Fix some defines in libaudit.h
639- Some auditd config strings were not initialized in aureport (#211443)
640- Updated man pages
641- Add Netlabel event types to libaudit
642- Update aureports to current audit event types
643- Update autrace a little
644- Deprecated all the old audit_rule functions from public API
645- Drop auparse library for the moment
646
647* Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
648- Add dist tag and bump version (#208532)
649- Make internal auditd buffers bigger for context info
650- Correct address resolving of hostname in logging functions
651- Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
652- Only =, != operators for arch & inode fields in auditctl (#206427)
653- Updated audit message type table
654- Remove watches from aureport since FS_WATCH is deprecated
655- Add audit_log_avc back temporarily (#208152)
656 
Note: See TracBrowser for help on using the repository browser.