source: projects/specs/trunk/a/audit/audit-vl.spec @ 11169

Revision 11169, 24.5 KB checked in by tomop, 7 years ago (diff)

audit-2.7.7-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3%{!?__python3: %global __python3 /usr/bin/python3}
4%{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print (get_python_lib())")}
5%{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
6
7%define sca_version 0.4.10
8%define sca_release 4
9
10Summary: User space tools for 2.6 kernel auditing
11Name: audit
12Version: 2.7.7
13Release: 1%{?_dist_release}
14License: GPLv2+
15Group: System Environment/Daemons
16URL: http://people.redhat.com/sgrubb/audit/
17Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
18#Patch10: audit-1.7.18-pthread.patch
19#Patch11: audit-1.7.18-krb5.patch
20#Patch12: audit-1.7.18-libaudit.patch
21
22Distribution: Vine Linux
23Vendor: Project Vine
24
25BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
26BuildRequires: gettext intltool libtool swig
27BuildRequires: python-devel python3-devel
28BuildRequires: openldap-devel
29BuildRequires: tcp_wrappers
30BuildRequires: krb5-devel
31BuildRequires: kernel-headers >= 2.6.18
32BuildRequires: libcap-ng-devel
33BuildRequires: automake >= 1.9
34BuildRequires: autoconf >= 2.59
35Requires: %{name}-libs = %{version}-%{release}
36Requires: chkconfig
37Requires(pre): coreutils
38
39%description
40The audit package contains the user space utilities for
41storing and searching the audit records generate by
42the audit subsystem in the Linux 2.6 kernel.
43
44%package libs
45Summary: Dynamic library for libaudit
46License: LGPLv2+
47Group: Development/Libraries
48
49%description libs
50The audit-libs package contains the dynamic libraries needed for
51applications to use the audit framework.
52
53%package libs-devel
54Summary: Header files and static library for libaudit
55License: LGPLv2+
56Group: Development/Libraries
57Requires: %{name}-libs = %{version}-%{release}
58Requires: kernel-headers >= 2.6.18
59
60%description libs-devel
61The audit-libs-devel package contains the static libraries and header
62files needed for developing applications that need to use the audit
63framework libraries.
64
65%package libs-python
66Summary: Python2 bindings for libaudit
67License: LGPLv2+
68Group: Development/Libraries
69Requires: %{name}-libs = %{version}-%{release}
70
71%description libs-python
72The audit-libs-python package contains the bindings so that libaudit
73and libauparse can be used by python2.
74
75%package libs-python3
76Summary: Python3 bindings for libaudit
77License: LGPLv2+
78Group: Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}
80
81%description libs-python3
82The audit-libs-python3 package contains the bindings so that libaudit
83and libauparse can be used by python3.
84
85%package -n audispd-plugins
86Summary: Plugins for the audit event dispatcher
87License: GPLv2+
88Group: System Environment/Daemons
89Requires: %{name} = %{version}-%{release}
90Requires: %{name}-libs = %{version}-%{release}
91Requires: openldap
92
93%description -n audispd-plugins
94The audispd-plugins package provides plugins for the real-time
95interface to the audit system, audispd. These plugins can do things
96like relay events to remote machines or analyze events for suspicious
97behavior.
98
99%package -n compat32-%{name}-libs
100Summary: Dynamic library for libaudit
101License: LGPLv2+
102Group: Development/Libraries
103
104%description -n compat32-%{name}-libs
105The audit-libs package contains the dynamic libraries needed for
106applications to use the audit framework.
107
108%prep
109%setup -q
110#%patch10 -p1
111#%patch11 -p1
112#%patch12 -p1
113
114%build
115%configure --sbindir=/sbin --libdir=/%{_lib} \
116    --with-python=yes --with-python3=yes \
117    --with-libcap-ng=yes --with-libwrap --enable-gssapi-krb5=yes
118make CFLAGS="%{optflags}" %{?_smp_mflags}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audispd/plugins.d,rc.d/init.d,audit/rules.d}}
123mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
124mkdir -p $RPM_BUILD_ROOT/%{_lib}
125mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
126mkdir -p $RPM_BUILD_ROOT/%{_var}/log/audit
127make DESTDIR=$RPM_BUILD_ROOT install
128
129mkdir -p $RPM_BUILD_ROOT/%{_libdir}
130# This winds up in the wrong place when libtool is involved
131mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
132mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
133curdir=`pwd`
134cd $RPM_BUILD_ROOT/%{_libdir}
135LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
136ln -s ../../%{_lib}/$LIBNAME libaudit.so
137LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
138ln -s ../../%{_lib}/$LIBNAME libauparse.so
139cd $curdir
140# Remove these items so they don't get picked up.
141rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
142rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
143
144find $RPM_BUILD_ROOT -name '*.la' -delete
145find $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages -name '*.a' -delete
146
147# Move the pkgconfig file
148mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
149
150# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
151touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
152touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
153
154#% check
155#make check
156
157%clean
158rm -rf $RPM_BUILD_ROOT
159rm -rf zos-remote-policy
160
161%post libs -p /sbin/ldconfig
162
163%post
164/sbin/chkconfig --add auditd
165# This is to migrate users from audit-1.0.x installations
166if [ -f /etc/auditd.conf ]; then
167   mv /etc/auditd.conf /etc/audit/auditd.conf
168fi
169if [ -f /etc/audit.rules ]; then
170   mv /etc/audit.rules /etc/audit/audit.rules
171fi
172# This is to enable the dispatcher option which was commented out
173if [ -f /etc/audit/auditd.conf ]; then
174   grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
175   if [ $? -eq 1 ] ; then
176      tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
177      if [ -n $tmp ]; then
178         sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
179         cat $tmp > /etc/audit/auditd.conf
180         rm -f $tmp
181      fi
182   fi
183fi
184
185%post -n compat32-%{name}-libs -p /sbin/ldconfig
186
187%preun
188if [ $1 -eq 0 ]; then
189   /sbin/service auditd stop > /dev/null 2>&1
190   /sbin/chkconfig --del auditd
191fi
192
193%postun libs -p /sbin/ldconfig
194
195%postun
196if [ $1 -ge 1 ]; then
197   /sbin/service auditd condrestart > /dev/null 2>&1 || :
198fi
199
200%postun -n compat32-%{name}-libs -p /sbin/ldconfig
201
202%files libs
203%defattr(-,root,root)
204%{!?_licensedir:%global license %%doc}
205%license COPYING.LIB
206/%{_lib}/libaudit.*
207/%{_lib}/libauparse.*
208%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
209%{_mandir}/man5/libaudit.conf.5.gz
210
211%files libs-devel
212%defattr(-,root,root)
213%{!?_licensedir:%global license %%doc}
214%license COPYING.LIB
215%doc contrib/skeleton.c contrib/plugin
216%{_libdir}/libaudit.a
217%{_libdir}/libauparse.a
218%{_libdir}/libaudit.so
219%{_libdir}/libauparse.so
220%{_includedir}/libaudit.h
221%{_includedir}/auparse.h
222%{_includedir}/auparse-defs.h
223%{_datadir}/aclocal/audit.m4
224%{_libdir}/pkgconfig/audit.pc
225%{_libdir}/pkgconfig/auparse.pc
226%{_mandir}/man3/*
227
228%files libs-python
229%defattr(-,root,root)
230%attr(755,root,root) %{python_sitearch}/_audit.so
231%attr(755,root,root) %{python_sitearch}/auparse.so
232%{python_sitearch}/audit.py*
233
234%files libs-python3
235%defattr(-,root,root,-)
236%attr(755,root,root) %{python3_sitearch}/*
237
238%files
239%defattr(-,root,root,-)
240%doc README ChangeLog rules init.d/auditd.cron
241%{!?_licensedir:%global license %%doc}
242%license COPYING
243%attr(644,root,root) %{_mandir}/man8/audispd.8.gz
244%attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
245%attr(644,root,root) %{_mandir}/man8/auditd.8.gz
246%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
247%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
248%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
249%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
250%attr(644,root,root) %{_mandir}/man8/aulast.8.gz
251%attr(644,root,root) %{_mandir}/man8/auvirt.8.gz
252%attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
253%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
254%attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
255%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
256%attr(644,root,root) %{_mandir}/man5/audispd.conf.5.gz
257%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
258%attr(750,root,root) /sbin/auditctl
259%attr(750,root,root) /sbin/auditd
260%attr(755,root,root) /sbin/ausearch
261%attr(755,root,root) /sbin/aureport
262%attr(750,root,root) /sbin/autrace
263%attr(750,root,root) /sbin/audispd
264%attr(750,root,root) /sbin/augenrules
265%attr(750,root,root) %{_bindir}/aulastlog
266%attr(750,root,root) %{_bindir}/aulast
267%attr(755,root,root) %{_bindir}/ausyscall
268%attr(755,root,root) %{_bindir}/auvirt
269%attr(755,root,root) /etc/rc.d/init.d/auditd
270%attr(750,root,root) %dir %{_var}/log/audit
271%attr(750,root,root) %dir /etc/audit
272%attr(750,root,root) %dir /etc/audit/rules.d
273%attr(750,root,root) %dir /etc/audisp
274%attr(750,root,root) %dir /etc/audisp/plugins.d
275%config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
276%ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
277%ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
278%config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
279%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
280%config(noreplace) %attr(640,root,root) /etc/audisp/audispd.conf
281%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/af_unix.conf
282%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
283
284%files -n audispd-plugins
285%defattr(-,root,root,-)
286%attr(640,root,root) /etc/audisp/plugins.d/syslog.conf
287%attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
288%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
289%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/audispd-zos-remote.conf
290%config(noreplace) %attr(640,root,root) /etc/audisp/zos-remote.conf
291%attr(750,root,root) /sbin/audispd-zos-remote
292%config(noreplace) %attr(640,root,root) /etc/audisp/audisp-remote.conf
293%config(noreplace) %attr(640,root,root) /etc/audisp/plugins.d/au-remote.conf
294%attr(750,root,root) /sbin/audisp-remote
295%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
296%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
297
298
299%if %{build_compat32}
300%files -n compat32-%{name}-libs
301%{!?_licensedir:%global license %%doc}
302%license COPYING.LIB
303%defattr(-,root,root)
304%attr(755,root,root) /%{_lib}/libaudit.*
305%attr(755,root,root) /%{_lib}/libauparse.*
306%endif
307
308%changelog
309* Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
310- new upstream release.
311- dropped all patches.
312- dropped system-config-audit.
313- added python3 bindings.
314
315* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
316- fix sca_release
317
318* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
319- create compat32-audit-libs subpackage
320
321* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
322- rebuild with python-2.7.2
323- add Patch12 (audit-1.7.18-libaudit.patch)
324
325* Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
326- new upstream release
327- rebuild with krb5-1.8.2
328
329* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
330- forgot to increment sca_release macro (why on earth is sca_release
331  individually defined from main package's release number anyway?)
332
333* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
334- rebuilt with gcc-4.4.3-3 on ppc
335
336* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
337- rebuilt with rpm-4.8.0-3 (on ppc)
338
339* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
340- rebuild with python-2.6
341
342* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
343- rebuild with openldap-2.4.11
344
345* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
346- initial build for Vine Linux
347- disable krb5, prelude and selinux
348- add ja.po (XXX: minimal)
349
350* Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
351- Add subject to audit daemon events (Chu Li)
352- Add tcp_wrappers support for auditd
353- Updated syscall tables for 2.6.27 kernel
354- Audit connect/disconnect of remote clients
355- Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
356
357* Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
358- Update system-config-audit to 0.4.8
359- Whole lot of bug fixes - see ChangeLog for details
360- Reimplement auditd main loop using libev
361- Add TCP listener to auditd to receive remote events
362- Fix scheduler problem (#457061)
363
364* Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
365- Move ausearch-expression to main package (#453437)
366
367* Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
368- Fix interpreting of keys in syscall records
369- Don't error on name=(null) PATH records in ausearch/report
370- Add key report to aureport
371- Update system-config-audit to 0.4.7 (Miloslav Trmac)
372- Add support for the filetype field option in auditctl new to 2.6.26 kernels
373
374* Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
375- Fix output of keys in ausearch interpretted mode
376- Fix ausearch/report --start now to not be reset to midnight
377- audispd now has a priority boost config option
378- Look for laddr in avcs reported via prelude
379- Detect page 0 mmaps and alert via prelude
380
381* Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
382- Fix overflow in audit_log_user_command, better (#438840)
383- ausearch was not matching path in avc records
384- audisp-prelude attempt to reposition index after examining each type
385- correct building of mls policy
386- Fix auparse iterating in auparse_find_field and next_field
387- Don't alert on USER_AVC's - they are not quite right
388
389* Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
390- Fix buffer overflow in audit_log_user_command, again (#438840)
391- Fix memory leak in EOE code in auditd (#440075)
392- In auditctl, don't use new operators in legacy rule format
393- Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
394
395* Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
396- Fix memleak in auditd eoe code
397
398* Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
399- Remove LSB headers from init scripts
400- Fix buffer overflow in audit_log_user_command again
401
402* Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
403- Handle user space avcs in prelude plugin
404- Fix watched account login detection for some failed login attempts
405- Couple fixups in audit logging functions (Miloslav Trmac)
406- Add support in auditctl for virtual keys
407- auparse_find_field_next was not iterating correctly, fixed it
408- Add idmef alerts for access or execution of watched file
409- Fix buffer overflow in audit_log_user_command
410- Add basic remote logging plugin - only sends & no flow control
411- Update ausearch with interpret fixes from auparse
412
413* Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
414- Apply hidden attribute cleanup patch (Miloslav Trmac)
415- Apply auparse expression interface patch (Miloslav Trmac)
416- Fix potential memleak in audit event dispatcher
417- Update system-config-audit to version 0.4.6 (Miloslav Trmac)
418- audisp-prelude alerts now controlled by config file
419- Updated syscall table for 2.6.25 kernel
420- Apply patch correcting acct field being misencoded (Miloslav Trmac)
421- Added watched account login detection for prelude plugin
422
423* Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
424- Update for gcc 4.3
425- Cleanup descriptors in audispd before running plugin
426- Fix 'recent' keyword for aureport/search
427- Fix SE Linux policy for zos_remote plugin
428- Add event type for group password authentication attempts
429- Couple of updates to the translation tables
430- Add detection of failed group authentication to audisp-prelude
431
432* Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
433- In ausearch/report, prefer -if to stdin
434- In ausearch/report, add new command line option --input-logs (#428860)
435- Updated audisp-prelude based on feedback from prelude-devel
436- Added prelude alert for promiscuous socket being opened
437- Added prelude alert for SE Linux policy enforcement changes
438- Added prelude alerts for Forbidden Login Locations and Time
439- Applied patch to auparse fixing error handling of searching by
440  interpreted value (Miloslav Trmac)
441
442* Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
443- Add prelude IDS plugin for IDMEF alerts
444- Add --user option to aulastlog command
445- Use desktop-file-install for system-config-audit
446- Avoid touching auditd.conf most of the time (#408501)
447
448* Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
449- Updates for spec file review
450- Adjust permission on selinux policy file
451
452* Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
453- Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
454- Check for audit log being writable by owner in auditd
455- If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
456- Updated CAPP, LSPP, and NISPOM rules for new capabilities
457- Added aulastlog utility
458
459* Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
460- Allow 0600 file perms for audit logs
461
462* Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
463- fchmod of log file was on wrong variable (#426934)
464- Allow use of errno strings for exit codes in audit rules
465
466* Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
467- Don't fchmod() /dev/null to mode 0400 (#426934)
468
469* Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
470- Add kernel release string to DEAMON_START events
471- Fix keep_logs when num_logs option disabled (#325561)
472- Fix auparse to handle node fields for syscall records
473- Update system-config-audit to version 0.4.5 (Miloslav Trmac)
474- Add keyword week-ago to aureport & ausearch start/end times
475- Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
476- Add RACF zos remote audispd plugin (Klaus Kiwi)
477- Add event queue overflow action to audispd
478
479* Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
480- Don't retry if the rt queue is full.
481
482* Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
483- Add support for searching by posix regular expressions in auparse
484- Route DEAMON events into rt interface
485- If event pipe is full, try again after doing local logging
486- Optionally add node/machine name to records in audit daemon
487- Update ausearch/aureport to specify nodes to search on
488- Fix segfault interpretting saddr fields in avcs
489
490* Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
491- Fix uninitialized variable in auparse (John Dennis)
492
493* Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
494- External plugin support in place
495- Fix reference counting in auparse python bindings (#263961)
496- Moved default af_unix plugin socket to /var/run/audispd_events
497
498* Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
499- Add newline to audispd string formatted events
500
501* Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
502- spec file cleanups
503- Update to s-c-audit 0.4.3
504
505* Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
506- Update Licence tags
507- Adding perm field should not set syscall added flag in auditctl
508- Fix segfault when aureport -if option is used
509- Fix auditctl to better check keys on rule lines
510- Add support for audit by TTY and other new event types
511- Auditd config option for group permission of audit logs
512- Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
513- New audit event dispatcher
514- Update syscall tables for 2.6.23 kernel
515
516* Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
517- Fix potential buffer overflow in print clone flags of auparse
518- Fix python traceback parsing watches without perm statement (Miloslav Trmac)
519- Update auditctl to handle legacy kernels when putting a watch on a dir
520- Fix acct interpretation in auparse
521
522* Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
523- Fix a double free when auditd receives SIGHUP
524- Move the system-config-audit menu entry to the Administration menu
525
526* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
527- Add system-config-audit (Miloslav Trmac)
528- Correct bug in audit_make_equivalent function (Al Viro)
529
530* Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
531- Add feed interface to auparse library (John Dennis)
532- Apply patch to libauparse for unresolved symbols (#241178)
533- Apply patch to add line numbers for file events in libauparse (John Dennis)
534- Change seresults to seresult in libauparse (John Dennis)
535- Add unit32_t definition to swig (#244210)
536- Add support for directory auditing
537- Update acct field to be escaped
538
539* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
540- Change buffer size to prevent truncation of DAEMON events with large labels
541- Fix memory leaks in auparse (John Dennis)
542- Update syscall tables for 2.6.21 kernel
543- Update capp & lspp rules
544- New python bindings for libauparse (John Dennis)
545
546* Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
547- New event dispatcher (James Antill)
548- Apply patches fixing man pages and Makefile.am (Philipp Hahn)
549- Apply patch correcting python libs permissions (Philipp Hahn)
550- Fix auditd segfault on reload
551- Fix bug in auparse library for file pointers and descriptors
552- Extract subject information out of daemon events for ausearch
553
554* Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
555- Remove requires kernel-headers for python-libs
556- Apply patch to prevent segfaults on auditd reload
557
558* Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
559- Updated autrace to monitor *at syscalls
560- Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
561- Finish reworking auditd config parser
562- In auparse, interpret open, fcntl, and clone flags
563- In auparse, when interpreting execve record types, run args through unencode
564- Add support for OBJ_PID message type
565- Event dispatcher updates
566
567* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
568- rebuild
569
570* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
571- NEW audit dispatcher program & plugin framework
572- Correct hidden variables in libauparse
573- Added NISPOM sample rules
574- Verify accessibility of files passed in auparse_init
575- Fix bug in parser library interpreting socketcalls
576- Add support for stdio FILE pointer in auparse_init
577- Adjust init script to allow anyone to status auditd (#230626)
578
579* Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
580- Add man pages
581- Reduce text relocations in parser library
582- Add -n option to auditd for no fork
583- Add exec option to space_left, admin_space_left, disk_full,
584  and disk_error - eg EXEC /usr/local/script
585
586* Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
587- updated audit_rule_fieldpair_data to handle perm correctly (#226780)
588- Finished search options for audit parsing library
589- Fix ausearch -se to work correctly
590- Fix auditd init script for /usr on netdev (#228528)
591- Parse avc seperms better when there are more than one
592
593* Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
594- New report about authentication attempts
595- Updates for python 2.5
596- update autrace to have resource usage mode
597- update auditctl to support immutable config
598- added audit_log_user_command function to libaudit api
599- interpret capabilities
600- added audit event parsing library
601- updates for 2.6.20 kernel
602
603* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
604- Make more adjustments for python 2.5
605
606* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
607- Fix a couple parsing problems (#217952)
608- Add tgkill to S390* syscall tables (#218484)
609- Fix error messages in ausearch/aureport
610
611* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
612- rebuild against python 2.5
613
614* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
615- Fix timestamp for libaudit.conf (#218053)
616
617* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
618- Fix minor parsing problem and add new msg types
619
620* Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
621- ausearch & aureport implement uid/gid caching
622- In ausearch & aureport, extract addr when hostname is unknown
623- In ausearch & aureport, test audit log presence O_RDONLY
624- New ausearch/aureport time keywords: recent, this-week, this-month, this-year
625- Added --add & --delete option to aureport
626- Update res parsing in config change events
627- Increase the size on audit daemon buffers
628- Parse avc_path records in ausearch/aureport
629- ausearch has new output mode, raw, for extracting events
630- ausearch/aureport can now read stdin
631- Rework AVC processing in ausearch/aureport
632- Added long options to ausearch and aureport
633
634* Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
635- In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
636- Fix some defines in libaudit.h
637- Some auditd config strings were not initialized in aureport (#211443)
638- Updated man pages
639- Add Netlabel event types to libaudit
640- Update aureports to current audit event types
641- Update autrace a little
642- Deprecated all the old audit_rule functions from public API
643- Drop auparse library for the moment
644
645* Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
646- Add dist tag and bump version (#208532)
647- Make internal auditd buffers bigger for context info
648- Correct address resolving of hostname in logging functions
649- Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
650- Only =, != operators for arch & inode fields in auditctl (#206427)
651- Updated audit message type table
652- Remove watches from aureport since FS_WATCH is deprecated
653- Add audit_log_avc back temporarily (#208152)
654 
Note: See TracBrowser for help on using the repository browser.