source: projects/specs/trunk/a/audit/audit-vl.spec @ 12535

Revision 12535, 26.5 KB checked in by tomop, 3 years ago (diff)

updated 3 packages

audit-3.0.1-1

initscripts-8.91.16-6

libsigsegv-2.13-1

Line 
1%bcond_with systemd
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4%define _unpackaged_files_terminate_build 1
5
6Summary: User space tools for 2.6 kernel auditing
7Name: audit
8Version: 3.0.1
9Release: 1%{?_dist_release}%{?with_systemd:.systemd}
10License: GPLv2+
11Group: system,admin-tools
12Distribution: Vine Linux
13Vendor: Project Vine
14
15URL: http://people.redhat.com/sgrubb/audit/
16Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
17Patch1: audit-3.0.2-sockaddr.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: gettext intltool libtool swig
21BuildRequires: python-devel python-rpm-macros
22BuildRequires: python3-devel python3-rpm-macros
23BuildRequires: openldap-devel
24BuildRequires: krb5-devel
25BuildRequires: kernel-headers >= 2.6.18
26BuildRequires: libcap-ng-devel
27BuildRequires: automake >= 1.9
28BuildRequires: autoconf >= 2.59
29%if %{with systemd}
30%{?systemd_requires}
31%else
32Requires(post): /sbin/chkconfig
33Requires(preun): /sbin/chkconfig
34Requires(preun): /sbin/service
35Requires(postun): /sbin/service
36%endif
37Requires: %{name}-libs = %{version}-%{release}
38Requires(pre): coreutils
39
40%description
41The audit package contains the user space utilities for
42storing and searching the audit records generate by
43the audit subsystem in the Linux 2.6 kernel.
44
45
46%package libs
47Summary: Dynamic library for libaudit
48License: LGPLv2+
49Group: system
50
51%description libs
52The audit-libs package contains the dynamic libraries needed for
53applications to use the audit framework.
54
55
56%package libs-devel
57Summary: Header files and static library for libaudit
58License: LGPLv2+
59Group: programming
60Requires: %{name}-libs = %{version}-%{release}
61Requires: kernel-headers >= 2.6.18
62
63%description libs-devel
64The audit-libs-devel package contains the static libraries and header
65files needed for developing applications that need to use the audit
66framework libraries.
67
68
69%package libs-python
70Summary: Python2 bindings for libaudit
71License: LGPLv2+
72Group: programming
73Requires: %{name}-libs = %{version}-%{release}
74
75%description libs-python
76The audit-libs-python package contains the bindings so that libaudit
77and libauparse can be used by python2.
78
79
80%package libs-python3
81Summary: Python3 bindings for libaudit
82License: LGPLv2+
83Group: programming
84Provides: python-audit = %{version}-%{release}
85Requires: %{name}-libs = %{version}-%{release}
86
87%description libs-python3
88The audit-libs-python3 package contains the bindings so that libaudit
89and libauparse can be used by python3.
90
91
92%package -n audispd-plugins
93Summary: Plugins for the audit event dispatcher
94Group: system
95License: GPLv2+
96Provides: python3-audit = %{version}-%{release}
97Requires: %{name} = %{version}-%{release}
98Requires: %{name}-libs = %{version}-%{release}
99
100%description -n audispd-plugins
101The audispd-plugins package provides plugins for the real-time
102interface to the audit system, audispd. These plugins can do things
103like relay events to remote machines or analyze events for suspicious
104behavior.
105
106
107%package -n audispd-plugins-zos
108Summary: z/OS plugin for the audit event dispatcher
109Group: system
110License: GPLv2+
111Requires: %{name}%{?_isa} = %{version}-%{release}
112Requires: %{name}-libs%{?_isa} = %{version}-%{release}
113Requires: openldap
114
115%description -n audispd-plugins-zos
116The audispd-plugins-zos package provides a plugin that will forward all
117incoming audit events, as they happen, to a configured z/OS SMF (Service
118Management Facility) database, through an IBM Tivoli Directory Server
119(ITDS) set for Remote Audit service.
120
121
122%package -n compat32-%{name}-libs
123Summary: Dynamic library for libaudit
124License: LGPLv2+
125Group: system
126
127%description -n compat32-%{name}-libs
128The audit-libs package contains the dynamic libraries needed for
129applications to use the audit framework.
130
131
132%debug_package
133
134
135%prep
136%setup -q -n audit-userspace-%{version}
137%patch1 -p1
138
139autoreconf -vif
140# Remove the ids code, its not ready
141sed -i 's/ ids / /' audisp/plugins/Makefile.in
142
143
144%build
145%configure --sbindir=/sbin --libdir=/%{_lib} \
146    --with-python=yes --with-python3=yes \
147    --with-libcap-ng=yes --enable-gssapi-krb5=yes \
148    --enable-zos-remote \
149    --enable-experimental \
150%if %{with systemd}
151    --enable-systemd
152%else
153    %{nil}
154%endif
155make CFLAGS="%{optflags}" %{?_smp_mflags}
156
157
158%install
159rm -rf $RPM_BUILD_ROOT
160mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audit/plugins.d,rc.d/init.d,audit/rules.d}}
161mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
162mkdir -p $RPM_BUILD_ROOT/%{_lib}
163mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
164mkdir -p --mode=0700 $RPM_BUILD_ROOT/%{_var}/log/audit
165mkdir -p $RPM_BUILD_ROOT/%{_var}/spool/audit
166make DESTDIR=$RPM_BUILD_ROOT install
167
168mkdir -p $RPM_BUILD_ROOT/%{_libdir}
169# This winds up in the wrong place when libtool is involved
170mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
171mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
172curdir=`pwd`
173cd $RPM_BUILD_ROOT/%{_libdir}
174LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
175ln -s ../../%{_lib}/$LIBNAME libaudit.so
176LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
177ln -s ../../%{_lib}/$LIBNAME libauparse.so
178cd $curdir
179# Remove these items so they don't get picked up.
180rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
181rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
182
183find $RPM_BUILD_ROOT -name '*.la' -delete
184find $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages -name '*.a' -delete
185
186# Move the pkgconfig file
187mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
188
189# On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
190touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
191touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
192
193%if %{with systemd}
194rm -rf %{buildroot}%{_libexecdir}/initscripts
195mkdir -p %{buildroot}%{_unitdir}
196mv %{buildroot}/usr/lib/systemd/system/auditd.service %{buildroot}%{_unitdir}/
197%endif
198
199
200%clean
201rm -rf $RPM_BUILD_ROOT
202rm -rf zos-remote-policy
203
204
205%post
206# This is to migrate users from audit-1.0.x installations
207if [ -f /etc/auditd.conf ]; then
208   mv /etc/auditd.conf /etc/audit/auditd.conf
209fi
210if [ -f /etc/audit.rules ]; then
211   mv /etc/audit.rules /etc/audit/audit.rules
212fi
213# This is to enable the dispatcher option which was commented out
214if [ -f /etc/audit/auditd.conf ]; then
215   grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
216   if [ $? -eq 1 ] ; then
217      tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
218      if [ -n $tmp ]; then
219         sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
220         cat $tmp > /etc/audit/auditd.conf
221         rm -f $tmp
222      fi
223   fi
224fi
225# Copy default rules into place on new installation
226files=`ls /etc/audit/rules.d/ 2>/dev/null | wc -w`
227if [ "$files" -eq 0 ] ; then
228# FESCO asked for audit to be off by default. #1117953
229        if [ -e %{_datadir}/%{name}/sample-rules/10-no-audit.rules ] ; then
230                cp %{_datadir}/%{name}/sample-rules/10-no-audit.rules /etc/audit/rules.d/audit.rules
231        else
232                touch /etc/audit/rules.d/audit.rules
233        fi
234        chmod 0600 /etc/audit/rules.d/audit.rules
235fi
236%if %{with systemd}
237%systemd_post auditd.service
238%else
239/sbin/chkconfig --add auditd
240%endif
241
242%preun
243%if %{with systemd}
244%systemd_preun auditd.service
245%else
246if [ $1 -eq 0 -o -x /bin/systemctl ]; then
247   /sbin/service auditd stop > /dev/null 2>&1
248   /sbin/chkconfig --del auditd
249fi
250%endif
251
252%postun
253%if %{with systemd}
254%systemd_postun_with_restart auditd.service
255%else
256if [ $1 -ge 1 ]; then
257   /sbin/service auditd condrestart > /dev/null 2>&1 || :
258fi
259%endif
260
261%post libs -p /sbin/ldconfig
262%postun libs -p /sbin/ldconfig
263
264%post -n compat32-%{name}-libs -p /sbin/ldconfig
265%postun -n compat32-%{name}-libs -p /sbin/ldconfig
266
267
268%files libs
269%defattr(-,root,root)
270%{!?_licensedir:%global license %%doc}
271%license COPYING.LIB
272/%{_lib}/libaudit.*
273/%{_lib}/libauparse.*
274%config(noreplace) %attr(640,root,root) /etc/libaudit.conf
275%{_mandir}/man5/libaudit.conf.5.gz
276
277%files libs-devel
278%defattr(-,root,root)
279%{!?_licensedir:%global license %%doc}
280%license COPYING.LIB
281%doc contrib/skeleton.c contrib/plugin
282%{_libdir}/libaudit.a
283%{_libdir}/libauparse.a
284%{_libdir}/libaudit.so
285%{_libdir}/libauparse.so
286%{_includedir}/libaudit.h
287%{_includedir}/auparse.h
288%{_includedir}/auparse-defs.h
289%{_datadir}/aclocal/audit.m4
290%{_libdir}/pkgconfig/audit.pc
291%{_libdir}/pkgconfig/auparse.pc
292%{_mandir}/man3/*
293
294%files libs-python
295%defattr(-,root,root)
296%attr(755,root,root) %{python_sitearch}/_audit.so
297%attr(755,root,root) %{python_sitearch}/auparse.so
298%{python_sitearch}/audit.py*
299
300%files libs-python3
301%defattr(-,root,root,-)
302%attr(755,root,root) %{python3_sitearch}/*
303
304%files
305%defattr(-,root,root,-)
306%doc README ChangeLog rules init.d/auditd.cron
307%{!?_licensedir:%global license %%doc}
308%license COPYING
309%dir %{_datadir}/%{name}
310%dir %{_datadir}/%{name}/sample-rules
311%attr(644,root,root) %{_datadir}/%{name}/sample-rules/*
312%attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
313%attr(644,root,root) %{_mandir}/man8/auditd.8.gz
314%attr(644,root,root) %{_mandir}/man8/aureport.8.gz
315%attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
316%attr(644,root,root) %{_mandir}/man8/autrace.8.gz
317%attr(644,root,root) %{_mandir}/man8/aulast.8.gz
318%attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
319%attr(644,root,root) %{_mandir}/man8/auvirt.8.gz
320%attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
321%attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
322%attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
323%attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
324%attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
325%attr(644,root,root) %{_mandir}/man5/auditd-plugins.5.gz
326%attr(750,root,root) /sbin/auditctl
327%attr(750,root,root) /sbin/auditd
328%attr(755,root,root) /sbin/ausearch
329%attr(755,root,root) /sbin/aureport
330%attr(750,root,root) /sbin/autrace
331%attr(750,root,root) /sbin/augenrules
332%attr(750,root,root) %{_bindir}/aulastlog
333%attr(750,root,root) %{_bindir}/aulast
334%attr(755,root,root) %{_bindir}/ausyscall
335%attr(755,root,root) %{_bindir}/auvirt
336%attr(750,root,root) %dir %{_var}/log/audit
337%attr(750,root,root) %dir /etc/audit
338%attr(750,root,root) %dir /etc/audit/rules.d
339%attr(750,root,root) %dir /etc/audit/plugins.d
340%config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
341%ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
342%ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
343%config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
344%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/af_unix.conf
345%if %{with systemd}
346%attr(644,root,root) %{_unitdir}/auditd.service
347%else
348%config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
349%attr(755,root,root) /etc/rc.d/init.d/auditd
350%endif
351
352%files -n audispd-plugins
353%defattr(-,root,root,-)
354%config(noreplace) %attr(640,root,root) /etc/audit/audisp-remote.conf
355%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-remote.conf
356%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/syslog.conf
357%config(noreplace) %attr(640,root,root) /etc/audit/audisp-statsd.conf
358%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-statsd.conf
359%attr(750,root,root) /sbin/audisp-remote
360%attr(750,root,root) /sbin/audisp-syslog
361%attr(750,root,root) /sbin/audisp-statsd
362%attr(700,root,root) %dir %{_var}/spool/audit
363%attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
364%attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
365%attr(644,root,root) %{_mandir}/man8/audisp-syslog.8.gz
366%attr(644,root,root) %{_mandir}/man8/audisp-statsd.8.gz
367
368%files -n audispd-plugins-zos
369%attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
370%attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
371%config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/audispd-zos-remote.conf
372%config(noreplace) %attr(640,root,root) /etc/audit/zos-remote.conf
373%attr(750,root,root) /sbin/audispd-zos-remote
374
375%if %{build_compat32}
376%files -n compat32-%{name}-libs
377%{!?_licensedir:%global license %%doc}
378%license COPYING.LIB
379%defattr(-,root,root)
380%attr(755,root,root) /%{_lib}/libaudit.*
381%attr(755,root,root) /%{_lib}/libauparse.*
382%endif
383
384
385%changelog
386* Fri Feb 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
387- new upstream release.
388- dropped Patch1.
389- imported Patch1 from rawhide.
390
391* Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-1
392- new upstream release.
393- imported Patch1 from rawhide.
394
395* Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
396- new upstream release.
397- dropped all patches.
398- dropped system-config-audit.
399- added python3 bindings.
400
401* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
402- fix sca_release
403
404* Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
405- create compat32-audit-libs subpackage
406
407* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
408- rebuild with python-2.7.2
409- add Patch12 (audit-1.7.18-libaudit.patch)
410
411* Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
412- new upstream release
413- rebuild with krb5-1.8.2
414
415* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
416- forgot to increment sca_release macro (why on earth is sca_release
417  individually defined from main package's release number anyway?)
418
419* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
420- rebuilt with gcc-4.4.3-3 on ppc
421
422* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
423- rebuilt with rpm-4.8.0-3 (on ppc)
424
425* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
426- rebuild with python-2.6
427
428* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
429- rebuild with openldap-2.4.11
430
431* Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
432- initial build for Vine Linux
433- disable krb5, prelude and selinux
434- add ja.po (XXX: minimal)
435
436* Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
437- Add subject to audit daemon events (Chu Li)
438- Add tcp_wrappers support for auditd
439- Updated syscall tables for 2.6.27 kernel
440- Audit connect/disconnect of remote clients
441- Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
442
443* Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
444- Update system-config-audit to 0.4.8
445- Whole lot of bug fixes - see ChangeLog for details
446- Reimplement auditd main loop using libev
447- Add TCP listener to auditd to receive remote events
448- Fix scheduler problem (#457061)
449
450* Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
451- Move ausearch-expression to main package (#453437)
452
453* Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
454- Fix interpreting of keys in syscall records
455- Don't error on name=(null) PATH records in ausearch/report
456- Add key report to aureport
457- Update system-config-audit to 0.4.7 (Miloslav Trmac)
458- Add support for the filetype field option in auditctl new to 2.6.26 kernels
459
460* Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
461- Fix output of keys in ausearch interpretted mode
462- Fix ausearch/report --start now to not be reset to midnight
463- audispd now has a priority boost config option
464- Look for laddr in avcs reported via prelude
465- Detect page 0 mmaps and alert via prelude
466
467* Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
468- Fix overflow in audit_log_user_command, better (#438840)
469- ausearch was not matching path in avc records
470- audisp-prelude attempt to reposition index after examining each type
471- correct building of mls policy
472- Fix auparse iterating in auparse_find_field and next_field
473- Don't alert on USER_AVC's - they are not quite right
474
475* Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
476- Fix buffer overflow in audit_log_user_command, again (#438840)
477- Fix memory leak in EOE code in auditd (#440075)
478- In auditctl, don't use new operators in legacy rule format
479- Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
480
481* Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
482- Fix memleak in auditd eoe code
483
484* Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
485- Remove LSB headers from init scripts
486- Fix buffer overflow in audit_log_user_command again
487
488* Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
489- Handle user space avcs in prelude plugin
490- Fix watched account login detection for some failed login attempts
491- Couple fixups in audit logging functions (Miloslav Trmac)
492- Add support in auditctl for virtual keys
493- auparse_find_field_next was not iterating correctly, fixed it
494- Add idmef alerts for access or execution of watched file
495- Fix buffer overflow in audit_log_user_command
496- Add basic remote logging plugin - only sends & no flow control
497- Update ausearch with interpret fixes from auparse
498
499* Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
500- Apply hidden attribute cleanup patch (Miloslav Trmac)
501- Apply auparse expression interface patch (Miloslav Trmac)
502- Fix potential memleak in audit event dispatcher
503- Update system-config-audit to version 0.4.6 (Miloslav Trmac)
504- audisp-prelude alerts now controlled by config file
505- Updated syscall table for 2.6.25 kernel
506- Apply patch correcting acct field being misencoded (Miloslav Trmac)
507- Added watched account login detection for prelude plugin
508
509* Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
510- Update for gcc 4.3
511- Cleanup descriptors in audispd before running plugin
512- Fix 'recent' keyword for aureport/search
513- Fix SE Linux policy for zos_remote plugin
514- Add event type for group password authentication attempts
515- Couple of updates to the translation tables
516- Add detection of failed group authentication to audisp-prelude
517
518* Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
519- In ausearch/report, prefer -if to stdin
520- In ausearch/report, add new command line option --input-logs (#428860)
521- Updated audisp-prelude based on feedback from prelude-devel
522- Added prelude alert for promiscuous socket being opened
523- Added prelude alert for SE Linux policy enforcement changes
524- Added prelude alerts for Forbidden Login Locations and Time
525- Applied patch to auparse fixing error handling of searching by
526  interpreted value (Miloslav Trmac)
527
528* Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
529- Add prelude IDS plugin for IDMEF alerts
530- Add --user option to aulastlog command
531- Use desktop-file-install for system-config-audit
532- Avoid touching auditd.conf most of the time (#408501)
533
534* Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
535- Updates for spec file review
536- Adjust permission on selinux policy file
537
538* Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
539- Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
540- Check for audit log being writable by owner in auditd
541- If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
542- Updated CAPP, LSPP, and NISPOM rules for new capabilities
543- Added aulastlog utility
544
545* Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
546- Allow 0600 file perms for audit logs
547
548* Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
549- fchmod of log file was on wrong variable (#426934)
550- Allow use of errno strings for exit codes in audit rules
551
552* Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
553- Don't fchmod() /dev/null to mode 0400 (#426934)
554
555* Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
556- Add kernel release string to DEAMON_START events
557- Fix keep_logs when num_logs option disabled (#325561)
558- Fix auparse to handle node fields for syscall records
559- Update system-config-audit to version 0.4.5 (Miloslav Trmac)
560- Add keyword week-ago to aureport & ausearch start/end times
561- Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
562- Add RACF zos remote audispd plugin (Klaus Kiwi)
563- Add event queue overflow action to audispd
564
565* Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
566- Don't retry if the rt queue is full.
567
568* Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
569- Add support for searching by posix regular expressions in auparse
570- Route DEAMON events into rt interface
571- If event pipe is full, try again after doing local logging
572- Optionally add node/machine name to records in audit daemon
573- Update ausearch/aureport to specify nodes to search on
574- Fix segfault interpretting saddr fields in avcs
575
576* Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
577- Fix uninitialized variable in auparse (John Dennis)
578
579* Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
580- External plugin support in place
581- Fix reference counting in auparse python bindings (#263961)
582- Moved default af_unix plugin socket to /var/run/audispd_events
583
584* Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
585- Add newline to audispd string formatted events
586
587* Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
588- spec file cleanups
589- Update to s-c-audit 0.4.3
590
591* Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
592- Update Licence tags
593- Adding perm field should not set syscall added flag in auditctl
594- Fix segfault when aureport -if option is used
595- Fix auditctl to better check keys on rule lines
596- Add support for audit by TTY and other new event types
597- Auditd config option for group permission of audit logs
598- Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
599- New audit event dispatcher
600- Update syscall tables for 2.6.23 kernel
601
602* Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
603- Fix potential buffer overflow in print clone flags of auparse
604- Fix python traceback parsing watches without perm statement (Miloslav Trmac)
605- Update auditctl to handle legacy kernels when putting a watch on a dir
606- Fix acct interpretation in auparse
607
608* Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
609- Fix a double free when auditd receives SIGHUP
610- Move the system-config-audit menu entry to the Administration menu
611
612* Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
613- Add system-config-audit (Miloslav Trmac)
614- Correct bug in audit_make_equivalent function (Al Viro)
615
616* Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
617- Add feed interface to auparse library (John Dennis)
618- Apply patch to libauparse for unresolved symbols (#241178)
619- Apply patch to add line numbers for file events in libauparse (John Dennis)
620- Change seresults to seresult in libauparse (John Dennis)
621- Add unit32_t definition to swig (#244210)
622- Add support for directory auditing
623- Update acct field to be escaped
624
625* Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
626- Change buffer size to prevent truncation of DAEMON events with large labels
627- Fix memory leaks in auparse (John Dennis)
628- Update syscall tables for 2.6.21 kernel
629- Update capp & lspp rules
630- New python bindings for libauparse (John Dennis)
631
632* Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
633- New event dispatcher (James Antill)
634- Apply patches fixing man pages and Makefile.am (Philipp Hahn)
635- Apply patch correcting python libs permissions (Philipp Hahn)
636- Fix auditd segfault on reload
637- Fix bug in auparse library for file pointers and descriptors
638- Extract subject information out of daemon events for ausearch
639
640* Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
641- Remove requires kernel-headers for python-libs
642- Apply patch to prevent segfaults on auditd reload
643
644* Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
645- Updated autrace to monitor *at syscalls
646- Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
647- Finish reworking auditd config parser
648- In auparse, interpret open, fcntl, and clone flags
649- In auparse, when interpreting execve record types, run args through unencode
650- Add support for OBJ_PID message type
651- Event dispatcher updates
652
653* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
654- rebuild
655
656* Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
657- NEW audit dispatcher program & plugin framework
658- Correct hidden variables in libauparse
659- Added NISPOM sample rules
660- Verify accessibility of files passed in auparse_init
661- Fix bug in parser library interpreting socketcalls
662- Add support for stdio FILE pointer in auparse_init
663- Adjust init script to allow anyone to status auditd (#230626)
664
665* Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
666- Add man pages
667- Reduce text relocations in parser library
668- Add -n option to auditd for no fork
669- Add exec option to space_left, admin_space_left, disk_full,
670  and disk_error - eg EXEC /usr/local/script
671
672* Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
673- updated audit_rule_fieldpair_data to handle perm correctly (#226780)
674- Finished search options for audit parsing library
675- Fix ausearch -se to work correctly
676- Fix auditd init script for /usr on netdev (#228528)
677- Parse avc seperms better when there are more than one
678
679* Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
680- New report about authentication attempts
681- Updates for python 2.5
682- update autrace to have resource usage mode
683- update auditctl to support immutable config
684- added audit_log_user_command function to libaudit api
685- interpret capabilities
686- added audit event parsing library
687- updates for 2.6.20 kernel
688
689* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
690- Make more adjustments for python 2.5
691
692* Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
693- Fix a couple parsing problems (#217952)
694- Add tgkill to S390* syscall tables (#218484)
695- Fix error messages in ausearch/aureport
696
697* Wed Dec  6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
698- rebuild against python 2.5
699
700* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
701- Fix timestamp for libaudit.conf (#218053)
702
703* Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
704- Fix minor parsing problem and add new msg types
705
706* Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
707- ausearch & aureport implement uid/gid caching
708- In ausearch & aureport, extract addr when hostname is unknown
709- In ausearch & aureport, test audit log presence O_RDONLY
710- New ausearch/aureport time keywords: recent, this-week, this-month, this-year
711- Added --add & --delete option to aureport
712- Update res parsing in config change events
713- Increase the size on audit daemon buffers
714- Parse avc_path records in ausearch/aureport
715- ausearch has new output mode, raw, for extracting events
716- ausearch/aureport can now read stdin
717- Rework AVC processing in ausearch/aureport
718- Added long options to ausearch and aureport
719
720* Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
721- In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
722- Fix some defines in libaudit.h
723- Some auditd config strings were not initialized in aureport (#211443)
724- Updated man pages
725- Add Netlabel event types to libaudit
726- Update aureports to current audit event types
727- Update autrace a little
728- Deprecated all the old audit_rule functions from public API
729- Drop auparse library for the moment
730
731* Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
732- Add dist tag and bump version (#208532)
733- Make internal auditd buffers bigger for context info
734- Correct address resolving of hostname in logging functions
735- Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
736- Only =, != operators for arch & inode fields in auditctl (#206427)
737- Updated audit message type table
738- Remove watches from aureport since FS_WATCH is deprecated
739- Add audit_log_avc back temporarily (#208152)
740 
Note: See TracBrowser for help on using the repository browser.