source: projects/specs/trunk/a/attr/attr-vl.spec @ 9747

Revision 9747, 10.5 KB checked in by tomop, 9 years ago (diff)

attr-2.4.47-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Utilities for managing filesystem extended attributes
4Name: attr
5Version: 2.4.47
6Release: 2%{?_dist_release}
7
8License: GPLv2+
9URL: http://oss.sgi.com/projects/xfs/
10Group: System Environment/Base
11
12Source: http://download.savannah.gnu.org/releases-noredirect/attr/attr-%{version}.src.tar.gz
13
14# silence compile-time warnings
15Patch1: 0001-attr-2.4.47-warnings.patch
16
17# install /etc/xattr.conf
18Patch2: 0002-attr-2.4.47-xattr-conf.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gettext
22BuildRequires: libtool
23Requires: libattr = %{version}-%{release}
24
25Conflicts: xfsdump < 2.0.0
26
27%description
28A set of tools for manipulating extended attributes on filesystem
29objects, in particular getfattr(1) and setfattr(1).
30An attr(1) command is also provided which is largely compatible
31with the SGI IRIX tool of the same name.
32
33%package -n libattr
34Summary: Dynamic library for extended attribute support
35Group: System Environment/Libraries
36License: LGPLv2+
37
38%description -n libattr
39This package contains the libattr.so dynamic library which contains
40the extended attribute system calls and library functions.
41
42%package -n libattr-devel
43Summary: Extended attribute static libraries and headers
44Group: Development/Libraries
45License: LGPLv2+
46Requires: libattr = %{version}-%{release}
47
48%description -n libattr-devel
49This package contains the libraries and header files needed to
50develop programs which make use of extended attributes.
51For Linux programs, the documented system call API is the
52recommended interface, but an SGI IRIX compatibility interface
53is also provided.
54
55Currently only ext2, ext3 and XFS support extended attributes.
56The SGI IRIX compatibility API built above the Linux system calls is
57used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
58
59You should install libattr-devel if you want to develop programs
60which make use of extended attributes.  If you install libattr-devel,
61you'll also want to install attr.
62
63# compat32
64%package -n compat32-libattr
65Summary: Dynamic library for extended attribute support
66Group: System Environment/Libraries
67License: LGPLv2+
68
69%description -n compat32-libattr
70This package contains the libattr.so dynamic library which contains
71the extended attribute system calls and library functions.
72
73%package -n compat32-libattr-devel
74Summary: Extended attribute static libraries and headers
75Group: Development/Libraries
76License: LGPLv2+
77Requires: libattr-devel = %{version}-%{release}
78Requires: compat32-libattr = %{version}-%{release}
79
80%description -n compat32-libattr-devel
81This package contains the libraries and header files needed to
82develop programs which make use of extended attributes.
83For Linux programs, the documented system call API is the
84recommended interface, but an SGI IRIX compatibility interface
85is also provided.
86
87Currently only ext2, ext3 and XFS support extended attributes.
88The SGI IRIX compatibility API built above the Linux system calls is
89used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
90
91You should install libattr-devel if you want to develop programs
92which make use of extended attributes.  If you install libattr-devel,
93you'll also want to install attr.
94
95
96%prep
97%setup -q
98%patch1 -p1
99%patch2 -p1
100
101%build
102# attr abuses libexecdir
103%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
104make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
105
106%install
107rm -rf %{buildroot}
108make install DESTDIR=%{buildroot}
109make install-dev DESTDIR=%{buildroot}
110make install-lib DESTDIR=%{buildroot}
111
112# get rid of libattr.a and libattr.la
113rm -f %{buildroot}/%{_lib}/libattr.a
114rm -f %{buildroot}/%{_lib}/libattr.la
115rm -f %{buildroot}%{_libdir}/libattr.a
116rm -f %{buildroot}%{_libdir}/libattr.la
117
118# fix links to shared libs and permissions
119rm -f %{buildroot}%{_libdir}/libattr.so
120mkdir -p %{buildroot}%{_libdir}
121ln -sf ../../%{_lib}/libattr.so %{buildroot}%{_libdir}/libattr.so
122chmod 0755 %{buildroot}/%{_lib}/libattr.so.*.*.*
123
124# remove documents without version
125rm -rf %{buildroot}%{_datadir}/doc/attr
126
127%find_lang %{name}
128
129%check
130if ./setfattr/setfattr -n user.name -v value .; then
131    make tests || exit $?
132
133    # FIXME: root-tests are not ready for the SELinux
134    #if test 0 = `id -u`; then
135    #    make root-tests || exit $?
136    #fi
137else
138    echo '*** xattrs are probably not supported by the file system,' \
139         'the test-suite will NOT run ***'
140fi
141
142%clean
143rm -rf %{buildroot}
144
145%post -n libattr
146/sbin/ldconfig
147
148%postun -n libattr
149/sbin/ldconfig
150
151%post -n compat32-libattr
152/sbin/ldconfig
153
154%postun -n compat32-libattr
155/sbin/ldconfig
156
157%files -f %{name}.lang
158%defattr(-,root,root)
159%doc doc
160%{_bindir}/attr
161%{_bindir}/getfattr
162%{_bindir}/setfattr
163%{_mandir}/man1/attr.1*
164%{_mandir}/man1/getfattr.1*
165%{_mandir}/man1/setfattr.1*
166#%{_mandir}/man5/attr.5*
167%exclude %{_mandir}/man5/attr.5*
168
169%files -n libattr-devel
170%defattr(-,root,root)
171/%{_lib}/libattr.so
172%{_includedir}/attr
173%{_libdir}/libattr.*
174%{_mandir}/man2/*attr.2*
175%{_mandir}/man3/attr_*.3.*
176
177%files -n libattr
178/%{_lib}/libattr.so.*
179%config(noreplace) %{_sysconfdir}/xattr.conf
180
181# compat32
182%if %{build_compat32}
183%files -n compat32-libattr-devel
184%defattr(-,root,root)
185/%{_lib}/libattr.so
186%{_libdir}/libattr.*
187
188%files -n compat32-libattr
189/%{_lib}/libattr.so.*
190%config(noreplace) %{_sysconfdir}/xattr.conf
191%endif
192
193%changelog
194* Fri Sep 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-2
195- removed a manpage (attr.5).
196
197* Fri Jul  4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-1
198- new upstream release.
199- replaced patches to the newest rawhide's.
200
201* Sat Apr  9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
202- new upstream release
203- remove static library from devel package
204- added Patch2-9
205  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
206  - fix typos in attr(1) man page (#669095)
207  * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
208  - setfattr.1: document supported encodings of values (#587516)
209  - getfattr: encode NULs properly with --encoding=text (#650539)
210  - getfattr: return non-zero exit code on failure (#660619)
211  - walk_tree: do not follow symlink to directory with -h (#660613)
212  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
213  - let attr depend on the same version of libattr (#595689)
214  - silence compile-time warnings
215  * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
216  - Fixed memory leaks (#485473)
217
218* Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
219- added compat32 package for x86_64 arch support
220
221* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
222- new upstream release
223
224* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
225- initial build for Vine Linux
226
227* Wed Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
228- New version 2.4.41
229- Removed useless attr-2.0.8-docperms.patch
230
231* Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
232- New version 2.4.39
233- Resolves #284121
234
235* Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
236- Removed explicit Requires(post + postun)
237- Resolves #225290
238
239* Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
240- New version 2.4.38
241- Resolves #245415
242
243* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
244- add disttag
245- remove trailing dot from summary
246- fix buildroot
247- -devel package requires same libattr version
248- change prereq to Requires(post)
249- escape macro in changelog
250- replace absolute link with relative link (libattr.so)
251- use %%doc macro
252
253* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
254- rebuild
255
256* Wed Jul  5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
257- new version 2.4.32
258- fixes segmentation fault in attr, which affects #189106
259
260* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
261- rebuild for -devel deps
262
263* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
264- bump again for double-long bug on ppc(64)
265
266* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
267- rebuilt for new gcc4.1 snapshot and glibc changes
268
269* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
270- new version 2.4.28
271
272* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
273- rebuilt
274
275* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
276- spec file cleanup
277- mark po files as lang specific
278
279* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
280- 2.4.24
281
282* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
283- update to 2.4.23
284
285* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
286- get rid of *.la files
287- remove duplicate doc files
288
289* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
290- Rebuild
291
292* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
293- Build requires libtool >= 1.5
294
295* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
296- Make libattr.so.* executable.
297
298* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
299- Update to latest upstream version.
300
301* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
302- Fix bug #125304 (Steve Grubb: build requires gettext)
303
304* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
305- rebuilt
306
307* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
308- Add missing %%defattr
309
310* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
311- Add /usr/include/attr to files manifest
312- Fix location of doc files, add main doc dir to files manifest
313
314* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
315- rebuilt
316
317* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
318- rebuilt
319
320* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
321- Fix libtool
322
323* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
324- update to attr-2.4.1
325
326* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
327- update/rebuild
328
329* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
330- set execute bits on library so that requires are generated.
331
332* Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
333- Redo multilib patch to work everywhere
334
335* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
336- Added fix to install libs in correct directory on 64bit machine
337
338* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
339- Made the package only own the one directory that is unique to it:
340  /usr/include/attr
341
342* Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
343- get perl out of base with attr-2.0.8-docperms.patch
344
345* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
346- Initial Red Hat package
347  Made as few changes as possible relative to upstream packaging to
348  make it easier to maintain long-term.  This means that some of
349  the techniques used here are definitely not standard Red Hat
350  techniques.  If you are looking for an example package to fit
351  into Red Hat Linux transparently, this would not be the one to
352  pick.
353- attr-devel -> libattr-devel
Note: See TracBrowser for help on using the repository browser.