source: projects/specs/trunk/a/attr/attr-vl.spec @ 8735

Revision 8735, 10.4 KB checked in by tomop, 10 years ago (diff)

filesystem tools.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Utilities for managing filesystem extended attributes
4Name: attr
5Version: 2.4.47
6Release: 1%{?_dist_release}
7
8License: GPLv2+
9URL: http://oss.sgi.com/projects/xfs/
10Group: System Environment/Base
11
12Source: http://download.savannah.gnu.org/releases-noredirect/attr/attr-%{version}.src.tar.gz
13
14# silence compile-time warnings
15Patch1: 0001-attr-2.4.47-warnings.patch
16
17# install /etc/xattr.conf
18Patch2: 0002-attr-2.4.47-xattr-conf.patch
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires: gettext
22BuildRequires: libtool
23Requires: libattr = %{version}-%{release}
24
25Conflicts: xfsdump < 2.0.0
26
27%description
28A set of tools for manipulating extended attributes on filesystem
29objects, in particular getfattr(1) and setfattr(1).
30An attr(1) command is also provided which is largely compatible
31with the SGI IRIX tool of the same name.
32
33%package -n libattr
34Summary: Dynamic library for extended attribute support
35Group: System Environment/Libraries
36License: LGPLv2+
37
38%description -n libattr
39This package contains the libattr.so dynamic library which contains
40the extended attribute system calls and library functions.
41
42%package -n libattr-devel
43Summary: Extended attribute static libraries and headers
44Group: Development/Libraries
45License: LGPLv2+
46Requires: libattr = %{version}-%{release}
47
48%description -n libattr-devel
49This package contains the libraries and header files needed to
50develop programs which make use of extended attributes.
51For Linux programs, the documented system call API is the
52recommended interface, but an SGI IRIX compatibility interface
53is also provided.
54
55Currently only ext2, ext3 and XFS support extended attributes.
56The SGI IRIX compatibility API built above the Linux system calls is
57used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
58
59You should install libattr-devel if you want to develop programs
60which make use of extended attributes.  If you install libattr-devel,
61you'll also want to install attr.
62
63# compat32
64%package -n compat32-libattr
65Summary: Dynamic library for extended attribute support
66Group: System Environment/Libraries
67License: LGPLv2+
68
69%description -n compat32-libattr
70This package contains the libattr.so dynamic library which contains
71the extended attribute system calls and library functions.
72
73%package -n compat32-libattr-devel
74Summary: Extended attribute static libraries and headers
75Group: Development/Libraries
76License: LGPLv2+
77Requires: libattr-devel = %{version}-%{release}
78Requires: compat32-libattr = %{version}-%{release}
79
80%description -n compat32-libattr-devel
81This package contains the libraries and header files needed to
82develop programs which make use of extended attributes.
83For Linux programs, the documented system call API is the
84recommended interface, but an SGI IRIX compatibility interface
85is also provided.
86
87Currently only ext2, ext3 and XFS support extended attributes.
88The SGI IRIX compatibility API built above the Linux system calls is
89used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
90
91You should install libattr-devel if you want to develop programs
92which make use of extended attributes.  If you install libattr-devel,
93you'll also want to install attr.
94
95
96%prep
97%setup -q
98%patch1 -p1
99%patch2 -p1
100
101%build
102# attr abuses libexecdir
103%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
104make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
105
106%install
107rm -rf %{buildroot}
108make install DESTDIR=%{buildroot}
109make install-dev DESTDIR=%{buildroot}
110make install-lib DESTDIR=%{buildroot}
111
112# get rid of libattr.a and libattr.la
113rm -f %{buildroot}/%{_lib}/libattr.a
114rm -f %{buildroot}/%{_lib}/libattr.la
115rm -f %{buildroot}%{_libdir}/libattr.a
116rm -f %{buildroot}%{_libdir}/libattr.la
117
118# fix links to shared libs and permissions
119rm -f %{buildroot}%{_libdir}/libattr.so
120mkdir -p %{buildroot}%{_libdir}
121ln -sf ../../%{_lib}/libattr.so %{buildroot}%{_libdir}/libattr.so
122chmod 0755 %{buildroot}/%{_lib}/libattr.so.*.*.*
123
124# remove documents without version
125rm -rf %{buildroot}%{_datadir}/doc/attr
126
127%find_lang %{name}
128
129%check
130if ./setfattr/setfattr -n user.name -v value .; then
131    make tests || exit $?
132
133    # FIXME: root-tests are not ready for the SELinux
134    #if test 0 = `id -u`; then
135    #    make root-tests || exit $?
136    #fi
137else
138    echo '*** xattrs are probably not supported by the file system,' \
139         'the test-suite will NOT run ***'
140fi
141
142%clean
143rm -rf %{buildroot}
144
145%post -n libattr
146/sbin/ldconfig
147
148%postun -n libattr
149/sbin/ldconfig
150
151%post -n compat32-libattr
152/sbin/ldconfig
153
154%postun -n compat32-libattr
155/sbin/ldconfig
156
157%files -f %{name}.lang
158%defattr(-,root,root)
159%doc doc
160%{_bindir}/attr
161%{_bindir}/getfattr
162%{_bindir}/setfattr
163%{_mandir}/man1/attr.1*
164%{_mandir}/man1/getfattr.1*
165%{_mandir}/man1/setfattr.1*
166%{_mandir}/man5/attr.5*
167
168%files -n libattr-devel
169%defattr(-,root,root)
170/%{_lib}/libattr.so
171%{_includedir}/attr
172%{_libdir}/libattr.*
173%{_mandir}/man2/*attr.2*
174%{_mandir}/man3/attr_*.3.*
175
176%files -n libattr
177/%{_lib}/libattr.so.*
178%config(noreplace) %{_sysconfdir}/xattr.conf
179
180# compat32
181%if %{build_compat32}
182%files -n compat32-libattr-devel
183%defattr(-,root,root)
184/%{_lib}/libattr.so
185%{_libdir}/libattr.*
186
187%files -n compat32-libattr
188/%{_lib}/libattr.so.*
189%config(noreplace) %{_sysconfdir}/xattr.conf
190%endif
191
192%changelog
193* Fri Jul  4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-1
194- new upstream release.
195- replaced patches to the newest rawhide's.
196
197* Sat Apr  9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
198- new upstream release
199- remove static library from devel package
200- added Patch2-9
201  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
202  - fix typos in attr(1) man page (#669095)
203  * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
204  - setfattr.1: document supported encodings of values (#587516)
205  - getfattr: encode NULs properly with --encoding=text (#650539)
206  - getfattr: return non-zero exit code on failure (#660619)
207  - walk_tree: do not follow symlink to directory with -h (#660613)
208  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
209  - let attr depend on the same version of libattr (#595689)
210  - silence compile-time warnings
211  * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
212  - Fixed memory leaks (#485473)
213
214* Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
215- added compat32 package for x86_64 arch support
216
217* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
218- new upstream release
219
220* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
221- initial build for Vine Linux
222
223* Wed Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
224- New version 2.4.41
225- Removed useless attr-2.0.8-docperms.patch
226
227* Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
228- New version 2.4.39
229- Resolves #284121
230
231* Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
232- Removed explicit Requires(post + postun)
233- Resolves #225290
234
235* Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
236- New version 2.4.38
237- Resolves #245415
238
239* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
240- add disttag
241- remove trailing dot from summary
242- fix buildroot
243- -devel package requires same libattr version
244- change prereq to Requires(post)
245- escape macro in changelog
246- replace absolute link with relative link (libattr.so)
247- use %%doc macro
248
249* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
250- rebuild
251
252* Wed Jul  5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
253- new version 2.4.32
254- fixes segmentation fault in attr, which affects #189106
255
256* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
257- rebuild for -devel deps
258
259* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
260- bump again for double-long bug on ppc(64)
261
262* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
263- rebuilt for new gcc4.1 snapshot and glibc changes
264
265* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
266- new version 2.4.28
267
268* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
269- rebuilt
270
271* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
272- spec file cleanup
273- mark po files as lang specific
274
275* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
276- 2.4.24
277
278* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
279- update to 2.4.23
280
281* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
282- get rid of *.la files
283- remove duplicate doc files
284
285* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
286- Rebuild
287
288* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
289- Build requires libtool >= 1.5
290
291* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
292- Make libattr.so.* executable.
293
294* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
295- Update to latest upstream version.
296
297* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
298- Fix bug #125304 (Steve Grubb: build requires gettext)
299
300* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
301- rebuilt
302
303* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
304- Add missing %%defattr
305
306* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
307- Add /usr/include/attr to files manifest
308- Fix location of doc files, add main doc dir to files manifest
309
310* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
311- rebuilt
312
313* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
314- rebuilt
315
316* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
317- Fix libtool
318
319* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
320- update to attr-2.4.1
321
322* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
323- update/rebuild
324
325* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
326- set execute bits on library so that requires are generated.
327
328* Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
329- Redo multilib patch to work everywhere
330
331* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
332- Added fix to install libs in correct directory on 64bit machine
333
334* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
335- Made the package only own the one directory that is unique to it:
336  /usr/include/attr
337
338* Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
339- get perl out of base with attr-2.0.8-docperms.patch
340
341* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
342- Initial Red Hat package
343  Made as few changes as possible relative to upstream packaging to
344  make it easier to maintain long-term.  This means that some of
345  the techniques used here are definitely not standard Red Hat
346  techniques.  If you are looking for an example package to fit
347  into Red Hat Linux transparently, this would not be the one to
348  pick.
349- attr-devel -> libattr-devel
Note: See TracBrowser for help on using the repository browser.