source: projects/specs/trunk/a/attr/attr-vl.spec @ 12120

Revision 12120, 10.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Utilities for managing filesystem extended attributes
4Name: attr
5Version: 2.4.48
6Release: 1%{?_dist_release}
7
8License: GPLv2+
9URL: http://oss.sgi.com/projects/xfs/
10Group: System Environment/Base
11
12Source: http://download.savannah.nongnu.org/releases/attr/attr-%{version}.tar.gz
13
14Vendor:        Project Vine
15Distribution:  Vine Linux
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: gettext
19BuildRequires: libtool
20Requires: libattr = %{version}-%{release}
21
22Conflicts: xfsdump < 2.0.0
23
24%description
25A set of tools for manipulating extended attributes on filesystem
26objects, in particular getfattr(1) and setfattr(1).
27An attr(1) command is also provided which is largely compatible
28with the SGI IRIX tool of the same name.
29
30%package -n libattr
31Summary: Dynamic library for extended attribute support
32Group: System Environment/Libraries
33License: LGPLv2+
34
35%description -n libattr
36This package contains the libattr.so dynamic library which contains
37the extended attribute system calls and library functions.
38
39%package -n libattr-devel
40Summary: Extended attribute static libraries and headers
41Group: Development/Libraries
42License: LGPLv2+
43Requires: libattr = %{version}-%{release}
44
45%description -n libattr-devel
46This package contains the libraries and header files needed to
47develop programs which make use of extended attributes.
48For Linux programs, the documented system call API is the
49recommended interface, but an SGI IRIX compatibility interface
50is also provided.
51
52Currently only ext2, ext3 and XFS support extended attributes.
53The SGI IRIX compatibility API built above the Linux system calls is
54used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
55
56You should install libattr-devel if you want to develop programs
57which make use of extended attributes.  If you install libattr-devel,
58you'll also want to install attr.
59
60# compat32
61%package -n compat32-libattr
62Summary: Dynamic library for extended attribute support
63Group: System Environment/Libraries
64License: LGPLv2+
65
66%description -n compat32-libattr
67This package contains the libattr.so dynamic library which contains
68the extended attribute system calls and library functions.
69
70%package -n compat32-libattr-devel
71Summary: Extended attribute static libraries and headers
72Group: Development/Libraries
73License: LGPLv2+
74Requires: libattr-devel = %{version}-%{release}
75Requires: compat32-libattr = %{version}-%{release}
76
77%description -n compat32-libattr-devel
78This package contains the libraries and header files needed to
79develop programs which make use of extended attributes.
80For Linux programs, the documented system call API is the
81recommended interface, but an SGI IRIX compatibility interface
82is also provided.
83
84Currently only ext2, ext3 and XFS support extended attributes.
85The SGI IRIX compatibility API built above the Linux system calls is
86used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
87
88You should install libattr-devel if you want to develop programs
89which make use of extended attributes.  If you install libattr-devel,
90you'll also want to install attr.
91
92
93%prep
94%setup -q
95
96%build
97# attr abuses libexecdir
98%configure --libdir=/%{_lib} --libexecdir=%{_libdir}
99make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
100
101%install
102rm -rf %{buildroot}
103make install DESTDIR=%{buildroot}
104#make install-dev DESTDIR=%{buildroot}
105#make install-lib DESTDIR=%{buildroot}
106
107# get rid of libattr.a and libattr.la
108rm -f %{buildroot}/%{_lib}/libattr.a
109rm -f %{buildroot}/%{_lib}/libattr.la
110rm -f %{buildroot}%{_libdir}/libattr.a
111rm -f %{buildroot}%{_libdir}/libattr.la
112
113# fix links to shared libs and permissions
114rm -f %{buildroot}%{_libdir}/libattr.so
115mkdir -p %{buildroot}%{_libdir}
116ln -sf ../../%{_lib}/libattr.so %{buildroot}%{_libdir}/libattr.so
117chmod 0755 %{buildroot}/%{_lib}/libattr.so.*.*.*
118
119# remove documents without version
120rm -rf %{buildroot}%{_datadir}/doc/attr
121
122mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
123
124%find_lang %{name}
125
126%check
127if ./setfattr/setfattr -n user.name -v value .; then
128    make tests || exit $?
129
130    # FIXME: root-tests are not ready for the SELinux
131    #if test 0 = `id -u`; then
132    #    make root-tests || exit $?
133    #fi
134else
135    echo '*** xattrs are probably not supported by the file system,' \
136         'the test-suite will NOT run ***'
137fi
138
139%clean
140rm -rf %{buildroot}
141
142%post -n libattr
143/sbin/ldconfig
144
145%postun -n libattr
146/sbin/ldconfig
147
148%post -n compat32-libattr
149/sbin/ldconfig
150
151%postun -n compat32-libattr
152/sbin/ldconfig
153
154%files -f %{name}.lang
155%defattr(-,root,root)
156%doc doc
157%{_bindir}/attr
158%{_bindir}/getfattr
159%{_bindir}/setfattr
160%{_mandir}/man1/attr.1*
161%{_mandir}/man1/getfattr.1*
162%{_mandir}/man1/setfattr.1*
163#%{_mandir}/man5/attr.5*
164%exclude %{_mandir}/man5/attr.5*
165
166%files -n libattr-devel
167%defattr(-,root,root)
168/%{_lib}/libattr.so
169%{_includedir}/attr
170%{_libdir}/libattr.*
171%{_libdir}/pkgconfig/*.pc
172%{_mandir}/man3/attr_*.3.*
173
174%files -n libattr
175/%{_lib}/libattr.so.*
176%config(noreplace) %{_sysconfdir}/xattr.conf
177
178# compat32
179%if %{build_compat32}
180%files -n compat32-libattr-devel
181%defattr(-,root,root)
182/%{_lib}/libattr.so
183%{_libdir}/libattr.*
184%{_libdir}/pkgconfig/*.pc
185
186%files -n compat32-libattr
187/%{_lib}/libattr.so.*
188%config(noreplace) %{_sysconfdir}/xattr.conf
189%endif
190
191%changelog
192* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-1
193- new upstream release.
194- dropped Patch1, 2.
195
196* Fri Sep 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-2
197- removed a manpage (attr.5).
198
199* Fri Jul  4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-1
200- new upstream release.
201- replaced patches to the newest rawhide's.
202
203* Sat Apr  9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
204- new upstream release
205- remove static library from devel package
206- added Patch2-9
207  * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
208  - fix typos in attr(1) man page (#669095)
209  * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
210  - setfattr.1: document supported encodings of values (#587516)
211  - getfattr: encode NULs properly with --encoding=text (#650539)
212  - getfattr: return non-zero exit code on failure (#660619)
213  - walk_tree: do not follow symlink to directory with -h (#660613)
214  * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
215  - let attr depend on the same version of libattr (#595689)
216  - silence compile-time warnings
217  * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
218  - Fixed memory leaks (#485473)
219
220* Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
221- added compat32 package for x86_64 arch support
222
223* Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
224- new upstream release
225
226* Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
227- initial build for Vine Linux
228
229* Wed Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
230- New version 2.4.41
231- Removed useless attr-2.0.8-docperms.patch
232
233* Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
234- New version 2.4.39
235- Resolves #284121
236
237* Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
238- Removed explicit Requires(post + postun)
239- Resolves #225290
240
241* Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
242- New version 2.4.38
243- Resolves #245415
244
245* Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
246- add disttag
247- remove trailing dot from summary
248- fix buildroot
249- -devel package requires same libattr version
250- change prereq to Requires(post)
251- escape macro in changelog
252- replace absolute link with relative link (libattr.so)
253- use %%doc macro
254
255* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
256- rebuild
257
258* Wed Jul  5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
259- new version 2.4.32
260- fixes segmentation fault in attr, which affects #189106
261
262* Wed Jun  7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
263- rebuild for -devel deps
264
265* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
266- bump again for double-long bug on ppc(64)
267
268* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
269- rebuilt for new gcc4.1 snapshot and glibc changes
270
271* Fri Feb  3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
272- new version 2.4.28
273
274* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
275- rebuilt
276
277* Tue Dec  6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
278- spec file cleanup
279- mark po files as lang specific
280
281* Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
282- 2.4.24
283
284* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
285- update to 2.4.23
286
287* Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
288- get rid of *.la files
289- remove duplicate doc files
290
291* Wed Feb  9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
292- Rebuild
293
294* Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
295- Build requires libtool >= 1.5
296
297* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
298- Make libattr.so.* executable.
299
300* Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
301- Update to latest upstream version.
302
303* Sun Aug  8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
304- Fix bug #125304 (Steve Grubb: build requires gettext)
305
306* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
307- rebuilt
308
309* Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
310- Add missing %%defattr
311
312* Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
313- Add /usr/include/attr to files manifest
314- Fix location of doc files, add main doc dir to files manifest
315
316* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
317- rebuilt
318
319* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
320- rebuilt
321
322* Tue Aug  5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
323- Fix libtool
324
325* Tue Jun  3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
326- update to attr-2.4.1
327
328* Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
329- update/rebuild
330
331* Sat Jan  4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
332- set execute bits on library so that requires are generated.
333
334* Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
335- Redo multilib patch to work everywhere
336
337* Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
338- Added fix to install libs in correct directory on 64bit machine
339
340* Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
341- Made the package only own the one directory that is unique to it:
342  /usr/include/attr
343
344* Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
345- get perl out of base with attr-2.0.8-docperms.patch
346
347* Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
348- Initial Red Hat package
349  Made as few changes as possible relative to upstream packaging to
350  make it easier to maintain long-term.  This means that some of
351  the techniques used here are definitely not standard Red Hat
352  techniques.  If you are looking for an example package to fit
353  into Red Hat Linux transparently, this would not be the one to
354  pick.
355- attr-devel -> libattr-devel
Note: See TracBrowser for help on using the repository browser.