source: projects/specs/trunk/a/at-spi/at-spi-vl.spec @ 521

Revision 521, 12.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define atk_version 1.24.0
4%define gtk2_version 2.14.0
5%define libbonobo_version 2.24.0
6%define orbit2_version 2.6.0
7%define pango_version 1.22.0
8
9Summary: Assistive Technology Service Provider Interface
10
11Name: at-spi
12Version: 1.24.0
13Release: 3%{?_dist_release}
14URL: http://developer.gnome.org/projects/gap/
15Source0: http://download.gnome.org/sources/at-spi/1.24/%{name}-%{version}.tar.bz2
16
17License: LGPLv2+
18Group: System Environment/Libraries
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: pango-devel >= %{pango_version}
21BuildRequires: gtk2-devel >= %{gtk2_version}
22BuildRequires: libbonobo-devel >= %{libbonobo_version}
23BuildRequires: ORBit2-devel >= %{orbit2_version}
24BuildRequires: atk-devel >= %{atk_version}
25BuildRequires: fontconfig
26BuildRequires: gettext
27BuildRequires: intltool
28BuildRequires: perl(XML::Parser)
29BuildRequires: libX11-devel
30BuildRequires: libXtst-devel
31BuildRequires: libXi-devel
32BuildRequires: libXevie-devel
33BuildRequires: libXt-devel
34
35Patch2: at-spi-silence-no-event-spew.patch
36
37%description
38at-spi allows assistive technologies to access GTK-based
39applications. Essentially it exposes the internals of applications for
40automation, so tools such as screen readers, magnifiers, or even
41scripting interfaces can query and interact with GUI controls.
42
43
44%package devel
45Summary: Development libraries and headers for at-spi
46Group: Development/Libraries
47Requires: %name = %{version}-%{release}
48Requires: atk-devel
49Requires: gtk2-devel
50Requires: libbonobo-devel
51Requires: ORBit2-devel
52Requires: pkgconfig
53
54%description devel
55Libraries and header files allowing compilation of apps that use at-spi.
56
57
58%package python
59Summary: Python bindings for at-spi
60Group: Development/Libraries
61Requires: %name = %{version}-%{release}
62Requires: python
63
64%description python
65Python bindings allowing to use at-spi in python programs.
66
67
68%prep
69%setup -q
70%patch2 -p1 -b .spew
71
72
73%build
74%configure --disable-gtk-doc --disable-static
75make
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make install DESTDIR=$RPM_BUILD_ROOT
80
81%find_lang at-spi
82
83rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
84rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
85rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
86
87%post
88/sbin/ldconfig
89export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
90gconftool-2 --makefile-install-rule \
91        %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
92
93%pre
94if [ "$1" -gt 1 ]; then
95    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
96    gconftool-2 --makefile-uninstall-rule \
97            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
98fi
99
100%preun
101if [ "$1" -eq 0 ]; then
102    export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
103    gconftool-2 --makefile-uninstall-rule \
104            %{_sysconfdir}/gconf/schemas/at-spi.schemas >& /dev/null ||:
105fi
106
107%postun -p /sbin/ldconfig
108
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files -f at-spi.lang
113%defattr(-,root,root)
114%doc AUTHORS COPYING NEWS README
115%{_sysconfdir}/gconf/schemas/at-spi.schemas
116%{_libdir}/lib*.so.*
117%{_libdir}/bonobo/servers/*
118%{_libdir}/orbit-2.0/*
119%{_libdir}/gtk-2.0/modules/*
120%{_libexecdir}/*
121
122%files devel
123%defattr(-,root,root)
124%{_datadir}/gtk-doc/html/*
125%{_datadir}/idl/*
126%{_libdir}/lib*.so
127%{_libdir}/pkgconfig/*
128%{_includedir}/*
129
130%files python
131%defattr(-,root,root)
132%{python_sitearch}/pyatspi/
133
134
135%changelog
136* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.24.0-3
137- rebuild with python-2.6
138
139* Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.24.0-2
140- remove BuildRequires gail-devel
141  (gtk2-2.14.x now includes/provides gail)
142
143* Sun Sep 28 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
144- initial build for Vine Linux
145
146* Mon Sep  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.92-1
147- Update to 1.23.92
148- Drop upstreamed patch
149
150* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-3
151- Fix an evo crash caused by the greeter crash fix
152
153* Fri Sep  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-2
154- Fix a greeter crash
155
156* Tue Sep  2 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.91-1
157- Update to 1.23.91
158
159* Wed Aug 20 2008 Jarod Wilson <jarod@redhat.com> - 1.23.6-2
160- Silence incessant atk-bridge spew filling xsession-errors (#459275)
161
162* Mon Aug  4 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.6-1
163- Update to 1.23.6
164
165* Mon Jul 21 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.5-1
166- Update to 1.23.5
167
168* Tue Jun  3 2008 Matthias Clasen <mclasen@redhat.com> - 1.23.3-1
169- Update to 1.23.3
170
171* Mon May  5 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-2
172- Bump rev
173
174* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.1-1
175- Update to 1.22.1
176
177* Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> - 1.22.0-1
178- Update to 1.22.0
179
180* Wed Mar  5 2008 Christopher Aillon <caillon@redhat.com> - 1.21-92-2
181- Perf improvement work from Ginn Chen to help a11y-enabled-firefox3
182
183* Mon Feb 25 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.92-1
184- Update to 1.21.92
185
186* Fri Feb  8 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-2
187- Rebuild for gcc 4.3
188
189* Mon Jan 14 2008 Matthias Clasen <mclasen@redhat.com> - 1.21.5-1
190- Update to 1.21.5
191
192* Thu Dec  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.3-1
193- Update to 1.21.3
194
195* Tue Nov 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.21.1-1
196- Update to 1.21.1
197
198* Mon Oct 15 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.1-1
199- Update to 1.20.1
200
201* Mon Sep 17 2007 Matthias Clasen <mclasen@redhat.com> - 1.20.0-1
202- Update to 1.20.0
203
204* Mon Aug  6 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-2
205- Update license field
206
207* Tue Jul 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.5-1
208- Update to 1.19.5
209
210* Mon Jun  4 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.3-1
211- Update to 1.19.3
212- Add a -python subpackage
213
214* Sun May 20 2007 Matthias Clasen <mclasen@redhat.com> - 1.19.1-1
215- Update to 1.19.1
216
217* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-2
218- Don't ship .la files
219
220* Mon Apr  9 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.1-1
221- Update to 1.18.1, which includes the previous patch
222- Drop obsolete patch
223- Fix a small memory leak
224
225* Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-2
226- Backport a patch to fix deadlocks in applications
227
228* Tue Mar 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.18.0-1
229- Update to 1.18.0
230- Drop obsolete patch
231
232* Thu Mar  8 2007 Ray Strode <rstrode@redhat.com> - 1.17.2-2
233- add a patch that might fix some deadlock issues (bug 329454)
234
235* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.2-1
236- Update to 1.17.2
237
238* Tue Feb 27 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.1-1
239- Update to 1.17.1
240
241* Thu Feb 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-2
242- Bump atk requirement
243
244* Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 1.17.0-1
245- Update to 1.17.0
246
247* Wed Jan 22 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.16-1
248- Update to 1.7.16
249
250* Wed Jan 10 2007 Matthias Clasen <mclasen@redhat.com> - 1.7.15-1
251- Update to 1.7.15
252
253* Tue Dec 19 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.14-1
254- Update to 1.7.14
255
256* Sat Dec  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-2
257- Small spec file cleanups
258
259* Tue Nov  7 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.13-1
260- Update to 1.7.13
261
262* Fri Oct 20 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.12-1
263- Update to 1.7.12
264
265* Wed Aug 23 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-2.fc6
266- Remove debug spew
267
268* Mon Aug 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.11-1.fc6
269- Update to 1.7.11
270- Drop upstreamed patch
271- Require pkgconfig in the -devel package
272
273* Wed Aug  2 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.10-1.fc6
274- Update to 1.7.10
275
276* Fri Jul 28 2006 Alexander Larsson <alexl@redhat.com> - 1.7.9-3
277- Fix segfault if a11y enabled on x86-64 (#196063)
278
279* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-2
280- Rebuild
281
282* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.9-1
283- Update to 1.7.9
284
285* Wed Jul 12 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.8-1
286- Update to 1.7.8
287
288* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.7.7-8.1
289- rebuild
290
291* Thu Jun  8 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-8
292- Add a BuildRequires
293
294* Mon May 22 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-7
295- Make it build in mock
296
297* Mon Apr 17 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-6
298- Revert the previous change
299
300* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-5
301- Fix a missing declaration
302- Fix segfaults on x86_64
303
304* Tue Apr  4 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.7-1
305- Update to 1.7.7
306
307* Thu Mar  9 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-2
308- Fix a crash on x86_64
309
310* Mon Feb 27 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.6-1
311- Update to 1.7.6
312
313* Tue Feb 21 2006 Matthias Clasen <mclasen@redhat.com> - 1.7.5-1
314- Update to 1.7.5
315
316* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.2
317- bump again for double-long bug on ppc(64)
318
319* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.7.4-1.1
320- rebuilt for new gcc4.1 snapshot and glibc changes
321
322* Tue Jan 31 2006 Matthias Clasen <mclasen@redhat.com> 1.7.4-1
323- Update to 1.7.4
324
325* Mon Jan 30 2006 Matthias Clasen <mclasen@redhat.com> 1.7.3-1
326- Update to 1.7.3
327
328* Tue Jan 17 2006 Matthias Clasen <mclasen@redhat.com> 1.7.2-1
329- Update to 1.7.2
330
331* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
332- rebuilt
333
334* Mon Oct 31 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-2
335- Switch requires to modular X
336
337* Wed Sep  7 2005 Matthias Clasen <mclasen@redhat.com> 1.6.6-1
338- Update to 1.6.6
339
340* Tue Aug 16 2005 Matthias Clasen <mclasen@redhat.com>
341- Rebuilt
342
343* Tue Jun 28 2005 Matthias Clasen <mclasen@redhat.com> 1.6.4-1
344- Update to 1.6.4
345
346* Mon Mar 14 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
347- Update to 1.6.3
348
349* Wed Mar  2 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-2
350- Rebuilt with gcc4
351
352* Wed Jan 26 2005 Matthias Clasen <mclasen@redhat.com> 1.6.2-1
353- Update to 1.6.2
354
355* Wed Sep 29 2004 Elliot Lee <sopwith@redhat.com> 1.6.0-3
356- Remove dependency on linc-devel
357
358* Fri Sep 24 2004 Mark McLoughlin <markmc@redhat.com> 1.6.0-2
359- Fix some random spec file issues (fixes #133430?)
360
361* Thu Sep 23 2004 Jonathan Blandford <jrb@redhat.com> 1.6.0-1
362- bump version
363
364* Wed Aug  4 2004 Mark McLoughlin <markmc@redhat.com> 1.5.3-1
365- Update to 1.5.3
366
367* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
368- rebuilt
369
370* Wed Mar 31 2004 Mark McLoughlin <markmc@redhat.com> 1.4.0-1
371- Update to 1.4.0
372
373* Wed Mar 10 2004 Mark McLoughlin <markmc@redhat.com> 1.3.15
374- Update to 1.3.15
375
376* Thu Mar 04 2004 Mark McLoughlin <markmc@redhat.com> 1.3.14-1
377- Update to 1.3.14
378
379* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
380- rebuilt
381
382* Thu Feb 26 2004 Alexander Larsson <alexl@redhat.com> 1.3.13-1
383- update to 1.3.13
384
385* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
386- rebuilt
387
388* Fri Jan 30 2004 Jonathan Blandford <jrb@redhat.com> 1.3.11-1
389- new version
390
391* Thu Oct  2 2003 Jonathan Blandford <jrb@redhat.com> 1.3.7-1
392- new version
393
394* Wed Aug 20 2003 Elliot Lee <sopwith@redhat.com> 1.1.9-3
395- Fix rebuild failure (stderr.patch)
396
397* Tue Jul 15 2003 Havoc Pennington <hp@redhat.com> 1.1.9-2
398- disable gtk doc
399
400* Mon Jul 14 2003 Havoc Pennington <hp@redhat.com>
401- automated rebuild
402
403* Mon Jul  7 2003 Havoc Pennington <hp@redhat.com> 1.1.9-1
404- 1.1.9
405- remove multilib patch fixed upstream
406
407* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
408- rebuilt
409
410* Fri Feb 14 2003 Havoc Pennington <hp@redhat.com> 1.1.8-3
411- kill Xft buildreq
412
413* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-2
414- rebuild to fix self-dependency
415
416* Tue Feb 11 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
417
418- extend multilib patch to cover -lXi
419
420* Tue Feb  4 2003 Havoc Pennington <hp@redhat.com> 1.1.8-1
421- 1.1.8
422
423* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
424- rebuilt
425
426* Wed Dec 11 2002 Elliot Lee <sopwith@redhat.com> 1.0.1-6
427- Add patch to help multilib systems find libXtst
428
429* Fri Dec  6 2002 Havoc Pennington <hp@redhat.com>
430- rebuild
431
432* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
433- rebuild with new libbonobo and gail
434
435* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
436- automated rebuild
437
438* Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
439- add libatk-bridge.so to the file list
440
441* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
442- 1.0.1
443- add at-spi-registryd to file list
444
445* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
446- rebuild in different environment
447
448* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
449- 1.0.0
450- add post/postun ldconfig
451
452* Wed May 29 2002 Bill Nottingham <notting@redhat.com>
453- rebuild again?
454
455* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
456- rebuild in different environment
457
458* Tue May 28 2002 Havoc Pennington <hp@redhat.com>
459- 0.12.1
460
461* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
462- Version 0.0.6
463
464* Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
465- rebuild in rawhide, seems to have been linked incorrectly
466
467* Thu Jan 24 2002 Havoc Pennington <hp@redhat.com>
468- rebuild in rawhide, upgrade to 0.0.5
469- add gail deps
470
471* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
472- Initial build.
473
474
Note: See TracBrowser for help on using the repository browser.