source: projects/specs/trunk/a/asymptote/asymptote-vl.spec @ 11695

Revision 11695, 15.5 KB checked in by ara_t, 6 years ago (diff)

asymptote: rebuild with gsl-2.4

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define texmf           %{_datadir}/texmf
5%define build_texmf     %{buildroot}%{texmf}
6
7%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
8
9%define emacspkg asy-mode
10
11Name:           asymptote
12Version:        2.38
13Release:        2%{?_dist_release}
14Summary:        Descriptive vector graphics language
15Summary(ja):    MetaPost に触発されたスクリプトベースのベクターグラフィック言語
16
17Group:          Applications/Publishing
18License:        GPLv3+
19URL:            http://asymptote.sourceforge.net/
20Source0:        http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
21Source1:        asy.gif
22Source2:        xasy.desktop
23#Source3:       asymptote.sty.204
24
25Source11:       %{emacspkg}-install.sh
26Source12:       %{emacspkg}-remove.sh
27#Source13:      %{name}-init.el
28
29#Patch0:         asymptote-2.00-settings.patch
30%if %{?_dist_release} == "vl6"
31Patch0:         asymptote-2.00-settings-vine-vl6.patch
32%else
33Patch0:         asymptote-2.00-settings-vine-vl7.patch
34%endif
35Patch2:         asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
36# This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
37Patch3:         asymptote-2.08-info-path-fix.patch
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40
41BuildRequires:  ncurses-devel
42BuildRequires:  readline-devel
43BuildRequires:  fftw3-devel >= 3.0
44BuildRequires:  gc-devel >= 6.8
45BuildRequires:  gsl-devel
46BuildRequires:  texlive-common
47%if %{?_dist_release} == "vl6"
48BuildRequires:  texlive-collection-texinfo
49BuildRequires:  texlive-collection-genericrecommended
50%else
51BuildRequires:  texlive-collection-plaingeneric
52BuildRequires:  texlive-collection-fontsrecommended
53BuildRequires:  texlive-collection-latexrecommended
54%endif
55BuildRequires:  ghostscript >= 9.14
56BuildRequires:  texinfo
57BuildRequires:  ImageMagick
58BuildRequires:  desktop-file-utils
59BuildRequires:  freeglut-devel
60BuildRequires:  zlib-devel
61BuildRequires:  libtool
62
63Requires:       texlive-common
64
65Requires(post): desktop-file-utils
66Requires(postun): desktop-file-utils
67
68# for /usr/bin/texhash and /sbin/install-info
69Requires(post): texlive, info
70Requires(postun): texlive, info
71
72Vendor: Project Vine
73Distribution: Vine Linux
74
75%define texpkgdir   %{texmf}/tex/latex/%{name}
76
77%description
78Asymptote is a powerful descriptive vector graphics language for technical
79drawings, inspired by MetaPost but with an improved C++-like syntax.
80Asymptote provides for figures the same high-quality level of typesetting
81that LaTeX does for scientific text.
82
83This package is custmized for Japanese.
84- added eplatex, platex to latex engines
85- use pdvips as dvips command
86
87%description -l ja
88Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
89テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
90Asymptote は科学的なテキストに対して LaTeX がしている組版のと
91同じくらい高品質なレベルの図を提供します.
92
93このパッケージは日本語向けにカスタマイズされています.
94- latex エンジンに eplatex, platex を追加
95- dvips コマンドとして pdvips を使う
96
97
98%package gui
99Summary: A graphical interface for Asymptote
100Summary(ja): Asymptote のためのグラフィカルインターフェース
101Group: Applications/Graphics
102Requires: %{name} = %{version}-%{release}
103Requires:       tkinter
104Requires:       python-imaging
105BuildArch:     noarch
106
107%description gui
108A graphical interface for Asymptote
109
110
111%package -n %{emacspkg}
112Summary: Emacs mode for editing Asymptote source code
113Summary(ja): Asymptote ソースコードを編集するための Emacs モード
114Group: Applications/Editors/Emacs
115Requires: %{name} = %{version}-%{release}
116BuildRequires: emacsen
117%prereq_ge     emacsen-common
118BuildArch:     noarch
119
120%description -n %{emacspkg}
121Emacs mode for editing Asymptote source code
122
123
124%prep
125%setup -q
126%patch0 -b .settings
127%patch2 -p1 -b .DSO
128%patch3 -p1 -b .path-fix
129%{__sed} -i 's/\r//' doc/CAD1.asy
130
131# convert to UTF-8
132iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
133%__mv examples/interpolate1.asy{.utf8,}
134autoreconf -i
135
136%build
137%configure \
138    --enable-gc=system \
139    --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
140    --with-latex=%{texmf}/tex/latex \
141     --with-context=%{texmf}/tex/context \
142     ;
143%__make %{?_smp_mflags}
144cd doc/
145%__make asy-latex.pdf
146%__make all
147
148%install
149%__rm -rf $RPM_BUILD_ROOT
150%__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
151
152%__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
153    $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
154
155# # Vim syntax file
156# for vimver in 63 64 70 71 ; do
157#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
158#     cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
159#     ln -s ../../../%{name}/asy.vim .
160# done
161
162# Move info file
163%__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
164
165# copy icon to pixmaps dir
166%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
167%__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
168
169%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
170desktop-file-install --vendor "vine"                  \
171        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
172        %{SOURCE2}
173
174# Clean up symlink
175%__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
176cd $RPM_BUILD_ROOT%{_bindir}
177%__ln_s ../share/%{name}/GUI/xasy.py xasy
178
179
180## <asy-mode>
181%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
182%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
183%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
184
185#
186# install el files
187#
188
189# install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
190# cd $RPM_BUILD_ROOT%{emacs_sitelisp}
191# ln -s ../../%{name}/asy-{mode,keywords}.el .
192# cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
193# ln -s ../../../%{name}/asy-init.el .
194
195%__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
196    $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
197
198
199#
200# install script (bytecompile el and install elc, remove)
201#
202
203%_installemacsenscript %{name} %{SOURCE11}
204
205%_removeemacsenscript  %{name} %{SOURCE12}
206
207## </asy-mode>
208
209
210%clean
211%__rm -rf $RPM_BUILD_ROOT
212
213
214%post
215/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
216/sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
217%{exec_texhash}
218
219
220%post -n %{emacspkg}
221if [ "$1" = 2 ]; then
222
223  %_emacsenPackageRemove %{name}
224
225fi
226
227%_addemacsenlist %{name}
228
229%_emacsenPackageInstall %{name}
230     
231
232%postun
233if [ $1 = 0 ]; then
234    /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
235    /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
236    %{exec_texhash}
237fi
238
239
240%preun -n %{emacspkg}
241if [ "$1" = 0 ]; then
242
243  %_emacsenPackageRemove %{name}
244
245  %_removeemacsenlist %{name}
246
247fi
248
249
250%files
251%defattr(-,root,root,-)
252%doc %{_defaultdocdir}/%{name}-%{version}/
253%{_bindir}/asy
254%{_datadir}/%{name}/
255%exclude %{_datadir}/asymptote/GUI/
256%{texpkgdir}/
257%{texmf}/tex/context/
258%{_mandir}/man1/*.1*
259%{_infodir}/*.info*
260##%{_datadir}/vim/vim*/syntax/asy.vim
261
262
263%files gui
264%{_bindir}/xasy
265%{_datadir}/applications/vine-xasy.desktop
266%{_datadir}/pixmaps/asy.gif
267%{_datadir}/asymptote/GUI/
268%{_mandir}/man*/xasy.*
269
270
271%files -n %{emacspkg}
272%defattr(-,root,root)
273%{_datadir}/emacs/site-lisp/%{name}
274%{_prefix}/lib/emacsen-common/packages/install/%{name}
275%{_prefix}/lib/emacsen-common/packages/remove/%{name}
276
277
278%changelog
279* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 2.38-2
280- build under gsl-2.4
281- change BuildRequires: texlive-collection-plaingeneric
282
283* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 2.38-1
284- new upstream release
285- renew Patch0: asymptote-2.00-settings-vine-vl7.patch
286- build under gsl-2.2.1
287- add BuildRequires:
288    texlive-collection-{plainextra,fontsrecommended,latexrecommended}
289    for VineSeed instead of texlive-collection-texinfo for Vine6
290- add Vendor and Distribution
291
292* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15-1
293- new upstream release
294- added asymptote-2.00-settings-vine-vl7.patch (vl7)
295  - For vl6, renamed asymptote-2.00-settings-vine.patch as
296    asymptote-2.00-settings-vine-vl6.patch
297- TeX Live 2011
298
299* Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
300- new upstream release
301
302* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
303- TeX Live 2009
304
305* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
306- rebuilt with new toolchain, libsigsegv-2.8
307- appled Patch1 again
308
309* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
310- don't apply Patch1 until gcc44 comes to VineSeed
311
312* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
313- separated Xasy to gui subpackage
314
315* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
316- initial build based on Fedora Development (fc11) package
317- applied asymptote-1.70-settings-vine.patch
318
319* Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
320- update to 1.70
321
322* Tue Apr  7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
323- update to 1.69
324
325* Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
326- update to 1.68
327
328* Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
329- update to 1.67
330
331* Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
332- update to 1.66
333
334* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
335- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
336
337* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
338- more gcc44 fixes with BIG_ENDIAN platforms
339
340* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
341- fix gcc44 issue with BIG_ENDIAN platforms
342
343* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
344- forgot to put in new source
345
346* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
347- 1.63
348
349* Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
350- 1.60
351
352* Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
353- 1.59
354
355* Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
356- 1.58
357
358* Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
359- 1.57
360
361* Tue Dec  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
362- 1.56
363
364* Tue Dec  2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
365- 1.54
366
367* Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
368- 1.52
369
370* Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
371- update to 1.51
372
373* Mon Nov  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
374- update to 1.49
375
376* Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
377- update to 1.47
378
379* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
380- update to 1.46
381
382* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
383- add missing BuildRequires
384
385* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
386- update to 1.44
387
388* Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
389- update to 1.43
390
391* Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
392- explicitly call "make asymptote.pdf" in doc/
393
394* Fri Apr  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
395- fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
396
397* Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
398- update to 1.42
399
400* Wed Feb  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
401- update to 1.41
402- enable desktop file for xasy
403
404* Thu Jan  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
405- bump to 1.37
406- fix gcc43 failures
407- drop triggers
408
409* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
410- Rebuild for selinux ppc32 issue.
411
412* Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
413- Update 1.33.
414
415* Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
416- Update to 1.32.
417- vim-common triggers: correction and improvements (#246131).
418
419* Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
420- Update to 1.31.
421
422* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
423- Update to 1.30.
424
425* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
426- Using "evince" as the default PS and PDF viewers (#244151).
427  (patch file: asymptote-1.29-settings.patch)
428- Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
429- Use relative symbolic links in the vim-common triggers.
430
431* Sat Jun  2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
432- Add asy-faq to install-info (#155750).
433- Add support for vim 7.1.
434
435* Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
436- Update to 1.29.
437
438* Tue May  8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
439- Update to 1.28.
440
441* Sat May  5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
442- Update to 1.27.
443
444* Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
445- Update to 1.26.
446
447* Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
448- Update to 1.25.
449
450* Sun Apr  1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
451- Update to 1.24.
452
453* Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
454- Update to 1.23.
455
456* Tue Mar  6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
457- Update to 1.22.
458
459* Sat Mar  3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
460- Update to 1.21.
461
462* Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
463- Update to 1.20.
464
465* Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
466- Update to 1.19.
467
468* Sun Nov  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
469- Update to 1.18.
470
471* Wed Nov  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
472- Update to 1.17.
473
474* Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
475- Update to 1.16.
476
477* Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
478- Update to 1.15.
479
480* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
481- Update to 1.13.
482
483* Thu Aug  3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
484- Update to 1.12.
485
486* Thu Jul  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
487- Update to 1.11.
488
489* Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
490- Update to 1.10.
491
492* Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
493- Update to 1.09.
494
495* Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
496- Update to 1.08.
497- Also installs the info file.
498
499* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
500- Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
501
502* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
503- Group: Development/Tools -> Applications/Publishing (#193154).
504
505* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
506- Emacs/Xemacs init file (#193154 comment 6).
507
508* Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
509- Directories ownership (#193154).
510
511* Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
512- Update to 1.06.
513- Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
514
515* Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
516- Update to 1.05.
517
518* Sun May  7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
519- Update to 1.04.
520
521* Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
522- Update to 1.03.
523
524* Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
525- First build.
526
527# vim:set ai ts=4 sw=4 sts=4 et:
Note: See TracBrowser for help on using the repository browser.