source: projects/specs/trunk/a/asymptote/asymptote-vl.spec @ 12272

Revision 12272, 16.1 KB checked in by ara_t, 5 years ago (diff)

asymptote: rebuild with current VineSeed environment

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define texmf           %{_datadir}/texmf
5%define build_texmf     %{buildroot}%{texmf}
6
7%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
8
9%define emacspkg asy-mode
10
11Name:           asymptote
12Version:        2.38
13Release:        3%{?_dist_release}
14Summary:        Descriptive vector graphics language
15Summary(ja):    MetaPost に触発されたスクリプトベースのベクターグラフィック言語
16
17Group:          Applications/Publishing
18License:        GPLv3+
19URL:            http://asymptote.sourceforge.net/
20Source0:        http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
21Source1:        asy.gif
22Source2:        xasy.desktop
23#Source3:       asymptote.sty.204
24
25Source11:       %{emacspkg}-install.sh
26Source12:       %{emacspkg}-remove.sh
27#Source13:      %{name}-init.el
28
29#Patch0:         asymptote-2.00-settings.patch
30%if %{?_dist_release} == "vl6"
31Patch0:         asymptote-2.00-settings-vine-vl6.patch
32%else
33Patch0:         asymptote-2.00-settings-vine-vl7.patch
34%endif
35Patch2:         asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
36# This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
37Patch3:         asymptote-2.08-info-path-fix.patch
38
39# https://bugs.archlinux.org/task/60678
40# https://github.com/vectorgraphics/asymptote/commit/38a59370dc5ac720c29e1424614a10f7384b943f
41Patch4:         asymptote-gc-fix.patch
42
43# https://github.com/vectorgraphics/asymptote/issues/47
44Patch5:         asymptote-bfnnconv.pl.patch
45
46BuildRoot:      %{_tmppath}/%{name}-%{version}-root
47
48BuildRequires:  ncurses-devel
49BuildRequires:  readline-devel
50BuildRequires:  fftw3-devel >= 3.0
51BuildRequires:  gc-devel >= 6.8
52BuildRequires:  gsl-devel
53BuildRequires:  texlive-common
54%if %{?_dist_release} == "vl6"
55BuildRequires:  texlive-collection-texinfo
56BuildRequires:  texlive-collection-genericrecommended
57%else
58BuildRequires:  texlive-collection-plaingeneric
59BuildRequires:  texlive-collection-fontsrecommended
60BuildRequires:  texlive-collection-latexrecommended
61%endif
62BuildRequires:  ghostscript >= 9.14
63BuildRequires:  texinfo
64BuildRequires:  ImageMagick
65BuildRequires:  desktop-file-utils
66BuildRequires:  freeglut-devel
67BuildRequires:  zlib-devel
68BuildRequires:  libtool
69BuildRequires:  mesa-libEGL-devel
70
71Requires:       texlive-common
72
73Requires(post): desktop-file-utils
74Requires(postun): desktop-file-utils
75
76# for /usr/bin/texhash and /sbin/install-info
77Requires(post): texlive, info
78Requires(postun): texlive, info
79
80Vendor: Project Vine
81Distribution: Vine Linux
82
83%define texpkgdir   %{texmf}/tex/latex/%{name}
84
85%description
86Asymptote is a powerful descriptive vector graphics language for technical
87drawings, inspired by MetaPost but with an improved C++-like syntax.
88Asymptote provides for figures the same high-quality level of typesetting
89that LaTeX does for scientific text.
90
91This package is custmized for Japanese.
92- added eplatex, platex to latex engines
93- use pdvips as dvips command
94
95%description -l ja
96Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
97テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
98Asymptote は科学的なテキストに対して LaTeX がしている組版のと
99同じくらい高品質なレベルの図を提供します.
100
101このパッケージは日本語向けにカスタマイズされています.
102- latex エンジンに eplatex, platex を追加
103- dvips コマンドとして pdvips を使う
104
105
106%package gui
107Summary: A graphical interface for Asymptote
108Summary(ja): Asymptote のためのグラフィカルインターフェース
109Group: Applications/Graphics
110Requires: %{name} = %{version}-%{release}
111Requires:       tkinter
112Requires:       python-imaging
113BuildArch:     noarch
114
115%description gui
116A graphical interface for Asymptote
117
118
119%package -n %{emacspkg}
120Summary: Emacs mode for editing Asymptote source code
121Summary(ja): Asymptote ソースコードを編集するための Emacs モード
122Group: Applications/Editors/Emacs
123Requires: %{name} = %{version}-%{release}
124BuildRequires: emacsen
125%prereq_ge     emacsen-common
126BuildArch:     noarch
127
128%description -n %{emacspkg}
129Emacs mode for editing Asymptote source code
130
131
132%prep
133%setup -q
134%patch0 -b .settings
135%patch2 -p1 -b .DSO
136%patch3 -p1 -b .path-fix
137%if %{?_dist_release} >= "vl7"
138%patch4 -b .gc-fix
139%patch5 -b .manual-fix
140%endif
141%{__sed} -i 's/\r//' doc/CAD1.asy
142
143# convert to UTF-8
144iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
145%__mv examples/interpolate1.asy{.utf8,}
146autoreconf -i
147
148%build
149%configure \
150    --enable-gc=system \
151    --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
152    --with-latex=%{texmf}/tex/latex \
153     --with-context=%{texmf}/tex/context \
154     ;
155%__make %{?_smp_mflags}
156cd doc/
157%__make asy-latex.pdf
158%__make all
159
160%install
161%__rm -rf $RPM_BUILD_ROOT
162%__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
163
164%__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
165    $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
166
167# # Vim syntax file
168# for vimver in 63 64 70 71 ; do
169#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
170#     cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
171#     ln -s ../../../%{name}/asy.vim .
172# done
173
174# Move info file
175%__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
176
177# copy icon to pixmaps dir
178%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
179%__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
180
181%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
182desktop-file-install --vendor "vine"                  \
183        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
184        %{SOURCE2}
185
186# Clean up symlink
187%__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
188cd $RPM_BUILD_ROOT%{_bindir}
189%__ln_s ../share/%{name}/GUI/xasy.py xasy
190
191
192## <asy-mode>
193%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
194%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
195%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
196
197#
198# install el files
199#
200
201# install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
202# cd $RPM_BUILD_ROOT%{emacs_sitelisp}
203# ln -s ../../%{name}/asy-{mode,keywords}.el .
204# cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
205# ln -s ../../../%{name}/asy-init.el .
206
207%__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
208    $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
209
210
211#
212# install script (bytecompile el and install elc, remove)
213#
214
215%_installemacsenscript %{name} %{SOURCE11}
216
217%_removeemacsenscript  %{name} %{SOURCE12}
218
219## </asy-mode>
220
221
222%clean
223%__rm -rf $RPM_BUILD_ROOT
224
225
226%post
227/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
228/sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
229%{exec_texhash}
230
231
232%post -n %{emacspkg}
233if [ "$1" = 2 ]; then
234
235  %_emacsenPackageRemove %{name}
236
237fi
238
239%_addemacsenlist %{name}
240
241%_emacsenPackageInstall %{name}
242     
243
244%postun
245if [ $1 = 0 ]; then
246    /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
247    /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
248    %{exec_texhash}
249fi
250
251
252%preun -n %{emacspkg}
253if [ "$1" = 0 ]; then
254
255  %_emacsenPackageRemove %{name}
256
257  %_removeemacsenlist %{name}
258
259fi
260
261
262%files
263%defattr(-,root,root,-)
264%doc %{_defaultdocdir}/%{name}-%{version}/
265%{_bindir}/asy
266%{_datadir}/%{name}/
267%exclude %{_datadir}/asymptote/GUI/
268%{texpkgdir}/
269%{texmf}/tex/context/
270%{_mandir}/man1/*.1*
271%{_infodir}/*.info*
272##%{_datadir}/vim/vim*/syntax/asy.vim
273
274
275%files gui
276%{_bindir}/xasy
277%{_datadir}/applications/vine-xasy.desktop
278%{_datadir}/pixmaps/asy.gif
279%{_datadir}/asymptote/GUI/
280%{_mandir}/man*/xasy.*
281
282
283%files -n %{emacspkg}
284%defattr(-,root,root)
285%{_datadir}/emacs/site-lisp/%{name}
286%{_prefix}/lib/emacsen-common/packages/install/%{name}
287%{_prefix}/lib/emacsen-common/packages/remove/%{name}
288
289
290%changelog
291* Mon Oct 14 2019 Toshiaki Ara <ara_t@384.jp> 2.38-3
292- rebuild under current VineSeed environment
293- add BuildRequires: mesa-libEGL-devel
294- change BuildRequires: texlive-collection-plainextra to texlive-collection-plaingeneric
295- add Patch4 for 'GC_throw_bad_alloc()'
296- add Patch5 for building manuals
297
298* Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 2.38-2
299- build under gsl-2.4
300
301* Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 2.38-1
302- new upstream release
303- renew Patch0: asymptote-2.00-settings-vine-vl7.patch
304- build under gsl-2.2.1
305- add BuildRequires:
306    texlive-collection-{plainextra,fontsrecommended,latexrecommended}
307    for VineSeed instead of texlive-collection-texinfo for Vine6
308- add Vendor and Distribution
309
310* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15-1
311- new upstream release
312- added asymptote-2.00-settings-vine-vl7.patch (vl7)
313  - For vl6, renamed asymptote-2.00-settings-vine.patch as
314    asymptote-2.00-settings-vine-vl6.patch
315- TeX Live 2011
316
317* Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
318- new upstream release
319
320* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
321- TeX Live 2009
322
323* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
324- rebuilt with new toolchain, libsigsegv-2.8
325- appled Patch1 again
326
327* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
328- don't apply Patch1 until gcc44 comes to VineSeed
329
330* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
331- separated Xasy to gui subpackage
332
333* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
334- initial build based on Fedora Development (fc11) package
335- applied asymptote-1.70-settings-vine.patch
336
337* Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
338- update to 1.70
339
340* Tue Apr  7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
341- update to 1.69
342
343* Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
344- update to 1.68
345
346* Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
347- update to 1.67
348
349* Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
350- update to 1.66
351
352* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
353- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
354
355* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
356- more gcc44 fixes with BIG_ENDIAN platforms
357
358* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
359- fix gcc44 issue with BIG_ENDIAN platforms
360
361* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
362- forgot to put in new source
363
364* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
365- 1.63
366
367* Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
368- 1.60
369
370* Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
371- 1.59
372
373* Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
374- 1.58
375
376* Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
377- 1.57
378
379* Tue Dec  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
380- 1.56
381
382* Tue Dec  2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
383- 1.54
384
385* Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
386- 1.52
387
388* Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
389- update to 1.51
390
391* Mon Nov  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
392- update to 1.49
393
394* Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
395- update to 1.47
396
397* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
398- update to 1.46
399
400* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
401- add missing BuildRequires
402
403* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
404- update to 1.44
405
406* Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
407- update to 1.43
408
409* Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
410- explicitly call "make asymptote.pdf" in doc/
411
412* Fri Apr  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
413- fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
414
415* Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
416- update to 1.42
417
418* Wed Feb  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
419- update to 1.41
420- enable desktop file for xasy
421
422* Thu Jan  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
423- bump to 1.37
424- fix gcc43 failures
425- drop triggers
426
427* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
428- Rebuild for selinux ppc32 issue.
429
430* Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
431- Update 1.33.
432
433* Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
434- Update to 1.32.
435- vim-common triggers: correction and improvements (#246131).
436
437* Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
438- Update to 1.31.
439
440* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
441- Update to 1.30.
442
443* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
444- Using "evince" as the default PS and PDF viewers (#244151).
445  (patch file: asymptote-1.29-settings.patch)
446- Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
447- Use relative symbolic links in the vim-common triggers.
448
449* Sat Jun  2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
450- Add asy-faq to install-info (#155750).
451- Add support for vim 7.1.
452
453* Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
454- Update to 1.29.
455
456* Tue May  8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
457- Update to 1.28.
458
459* Sat May  5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
460- Update to 1.27.
461
462* Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
463- Update to 1.26.
464
465* Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
466- Update to 1.25.
467
468* Sun Apr  1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
469- Update to 1.24.
470
471* Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
472- Update to 1.23.
473
474* Tue Mar  6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
475- Update to 1.22.
476
477* Sat Mar  3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
478- Update to 1.21.
479
480* Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
481- Update to 1.20.
482
483* Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
484- Update to 1.19.
485
486* Sun Nov  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
487- Update to 1.18.
488
489* Wed Nov  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
490- Update to 1.17.
491
492* Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
493- Update to 1.16.
494
495* Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
496- Update to 1.15.
497
498* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
499- Update to 1.13.
500
501* Thu Aug  3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
502- Update to 1.12.
503
504* Thu Jul  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
505- Update to 1.11.
506
507* Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
508- Update to 1.10.
509
510* Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
511- Update to 1.09.
512
513* Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
514- Update to 1.08.
515- Also installs the info file.
516
517* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
518- Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
519
520* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
521- Group: Development/Tools -> Applications/Publishing (#193154).
522
523* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
524- Emacs/Xemacs init file (#193154 comment 6).
525
526* Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
527- Directories ownership (#193154).
528
529* Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
530- Update to 1.06.
531- Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
532
533* Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
534- Update to 1.05.
535
536* Sun May  7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
537- Update to 1.04.
538
539* Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
540- Update to 1.03.
541
542* Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
543- First build.
544
545# vim:set ai ts=4 sw=4 sts=4 et:
Note: See TracBrowser for help on using the repository browser.