source: projects/specs/trunk/a/asymptote/asymptote-vl.spec @ 5239

Revision 5239, 14.8 KB checked in by munepi, 12 years ago (diff)

updated asymptote

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(post):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3
4%define texmf           %{_datadir}/texmf
5%define build_texmf     %{buildroot}%{texmf}
6
7%define exec_texhash    [ -x %{_bindir}/texhash ] && %{_bindir}/env - %{_bindir}/texhash 2> /dev/null
8
9%define emacspkg asy-mode
10
11Name:           asymptote
12Version:        2.15
13Release:        1%{?_dist_release}
14Summary:        Descriptive vector graphics language
15Summary(ja):    MetaPost に触発されたスクリプトベースのベクターグラフィック言語
16
17Group:          Applications/Publishing
18License:        GPLv3+
19URL:            http://asymptote.sourceforge.net/
20Source0:        http://dl.sourceforge.net/sourceforge/asymptote/asymptote-%{version}.src.tgz
21Source1:        asy.gif
22Source2:        xasy.desktop
23#Source3:       asymptote.sty.204
24
25Source11:       %{emacspkg}-install.sh
26Source12:       %{emacspkg}-remove.sh
27#Source13:      %{name}-init.el
28
29#Patch0:         asymptote-2.00-settings.patch
30%if %{?_dist_release} == "vl6"
31Patch0:         asymptote-2.00-settings-vine-vl6.patch
32%else
33Patch0:         asymptote-2.00-settings-vine-vl7.patch
34%endif
35Patch2:         asymptote-1.91-fix-implicit-DSO-linking-libGL.patch
36# This doesn't need to go upstream. We put the info file in the topdir, not a subdir, so we need this fix.
37Patch3:         asymptote-2.08-info-path-fix.patch
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40
41BuildRequires:  ncurses-devel
42BuildRequires:  readline-devel
43BuildRequires:  fftw3-devel >= 3.0
44BuildRequires:  gc-devel >= 6.8
45BuildRequires:  gsl-devel
46BuildRequires:  texlive-common
47BuildRequires:  texlive-collection-texinfo
48BuildRequires:  texlive-collection-genericrecommended
49BuildRequires:  ghostscript
50BuildRequires:  texinfo
51BuildRequires:  ImageMagick
52BuildRequires:  desktop-file-utils
53BuildRequires:  freeglut-devel
54BuildRequires:  zlib-devel
55BuildRequires:  libtool
56
57Requires:       texlive-common
58
59Requires(post): desktop-file-utils
60Requires(postun): desktop-file-utils
61
62# for /usr/bin/texhash and /sbin/install-info
63Requires(post): texlive, info
64Requires(postun): texlive, info
65
66%define texpkgdir   %{texmf}/tex/latex/%{name}
67
68%description
69Asymptote is a powerful descriptive vector graphics language for technical
70drawings, inspired by MetaPost but with an improved C++-like syntax.
71Asymptote provides for figures the same high-quality level of typesetting
72that LaTeX does for scientific text.
73
74This package is custmized for Japanese.
75- added eplatex, platex to latex engines
76- use pdvips as dvips command
77
78%description -l ja
79Asymptote は MetaPost に触発されているが,C++ のような構文に改良された,
80テクニカルな図面のための強力な記述ベクターグラフィックス言語です.
81Asymptote は科学的なテキストに対して LaTeX がしている組版のと
82同じくらい高品質なレベルの図を提供します.
83
84このパッケージは日本語向けにカスタマイズされています.
85- latex エンジンに eplatex, platex を追加
86- dvips コマンドとして pdvips を使う
87
88
89%package gui
90Summary: A graphical interface for Asymptote
91Summary(ja): Asymptote のためのグラフィカルインターフェース
92Group: Applications/Graphics
93Requires: %{name} = %{version}-%{release}
94Requires:       tkinter
95Requires:       python-imaging
96BuildArch:     noarch
97
98%description gui
99A graphical interface for Asymptote
100
101
102%package -n %{emacspkg}
103Summary: Emacs mode for editing Asymptote source code
104Summary(ja): Asymptote ソースコードを編集するための Emacs モード
105Group: Applications/Editors/Emacs
106Requires: %{name} = %{version}-%{release}
107BuildRequires: emacsen
108%prereq_ge     emacsen-common
109BuildArch:     noarch
110
111%description -n %{emacspkg}
112Emacs mode for editing Asymptote source code
113
114
115%prep
116%setup -q
117%patch0 -p1 -b .settings
118%patch2 -p1 -b .DSO
119%patch3 -p1 -b .path-fix
120%{__sed} -i 's/\r//' doc/CAD1.asy
121
122# convert to UTF-8
123iconv -f iso-8859-1 -t utf-8 -o examples/interpolate1.asy{.utf8,}
124%__mv examples/interpolate1.asy{.utf8,}
125autoreconf -i
126
127%build
128%configure \
129    --enable-gc=system \
130    --with-docdir=%{_defaultdocdir}/%{name}-%{version}/ \
131    --with-latex=%{texmf}/tex/latex \
132     --with-context=%{texmf}/tex/context \
133     ;
134%__make %{?_smp_mflags}
135cd doc/
136%__make asy-latex.pdf
137%__make all
138
139%install
140%__rm -rf $RPM_BUILD_ROOT
141%__make install DESTDIR=%{buildroot} mandir=%{buildroot}%{_mandir}
142
143%__install -p -m 644 BUGS ChangeLog LICENSE README ReleaseNotes TODO \
144    $RPM_BUILD_ROOT%{_defaultdocdir}/%{name}-%{version}/
145
146# # Vim syntax file
147# for vimver in 63 64 70 71 ; do
148#     install -dm 755 $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
149#     cd $RPM_BUILD_ROOT%{_datadir}/vim/vim$vimver/syntax
150#     ln -s ../../../%{name}/asy.vim .
151# done
152
153# Move info file
154%__mv %{buildroot}%{_infodir}/asymptote/asymptote.info %{buildroot}%{_infodir}/asymptote.info
155
156# copy icon to pixmaps dir
157%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/pixmaps/
158%__cp %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/pixmaps/
159
160%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/applications
161desktop-file-install --vendor "vine"                  \
162        --dir $RPM_BUILD_ROOT%{_datadir}/applications   \
163        %{SOURCE2}
164
165# Clean up symlink
166%__rm -rf $RPM_BUILD_ROOT%{_bindir}/xasy
167cd $RPM_BUILD_ROOT%{_bindir}
168%__ln_s ../share/%{name}/GUI/xasy.py xasy
169
170
171## <asy-mode>
172%__mkdir_p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}
173%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
174%__mkdir_p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
175
176#
177# install el files
178#
179
180# install -dm 755 $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
181# cd $RPM_BUILD_ROOT%{emacs_sitelisp}
182# ln -s ../../%{name}/asy-{mode,keywords}.el .
183# cd $RPM_BUILD_ROOT%{emacs_sitelisp}/site-start.d
184# ln -s ../../../%{name}/asy-init.el .
185
186%__mv $RPM_BUILD_ROOT%{_datadir}/%{name}/asy-{init,mode,keywords}.el \
187    $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
188
189
190#
191# install script (bytecompile el and install elc, remove)
192#
193
194%_installemacsenscript %{name} %{SOURCE11}
195
196%_removeemacsenscript  %{name} %{SOURCE12}
197
198## </asy-mode>
199
200
201%clean
202%__rm -rf $RPM_BUILD_ROOT
203
204
205%post
206/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir 2>/dev/null || :
207/sbin/install-info %{_infodir}/asy-faq.info.gz %{_infodir}/dir 2>/dev/null || :
208%{exec_texhash}
209
210
211%post -n %{emacspkg}
212if [ "$1" = 2 ]; then
213
214  %_emacsenPackageRemove %{name}
215
216fi
217
218%_addemacsenlist %{name}
219
220%_emacsenPackageInstall %{name}
221     
222
223%postun
224if [ $1 = 0 ]; then
225    /sbin/install-info --delete %{name} %{_infodir}/dir 2>/dev/null || :
226    /sbin/install-info --delete asy-faq %{_infodir}/dir 2>/dev/null || :
227    %{exec_texhash}
228fi
229
230
231%preun -n %{emacspkg}
232if [ "$1" = 0 ]; then
233
234  %_emacsenPackageRemove %{name}
235
236  %_removeemacsenlist %{name}
237
238fi
239
240
241%files
242%defattr(-,root,root,-)
243%doc %{_defaultdocdir}/%{name}-%{version}/
244%{_bindir}/asy
245%{_datadir}/%{name}/
246%exclude %{_datadir}/asymptote/GUI/
247%{texpkgdir}/
248%{texmf}/tex/context/
249%{_mandir}/man1/*.1*
250%{_infodir}/*.info*
251##%{_datadir}/vim/vim*/syntax/asy.vim
252
253
254%files gui
255%{_bindir}/xasy
256%{_datadir}/applications/vine-xasy.desktop
257%{_datadir}/pixmaps/asy.gif
258%{_datadir}/asymptote/GUI/
259%{_mandir}/man*/xasy.*
260
261
262%files -n %{emacspkg}
263%defattr(-,root,root)
264%{_datadir}/emacs/site-lisp/%{name}
265%{_prefix}/lib/emacsen-common/packages/install/%{name}
266%{_prefix}/lib/emacsen-common/packages/remove/%{name}
267
268
269%changelog
270* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.15-1
271- new upstream release
272- added asymptote-2.00-settings-vine-vl7.patch (vl7)
273  - For vl6, renamed asymptote-2.00-settings-vine.patch as
274    asymptote-2.00-settings-vine-vl6.patch
275- TeX Live 2011
276
277* Sat Jun 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 2.10-1
278- new upstream release
279
280* Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 1.70-5
281- TeX Live 2009
282
283* Tue Feb 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.70-4
284- rebuilt with new toolchain, libsigsegv-2.8
285- appled Patch1 again
286
287* Tue Jun 16 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.70-3
288- don't apply Patch1 until gcc44 comes to VineSeed
289
290* Fri May 15 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-2
291- separated Xasy to gui subpackage
292
293* Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.70-1
294- initial build based on Fedora Development (fc11) package
295- applied asymptote-1.70-settings-vine.patch
296
297* Mon Apr 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.70-1
298- update to 1.70
299
300* Tue Apr  7 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.69-1
301- update to 1.69
302
303* Wed Mar 25 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.68-1
304- update to 1.68
305
306* Thu Mar 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.67-1
307- update to 1.67
308
309* Fri Feb 27 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.66-1
310- update to 1.66
311
312* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.63-5
313- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
314
315* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-4
316- more gcc44 fixes with BIG_ENDIAN platforms
317
318* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-3
319- fix gcc44 issue with BIG_ENDIAN platforms
320
321* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-2
322- forgot to put in new source
323
324* Wed Feb 18 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.63-1
325- 1.63
326
327* Fri Jan 30 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.60-1
328- 1.60
329
330* Mon Jan 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.59-1
331- 1.59
332
333* Mon Jan 12 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.58-1
334- 1.58
335
336* Mon Dec 15 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.57-1
337- 1.57
338
339* Tue Dec  9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.56-1
340- 1.56
341
342* Tue Dec  2 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.54-1
343- 1.54
344
345* Tue Nov 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.52-1
346- 1.52
347
348* Tue Nov 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.51-1
349- update to 1.51
350
351* Mon Nov  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.49-1
352- update to 1.49
353
354* Sun Oct 26 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.47-1
355- update to 1.47
356
357* Mon Oct 20 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.46-1
358- update to 1.46
359
360* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2
361- add missing BuildRequires
362
363* Mon Oct  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-1
364- update to 1.44
365
366* Fri Jun 13 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.43-1
367- update to 1.43
368
369* Fri Apr 25 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-3
370- explicitly call "make asymptote.pdf" in doc/
371
372* Fri Apr  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-2
373- fix build failure (use _POSIX_ARG_MAX) resolves bz 440799
374
375* Thu Feb 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.42-1
376- update to 1.42
377
378* Wed Feb  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.41-1
379- update to 1.41
380- enable desktop file for xasy
381
382* Thu Jan  3 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.37-1
383- bump to 1.37
384- fix gcc43 failures
385- drop triggers
386
387* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - sh: kpsewhich: command not found
388- Rebuild for selinux ppc32 issue.
389
390* Sun Jul 29 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.33-1
391- Update 1.33.
392
393* Sat Jun 30 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.32-1
394- Update to 1.32.
395- vim-common triggers: correction and improvements (#246131).
396
397* Wed Jun 27 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.31-1
398- Update to 1.31.
399
400* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.30-1
401- Update to 1.30.
402
403* Sat Jun 16 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-3
404- Using "evince" as the default PS and PDF viewers (#244151).
405  (patch file: asymptote-1.29-settings.patch)
406- Use relative symbolic links in the {emacs,xemacs}-common triggers (#155750).
407- Use relative symbolic links in the vim-common triggers.
408
409* Sat Jun  2 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-2
410- Add asy-faq to install-info (#155750).
411- Add support for vim 7.1.
412
413* Mon May 21 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.29-1
414- Update to 1.29.
415
416* Tue May  8 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.28-1
417- Update to 1.28.
418
419* Sat May  5 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.27-1
420- Update to 1.27.
421
422* Wed Apr 25 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.26-1
423- Update to 1.26.
424
425* Tue Apr 10 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.25-1
426- Update to 1.25.
427
428* Sun Apr  1 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.24-1
429- Update to 1.24.
430
431* Sun Mar 11 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.23-1
432- Update to 1.23.
433
434* Tue Mar  6 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.22-1
435- Update to 1.22.
436
437* Sat Mar  3 2007 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.21-1
438- Update to 1.21.
439
440* Fri Dec 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.20-1
441- Update to 1.20.
442
443* Sat Dec 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.19-1
444- Update to 1.19.
445
446* Sun Nov  5 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.18-1
447- Update to 1.18.
448
449* Wed Nov  1 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.17-1
450- Update to 1.17.
451
452* Wed Oct 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.16-1
453- Update to 1.16.
454
455* Sun Oct 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.15-1
456- Update to 1.15.
457
458* Wed Sep  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.13-1
459- Update to 1.13.
460
461* Thu Aug  3 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1
462- Update to 1.12.
463
464* Thu Jul  6 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1
465- Update to 1.11.
466
467* Wed Jun 28 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.10-1
468- Update to 1.10.
469
470* Fri Jun 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.09-1
471- Update to 1.09.
472
473* Thu Jun 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.08-1
474- Update to 1.08.
475- Also installs the info file.
476
477* Mon May 29 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-5
478- Fedora Core 6: the texinfo package has been splitted (texinfo + texinfo-tex).
479
480* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-4
481- Group: Development/Tools -> Applications/Publishing (#193154).
482
483* Sat May 27 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-3
484- Emacs/Xemacs init file (#193154 comment 6).
485
486* Fri May 26 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-2
487- Directories ownership (#193154).
488
489* Wed May 24 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
490- Update to 1.06.
491- Using triggers to install the Vim syntax file and the Emacs/Xemacs mode file.
492
493* Mon May 22 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.05-1
494- Update to 1.05.
495
496* Sun May  7 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.04-1
497- Update to 1.04.
498
499* Fri Mar 31 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.03-1
500- Update to 1.03.
501
502* Thu Mar 23 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.02-1
503- First build.
504
505# vim:set ai ts=4 sw=4 sts=4 et:
Note: See TracBrowser for help on using the repository browser.