source: projects/specs/trunk/a/apr/apr-vl.spec @ 11916

Revision 11916, 13.6 KB checked in by tomop, 5 years ago (diff)

apr-1.6.5-1

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Name: apr
7Summary: Apache Portable Runtime library
8Summary(ja): Apache ポータブルランタイムライブラリ
9Version: 1.6.5
10Release: 1%{?_dist_release}
11
12Group: System Environment/Libraries
13License: Apache Software License
14URL: http://apr.apache.org/
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19Source0: %{name}-%{version}.tar.bz2
20Source1: apr-wrapper.h
21Patch1: apr-1.6.3-r1834495.patch
22Patch3: apr-1.2.2-locktimeout.patch
23Patch4: apr-1.2.2-libdir.patch
24Patch5: apr-1.3.3-pkgconf.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: autoconf, libtool, python, doxygen
28BuildRequires: libuuid-devel
29# To enable SCTP support
30BuildRequires: lksctp-tools-devel
31
32Conflicts: subversion < 0.20.1-2
33Obsoletes: apache2-apr
34
35%description
36The mission of the Apache Portable Runtime (APR) is to provide a
37free library of C data structures and routines, forming a system
38portability layer to as many operating systems as possible,
39including Unices, MS Win32, BeOS and OS/2.
40
41%package devel
42Summary: APR library development kit
43Summary(ja): APR ライブラリ開発キット
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46Conflicts: subversion-devel < 0.20.1-2
47Obsoletes: apache2-apr-devel
48
49%description devel
50This package provides the support files which can be used to
51build applications using the APR library.  The mission of the
52Apache Portable Runtime (APR) is to provide a free library of
53C data structures and routines.
54
55%prep
56%setup -q
57%patch1 -p1 -b .r1834495
58%patch3 -p1 -b .locktimeout
59%patch4 -p1 -b .libdir
60%patch5 -p1 -b .pkgconf
61
62%build
63# regenerate configure script etc.
64./buildconf
65
66# Forcibly prevent detection of shm_open (which then picks up but
67# does not use -lrt).
68export ac_cv_search_shm_open=no
69
70%configure \
71        --includedir=%{_includedir}/apr-%{aprver} \
72        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
73        --with-devrandom=/dev/urandom \
74        --disable-static \
75        CC=gcc CXX=g++
76make %{?_smp_mflags} && make dox
77
78%install
79rm -rf $RPM_BUILD_ROOT
80make install DESTDIR=$RPM_BUILD_ROOT
81
82# Move docs to more convenient location
83rm -rf html
84mkdir -p html
85cp -pr docs/dox/html/* html/
86# mv docs/dox/html html
87
88# Trim exported dependecies
89sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
90      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
91sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
92      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
93
94%ifarch %{multilib_arches}
95# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
96# packages:
97mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
98   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
99install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
100%endif
101
102# Unpackaged files:
103rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
104rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
105
106%check
107# Fail if LFS support isn't present in a 32-bit build, since this
108# breaks ABI and the soname doesn't change: see #254241
109if grep 'define SIZEOF_VOIDP 4' include/apr.h \
110   && ! grep off64_t include/apr.h; then
111  cat config.log
112  : LFS support not present in 32-bit build
113  exit 1
114fi
115pushd test
116  make %{?_smp_mflags}
117  ./testall -v -q
118popd
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124
125%postun -p /sbin/ldconfig
126
127%files
128%defattr(-,root,root,-)
129%doc CHANGES LICENSE NOTICE
130%{_libdir}/libapr-%{aprver}.so.*
131
132%files devel
133%defattr(-,root,root,-)
134%doc docs/APRDesign.html docs/canonical_filenames.html
135%doc docs/incomplete_types docs/non_apr_programs
136%{_bindir}/apr-%{aprver}-config
137#{_libdir}/libapr-%{aprver}.a
138%{_libdir}/libapr-%{aprver}.so
139%{_libdir}/pkgconfig/*.pc
140%dir %{_libdir}/apr-%{aprver}
141%dir %{_libdir}/apr-%{aprver}/build
142%{_libdir}/apr-%{aprver}/build/*
143%dir %{_includedir}/apr-%{aprver}
144%{_includedir}/apr-%{aprver}/*.h
145
146%changelog
147* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.5-1
148- updated to 1.6.5.
149- dropped Patch2.
150- imported Patch1 from rawhide.
151
152* Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
153- updated to 1.5.2.
154
155* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
156- update to 1.5.1
157
158* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
159- new upstream release
160
161* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
162- new upstream release
163- built with rpm-4.8.1
164- removed static libraries from devel package
165
166* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
167- rebuilt with new toolchain
168
169* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
170- new upstream release
171
172* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
173- new upstream release with security fix (CVE-2009-2412)
174
175* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
176- new upstream release
177
178* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
179- new upstream release
180- updated Patch5
181
182* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
183- new upstream release
184- removed Patch1 and 6
185
186* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
187- removed *.la files from devel package
188
189* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
190- new upstream release
191- added Patch2 and 6 from Fedora
192  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
193  - add fix for use of %%pI with psprintf
194  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
195  - use RTLD_DEEPBIND in apr_dso_open by default
196
197* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
198- new upstream release
199
200* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
201- new upstream release
202
203* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
204- remove Requires: gcc = %%(gcc -dumpversion)
205
206* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
207- rebuilt with new toolchain
208
209* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
210- new upstream release
211
212* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
213- initial build for Vine Linux based on FC package
214
215* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
216- fix another multilib conflict (#192659)
217
218* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
219- BR e2fsprogs-devel for libuuid
220
221* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
222- use multilib parallel-installation wrapper hack for apr.h
223
224* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
225- fix installbuilddir in apr-1-config
226
227* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
228- update to 1.2.7
229- use pkg-config in apr-1-config to make it libdir-agnostic
230
231* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
232- update to 1.2.6
233
234* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
235- bump again for double-long bug on ppc(64)
236
237* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
238- rebuilt for new gcc4.1 snapshot and glibc changes
239
240* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
241- fix namespace pollution (r354824, r355464)
242
243* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
244- fix build with recent glibc (#176911)
245
246* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
247- rebuilt again
248
249* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
250- rebuilt
251
252* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
253- rebuild for new gcc
254
255* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
256- add apr_file_seek() fixes from upstream (r326593, r326597)
257
258* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
259- apr-1-config: strip more exports (#175124)
260
261* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
262- avoid linking against -lrt
263- don't print -L${libdir} in --libs output
264- don't export -lcrypt/-luuid in .la file
265
266* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
267- update to 1.2.2
268
269* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
270- use RTLD_DEEPBIND in apr_dso_open by default
271
272* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
273- update to 0.9.7
274
275* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
276- rebuild for new gcc
277
278* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
279- don't override CFLAGS at build time
280- allow setting TCP_NODELAY and TCP_CORK concurrently
281- use _exit() not exit() in child if exec*() fails (upstream #30913)
282
283* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
284- add from 0.9.x branch:
285 * fix for apr_{uid,gid}_* error handling (r239592)
286 * fix for apr_file_ write flushing (r267192)
287- add backport for use of readdir64_r (r265032, r265681, r265684)
288
289* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
290- rebuild
291
292* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
293- fix apr_procattr_child_*_set error handling
294
295* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
296- have apr-devel depend on specific version of gcc
297- add NOTICE to docdir
298
299* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
300- update to 0.9.6
301
302* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
303- don't disable sendfile on s390 (IBM LTC, #146891)
304
305* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
306- really fix apr-config --srcdir
307
308* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
309- fix apr-config --srcdir again
310
311* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
312- update to 0.9.5
313
314* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
315- rebuild
316
317* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
318- have -devel require apr of same V-R
319
320* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
321- backport fixes from HEAD:
322 * correct implementation of nested mutexes
323 * support for POSIX semaphores on LP64 platforms
324
325* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
326- rebuild for another attempt at using sem_open
327
328* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
329- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
330
331* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
332- rebuild
333
334* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
335- rebuild now /dev/shm is mounted
336
337* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
338- add fix for cleanup structure reuse (part of upstream #23567)
339
340* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
341- rebuilt
342
343* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
344- add support for setuid/setgid/sticky bits (Andr辿 Malo)
345- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
346
347* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
348- enable posixsem and process-shared pthread mutex support, but
349  ensure that sysvsem remains the default mechanism
350
351* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
352- entirely remove 2Gb file size limit from apr_file_copy();
353  fixes "svnadmin hotcopy" on repos with >2Gb strings table
354- work around getnameinfo bugs with v4-mapped addresses
355- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
356
357* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
358- use APR_LARGEFILE in apr_file_{copy,append}
359
360* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
361- add APR_LARGEFILE flag
362
363* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
364- fix configure check for mmap of /dev/zero
365- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
366
367* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
368- rebuilt
369
370* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
371- undocument apr_dir_read() ordering constraint and fix tests
372
373* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
374- rebuilt without -Wall -Werror
375
376* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
377- rebuilt
378
379* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
380- define apr_off_t as int/long/... to prevent it changing
381  with _FILE_OFFSET_BITS on 32-bit platforms
382
383* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
384- add apr_temp_dir_get fixes from HEAD
385
386* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
387- ensure that libapr is linked against libpthread
388- don't link libapr against -lnsl
389
390* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
391- -devel package no longer requires libtool
392
393* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
394- disable tests on x86_64 (#97611)
395
396* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
397- update to 0.9.4, enable tests
398- ensure that libresolv is not used
399
400* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
401- use /dev/urandom (#103049)
402
403* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
404- add back CC=gcc, CXX=g++
405
406* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
407- rebuild
408
409* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
410- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
411
412* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
413- support --cc and --cpp arguments in apr-config
414
415* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
416- force libtool to use CC=gcc, CXX=g++
417
418* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
419- fix libtool location in apr_rules.mk
420
421* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
422- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
423- include a working libtool script rather than relying on
424 /usr/bin/libtool (#97695)
425
426* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
427- don't use /usr/bin/libtool
428
429* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
430- rebuilt
431
432* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
433- add fix for psprintf memory corruption (CAN-2003-0245)
434- remove executable bit from apr_poll.h
435
436* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
437- link libapr against libpthread
438- make apr-devel conflict with old subversion-devel
439- fix License
440
441* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
442- run ldconfig in post/postun
443
444* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
445- patch test suite to not care if IPv6 is disabled
446
447* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
448- initial build
Note: See TracBrowser for help on using the repository browser.