source: projects/specs/trunk/a/apr/apr-vl.spec @ 12478

Revision 12478, 13.8 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

apache2-2.4.46-1

appstream-data-7-2

apr-util-1.6.1-2

apr-1.7.0-2

e2fsprogs-1.45.6-1

gnome-calculator-3.36.0-1

golang-1.15-1

tmux-3.1b-1

valgrind-3.16.1-1

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Summary: Apache Portable Runtime library
7Summary(ja): Apache ポータブルランタイムライブラリ
8Name: apr
9Version: 1.7.0
10Release: 2%{?_dist_release}
11Group: system
12Vendor: Project Vine
13Distribution: Vine Linux
14
15License: Apache Software License
16URL: https://apr.apache.org/
17Source0: http://ftp.tsukuba.wide.ad.jp/software/apache//apr/%{name}-%{version}.tar.bz2
18Source1: apr-wrapper.h
19Patch4: apr-1.2.2-libdir.patch
20Patch5: apr-1.3.3-pkgconf.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: autoconf, libtool, python, doxygen
24BuildRequires: libuuid-devel
25# To enable SCTP support
26BuildRequires: lksctp-tools-devel
27
28Conflicts: subversion < 0.20.1-2
29Obsoletes: apache2-apr
30
31%description
32The mission of the Apache Portable Runtime (APR) is to provide a
33free library of C data structures and routines, forming a system
34portability layer to as many operating systems as possible,
35including Unices, MS Win32, BeOS and OS/2.
36
37
38%package devel
39Summary: APR library development kit
40Summary(ja): APR ライブラリ開発キット
41Group: programming
42Requires: %{name} = %{version}-%{release}
43Conflicts: subversion-devel < 0.20.1-2
44Obsoletes: apache2-apr-devel
45
46%description devel
47This package provides the support files which can be used to
48build applications using the APR library.  The mission of the
49Apache Portable Runtime (APR) is to provide a free library of
50C data structures and routines.
51
52
53%prep
54%setup -q
55%patch4 -p1 -b .libdir
56%patch5 -p1 -b .pkgconf
57
58
59%build
60# regenerate configure script etc.
61./buildconf
62
63# Forcibly prevent detection of shm_open (which then picks up but
64# does not use -lrt).
65export ac_cv_search_shm_open=no
66
67%configure \
68        --includedir=%{_includedir}/apr-%{aprver} \
69        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
70        --with-devrandom=/dev/urandom \
71        --disable-static \
72        CC=gcc CXX=g++
73make %{?_smp_mflags} && make dox
74
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make install DESTDIR=$RPM_BUILD_ROOT
79
80# Move docs to more convenient location
81rm -rf html
82mkdir -p html
83cp -pr docs/dox/html/* html/
84# mv docs/dox/html html
85
86# Trim exported dependecies
87sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
88      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
89sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
90      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
91
92%ifarch %{multilib_arches}
93# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
94# packages:
95mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
96   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
97install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
98%endif
99
100# Unpackaged files:
101rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
102rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
103
104
105%check
106# Fail if LFS support isn't present in a 32-bit build, since this
107# breaks ABI and the soname doesn't change: see #254241
108if grep 'define SIZEOF_VOIDP 4' include/apr.h \
109   && ! grep off64_t include/apr.h; then
110  cat config.log
111  : LFS support not present in 32-bit build
112  exit 1
113fi
114pushd test
115  make %{?_smp_mflags}
116  ./testall -v -q
117popd
118
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123
124%post -p /sbin/ldconfig
125%postun -p /sbin/ldconfig
126
127
128%files
129%defattr(-,root,root,-)
130%license LICENSE
131%doc CHANGES NOTICE
132%{_libdir}/libapr-%{aprver}.so.*
133
134%files devel
135%defattr(-,root,root,-)
136%doc docs/APRDesign.html docs/canonical_filenames.html
137%doc docs/incomplete_types docs/non_apr_programs
138%{_bindir}/apr-%{aprver}-config
139#{_libdir}/libapr-%{aprver}.a
140%{_libdir}/libapr-%{aprver}.so
141%{_libdir}/pkgconfig/*.pc
142%dir %{_libdir}/apr-%{aprver}
143%dir %{_libdir}/apr-%{aprver}/build
144%{_libdir}/apr-%{aprver}/build/*
145%dir %{_includedir}/apr-%{aprver}
146%{_includedir}/apr-%{aprver}/*.h
147
148
149%changelog
150* Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-2
151- rebuilt with current environment.
152
153* Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-1
154- updated to 1.7.0.
155- dropped Patch1 and 3: fixed in upstream.
156
157* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.5-1
158- updated to 1.6.5.
159- dropped Patch2.
160- imported Patch1 from rawhide.
161
162* Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
163- updated to 1.5.2.
164
165* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
166- update to 1.5.1
167
168* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
169- new upstream release
170
171* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
172- new upstream release
173- built with rpm-4.8.1
174- removed static libraries from devel package
175
176* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
177- rebuilt with new toolchain
178
179* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
180- new upstream release
181
182* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
183- new upstream release with security fix (CVE-2009-2412)
184
185* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
186- new upstream release
187
188* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
189- new upstream release
190- updated Patch5
191
192* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
193- new upstream release
194- removed Patch1 and 6
195
196* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
197- removed *.la files from devel package
198
199* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
200- new upstream release
201- added Patch2 and 6 from Fedora
202  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
203  - add fix for use of %%pI with psprintf
204  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
205  - use RTLD_DEEPBIND in apr_dso_open by default
206
207* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
208- new upstream release
209
210* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
211- new upstream release
212
213* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
214- remove Requires: gcc = %%(gcc -dumpversion)
215
216* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
217- rebuilt with new toolchain
218
219* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
220- new upstream release
221
222* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
223- initial build for Vine Linux based on FC package
224
225* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
226- fix another multilib conflict (#192659)
227
228* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
229- BR e2fsprogs-devel for libuuid
230
231* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
232- use multilib parallel-installation wrapper hack for apr.h
233
234* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
235- fix installbuilddir in apr-1-config
236
237* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
238- update to 1.2.7
239- use pkg-config in apr-1-config to make it libdir-agnostic
240
241* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
242- update to 1.2.6
243
244* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
245- bump again for double-long bug on ppc(64)
246
247* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
248- rebuilt for new gcc4.1 snapshot and glibc changes
249
250* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
251- fix namespace pollution (r354824, r355464)
252
253* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
254- fix build with recent glibc (#176911)
255
256* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
257- rebuilt again
258
259* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
260- rebuilt
261
262* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
263- rebuild for new gcc
264
265* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
266- add apr_file_seek() fixes from upstream (r326593, r326597)
267
268* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
269- apr-1-config: strip more exports (#175124)
270
271* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
272- avoid linking against -lrt
273- don't print -L${libdir} in --libs output
274- don't export -lcrypt/-luuid in .la file
275
276* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
277- update to 1.2.2
278
279* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
280- use RTLD_DEEPBIND in apr_dso_open by default
281
282* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
283- update to 0.9.7
284
285* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
286- rebuild for new gcc
287
288* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
289- don't override CFLAGS at build time
290- allow setting TCP_NODELAY and TCP_CORK concurrently
291- use _exit() not exit() in child if exec*() fails (upstream #30913)
292
293* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
294- add from 0.9.x branch:
295 * fix for apr_{uid,gid}_* error handling (r239592)
296 * fix for apr_file_ write flushing (r267192)
297- add backport for use of readdir64_r (r265032, r265681, r265684)
298
299* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
300- rebuild
301
302* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
303- fix apr_procattr_child_*_set error handling
304
305* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
306- have apr-devel depend on specific version of gcc
307- add NOTICE to docdir
308
309* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
310- update to 0.9.6
311
312* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
313- don't disable sendfile on s390 (IBM LTC, #146891)
314
315* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
316- really fix apr-config --srcdir
317
318* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
319- fix apr-config --srcdir again
320
321* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
322- update to 0.9.5
323
324* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
325- rebuild
326
327* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
328- have -devel require apr of same V-R
329
330* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
331- backport fixes from HEAD:
332 * correct implementation of nested mutexes
333 * support for POSIX semaphores on LP64 platforms
334
335* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
336- rebuild for another attempt at using sem_open
337
338* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
339- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
340
341* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
342- rebuild
343
344* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
345- rebuild now /dev/shm is mounted
346
347* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
348- add fix for cleanup structure reuse (part of upstream #23567)
349
350* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
351- rebuilt
352
353* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
354- add support for setuid/setgid/sticky bits (Andr辿 Malo)
355- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
356
357* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
358- enable posixsem and process-shared pthread mutex support, but
359  ensure that sysvsem remains the default mechanism
360
361* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
362- entirely remove 2Gb file size limit from apr_file_copy();
363  fixes "svnadmin hotcopy" on repos with >2Gb strings table
364- work around getnameinfo bugs with v4-mapped addresses
365- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
366
367* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
368- use APR_LARGEFILE in apr_file_{copy,append}
369
370* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
371- add APR_LARGEFILE flag
372
373* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
374- fix configure check for mmap of /dev/zero
375- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
376
377* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
378- rebuilt
379
380* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
381- undocument apr_dir_read() ordering constraint and fix tests
382
383* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
384- rebuilt without -Wall -Werror
385
386* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
387- rebuilt
388
389* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
390- define apr_off_t as int/long/... to prevent it changing
391  with _FILE_OFFSET_BITS on 32-bit platforms
392
393* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
394- add apr_temp_dir_get fixes from HEAD
395
396* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
397- ensure that libapr is linked against libpthread
398- don't link libapr against -lnsl
399
400* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
401- -devel package no longer requires libtool
402
403* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
404- disable tests on x86_64 (#97611)
405
406* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
407- update to 0.9.4, enable tests
408- ensure that libresolv is not used
409
410* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
411- use /dev/urandom (#103049)
412
413* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
414- add back CC=gcc, CXX=g++
415
416* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
417- rebuild
418
419* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
420- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
421
422* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
423- support --cc and --cpp arguments in apr-config
424
425* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
426- force libtool to use CC=gcc, CXX=g++
427
428* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
429- fix libtool location in apr_rules.mk
430
431* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
432- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
433- include a working libtool script rather than relying on
434 /usr/bin/libtool (#97695)
435
436* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
437- don't use /usr/bin/libtool
438
439* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
440- rebuilt
441
442* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
443- add fix for psprintf memory corruption (CAN-2003-0245)
444- remove executable bit from apr_poll.h
445
446* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
447- link libapr against libpthread
448- make apr-devel conflict with old subversion-devel
449- fix License
450
451* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
452- run ldconfig in post/postun
453
454* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
455- patch test suite to not care if IPv6 is disabled
456
457* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
458- initial build
Note: See TracBrowser for help on using the repository browser.