source: projects/specs/trunk/a/apr/apr-vl.spec @ 12278

Revision 12278, 13.7 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

apr-1.7.0-1

busybox-1.30.1-1

file-5.37-1

libgsf-1.14.46-1

libsndfile-1.0.28-2

subversion-1.12.2-1

uClibc-ng-1.0.32-1

wireshark-3.0.5-1

Line 
1%define aprver 1
2
3# Arches on which the multilib apr.h hack is needed:
4%define multilib_arches %{ix86} ia64 ppc ppc64 s390 s390x x86_64
5
6Name: apr
7Summary: Apache Portable Runtime library
8Summary(ja): Apache ポータブルランタイムライブラリ
9Version: 1.7.0
10Release: 1%{?_dist_release}
11
12Group: System Environment/Libraries
13License: Apache Software License
14URL: https://apr.apache.org/
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19Source0: http://ftp.tsukuba.wide.ad.jp/software/apache//apr/%{name}-%{version}.tar.bz2
20Source1: apr-wrapper.h
21Patch4: apr-1.2.2-libdir.patch
22Patch5: apr-1.3.3-pkgconf.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-root
25BuildRequires: autoconf, libtool, python, doxygen
26BuildRequires: libuuid-devel
27# To enable SCTP support
28BuildRequires: lksctp-tools-devel
29
30Conflicts: subversion < 0.20.1-2
31Obsoletes: apache2-apr
32
33%description
34The mission of the Apache Portable Runtime (APR) is to provide a
35free library of C data structures and routines, forming a system
36portability layer to as many operating systems as possible,
37including Unices, MS Win32, BeOS and OS/2.
38
39%package devel
40Summary: APR library development kit
41Summary(ja): APR ライブラリ開発キット
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Conflicts: subversion-devel < 0.20.1-2
45Obsoletes: apache2-apr-devel
46
47%description devel
48This package provides the support files which can be used to
49build applications using the APR library.  The mission of the
50Apache Portable Runtime (APR) is to provide a free library of
51C data structures and routines.
52
53%prep
54%setup -q
55%patch4 -p1 -b .libdir
56%patch5 -p1 -b .pkgconf
57
58%build
59# regenerate configure script etc.
60./buildconf
61
62# Forcibly prevent detection of shm_open (which then picks up but
63# does not use -lrt).
64export ac_cv_search_shm_open=no
65
66%configure \
67        --includedir=%{_includedir}/apr-%{aprver} \
68        --with-installbuilddir=%{_libdir}/apr-%{aprver}/build \
69        --with-devrandom=/dev/urandom \
70        --disable-static \
71        CC=gcc CXX=g++
72make %{?_smp_mflags} && make dox
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make install DESTDIR=$RPM_BUILD_ROOT
77
78# Move docs to more convenient location
79rm -rf html
80mkdir -p html
81cp -pr docs/dox/html/* html/
82# mv docs/dox/html html
83
84# Trim exported dependecies
85sed -ri '/^dependency_libs/{s,-l(uuid|crypt) ,,g}' \
86      $RPM_BUILD_ROOT%{_libdir}/libapr*.la
87sed -ri '/^LIBS=/{s,-l(uuid|crypt) ,,g;s/  */ /g}' \
88      $RPM_BUILD_ROOT%{_bindir}/apr-%{aprver}-config
89
90%ifarch %{multilib_arches}
91# Ugly hack to allow parallel installation of 32-bit and 64-bit apr-devel
92# packages:
93mv $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h \
94   $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr-%{_arch}.h
95install -c -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_includedir}/apr-%{aprver}/apr.h
96%endif
97
98# Unpackaged files:
99rm -f $RPM_BUILD_ROOT%{_libdir}/apr.exp
100rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
101
102%check
103# Fail if LFS support isn't present in a 32-bit build, since this
104# breaks ABI and the soname doesn't change: see #254241
105if grep 'define SIZEOF_VOIDP 4' include/apr.h \
106   && ! grep off64_t include/apr.h; then
107  cat config.log
108  : LFS support not present in 32-bit build
109  exit 1
110fi
111pushd test
112  make %{?_smp_mflags}
113  ./testall -v -q
114popd
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%files
124%defattr(-,root,root,-)
125%license LICENSE
126%doc CHANGES NOTICE
127%{_libdir}/libapr-%{aprver}.so.*
128
129%files devel
130%defattr(-,root,root,-)
131%doc docs/APRDesign.html docs/canonical_filenames.html
132%doc docs/incomplete_types docs/non_apr_programs
133%{_bindir}/apr-%{aprver}-config
134#{_libdir}/libapr-%{aprver}.a
135%{_libdir}/libapr-%{aprver}.so
136%{_libdir}/pkgconfig/*.pc
137%dir %{_libdir}/apr-%{aprver}
138%dir %{_libdir}/apr-%{aprver}/build
139%{_libdir}/apr-%{aprver}/build/*
140%dir %{_includedir}/apr-%{aprver}
141%{_includedir}/apr-%{aprver}/*.h
142
143%changelog
144* Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-1
145- updated to 1.7.0.
146- dropped Patch1 and 3: fixed in upstream.
147
148* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.5-1
149- updated to 1.6.5.
150- dropped Patch2.
151- imported Patch1 from rawhide.
152
153* Mon May 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
154- updated to 1.5.2.
155
156* Thu May 22 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.1-1
157- update to 1.5.1
158
159* Sat Oct  1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.5-1
160- new upstream release
161
162* Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.2-1
163- new upstream release
164- built with rpm-4.8.1
165- removed static libraries from devel package
166
167* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.10-1
168- rebuilt with new toolchain
169
170* Thu Dec 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.9-1
171- new upstream release
172
173* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.8-1
174- new upstream release with security fix (CVE-2009-2412)
175
176* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.5-1
177- new upstream release
178
179* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.3-1vl5
180- new upstream release
181- updated Patch5
182
183* Wed Jun 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-1vl5
184- new upstream release
185- removed Patch1 and 6
186
187* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-2vl5
188- removed *.la files from devel package
189
190* Sat Apr  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1vl5
191- new upstream release
192- added Patch2 and 6 from Fedora
193  * Mon Jun 19 2006 Joe Orton <jorton@redhat.com> 1.2.7-9
194  - add fix for use of %%pI with psprintf
195  * Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
196  - use RTLD_DEEPBIND in apr_dso_open by default
197
198* Sat Sep 29 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.11-0vl1
199- new upstream release
200
201* Thu Jul 26 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.9-0vl1
202- new upstream release
203
204* Mon May 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl3
205- remove Requires: gcc = %%(gcc -dumpversion)
206
207* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.8-0vl2
208- rebuilt with new toolchain
209
210* Sat Jan 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.8-0vl1
211- new upstream release
212
213* Mon May 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
214- initial build for Vine Linux based on FC package
215
216* Tue May 23 2006 Joe Orton <jorton@redhat.com> 1.2.7-7
217- fix another multilib conflict (#192659)
218
219* Tue May 16 2006 Joe Orton <jorton@redhat.com> 1.2.7-6
220- BR e2fsprogs-devel for libuuid
221
222* Mon May  8 2006 Joe Orton <jorton@redhat.com> 1.2.7-4
223- use multilib parallel-installation wrapper hack for apr.h
224
225* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-3
226- fix installbuilddir in apr-1-config
227
228* Tue May  2 2006 Joe Orton <jorton@redhat.com> 1.2.7-2
229- update to 1.2.7
230- use pkg-config in apr-1-config to make it libdir-agnostic
231
232* Thu Apr  6 2006 Joe Orton <jorton@redhat.com> 1.2.6-2
233- update to 1.2.6
234
235* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.2
236- bump again for double-long bug on ppc(64)
237
238* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.2-7.1
239- rebuilt for new gcc4.1 snapshot and glibc changes
240
241* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-7
242- fix namespace pollution (r354824, r355464)
243
244* Wed Jan  4 2006 Joe Orton <jorton@redhat.com> 1.2.2-6
245- fix build with recent glibc (#176911)
246
247* Tue Jan  3 2006 Jesse Keating <jkeating@redhat.com> 1.2.2-5.2
248- rebuilt again
249
250* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
251- rebuilt
252
253* Fri Dec  9 2005 Joe Orton <jorton@redhat.com> 1.2.2-5
254- rebuild for new gcc
255
256* Thu Dec  8 2005 Joe Orton <jorton@redhat.com> 1.2.2-4
257- add apr_file_seek() fixes from upstream (r326593, r326597)
258
259* Wed Dec  7 2005 Joe Orton <jorton@redhat.com> 1.2.2-3
260- apr-1-config: strip more exports (#175124)
261
262* Tue Dec  6 2005 Joe Orton <jorton@redhat.com> 1.2.2-2
263- avoid linking against -lrt
264- don't print -L${libdir} in --libs output
265- don't export -lcrypt/-luuid in .la file
266
267* Fri Dec  2 2005 Joe Orton <jorton@redhat.com> 1.2.2-1
268- update to 1.2.2
269
270* Thu Nov 24 2005 Joe Orton <jorton@redhat.com> 0.9.7-3
271- use RTLD_DEEPBIND in apr_dso_open by default
272
273* Thu Oct 20 2005 Joe Orton <jorton@redhat.com> 0.9.7-2
274- update to 0.9.7
275
276* Fri Sep 30 2005 Florian La Roche <laroche@redhat.com>
277- rebuild for new gcc
278
279* Thu Sep 15 2005 Joe Orton <jorton@redhat.com> 0.9.6-6
280- don't override CFLAGS at build time
281- allow setting TCP_NODELAY and TCP_CORK concurrently
282- use _exit() not exit() in child if exec*() fails (upstream #30913)
283
284* Fri Sep  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-5
285- add from 0.9.x branch:
286 * fix for apr_{uid,gid}_* error handling (r239592)
287 * fix for apr_file_ write flushing (r267192)
288- add backport for use of readdir64_r (r265032, r265681, r265684)
289
290* Mon Jul 11 2005 Florian La Roche <laroche@redhat.com>
291- rebuild
292
293* Tue May 17 2005 Joe Orton <jorton@redhat.com> 0.9.6-3
294- fix apr_procattr_child_*_set error handling
295
296* Tue Mar  1 2005 Joe Orton <jorton@redhat.com> 0.9.6-2
297- have apr-devel depend on specific version of gcc
298- add NOTICE to docdir
299
300* Wed Feb  9 2005 Joe Orton <jorton@redhat.com> 0.9.6-1
301- update to 0.9.6
302
303* Wed Feb  2 2005 Joe Orton <jorton@redhat.com> 0.9.5-4
304- don't disable sendfile on s390 (IBM LTC, #146891)
305
306* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-3
307- really fix apr-config --srcdir
308
309* Mon Nov 22 2004 Joe Orton <jorton@redhat.com> 0.9.5-2
310- fix apr-config --srcdir again
311
312* Sun Nov 21 2004 Joe Orton <jorton@redhat.com> 0.9.5-1
313- update to 0.9.5
314
315* Mon Sep 27 2004 Joe Orton <jorton@redhat.com> 0.9.4-24
316- rebuild
317
318* Wed Sep  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-23
319- have -devel require apr of same V-R
320
321* Tue Aug 31 2004 Joe Orton <jorton@redhat.com> 0.9.4-22
322- backport fixes from HEAD:
323 * correct implementation of nested mutexes
324 * support for POSIX semaphores on LP64 platforms
325
326* Thu Jul 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-21
327- rebuild for another attempt at using sem_open
328
329* Tue Jul 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-20
330- move sticky/suid bits outside APR_OS_DEFAULT bitmask (Greg Hudson)
331
332* Thu Jul  1 2004 Joe Orton <jorton@redhat.com> 0.9.4-19
333- rebuild
334
335* Wed Jun 30 2004 Joe Orton <jorton@redhat.com> 0.9.4-18
336- rebuild now /dev/shm is mounted
337
338* Thu Jun 17 2004 Joe Orton <jorton@redhat.com> 0.9.4-17
339- add fix for cleanup structure reuse (part of upstream #23567)
340
341* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
342- rebuilt
343
344* Thu Jun 10 2004 Joe Orton <jorton@redhat.com> 0.9.4-15
345- add support for setuid/setgid/sticky bits (Andr辿 Malo)
346- add apr_threadattr_{guardsize,stacksize}_set() (latter by Jeff Trawick)
347
348* Mon Jun  7 2004 Joe Orton <jorton@redhat.com> 0.9.4-14
349- enable posixsem and process-shared pthread mutex support, but
350  ensure that sysvsem remains the default mechanism
351
352* Mon May 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-13
353- entirely remove 2Gb file size limit from apr_file_copy();
354  fixes "svnadmin hotcopy" on repos with >2Gb strings table
355- work around getnameinfo bugs with v4-mapped addresses
356- fix apr_time_exp_get() for dates in 2038 (Philip Martin)
357
358* Thu May 13 2004 Joe Orton <jorton@redhat.com> 0.9.4-12
359- use APR_LARGEFILE in apr_file_{copy,append}
360
361* Wed Mar 24 2004 Joe Orton <jorton@redhat.com> 0.9.4-11
362- add APR_LARGEFILE flag
363
364* Mon Mar 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-10
365- fix configure check for mmap of /dev/zero
366- just put -D_GNU_SOURCE in CPPFLAGS not _{BSD,SVID,XOPEN}_SOURCE
367
368* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-9.1
369- rebuilt
370
371* Thu Feb 19 2004 Joe Orton <jorton@redhat.com> 0.9.4-9
372- undocument apr_dir_read() ordering constraint and fix tests
373
374* Sun Feb 15 2004 Joe Orton <jorton@redhat.com> 0.9.4-8
375- rebuilt without -Wall -Werror
376
377* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 0.9.4-7
378- rebuilt
379
380* Tue Feb  3 2004 Joe Orton <jorton@redhat.com> 0.9.4-6
381- define apr_off_t as int/long/... to prevent it changing
382  with _FILE_OFFSET_BITS on 32-bit platforms
383
384* Mon Jan 12 2004 Joe Orton <jorton@redhat.com> 0.9.4-5
385- add apr_temp_dir_get fixes from HEAD
386
387* Thu Jan  8 2004 Joe Orton <jorton@redhat.com> 0.9.4-4
388- ensure that libapr is linked against libpthread
389- don't link libapr against -lnsl
390
391* Thu Nov 13 2003 Joe Orton <jorton@redhat.com> 0.9.4-3
392- -devel package no longer requires libtool
393
394* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-2
395- disable tests on x86_64 (#97611)
396
397* Fri Oct  3 2003 Joe Orton <jorton@redhat.com> 0.9.4-1
398- update to 0.9.4, enable tests
399- ensure that libresolv is not used
400
401* Sun Sep  7 2003 Joe Orton <jorton@redhat.com> 0.9.3-14
402- use /dev/urandom (#103049)
403
404* Thu Jul 24 2003 Joe Orton <jorton@redhat.com> 0.9.3-13
405- add back CC=gcc, CXX=g++
406
407* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.9.3-12
408- rebuild
409
410* Mon Jul 14 2003 Joe Orton <jorton@redhat.com> 0.9.3-11
411- work round useless autoconf 2.57 AC_DECL_SYS_SIGLIST
412
413* Thu Jul 10 2003 Joe Orton <jorton@redhat.com> 0.9.3-10
414- support --cc and --cpp arguments in apr-config
415
416* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-9
417- force libtool to use CC=gcc, CXX=g++
418
419* Thu Jul  3 2003 Joe Orton <jorton@redhat.com> 0.9.3-8
420- fix libtool location in apr_rules.mk
421
422* Mon Jun 30 2003 Joe Orton <jorton@redhat.com> 0.9.3-7
423- use AI_ADDRCONFIG in getaddrinfo() support (#73350)
424- include a working libtool script rather than relying on
425 /usr/bin/libtool (#97695)
426
427* Wed Jun 18 2003 Joe Orton <jorton@redhat.com> 0.9.3-6
428- don't use /usr/bin/libtool
429
430* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
431- rebuilt
432
433* Tue May 20 2003 Joe Orton <jorton@redhat.com> 0.9.3-5
434- add fix for psprintf memory corruption (CAN-2003-0245)
435- remove executable bit from apr_poll.h
436
437* Thu May  1 2003 Joe Orton <jorton@redhat.com> 0.9.3-4
438- link libapr against libpthread
439- make apr-devel conflict with old subversion-devel
440- fix License
441
442* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-3
443- run ldconfig in post/postun
444
445* Tue Apr 29 2003 Joe Orton <jorton@redhat.com> 0.9.3-2
446- patch test suite to not care if IPv6 is disabled
447
448* Mon Apr 28 2003 Joe Orton <jorton@redhat.com> 0.9.3-1
449- initial build
Note: See TracBrowser for help on using the repository browser.