source: projects/specs/trunk/O/ORBit2/ORBit2-vl.spec @ 787

Revision 787, 11.9 KB checked in by inagaki, 14 years ago (diff)

updated: ORBit2

Line 
1%define libidl_version 0.8.11
2%define glib2_version 2.20.0
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5Summary: A high-performance CORBA Object Request Broker.
6Summary(ja): 高性能な CORBA Object Request Broker.
7Name: ORBit2
8Version: 2.14.18
9Release: 1%{?_dist_release}
10Group: System Environment/Libraries
11License: LGPL/GPL
12URL: http://www.labs.redhat.com/orbit/
13
14Source: %{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libIDL-devel >= %{libidl_version}
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: gtk-doc
20
21%description
22ORBit is a high-performance CORBA (Common Object Request Broker
23Architecture) ORB (object request broker). It allows programs to
24send requests and receive replies from other programs, regardless
25of the locations of the two programs. CORBA is an architecture that
26enables communication between program objects, regardless of the
27programming language they're written in or the operating system they
28run on.
29
30You will need to install this package and ORBit-devel if you want to
31write programs that use CORBA technology.
32#'
33
34%package devel
35Summary: Development libraries, header files and utilities for ORBit.
36Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: indent
40Requires: libIDL-devel >= %{libidl_version}
41Requires: glib2-devel >= %{glib2_version}
42Conflicts: ORBit-devel <= 0.5.8
43
44%description devel
45ORBit is a high-performance CORBA (Common Object Request Broker
46Architecture) ORB (object request broker) with support for the
47C language.
48
49This package contains the header files, libraries and utilities
50necessary to write programs that use CORBA technology. If you want to
51write such programs, you'll also need to install the ORBIT package.
52#'
53
54%package -n compat32-%{name}
55Summary: A high-performance CORBA Object Request Broker.
56Summary(ja): 高性能な CORBA Object Request Broker.
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59
60%description -n compat32-%{name}
61ORBit is a high-performance CORBA (Common Object Request Broker
62Architecture) ORB (object request broker). It allows programs to
63send requests and receive replies from other programs, regardless
64of the locations of the two programs. CORBA is an architecture that
65enables communication between program objects, regardless of the
66programming language they're written in or the operating system they
67run on.
68
69You will need to install this package and ORBit-devel if you want to
70write programs that use CORBA technology.
71#'
72
73%package -n compat32-%{name}-devel
74Summary: Development libraries, header files and utilities for ORBit.
75Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78Requires: compat32-%{name} = %{version}-%{release}
79Requires: compat32-libIDL-devel >= %{libidl_version}
80Requires: compat32-glib2-devel >= %{glib2_version}
81
82%description -n compat32-%{name}-devel
83ORBit is a high-performance CORBA (Common Object Request Broker
84Architecture) ORB (object request broker) with support for the
85C language.
86
87This package contains the header files, libraries and utilities
88necessary to write programs that use CORBA technology. If you want to
89write such programs, you'll also need to install the ORBIT package.
90#'
91
92%prep
93%setup -q
94
95echo "glib-2.0 version is `pkg-config --modversion glib-2.0`"
96
97%build
98%configure --enable-gtk-doc
99# don't use smp flags
100export tagname=CC
101make LIBTOOL=/usr/bin/libtool
102
103%install
104rm -rf $RPM_BUILD_ROOT
105export tagname=CC
106%makeinstall LIBTOOL=/usr/bin/libtool
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/libORBit*.{a,la}
109rm -f $RPM_BUILD_ROOT%{_libdir}/ORBit-2.0/*.*a
110rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
111
112rm -f $RPM_BUILD_ROOT%{_bindir}/linc-cleanup-sockets
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(-,root,root)
127%doc AUTHORS COPYING ChangeLog NEWS README TODO
128%{_libdir}/*.so.*
129%{_libdir}/orbit-2.0/*.so*
130
131%files devel
132%defattr(-,root,root)
133%{_libdir}/*.so
134# this is needed by libbonobo
135%{_libdir}/libname-server-2.a
136%{_libdir}/pkgconfig/*
137%{_bindir}/orbit-idl-2
138%{_bindir}/typelib-dump
139%{_bindir}/orbit2-config
140%{_bindir}/ior-decode-2
141#%{_bindir}/linc-cleanup-sockets
142%{_includedir}/*
143%{_datadir}/aclocal/*.m4
144%{_datadir}/idl/orbit-2.0/
145%{_datadir}/gtk-doc/html/ORBit2
146
147# compat32
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root)
151%{_libdir}/*.so.*
152%{_libdir}/orbit-2.0/*.so*
153
154%files -n compat32-%{name}-devel
155%defattr(-,root,root)
156%{_libdir}/*.so
157# this is needed by libbonobo
158%{_libdir}/libname-server-2.a
159%{_libdir}/pkgconfig/*
160%endif
161
162%changelog
163* Sat Apr 10 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.14.18-1
164- new upstream release
165- built with new toolchain
166
167* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.17-3
168- added compat32 package for x86_64 arch support
169- added BuildRequires: gtk-doc
170- re-added a static library, %%{_libdir}/libname-server-2.a that is needed by libbonobo
171
172* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.17-2
173- remove static libs
174
175* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.17-1
176- new upstream release
177
178* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.16-1
179- new upstream release
180- built with libIDL-0.8.11
181- spec in UTF-8
182
183* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.12-2vl5
184- rebuilt without libIDL-2.la
185
186* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.12-1vl5
187- new upstream release
188- built with libIDL-0.8.10
189- remove BuildRequires: automake16
190
191* Sat Jan 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.11-0vl1
192- new upstream release
193
194* Mon Jan 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.10-0vl2
195- dropt %%{_smp_mflags} to make
196
197* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.10-0vl1
198- new upstream release
199
200* Tue Oct  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.9-0vl1
201- new upstream release
202- changed Group to System Environment/Libraries
203
204* Fri Mar 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.7-0vl1
205- new upstream release
206
207* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
208- new upstream release
209
210* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
211- new upstream release
212
213* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.3-0vl1
214- new upstream release
215
216* Sun Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.5-0vl1
217- new upstream release
218
219* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.4-0vl1
220- new upstream release
221
222* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
223- new upstream release
224
225* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
226- new upstream release
227- added gtk-doc directory
228
229* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
230- new upstream release
231
232* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.8-0vl1
233- new upstream release
234
235* Tue Feb 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-0vl3
236- add patch0 from fedora
237
238* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl2
239- rebuild with new toolchains
240
241* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
242- new upstream release
243- rebuild with new toolchains
244
245* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
246- new upstream release
247
248* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
249- new upstream release
250
251* Fri Jul 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-0vl1
252- new upstream release
253
254* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
255- new upstream release
256
257* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
258- new upstream release
259
260* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
261- build for Vine Linux
262
263* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
264- 2.4.1
265
266* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
267- automated rebuild
268
269* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
270- rebuild in different environment
271
272* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
273- 2.4.0
274
275* Sun May 26 2002 Tim Powers <timp@redhat.com>
276- automated rebuild
277
278* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
279- rebuild in different environment
280
281* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
282- 2.3.109
283
284* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
285- 2.3.108
286
287* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
288- 2.3.107
289
290* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
291- 2.3.105
292
293* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
294- Version 2.3.103
295- Rebuild for dependencies
296
297* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
298- automated rebuild
299
300* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
301- build system somehow built against libglib-1.3.so.11
302  even though pkg-config found 1.3.12? wtf?
303  trying again
304
305* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
306- 2.3.100.90 snap
307
308* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
309- 2.3.99
310
311* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
312- new snap 2.3.97.90, rebuild for glib 1.3.11
313
314* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
315- new snap, glib 1.3.10 rebuild
316
317* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
318- check rebuild against new linc with headers moved
319- remove epoch, that was a screwup
320
321* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
322- cvs snap
323- require specific glib2
324
325* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
326- 2.3.95 tarball
327- depend on new standalone libIDL, remove all libIDL stuff from file list
328
329* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
330- require specific linc version, unrequire specific glib version since
331  we get that via linc
332
333* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
334- newer orbit2 from CVS
335
336* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
337- conflict with old orbit with headers not moved
338
339* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
340- renaming more things
341- remove smp flags, doesn't work atm
342- fix .pc file, trying to get bonobo-activation to build
343
344* Tue Sep 11 2001 Havoc Pennington <hp@redhat.com>
345- kill all file conflicts with ORBit1
346
347* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
348- convert to ORBit2 spec file (from ORBit original)
349
350* Tue Jul 24 2001 Alexander Larsson <alexl@redhat.com>
351- Added glib-devel BuildRequires
352
353* Thu Jun 21 2001 Elliot Lee <sopwith@redhat.com> 0.5.8-2
354- Use _smp_mflags if possible.
355
356* Mon May 14 2001 Jonathan Blandford <jrb@redhat.com>
357- bumped version
358
359* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
360- Rebuild for GTK+-1.2.9
361
362* Tue Jan 30 2001 Elliot Lee <sopwith@redhat.com>
363- 0.5.7 for real
364
365* Thu Jan 18 2001 Elliot Lee <sopwith@redhat.com>
366- 0.5.7
367
368* Tue Dec 19 2000 Elliot Lee <sopwith@redhat.com>
369- 0.5.6
370
371* Thu Nov 30 2000 Elliot Lee <sopwith@redhat.com>
372- 0.5.5
373
374* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
375- Up Epoch and release
376
377* Tue Jul 25 2000 Elliot Lee <sopwith@redhat.com>
378- 0.5.3
379
380* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
381- fixed to work with new cpp.
382
383* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
384- automatic rebuild
385
386* Tue Jul 11 2000 Jonathan Blandford <jrb@redhat.com>
387- Upgraded to 0.5.2 - a bug fix release.
388
389* Tue Jun 27 2000 Havoc Pennington <hp@redhat.com>
390- Trying to build the package for Preston and the build
391  system wants a new changelog entry
392
393* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
394- defattr the devel pkg
395- FHS paths
396
397* Fri May 19 2000 Jonathan Blandford <jrb@redhat.com>
398- Upgraded to 0.5.1
399
400* Tue Feb  3 2000 Elliot Lee <sopwith@redhat.com> 0.5.0-3
401- Strip shared libraries
402
403* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.4.94-1
404- Spec file fixes from RHL 6.0.
405
406* Wed Jun 2 1999  Jose Mercado <jmercado@mit.edu>
407- Fixed configure.in so spec.in could be used.
408
409* Mon Nov 23 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
410
411- improved %files section, and added use of %{prefix} and install-info
412  (well,... no. The info file has not dir info inside, commented out)
Note: See TracBrowser for help on using the repository browser.