source: projects/specs/trunk/O/ORBit2/ORBit2-vl.spec @ 8084

Revision 8084, 12.3 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define libidl_version 0.8.14
2%define glib2_version 2.26.0
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5Summary: A high-performance CORBA Object Request Broker.
6Summary(ja): 高性能な CORBA Object Request Broker.
7Name: ORBit2
8Version: 2.14.19
9Release: 2%{?_dist_release}
10Group: System Environment/Libraries
11License: LGPL/GPL
12URL: http://www.labs.redhat.com/orbit/
13
14Source: %{name}-%{version}.tar.bz2
15
16Patch0: ORBit2-2.14.19-git20130514.patch
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: libIDL-devel >= %{libidl_version}
19BuildRequires: glib2-devel >= %{glib2_version}
20BuildRequires: gtk-doc
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26ORBit is a high-performance CORBA (Common Object Request Broker
27Architecture) ORB (object request broker). It allows programs to
28send requests and receive replies from other programs, regardless
29of the locations of the two programs. CORBA is an architecture that
30enables communication between program objects, regardless of the
31programming language they're written in or the operating system they
32run on.
33
34You will need to install this package and ORBit-devel if you want to
35write programs that use CORBA technology.
36#'
37
38%package devel
39Summary: Development libraries, header files and utilities for ORBit.
40Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: indent
44Requires: libIDL-devel >= %{libidl_version}
45Requires: glib2-devel >= %{glib2_version}
46Conflicts: ORBit-devel <= 0.5.8
47
48%description devel
49ORBit is a high-performance CORBA (Common Object Request Broker
50Architecture) ORB (object request broker) with support for the
51C language.
52
53This package contains the header files, libraries and utilities
54necessary to write programs that use CORBA technology. If you want to
55write such programs, you'll also need to install the ORBIT package.
56#'
57
58%package -n compat32-%{name}
59Summary: A high-performance CORBA Object Request Broker.
60Summary(ja): 高性能な CORBA Object Request Broker.
61Group: System Environment/Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description -n compat32-%{name}
65ORBit is a high-performance CORBA (Common Object Request Broker
66Architecture) ORB (object request broker). It allows programs to
67send requests and receive replies from other programs, regardless
68of the locations of the two programs. CORBA is an architecture that
69enables communication between program objects, regardless of the
70programming language they're written in or the operating system they
71run on.
72
73You will need to install this package and ORBit-devel if you want to
74write programs that use CORBA technology.
75#'
76
77%package -n compat32-%{name}-devel
78Summary: Development libraries, header files and utilities for ORBit.
79Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
80Group: Development/Libraries
81Requires: %{name}-devel = %{version}-%{release}
82Requires: compat32-%{name} = %{version}-%{release}
83Requires: compat32-libIDL-devel >= %{libidl_version}
84Requires: compat32-glib2-devel >= %{glib2_version}
85
86%description -n compat32-%{name}-devel
87ORBit is a high-performance CORBA (Common Object Request Broker
88Architecture) ORB (object request broker) with support for the
89C language.
90
91This package contains the header files, libraries and utilities
92necessary to write programs that use CORBA technology. If you want to
93write such programs, you'll also need to install the ORBIT package.
94#'
95
96%prep
97%setup -q
98%patch0 -p1
99
100echo "glib-2.0 version is `pkg-config --modversion glib-2.0`"
101
102%build
103autoreconf -if
104%configure --enable-gtk-doc
105# don't use smp flags
106export tagname=CC
107make LIBTOOL=/usr/bin/libtool
108
109%install
110rm -rf $RPM_BUILD_ROOT
111export tagname=CC
112%makeinstall LIBTOOL=/usr/bin/libtool
113
114rm -f $RPM_BUILD_ROOT%{_libdir}/libORBit*.{a,la}
115rm -f $RPM_BUILD_ROOT%{_libdir}/ORBit-2.0/*.*a
116rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
117
118rm -f $RPM_BUILD_ROOT%{_bindir}/linc-cleanup-sockets
119
120%post -p /sbin/ldconfig
121
122%postun -p /sbin/ldconfig
123
124%post -n compat32-%{name} -p /sbin/ldconfig
125
126%postun -n compat32-%{name} -p /sbin/ldconfig
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%files
132%defattr(-,root,root)
133%doc AUTHORS COPYING ChangeLog NEWS README TODO
134%{_libdir}/*.so.*
135%{_libdir}/orbit-2.0/*.so*
136
137%files devel
138%defattr(-,root,root)
139%{_libdir}/*.so
140# this is needed by libbonobo
141%{_libdir}/libname-server-2.a
142%{_libdir}/pkgconfig/*
143%{_bindir}/orbit-idl-2
144%{_bindir}/typelib-dump
145%{_bindir}/orbit2-config
146%{_bindir}/ior-decode-2
147#%{_bindir}/linc-cleanup-sockets
148%{_includedir}/*
149%{_datadir}/aclocal/*.m4
150%{_datadir}/idl/orbit-2.0/
151%{_datadir}/gtk-doc/html/ORBit2
152
153# compat32
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-,root,root)
157%{_libdir}/*.so.*
158%{_libdir}/orbit-2.0/*.so*
159
160%files -n compat32-%{name}-devel
161%defattr(-,root,root)
162%{_libdir}/*.so
163# this is needed by libbonobo
164%{_libdir}/libname-server-2.a
165%endif
166
167%changelog
168* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.19-2
169- rebuild with VineSeed environment
170- add Patch0 (ORBit2-2.14.19-git20130514.patch)
171
172* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.19-1
173- new upstream release
174
175* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.14.18-2
176- build with rpm-4.8.1-1 for pkg-config file
177
178* Sat Apr 10 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.14.18-1
179- new upstream release
180- built with new toolchain
181
182* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.17-3
183- added compat32 package for x86_64 arch support
184- added BuildRequires: gtk-doc
185- re-added a static library, %%{_libdir}/libname-server-2.a that is needed by libbonobo
186
187* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.17-2
188- remove static libs
189
190* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.17-1
191- new upstream release
192
193* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.16-1
194- new upstream release
195- built with libIDL-0.8.11
196- spec in UTF-8
197
198* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.12-2vl5
199- rebuilt without libIDL-2.la
200
201* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.12-1vl5
202- new upstream release
203- built with libIDL-0.8.10
204- remove BuildRequires: automake16
205
206* Sat Jan 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.11-0vl1
207- new upstream release
208
209* Mon Jan 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.10-0vl2
210- dropt %%{_smp_mflags} to make
211
212* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.10-0vl1
213- new upstream release
214
215* Tue Oct  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.9-0vl1
216- new upstream release
217- changed Group to System Environment/Libraries
218
219* Fri Mar 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.7-0vl1
220- new upstream release
221
222* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
223- new upstream release
224
225* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
226- new upstream release
227
228* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.3-0vl1
229- new upstream release
230
231* Sat Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.5-0vl1
232- new upstream release
233
234* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.4-0vl1
235- new upstream release
236
237* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
238- new upstream release
239
240* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
241- new upstream release
242- added gtk-doc directory
243
244* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
245- new upstream release
246
247* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.8-0vl1
248- new upstream release
249
250* Tue Feb 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-0vl3
251- add patch0 from fedora
252
253* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl2
254- rebuild with new toolchains
255
256* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
257- new upstream release
258- rebuild with new toolchains
259
260* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
261- new upstream release
262
263* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
264- new upstream release
265
266* Fri Jul 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-0vl1
267- new upstream release
268
269* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
270- new upstream release
271
272* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
273- new upstream release
274
275* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
276- build for Vine Linux
277
278* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
279- 2.4.1
280
281* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
282- automated rebuild
283
284* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
285- rebuild in different environment
286
287* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
288- 2.4.0
289
290* Sun May 26 2002 Tim Powers <timp@redhat.com>
291- automated rebuild
292
293* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
294- rebuild in different environment
295
296* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
297- 2.3.109
298
299* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
300- 2.3.108
301
302* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
303- 2.3.107
304
305* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
306- 2.3.105
307
308* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
309- Version 2.3.103
310- Rebuild for dependencies
311
312* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
313- automated rebuild
314
315* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
316- build system somehow built against libglib-1.3.so.11
317  even though pkg-config found 1.3.12? wtf?
318  trying again
319
320* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
321- 2.3.100.90 snap
322
323* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
324- 2.3.99
325
326* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
327- new snap 2.3.97.90, rebuild for glib 1.3.11
328
329* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
330- new snap, glib 1.3.10 rebuild
331
332* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
333- check rebuild against new linc with headers moved
334- remove epoch, that was a screwup
335
336* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
337- cvs snap
338- require specific glib2
339
340* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
341- 2.3.95 tarball
342- depend on new standalone libIDL, remove all libIDL stuff from file list
343
344* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
345- require specific linc version, unrequire specific glib version since
346  we get that via linc
347
348* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
349- newer orbit2 from CVS
350
351* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
352- conflict with old orbit with headers not moved
353
354* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
355- renaming more things
356- remove smp flags, doesn't work atm
357- fix .pc file, trying to get bonobo-activation to build
358
359* Tue Sep 11 2001 Havoc Pennington <hp@redhat.com>
360- kill all file conflicts with ORBit1
361
362* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
363- convert to ORBit2 spec file (from ORBit original)
364
365* Tue Jul 24 2001 Alexander Larsson <alexl@redhat.com>
366- Added glib-devel BuildRequires
367
368* Thu Jun 21 2001 Elliot Lee <sopwith@redhat.com> 0.5.8-2
369- Use _smp_mflags if possible.
370
371* Mon May 14 2001 Jonathan Blandford <jrb@redhat.com>
372- bumped version
373
374* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
375- Rebuild for GTK+-1.2.9
376
377* Tue Jan 30 2001 Elliot Lee <sopwith@redhat.com>
378- 0.5.7 for real
379
380* Thu Jan 18 2001 Elliot Lee <sopwith@redhat.com>
381- 0.5.7
382
383* Tue Dec 19 2000 Elliot Lee <sopwith@redhat.com>
384- 0.5.6
385
386* Thu Nov 30 2000 Elliot Lee <sopwith@redhat.com>
387- 0.5.5
388
389* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
390- Up Epoch and release
391
392* Tue Jul 25 2000 Elliot Lee <sopwith@redhat.com>
393- 0.5.3
394
395* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
396- fixed to work with new cpp.
397
398* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
399- automatic rebuild
400
401* Tue Jul 11 2000 Jonathan Blandford <jrb@redhat.com>
402- Upgraded to 0.5.2 - a bug fix release.
403
404* Tue Jun 27 2000 Havoc Pennington <hp@redhat.com>
405- Trying to build the package for Preston and the build
406  system wants a new changelog entry
407
408* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
409- defattr the devel pkg
410- FHS paths
411
412* Fri May 19 2000 Jonathan Blandford <jrb@redhat.com>
413- Upgraded to 0.5.1
414
415* Thu Feb  3 2000 Elliot Lee <sopwith@redhat.com> 0.5.0-3
416- Strip shared libraries
417
418* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.4.94-1
419- Spec file fixes from RHL 6.0.
420
421* Wed Jun 2 1999  Jose Mercado <jmercado@mit.edu>
422- Fixed configure.in so spec.in could be used.
423
424* Mon Nov 23 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
425
426- improved %files section, and added use of %{prefix} and install-info
427  (well,... no. The info file has not dir info inside, commented out)
Note: See TracBrowser for help on using the repository browser.