source: projects/specs/trunk/O/ORBit2/ORBit2-vl.spec @ 1856

Revision 1856, 12.0 KB checked in by iwaim, 14 years ago (diff)

build with rpm-4.8.1-1; see [VineSeed:21791]

Line 
1%define libidl_version 0.8.11
2%define glib2_version 2.20.0
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4
5Summary: A high-performance CORBA Object Request Broker.
6Summary(ja): 高性能な CORBA Object Request Broker.
7Name: ORBit2
8Version: 2.14.18
9Release: 2%{?_dist_release}
10Group: System Environment/Libraries
11License: LGPL/GPL
12URL: http://www.labs.redhat.com/orbit/
13
14Source: %{name}-%{version}.tar.bz2
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: libIDL-devel >= %{libidl_version}
18BuildRequires: glib2-devel >= %{glib2_version}
19BuildRequires: gtk-doc
20
21%description
22ORBit is a high-performance CORBA (Common Object Request Broker
23Architecture) ORB (object request broker). It allows programs to
24send requests and receive replies from other programs, regardless
25of the locations of the two programs. CORBA is an architecture that
26enables communication between program objects, regardless of the
27programming language they're written in or the operating system they
28run on.
29
30You will need to install this package and ORBit-devel if you want to
31write programs that use CORBA technology.
32#'
33
34%package devel
35Summary: Development libraries, header files and utilities for ORBit.
36Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39Requires: indent
40Requires: libIDL-devel >= %{libidl_version}
41Requires: glib2-devel >= %{glib2_version}
42Conflicts: ORBit-devel <= 0.5.8
43
44%description devel
45ORBit is a high-performance CORBA (Common Object Request Broker
46Architecture) ORB (object request broker) with support for the
47C language.
48
49This package contains the header files, libraries and utilities
50necessary to write programs that use CORBA technology. If you want to
51write such programs, you'll also need to install the ORBIT package.
52#'
53
54%package -n compat32-%{name}
55Summary: A high-performance CORBA Object Request Broker.
56Summary(ja): 高性能な CORBA Object Request Broker.
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59
60%description -n compat32-%{name}
61ORBit is a high-performance CORBA (Common Object Request Broker
62Architecture) ORB (object request broker). It allows programs to
63send requests and receive replies from other programs, regardless
64of the locations of the two programs. CORBA is an architecture that
65enables communication between program objects, regardless of the
66programming language they're written in or the operating system they
67run on.
68
69You will need to install this package and ORBit-devel if you want to
70write programs that use CORBA technology.
71#'
72
73%package -n compat32-%{name}-devel
74Summary: Development libraries, header files and utilities for ORBit.
75Summary(ja): ORBit の開発用ライブラリ,ヘッダファイル,ユーテリティ
76Group: Development/Libraries
77Requires: %{name}-devel = %{version}-%{release}
78Requires: compat32-%{name} = %{version}-%{release}
79Requires: compat32-libIDL-devel >= %{libidl_version}
80Requires: compat32-glib2-devel >= %{glib2_version}
81
82%description -n compat32-%{name}-devel
83ORBit is a high-performance CORBA (Common Object Request Broker
84Architecture) ORB (object request broker) with support for the
85C language.
86
87This package contains the header files, libraries and utilities
88necessary to write programs that use CORBA technology. If you want to
89write such programs, you'll also need to install the ORBIT package.
90#'
91
92%prep
93%setup -q
94
95echo "glib-2.0 version is `pkg-config --modversion glib-2.0`"
96
97%build
98%configure --enable-gtk-doc
99# don't use smp flags
100export tagname=CC
101make LIBTOOL=/usr/bin/libtool
102
103%install
104rm -rf $RPM_BUILD_ROOT
105export tagname=CC
106%makeinstall LIBTOOL=/usr/bin/libtool
107
108rm -f $RPM_BUILD_ROOT%{_libdir}/libORBit*.{a,la}
109rm -f $RPM_BUILD_ROOT%{_libdir}/ORBit-2.0/*.*a
110rm -f $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
111
112rm -f $RPM_BUILD_ROOT%{_bindir}/linc-cleanup-sockets
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%files
126%defattr(-,root,root)
127%doc AUTHORS COPYING ChangeLog NEWS README TODO
128%{_libdir}/*.so.*
129%{_libdir}/orbit-2.0/*.so*
130
131%files devel
132%defattr(-,root,root)
133%{_libdir}/*.so
134# this is needed by libbonobo
135%{_libdir}/libname-server-2.a
136%{_libdir}/pkgconfig/*
137%{_bindir}/orbit-idl-2
138%{_bindir}/typelib-dump
139%{_bindir}/orbit2-config
140%{_bindir}/ior-decode-2
141#%{_bindir}/linc-cleanup-sockets
142%{_includedir}/*
143%{_datadir}/aclocal/*.m4
144%{_datadir}/idl/orbit-2.0/
145%{_datadir}/gtk-doc/html/ORBit2
146
147# compat32
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root)
151%{_libdir}/*.so.*
152%{_libdir}/orbit-2.0/*.so*
153
154%files -n compat32-%{name}-devel
155%defattr(-,root,root)
156%{_libdir}/*.so
157# this is needed by libbonobo
158%{_libdir}/libname-server-2.a
159%{_libdir}/pkgconfig/*
160%endif
161
162%changelog
163* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.14.18-2
164- build with rpm-4.8.1-1 for pkg-config file
165
166* Sat Apr 10 2010 Ryoichic INAGAKI <ryo1@bc.wakwak.com> 2.14.18-1
167- new upstream release
168- built with new toolchain
169
170* Sat Jul 11 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.17-3
171- added compat32 package for x86_64 arch support
172- added BuildRequires: gtk-doc
173- re-added a static library, %%{_libdir}/libname-server-2.a that is needed by libbonobo
174
175* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.17-2
176- remove static libs
177
178* Sat Mar  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.17-1
179- new upstream release
180
181* Tue Sep 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.16-1
182- new upstream release
183- built with libIDL-0.8.11
184- spec in UTF-8
185
186* Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.12-2vl5
187- rebuilt without libIDL-2.la
188
189* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.12-1vl5
190- new upstream release
191- built with libIDL-0.8.10
192- remove BuildRequires: automake16
193
194* Sat Jan 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.11-0vl1
195- new upstream release
196
197* Mon Jan 14 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.10-0vl2
198- dropt %%{_smp_mflags} to make
199
200* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.10-0vl1
201- new upstream release
202
203* Tue Oct  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.9-0vl1
204- new upstream release
205- changed Group to System Environment/Libraries
206
207* Fri Mar 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.7-0vl1
208- new upstream release
209
210* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
211- new upstream release
212
213* Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
214- new upstream release
215
216* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.3-0vl1
217- new upstream release
218
219* Sun Feb 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.5-0vl1
220- new upstream release
221
222* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.4-0vl1
223- new upstream release
224
225* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
226- new upstream release
227
228* Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
229- new upstream release
230- added gtk-doc directory
231
232* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
233- new upstream release
234
235* Fri Oct 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.8-0vl1
236- new upstream release
237
238* Tue Feb 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-0vl3
239- add patch0 from fedora
240
241* Fri Jan 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl2
242- rebuild with new toolchains
243
244* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
245- new upstream release
246- rebuild with new toolchains
247
248* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
249- new upstream release
250
251* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
252- new upstream release
253
254* Fri Jul 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.3-0vl1
255- new upstream release
256
257* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
258- new upstream release
259
260* Sat Jan  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-0vl1
261- new upstream release
262
263* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-0vl1
264- build for Vine Linux
265
266* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
267- 2.4.1
268
269* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
270- automated rebuild
271
272* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
273- rebuild in different environment
274
275* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
276- 2.4.0
277
278* Sun May 26 2002 Tim Powers <timp@redhat.com>
279- automated rebuild
280
281* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
282- rebuild in different environment
283
284* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
285- 2.3.109
286
287* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
288- 2.3.108
289
290* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
291- 2.3.107
292
293* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
294- 2.3.105
295
296* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
297- Version 2.3.103
298- Rebuild for dependencies
299
300* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
301- automated rebuild
302
303* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
304- build system somehow built against libglib-1.3.so.11
305  even though pkg-config found 1.3.12? wtf?
306  trying again
307
308* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
309- 2.3.100.90 snap
310
311* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
312- 2.3.99
313
314* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
315- new snap 2.3.97.90, rebuild for glib 1.3.11
316
317* Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
318- new snap, glib 1.3.10 rebuild
319
320* Tue Oct  9 2001 Havoc Pennington <hp@redhat.com>
321- check rebuild against new linc with headers moved
322- remove epoch, that was a screwup
323
324* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
325- cvs snap
326- require specific glib2
327
328* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
329- 2.3.95 tarball
330- depend on new standalone libIDL, remove all libIDL stuff from file list
331
332* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
333- require specific linc version, unrequire specific glib version since
334  we get that via linc
335
336* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
337- newer orbit2 from CVS
338
339* Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
340- conflict with old orbit with headers not moved
341
342* Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
343- renaming more things
344- remove smp flags, doesn't work atm
345- fix .pc file, trying to get bonobo-activation to build
346
347* Tue Sep 11 2001 Havoc Pennington <hp@redhat.com>
348- kill all file conflicts with ORBit1
349
350* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
351- convert to ORBit2 spec file (from ORBit original)
352
353* Tue Jul 24 2001 Alexander Larsson <alexl@redhat.com>
354- Added glib-devel BuildRequires
355
356* Thu Jun 21 2001 Elliot Lee <sopwith@redhat.com> 0.5.8-2
357- Use _smp_mflags if possible.
358
359* Mon May 14 2001 Jonathan Blandford <jrb@redhat.com>
360- bumped version
361
362* Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
363- Rebuild for GTK+-1.2.9
364
365* Tue Jan 30 2001 Elliot Lee <sopwith@redhat.com>
366- 0.5.7 for real
367
368* Thu Jan 18 2001 Elliot Lee <sopwith@redhat.com>
369- 0.5.7
370
371* Tue Dec 19 2000 Elliot Lee <sopwith@redhat.com>
372- 0.5.6
373
374* Thu Nov 30 2000 Elliot Lee <sopwith@redhat.com>
375- 0.5.5
376
377* Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
378- Up Epoch and release
379
380* Tue Jul 25 2000 Elliot Lee <sopwith@redhat.com>
381- 0.5.3
382
383* Wed Jul 19 2000 Jonathan Blandford <jrb@redhat.com>
384- fixed to work with new cpp.
385
386* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
387- automatic rebuild
388
389* Tue Jul 11 2000 Jonathan Blandford <jrb@redhat.com>
390- Upgraded to 0.5.2 - a bug fix release.
391
392* Tue Jun 27 2000 Havoc Pennington <hp@redhat.com>
393- Trying to build the package for Preston and the build
394  system wants a new changelog entry
395
396* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
397- defattr the devel pkg
398- FHS paths
399
400* Fri May 19 2000 Jonathan Blandford <jrb@redhat.com>
401- Upgraded to 0.5.1
402
403* Tue Feb  3 2000 Elliot Lee <sopwith@redhat.com> 0.5.0-3
404- Strip shared libraries
405
406* Mon Aug 30 1999 Elliot Lee <sopwith@redhat.com> 0.4.94-1
407- Spec file fixes from RHL 6.0.
408
409* Wed Jun 2 1999  Jose Mercado <jmercado@mit.edu>
410- Fixed configure.in so spec.in could be used.
411
412* Mon Nov 23 1998 Pablo Saratxaga <srtxg@chanae.alphanet.ch>
413
414- improved %files section, and added use of %{prefix} and install-info
415  (well,... no. The info file has not dir info inside, commented out)
Note: See TracBrowser for help on using the repository browser.