source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 8353

Revision 8353, 12.0 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3%define ppp_version 2.4.5
4%define glib2_version 2.40
5
6Summary: Mobile broadband modem management service
7Summary(ja): Mobile broadband modem management service
8Name: ModemManager
9Version: 1.2.0
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14
15#
16# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
17# tarball built with:
18#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
19#    make distcheck
20#
21#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
22
23Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
24
25Patch0: buildsys-hates-openpty.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28Requires: dbus-glib
29Requires: glib2
30BuildRequires: glib2-devel >= %{glib2_version}
31BuildRequires: dbus-glib-devel >= 0.92
32BuildRequires: libgudev1-devel >= 143
33BuildRequires: ppp = %{ppp_version}
34BuildRequires: ppp-devel = %{ppp_version}
35BuildRequires: automake autoconf intltool libtool
36BuildRequires: gtk-doc
37# for xsltproc
38BuildRequires: libxslt
39
40%description
41The ModemManager service manages WWAN modems and provides a consistent API for
42interacting with these devices to client applications.
43
44
45%package        devel
46Summary:        Development tools for %{name}
47Summary(ja):    %{name} の開発環境
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50Requires:       pkgconfig
51
52%description    devel
53Header files and libraries for building a extension library for the %{name}.
54
55
56%package        glib
57Summary:        Libraries for adding ModemManager support to applications that use glib.
58Group:          Development/Libraries
59Requires:       glib2 >= %{glib2_version}
60
61%description    glib
62This package contains the libraries that make it easier to use some ModemManager
63functionality from applications that use glib.
64
65
66%package        glib-devel
67Summary:        Development tools for %{name}-glib
68Summary(ja):    %{name}-glib の開発環境
69Group:          Development/Libraries
70Requires:       %{name}-glib = %{version}-%{release}
71Requires:       %{name}-devel = %{version}-%{release}
72Requires:       glib2-devel
73Requires:       pkgconfig
74
75%description    glib-devel
76Header files and libraries for building a extension library for the %{name}-glib.
77
78%prep
79%setup -q
80%patch0 -p1 -b .pty
81
82%build
83autoreconf -if
84intltoolize --force
85pppddir=`ls -1d %{_libdir}/pppd/2*`
86%configure \
87        --enable-more-warnings=yes \
88        --with-udev-base-dir=/lib/udev \
89        --with-tests=yes \
90        --enable-gtk-doc=yes \
91        --without-qmi \
92        --disable-static \
93        --with-pppd-plugin-dir=$pppddir \
94        --with-polkit=no \
95        --with-mbim=no
96
97make %{?_smp_mflags}
98
99%check
100make check
101
102%install
103make install DESTDIR=$RPM_BUILD_ROOT
104
105find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
106rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
107
108%find_lang %{name}
109
110%post
111/sbin/ldconfig
112touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
113
114%postun
115/sbin/ldconfig
116if [ $1 -eq 0 ]; then
117  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
118  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
119fi
120
121%posttrans
122gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
123
124%post   glib -p /sbin/ldconfig
125%postun glib -p /sbin/ldconfig
126
127%files -f %{name}.lang
128%defattr(0644, root, root, 0755)
129%doc COPYING README
130%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
131%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
132%attr(0755,root,root) %{_sbindir}/ModemManager
133%attr(0755,root,root) %{_bindir}/mmcli
134%dir %{_libdir}/%{name}
135%attr(0755,root,root) %{_libdir}/%{name}/*.so*
136/lib/udev/rules.d/*
137%{_datadir}/dbus-1/interfaces/*.xml
138%{_datadir}/icons/hicolor/22x22/apps/*.png
139%{_mandir}/man8/*
140
141%files devel
142%defattr(0644, root, root, 0755)
143%{_includedir}/ModemManager/*.h
144%dir %{_datadir}/gtk-doc/html/%{name}
145%{_datadir}/gtk-doc/html/%{name}/*
146%{_libdir}/pkgconfig/%{name}.pc
147
148%files glib
149%defattr(0644, root, root, 0755)
150%{_libdir}/libmm-glib.so.*
151
152%files glib-devel
153%defattr(0644, root, root, 0755)
154%{_libdir}/libmm-glib.so
155%dir %{_includedir}/libmm-glib
156%{_includedir}/libmm-glib/*.h
157%{_libdir}/pkgconfig/mm-glib.pc
158%dir %{_datadir}/gtk-doc/html/libmm-glib
159%{_datadir}/gtk-doc/html/libmm-glib/*
160
161
162%changelog
163* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
164- new upstream release
165- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
166
167* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
168- add Patch1 (ModemManager-1.0.0-git20130911.patch)
169
170* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
171- new upstream release
172- update Patch0
173
174* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
175- update to 0.7.991 snapshot
176- fix spec file based on FC package
177  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
178  - Update to 0.7.991 snapshot
179  - Fix SMS validity parsing
180  - Allow registration changes to 'searching' without disconnecting
181  - Fix reading SMS messages from some QMI-based devices
182  - Increase connection timeout for Novatel E362
183  - Fix PIN retries checking when unlocking Ericsson devices
184  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
185- add configure option (--enable-gtk-doc=yes, --without-qmi)
186
187* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
188- new upstream release
189
190* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
191- new upstream release
192
193* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
194- delete Patch20
195
196* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
197- update Patch20 (ModemManager-0.4-git20110428.patch)
198- delete Patch21,22
199
200* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
201- update to 0.4
202- add Patch20 (ModemManager-0.4-git20100720.patch)
203- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
204- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
205
206* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
207- initial build for Vine Linux
208
209* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
210- core: ignore some failures on disconnect (rh #578280)
211- core: add support for platform serial devices
212- gsm: better Blackberry DUN support
213- gsm: periodically poll access technology
214- cdma: prevent crash on modem removal (rh #571921)
215- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
216- novatel: better signal strength reporting on CDMA cards
217- novatel: add access technology and mode preference support on GSM cards
218- zte: fix mode preference retrieval
219- longcheer: add support for Zoom modems (4595, 4596, etc)
220- longcheer: add access technology and mode preference support
221
222* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
223- Silence %%post
224- Update scripts
225
226* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
227- gsm: fix parsing Blackberry supported character sets response
228
229* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
230- mbm: fix retrieval of current allowed mode
231- gsm: fix initialization issues with some devices (like Blackberries)
232
233* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
234- core: fix detection of some generic devices (rh #579247)
235- core: fix detection regression of some Huawei devices in 0.3-5
236- cdma: periodically poll registration state and signal quality
237- cdma: really fix registration detection on various devices (rh #569067)
238
239* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
240- core: fix PPC/SPARC/etc builds
241
242* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
243- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
244- cdma: handle signal quality requests while connected for more devices
245- cdma: handle serving system requests while connected for more devices
246- gsm: determine current access technology earlier
247- huawei: work around automatic registration issues on some devices
248
249* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
250- core: ensure enabled modems are disabled when MM stops
251- core: better capability detection for Blackberry devices (rh #573510)
252- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
253- gsm: don't block modem when it requires PIN2
254- option: fix access technology updates
255
256* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
257- mbm: add device IDs for C3607w
258- mbm: fail earlier during connection failures
259- mbm: fix username/password authentication when checked by the network
260- hso: implement asynchronous signal quality updates
261- option: implement asynchronous signal quality updates
262- novatel: correctly handle CDMA signal quality
263- core: basic PolicyKit support
264- core: fix direct GSM registration information requests
265- core: general GSM PIN/PUK unlock fixes
266- core: poll GSM registration state internally for quicker status updates
267- core: implement GSM 2G/3G preference
268- core: implement GSM roaming allowed/disallowed preference
269- core: emit signals on access technology changes
270- core: better handling of disconnections
271- core: fix simple CDMA status requests
272
273* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
274- core: startup speed improvements
275- core: GSM PIN checking improvements
276- huawei: fix EVDO-only connections on various devices (rh #553199)
277- longcheer: add support for more devices
278
279* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
280- anydata: new plugin for AnyData CDMA modems (rh #547294)
281- core: fix crashes when devices are unplugged during operation (rh #553953)
282- cdma: prefer primary port for status/registration queries
283- core: fix probing/detection of some PIN-locked devices (rh #551376)
284- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
285- gsm: fix Nokia N80 network scan parsing
286
287* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
288- core: fix apparent hangs by limiting retried serial writes
289- gsm: ensure modem state is reset when disabled
290
291* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
292- sierra: fix CDMA registration detection in some cases (rh #547513)
293
294* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
295- sierra: ensure CDMA device is powered up when trying to use it
296- cdma: better signal quality parsing (fixes ex Huawei EC168C)
297- zte: handle unsolicited messages better during probing
298
299* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
300- cdma: fix signal strength reporting on some devices
301- cdma: better registration state detection when dialing (ex Sierra 5275)
302- option: always use the correct tty for dialing commands
303
304* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
305- core: fix reconnect after manual disconnect (rh #541314)
306- core: fix various segfaults during registration
307- core: fix probing of various modems on big-endian architectures (ie PPC)
308- core: implement modem states to avoid duplicate operations
309- hso: fix authentication for Icera-based devices like iCON 505
310- zte: use correct port for new devices
311- nozomi: fix detection
312
313* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
314- Update to latest git
315- core: fix pppd 2.4.5 errors about 'baudrate 0'
316- cdma: wait for network registration before trying to connect
317- gsm: add cell access technology reporting
318- gsm: allow longer-running network scans
319- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
320- nokia: don't power down phones on disconnect
321- hso: fix disconnection/disable
322
323* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
324- Fixes for Motorola and Ericsson devices
325- Fixes for CDMA "serving-system" command parsing
326
327* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
328- Fix a typo in one of the udev rules files
329
330* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
331- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
332
333* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
334- Fix source repo location
335- Fix directory ownership
336
337* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
338- Initial version
339
Note: See TracBrowser for help on using the repository browser.