source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 6011

Revision 6011, 9.3 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1#%define snapshot .git20100720
2%define snapshot %{nil}
3%define ppp_version 2.4.5
4
5Summary: Mobile broadband modem management service
6Summary(ja): Mobile broadband modem management service
7Name: ModemManager
8Version: 0.5.2.0
9Release: 1%{?snapshot}%{?_dist_release}
10License: GPLv2+
11Group: System Environment/Base
12URL: http://www.gnome.org/projects/NetworkManager/
13
14#
15# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
16# tarball built with:
17#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
18#    make distcheck
19#
20Source: %{name}-%{version}%{?snapshot}.tar.xz
21Patch1: %{name}-0.3-jp-modems.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24Requires: dbus-glib
25Requires: glib2
26BuildRequires: glib2-devel >= 2.26.1
27BuildRequires: dbus-glib-devel >= 0.92
28BuildRequires: libgudev-devel >= 143
29BuildRequires: ppp = %{ppp_version}
30BuildRequires: ppp-devel = %{ppp_version}
31BuildRequires: polkit-devel
32BuildRequires: automake autoconf intltool libtool
33# for xsltproc
34BuildRequires: libxslt
35
36%description
37The ModemManager service provides a consistent API to operate many different
38modems, including mobile broadband (3G) devices.
39
40%prep
41%setup -q
42%patch1 -p1 -b .jp-modems
43
44%build
45autoreconf -i
46pppddir=`ls -1d %{_libdir}/pppd/2*`
47%configure \
48        --enable-more-warnings=yes \
49        --with-udev-base-dir=/lib/udev \
50        --with-tests=yes \
51        --with-docs=yes \
52        --disable-static \
53        --with-pppd-plugin-dir=$pppddir \
54        --with-polkit=no
55
56make %{?_smp_mflags}
57
58%check
59make check
60
61%install
62make install DESTDIR=$RPM_BUILD_ROOT
63
64rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
65rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
66rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
67rm -f $RPM_BUILD_ROOT%{_includedir}/mm/mm-modem.h
68
69%post
70/sbin/ldconfig
71touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
72
73%postun
74/sbin/ldconfig
75if [ $1 -eq 0 ]; then
76  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
77  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
78fi
79
80%posttrans
81gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
82
83%files
84%defattr(0644, root, root, 0755)
85%doc COPYING README
86%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
87%{_datadir}/dbus-1/interfaces/*.xml
88%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
89%attr(0755,root,root) %{_sbindir}/modem-manager
90%dir %{_libdir}/%{name}
91%attr(0755,root,root) %{_libdir}/%{name}/*.so*
92/lib/udev/rules.d/*
93%{_datadir}/polkit-1/actions/*.policy
94%{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
95
96%changelog
97* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
98- new upstream release
99
100* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
101- new upstream release
102
103* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
104- delete Patch20
105
106* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
107- update Patch20 (ModemManager-0.4-git20110428.patch)
108- delete Patch21,22
109
110* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
111- update to 0.4
112- add Patch20 (ModemManager-0.4-git20100720.patch)
113- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
114- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
115
116* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
117- initial build for Vine Linux
118
119* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
120- core: ignore some failures on disconnect (rh #578280)
121- core: add support for platform serial devices
122- gsm: better Blackberry DUN support
123- gsm: periodically poll access technology
124- cdma: prevent crash on modem removal (rh #571921)
125- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
126- novatel: better signal strength reporting on CDMA cards
127- novatel: add access technology and mode preference support on GSM cards
128- zte: fix mode preference retrieval
129- longcheer: add support for Zoom modems (4595, 4596, etc)
130- longcheer: add access technology and mode preference support
131
132* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
133- Silence %%post
134- Update scripts
135
136* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
137- gsm: fix parsing Blackberry supported character sets response
138
139* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
140- mbm: fix retrieval of current allowed mode
141- gsm: fix initialization issues with some devices (like Blackberries)
142
143* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
144- core: fix detection of some generic devices (rh #579247)
145- core: fix detection regression of some Huawei devices in 0.3-5
146- cdma: periodically poll registration state and signal quality
147- cdma: really fix registration detection on various devices (rh #569067)
148
149* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
150- core: fix PPC/SPARC/etc builds
151
152* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
153- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
154- cdma: handle signal quality requests while connected for more devices
155- cdma: handle serving system requests while connected for more devices
156- gsm: determine current access technology earlier
157- huawei: work around automatic registration issues on some devices
158
159* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
160- core: ensure enabled modems are disabled when MM stops
161- core: better capability detection for Blackberry devices (rh #573510)
162- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
163- gsm: don't block modem when it requires PIN2
164- option: fix access technology updates
165
166* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
167- mbm: add device IDs for C3607w
168- mbm: fail earlier during connection failures
169- mbm: fix username/password authentication when checked by the network
170- hso: implement asynchronous signal quality updates
171- option: implement asynchronous signal quality updates
172- novatel: correctly handle CDMA signal quality
173- core: basic PolicyKit support
174- core: fix direct GSM registration information requests
175- core: general GSM PIN/PUK unlock fixes
176- core: poll GSM registration state internally for quicker status updates
177- core: implement GSM 2G/3G preference
178- core: implement GSM roaming allowed/disallowed preference
179- core: emit signals on access technology changes
180- core: better handling of disconnections
181- core: fix simple CDMA status requests
182
183* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
184- core: startup speed improvements
185- core: GSM PIN checking improvements
186- huawei: fix EVDO-only connections on various devices (rh #553199)
187- longcheer: add support for more devices
188
189* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
190- anydata: new plugin for AnyData CDMA modems (rh #547294)
191- core: fix crashes when devices are unplugged during operation (rh #553953)
192- cdma: prefer primary port for status/registration queries
193- core: fix probing/detection of some PIN-locked devices (rh #551376)
194- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
195- gsm: fix Nokia N80 network scan parsing
196
197* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
198- core: fix apparent hangs by limiting retried serial writes
199- gsm: ensure modem state is reset when disabled
200
201* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
202- sierra: fix CDMA registration detection in some cases (rh #547513)
203
204* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
205- sierra: ensure CDMA device is powered up when trying to use it
206- cdma: better signal quality parsing (fixes ex Huawei EC168C)
207- zte: handle unsolicited messages better during probing
208
209* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
210- cdma: fix signal strength reporting on some devices
211- cdma: better registration state detection when dialing (ex Sierra 5275)
212- option: always use the correct tty for dialing commands
213
214* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
215- core: fix reconnect after manual disconnect (rh #541314)
216- core: fix various segfaults during registration
217- core: fix probing of various modems on big-endian architectures (ie PPC)
218- core: implement modem states to avoid duplicate operations
219- hso: fix authentication for Icera-based devices like iCON 505
220- zte: use correct port for new devices
221- nozomi: fix detection
222
223* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
224- Update to latest git
225- core: fix pppd 2.4.5 errors about 'baudrate 0'
226- cdma: wait for network registration before trying to connect
227- gsm: add cell access technology reporting
228- gsm: allow longer-running network scans
229- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
230- nokia: don't power down phones on disconnect
231- hso: fix disconnection/disable
232
233* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
234- Fixes for Motorola and Ericsson devices
235- Fixes for CDMA "serving-system" command parsing
236
237* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
238- Fix a typo in one of the udev rules files
239
240* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
241- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
242
243* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
244- Fix source repo location
245- Fix directory ownership
246
247* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
248- Initial version
249
Note: See TracBrowser for help on using the repository browser.