source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 985

Revision 985, 8.5 KB checked in by daisuke, 14 years ago (diff)

ModemManager?,mobile-broadband-provider-info: new package

Line 
1%define snapshot .git20100502
2%define ppp_version 2.4.4
3
4Summary: Mobile broadband modem management service
5Summary(ja): Mobile broadband modem management service
6Name: ModemManager
7Version: 0.3
8Release: 1%{?snapshot}%{?_dist_release}
9License: GPLv2+
10Group: System Environment/Base
11URL: http://www.gnome.org/projects/NetworkManager/
12
13#
14# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
15# tarball built with:
16#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
17#    make distcheck
18#
19Source: %{name}-%{version}%{?snapshot}.tar.bz2
20Patch1: %{name}-0.3-jp-modems.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23Requires: dbus-glib
24Requires: glib2
25BuildRequires: glib2-devel >= 2.18
26BuildRequires: dbus-glib-devel >= 0.82
27BuildRequires: libgudev-devel >= 143
28BuildRequires: ppp = %{ppp_version}
29BuildRequires: ppp-devel = %{ppp_version}
30BuildRequires: polkit-devel
31BuildRequires: automake autoconf intltool libtool
32# for xsltproc
33BuildRequires: libxslt
34
35%description
36The ModemManager service provides a consistent API to operate many different
37modems, including mobile broadband (3G) devices.
38
39%prep
40%setup -q
41%patch1 -p1 -b .jp-modems
42
43%build
44
45pppddir=`ls -1d %{_libdir}/pppd/2*`
46%configure \
47        --enable-more-warnings=yes \
48        --with-udev-base-dir=/lib/udev \
49        --with-tests=yes \
50        --with-docs=yes \
51        --disable-static \
52        --with-pppd-plugin-dir=$pppddir \
53        --with-polkit=no
54
55make %{?_smp_mflags}
56
57%check
58make check
59
60%install
61make install DESTDIR=$RPM_BUILD_ROOT
62
63rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
64rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
65rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
66
67%post
68/sbin/ldconfig
69touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
70
71%postun
72/sbin/ldconfig
73if [ $1 -eq 0 ]; then
74  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
75  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
76fi
77
78%posttrans
79gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
80
81%files
82%defattr(0644, root, root, 0755)
83%doc COPYING README
84%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
85%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
86%attr(0755,root,root) %{_sbindir}/modem-manager
87%dir %{_libdir}/%{name}
88%attr(0755,root,root) %{_libdir}/%{name}/*.so*
89/lib/udev/rules.d/*
90%{_datadir}/polkit-1/actions/*.policy
91%{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
92
93%changelog
94* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
95- initial build for Vine Linux
96
97* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
98- core: ignore some failures on disconnect (rh #578280)
99- core: add support for platform serial devices
100- gsm: better Blackberry DUN support
101- gsm: periodically poll access technology
102- cdma: prevent crash on modem removal (rh #571921)
103- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
104- novatel: better signal strength reporting on CDMA cards
105- novatel: add access technology and mode preference support on GSM cards
106- zte: fix mode preference retrieval
107- longcheer: add support for Zoom modems (4595, 4596, etc)
108- longcheer: add access technology and mode preference support
109
110* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
111- Silence %%post
112- Update scripts
113
114* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
115- gsm: fix parsing Blackberry supported character sets response
116
117* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
118- mbm: fix retrieval of current allowed mode
119- gsm: fix initialization issues with some devices (like Blackberries)
120
121* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
122- core: fix detection of some generic devices (rh #579247)
123- core: fix detection regression of some Huawei devices in 0.3-5
124- cdma: periodically poll registration state and signal quality
125- cdma: really fix registration detection on various devices (rh #569067)
126
127* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
128- core: fix PPC/SPARC/etc builds
129
130* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
131- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
132- cdma: handle signal quality requests while connected for more devices
133- cdma: handle serving system requests while connected for more devices
134- gsm: determine current access technology earlier
135- huawei: work around automatic registration issues on some devices
136
137* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
138- core: ensure enabled modems are disabled when MM stops
139- core: better capability detection for Blackberry devices (rh #573510)
140- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
141- gsm: don't block modem when it requires PIN2
142- option: fix access technology updates
143
144* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
145- mbm: add device IDs for C3607w
146- mbm: fail earlier during connection failures
147- mbm: fix username/password authentication when checked by the network
148- hso: implement asynchronous signal quality updates
149- option: implement asynchronous signal quality updates
150- novatel: correctly handle CDMA signal quality
151- core: basic PolicyKit support
152- core: fix direct GSM registration information requests
153- core: general GSM PIN/PUK unlock fixes
154- core: poll GSM registration state internally for quicker status updates
155- core: implement GSM 2G/3G preference
156- core: implement GSM roaming allowed/disallowed preference
157- core: emit signals on access technology changes
158- core: better handling of disconnections
159- core: fix simple CDMA status requests
160
161* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
162- core: startup speed improvements
163- core: GSM PIN checking improvements
164- huawei: fix EVDO-only connections on various devices (rh #553199)
165- longcheer: add support for more devices
166
167* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
168- anydata: new plugin for AnyData CDMA modems (rh #547294)
169- core: fix crashes when devices are unplugged during operation (rh #553953)
170- cdma: prefer primary port for status/registration queries
171- core: fix probing/detection of some PIN-locked devices (rh #551376)
172- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
173- gsm: fix Nokia N80 network scan parsing
174
175* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
176- core: fix apparent hangs by limiting retried serial writes
177- gsm: ensure modem state is reset when disabled
178
179* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
180- sierra: fix CDMA registration detection in some cases (rh #547513)
181
182* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
183- sierra: ensure CDMA device is powered up when trying to use it
184- cdma: better signal quality parsing (fixes ex Huawei EC168C)
185- zte: handle unsolicited messages better during probing
186
187* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
188- cdma: fix signal strength reporting on some devices
189- cdma: better registration state detection when dialing (ex Sierra 5275)
190- option: always use the correct tty for dialing commands
191
192* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
193- core: fix reconnect after manual disconnect (rh #541314)
194- core: fix various segfaults during registration
195- core: fix probing of various modems on big-endian architectures (ie PPC)
196- core: implement modem states to avoid duplicate operations
197- hso: fix authentication for Icera-based devices like iCON 505
198- zte: use correct port for new devices
199- nozomi: fix detection
200
201* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
202- Update to latest git
203- core: fix pppd 2.4.5 errors about 'baudrate 0'
204- cdma: wait for network registration before trying to connect
205- gsm: add cell access technology reporting
206- gsm: allow longer-running network scans
207- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
208- nokia: don't power down phones on disconnect
209- hso: fix disconnection/disable
210
211* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
212- Fixes for Motorola and Ericsson devices
213- Fixes for CDMA "serving-system" command parsing
214
215* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
216- Fix a typo in one of the udev rules files
217
218* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
220
221* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
222- Fix source repo location
223- Fix directory ownership
224
225* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
226- Initial version
227
Note: See TracBrowser for help on using the repository browser.