source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 2422

Revision 2422, 9.0 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1#%define snapshot .git20100720
2%define snapshot %{nil}
3%define ppp_version 2.4.4
4
5Summary: Mobile broadband modem management service
6Summary(ja): Mobile broadband modem management service
7Name: ModemManager
8Version: 0.4
9Release: 1%{?snapshot}%{?_dist_release}
10License: GPLv2+
11Group: System Environment/Base
12URL: http://www.gnome.org/projects/NetworkManager/
13
14#
15# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
16# tarball built with:
17#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
18#    make distcheck
19#
20Source: %{name}-%{version}%{?snapshot}.tar.bz2
21Patch1: %{name}-0.3-jp-modems.patch
22Patch20: %{name}-0.4-git20100720.patch
23Patch21: %{name}-0.4-glib2-2.25.12.patch
24Patch22: %{name}-0.4-dbus-glib-property-access-bug.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
27Requires: dbus-glib
28Requires: glib2
29BuildRequires: glib2-devel >= 2.26.1
30BuildRequires: dbus-glib-devel >= 0.92
31BuildRequires: libgudev-devel >= 143
32BuildRequires: ppp = %{ppp_version}
33BuildRequires: ppp-devel = %{ppp_version}
34BuildRequires: polkit-devel
35BuildRequires: automake autoconf intltool libtool
36# for xsltproc
37BuildRequires: libxslt
38
39%description
40The ModemManager service provides a consistent API to operate many different
41modems, including mobile broadband (3G) devices.
42
43%prep
44%setup -q
45%patch1 -p1 -b .jp-modems
46%patch20 -p1 -b .git20100720
47%patch21 -p1 -b .glib2
48%patch22 -p1 -b .dbus-glib
49
50%build
51autoreconf -i
52pppddir=`ls -1d %{_libdir}/pppd/2*`
53%configure \
54        --enable-more-warnings=yes \
55        --with-udev-base-dir=/lib/udev \
56        --with-tests=yes \
57        --with-docs=yes \
58        --disable-static \
59        --with-pppd-plugin-dir=$pppddir \
60        --with-polkit=no
61
62make %{?_smp_mflags}
63
64%check
65make check
66
67%install
68make install DESTDIR=$RPM_BUILD_ROOT
69
70rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
71rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.la
72rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
73
74%post
75/sbin/ldconfig
76touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
77
78%postun
79/sbin/ldconfig
80if [ $1 -eq 0 ]; then
81  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
82  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
83fi
84
85%posttrans
86gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
87
88%files
89%defattr(0644, root, root, 0755)
90%doc COPYING README
91%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager.conf
92%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager.service
93%attr(0755,root,root) %{_sbindir}/modem-manager
94%dir %{_libdir}/%{name}
95%attr(0755,root,root) %{_libdir}/%{name}/*.so*
96/lib/udev/rules.d/*
97%{_datadir}/polkit-1/actions/*.policy
98%{_datadir}/icons/hicolor/22x22/apps/modem-manager.png
99
100%changelog
101* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
102- update to 0.4
103- add Patch20 (ModemManager-0.4-git20100720.patch)
104- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
105- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
106
107* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
108- initial build for Vine Linux
109
110* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
111- core: ignore some failures on disconnect (rh #578280)
112- core: add support for platform serial devices
113- gsm: better Blackberry DUN support
114- gsm: periodically poll access technology
115- cdma: prevent crash on modem removal (rh #571921)
116- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
117- novatel: better signal strength reporting on CDMA cards
118- novatel: add access technology and mode preference support on GSM cards
119- zte: fix mode preference retrieval
120- longcheer: add support for Zoom modems (4595, 4596, etc)
121- longcheer: add access technology and mode preference support
122
123* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
124- Silence %%post
125- Update scripts
126
127* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
128- gsm: fix parsing Blackberry supported character sets response
129
130* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
131- mbm: fix retrieval of current allowed mode
132- gsm: fix initialization issues with some devices (like Blackberries)
133
134* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
135- core: fix detection of some generic devices (rh #579247)
136- core: fix detection regression of some Huawei devices in 0.3-5
137- cdma: periodically poll registration state and signal quality
138- cdma: really fix registration detection on various devices (rh #569067)
139
140* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
141- core: fix PPC/SPARC/etc builds
142
143* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
144- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
145- cdma: handle signal quality requests while connected for more devices
146- cdma: handle serving system requests while connected for more devices
147- gsm: determine current access technology earlier
148- huawei: work around automatic registration issues on some devices
149
150* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
151- core: ensure enabled modems are disabled when MM stops
152- core: better capability detection for Blackberry devices (rh #573510)
153- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
154- gsm: don't block modem when it requires PIN2
155- option: fix access technology updates
156
157* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
158- mbm: add device IDs for C3607w
159- mbm: fail earlier during connection failures
160- mbm: fix username/password authentication when checked by the network
161- hso: implement asynchronous signal quality updates
162- option: implement asynchronous signal quality updates
163- novatel: correctly handle CDMA signal quality
164- core: basic PolicyKit support
165- core: fix direct GSM registration information requests
166- core: general GSM PIN/PUK unlock fixes
167- core: poll GSM registration state internally for quicker status updates
168- core: implement GSM 2G/3G preference
169- core: implement GSM roaming allowed/disallowed preference
170- core: emit signals on access technology changes
171- core: better handling of disconnections
172- core: fix simple CDMA status requests
173
174* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
175- core: startup speed improvements
176- core: GSM PIN checking improvements
177- huawei: fix EVDO-only connections on various devices (rh #553199)
178- longcheer: add support for more devices
179
180* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
181- anydata: new plugin for AnyData CDMA modems (rh #547294)
182- core: fix crashes when devices are unplugged during operation (rh #553953)
183- cdma: prefer primary port for status/registration queries
184- core: fix probing/detection of some PIN-locked devices (rh #551376)
185- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
186- gsm: fix Nokia N80 network scan parsing
187
188* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
189- core: fix apparent hangs by limiting retried serial writes
190- gsm: ensure modem state is reset when disabled
191
192* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
193- sierra: fix CDMA registration detection in some cases (rh #547513)
194
195* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
196- sierra: ensure CDMA device is powered up when trying to use it
197- cdma: better signal quality parsing (fixes ex Huawei EC168C)
198- zte: handle unsolicited messages better during probing
199
200* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
201- cdma: fix signal strength reporting on some devices
202- cdma: better registration state detection when dialing (ex Sierra 5275)
203- option: always use the correct tty for dialing commands
204
205* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
206- core: fix reconnect after manual disconnect (rh #541314)
207- core: fix various segfaults during registration
208- core: fix probing of various modems on big-endian architectures (ie PPC)
209- core: implement modem states to avoid duplicate operations
210- hso: fix authentication for Icera-based devices like iCON 505
211- zte: use correct port for new devices
212- nozomi: fix detection
213
214* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
215- Update to latest git
216- core: fix pppd 2.4.5 errors about 'baudrate 0'
217- cdma: wait for network registration before trying to connect
218- gsm: add cell access technology reporting
219- gsm: allow longer-running network scans
220- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
221- nokia: don't power down phones on disconnect
222- hso: fix disconnection/disable
223
224* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
225- Fixes for Motorola and Ericsson devices
226- Fixes for CDMA "serving-system" command parsing
227
228* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
229- Fix a typo in one of the udev rules files
230
231* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
232- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
233
234* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
235- Fix source repo location
236- Fix directory ownership
237
238* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
239- Initial version
240
Note: See TracBrowser for help on using the repository browser.