source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 11571

Revision 11571, 13.4 KB checked in by tomop, 6 years ago (diff)

ModemManager?-1.6.12-1

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3#define ppp_version 2.4.7
4%define glib2_version 2.40
5
6Name: ModemManager
7Summary: Mobile broadband modem management service
8Summary(ja): Mobile broadband modem management service
9Version: 1.6.12
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14Vendor:                 Project Vine
15Distribution:   Vine Linux
16#
17# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
18# tarball built with:
19#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
20#    make distcheck
21#
22#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
23
24Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
25
26Patch0: buildsys-hates-openpty.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: glib2-devel >= %{glib2_version}
30BuildRequires: libgudev-devel
31BuildRequires: automake autoconf intltool libtool
32BuildRequires: gobject-introspection-devel
33BuildRequires: polkit-devel
34BuildRequires: gtk-doc
35# for xsltproc
36BuildRequires: libxslt
37Requires: dbus-glib
38
39%description
40The ModemManager service manages WWAN modems and provides a consistent API for
41interacting with these devices to client applications.
42
43
44%package        devel
45Summary:        Development tools for %{name}
46Summary(ja):    %{name} の開発環境
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description    devel
52Header files and libraries for building a extension library for the %{name}.
53
54
55%package        glib
56Summary:        Libraries for adding ModemManager support to applications that use glib.
57Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
58Group:          System Environment/Libraries
59Requires:       glib2 >= %{glib2_version}
60
61%description    glib
62This package contains the libraries that make it easier to use some ModemManager
63functionality from applications that use glib.
64
65
66%package        glib-devel
67Summary:        Development tools for %{name}-glib
68Summary(ja):    %{name}-glib の開発環境
69Group:          Development/Libraries
70Requires:       %{name}-glib = %{version}-%{release}
71Requires:       %{name}-devel = %{version}-%{release}
72Requires:       glib2-devel
73Requires:       pkgconfig
74
75%description    glib-devel
76Header files and libraries for building a extension library for the %{name}-glib.
77
78%prep
79%setup -q
80%patch0 -p1 -b .pty
81
82%build
83aclocal
84autoconf
85automake
86#pppddir=`ls -1d %{_libdir}/pppd/2*`
87%configure \
88        --disable-static \
89        --enable-gtk-doc=yes \
90        --enable-vala=no \
91        --enable-more-warnings=yes \
92        --with-udev-base-dir=/lib/udev \
93        --without-mbim \
94        --without-qmi \
95        --with-dist-version=%{version}-%{release}
96
97
98make %{?_smp_mflags}
99
100%check
101make check
102
103%install
104make install DESTDIR=$RPM_BUILD_ROOT
105
106find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
107#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
108
109%find_lang %{name}
110
111%post
112/sbin/ldconfig
113touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
114
115%postun
116/sbin/ldconfig
117if [ $1 -eq 0 ]; then
118  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
119  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
120fi
121
122%posttrans
123gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
124
125%post   glib -p /sbin/ldconfig
126%postun glib -p /sbin/ldconfig
127
128%files -f %{name}.lang
129%defattr(-,root, root,-)
130%doc COPYING README
131%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
132%{_libdir}/girepository-1.0/ModemManager-1.0.typelib
133%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
134%attr(0755,root,root) %{_sbindir}/ModemManager
135%attr(0755,root,root) %{_bindir}/mmcli
136%dir %{_libdir}/%{name}
137%attr(0755,root,root) %{_libdir}/%{name}/*.so*
138/lib/udev/rules.d/*
139%{_datadir}/dbus-1/interfaces/*.xml
140%{_datadir}/icons/hicolor/22x22/apps/*.png
141%{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
142%{_mandir}/man8/*
143
144%files devel
145%defattr(-,root,root,-)
146%{_includedir}/ModemManager/*.h
147%dir %{_datadir}/gtk-doc/html/%{name}
148%{_datadir}/gir-1.0/ModemManager-1.0.gir
149%{_datadir}/gtk-doc/html/%{name}/*
150%{_libdir}/pkgconfig/%{name}.pc
151
152%files glib
153%defattr(-,root,root,-)
154%{_libdir}/libmm-glib.so.*
155
156%files glib-devel
157%defattr(-,root,root,-)
158%{_libdir}/libmm-glib.so
159%dir %{_includedir}/libmm-glib
160%{_includedir}/libmm-glib/*.h
161%{_libdir}/pkgconfig/mm-glib.pc
162%dir %{_datadir}/gtk-doc/html/libmm-glib
163%{_datadir}/gtk-doc/html/libmm-glib/*
164
165
166%changelog
167* Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
168- new upstream release.
169
170* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
171- new upstream release
172- change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
173
174* Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
175- fix spec file
176
177* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
178- fix spec file
179
180* Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
181- new upstream release
182- add BuildRequires: gobject-introspection-devel, polkit-devel
183
184* Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
185- new upstream release
186
187* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
188- new upstream release
189
190* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
191- new upstream release
192
193* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
194- new upstream release
195
196* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
197- new upstream release
198
199* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
200- moved ModemManager-glib to System Environment/Libraries Group
201- removed BR: ppp, ppp-devel and dbus-glib-devel
202
203* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
204- new upstream release
205- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
206
207* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
208- add Patch1 (ModemManager-1.0.0-git20130911.patch)
209
210* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
211- new upstream release
212- update Patch0
213
214* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
215- update to 0.7.991 snapshot
216- fix spec file based on FC package
217  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
218  - Update to 0.7.991 snapshot
219  - Fix SMS validity parsing
220  - Allow registration changes to 'searching' without disconnecting
221  - Fix reading SMS messages from some QMI-based devices
222  - Increase connection timeout for Novatel E362
223  - Fix PIN retries checking when unlocking Ericsson devices
224  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
225- add configure option (--enable-gtk-doc=yes, --without-qmi)
226
227* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
228- new upstream release
229
230* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
231- new upstream release
232
233* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
234- delete Patch20
235
236* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
237- update Patch20 (ModemManager-0.4-git20110428.patch)
238- delete Patch21,22
239
240* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
241- update to 0.4
242- add Patch20 (ModemManager-0.4-git20100720.patch)
243- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
244- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
245
246* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
247- initial build for Vine Linux
248
249* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
250- core: ignore some failures on disconnect (rh #578280)
251- core: add support for platform serial devices
252- gsm: better Blackberry DUN support
253- gsm: periodically poll access technology
254- cdma: prevent crash on modem removal (rh #571921)
255- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
256- novatel: better signal strength reporting on CDMA cards
257- novatel: add access technology and mode preference support on GSM cards
258- zte: fix mode preference retrieval
259- longcheer: add support for Zoom modems (4595, 4596, etc)
260- longcheer: add access technology and mode preference support
261
262* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
263- Silence %%post
264- Update scripts
265
266* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
267- gsm: fix parsing Blackberry supported character sets response
268
269* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
270- mbm: fix retrieval of current allowed mode
271- gsm: fix initialization issues with some devices (like Blackberries)
272
273* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
274- core: fix detection of some generic devices (rh #579247)
275- core: fix detection regression of some Huawei devices in 0.3-5
276- cdma: periodically poll registration state and signal quality
277- cdma: really fix registration detection on various devices (rh #569067)
278
279* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
280- core: fix PPC/SPARC/etc builds
281
282* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
283- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
284- cdma: handle signal quality requests while connected for more devices
285- cdma: handle serving system requests while connected for more devices
286- gsm: determine current access technology earlier
287- huawei: work around automatic registration issues on some devices
288
289* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
290- core: ensure enabled modems are disabled when MM stops
291- core: better capability detection for Blackberry devices (rh #573510)
292- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
293- gsm: don't block modem when it requires PIN2
294- option: fix access technology updates
295
296* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
297- mbm: add device IDs for C3607w
298- mbm: fail earlier during connection failures
299- mbm: fix username/password authentication when checked by the network
300- hso: implement asynchronous signal quality updates
301- option: implement asynchronous signal quality updates
302- novatel: correctly handle CDMA signal quality
303- core: basic PolicyKit support
304- core: fix direct GSM registration information requests
305- core: general GSM PIN/PUK unlock fixes
306- core: poll GSM registration state internally for quicker status updates
307- core: implement GSM 2G/3G preference
308- core: implement GSM roaming allowed/disallowed preference
309- core: emit signals on access technology changes
310- core: better handling of disconnections
311- core: fix simple CDMA status requests
312
313* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
314- core: startup speed improvements
315- core: GSM PIN checking improvements
316- huawei: fix EVDO-only connections on various devices (rh #553199)
317- longcheer: add support for more devices
318
319* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
320- anydata: new plugin for AnyData CDMA modems (rh #547294)
321- core: fix crashes when devices are unplugged during operation (rh #553953)
322- cdma: prefer primary port for status/registration queries
323- core: fix probing/detection of some PIN-locked devices (rh #551376)
324- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
325- gsm: fix Nokia N80 network scan parsing
326
327* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
328- core: fix apparent hangs by limiting retried serial writes
329- gsm: ensure modem state is reset when disabled
330
331* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
332- sierra: fix CDMA registration detection in some cases (rh #547513)
333
334* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
335- sierra: ensure CDMA device is powered up when trying to use it
336- cdma: better signal quality parsing (fixes ex Huawei EC168C)
337- zte: handle unsolicited messages better during probing
338
339* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
340- cdma: fix signal strength reporting on some devices
341- cdma: better registration state detection when dialing (ex Sierra 5275)
342- option: always use the correct tty for dialing commands
343
344* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
345- core: fix reconnect after manual disconnect (rh #541314)
346- core: fix various segfaults during registration
347- core: fix probing of various modems on big-endian architectures (ie PPC)
348- core: implement modem states to avoid duplicate operations
349- hso: fix authentication for Icera-based devices like iCON 505
350- zte: use correct port for new devices
351- nozomi: fix detection
352
353* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
354- Update to latest git
355- core: fix pppd 2.4.5 errors about 'baudrate 0'
356- cdma: wait for network registration before trying to connect
357- gsm: add cell access technology reporting
358- gsm: allow longer-running network scans
359- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
360- nokia: don't power down phones on disconnect
361- hso: fix disconnection/disable
362
363* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
364- Fixes for Motorola and Ericsson devices
365- Fixes for CDMA "serving-system" command parsing
366
367* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
368- Fix a typo in one of the udev rules files
369
370* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
371- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
372
373* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
374- Fix source repo location
375- Fix directory ownership
376
377* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
378- Initial version
379
Note: See TracBrowser for help on using the repository browser.