source: projects/specs/trunk/M/ModemManager/ModemManager-vl.spec @ 12000

Revision 12000, 13.8 KB checked in by tomop, 5 years ago (diff)

new: elogind-239.3 (and packages that depends on elogind)

Line 
1#%define git_snapshot .git20130607
2%define git_snapshot %{nil}
3#define ppp_version 2.4.7
4%define glib2_version 2.40
5
6Name: ModemManager
7Summary: Mobile broadband modem management service
8Summary(ja): モバイルブロードバンドモデム運用サービス
9Version: 1.8.2
10Release: 1%{git_snapshot}%{?_dist_release}
11License: GPLv2+
12Group: System Environment/Base
13URL: http://www.gnome.org/projects/NetworkManager/
14Vendor:                 Project Vine
15Distribution:   Vine Linux
16#
17# Source from git://anongit.freedesktop.org/ModemManager/ModemManager
18# tarball built with:
19#    ./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var
20#    make distcheck
21#
22#Source: %{name}-%{version}%{git_snapshot}.tar.bz2
23
24Source: http://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
25
26Patch0: buildsys-hates-openpty.patch
27Patch1: ModemManager-1.8.2-elogind-1.patch
28
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: glib2-devel >= %{glib2_version}
32BuildRequires: libgudev-devel
33BuildRequires: elogind-devel
34BuildRequires: automake autoconf intltool libtool
35BuildRequires: gobject-introspection-devel
36BuildRequires: polkit-devel
37BuildRequires: gtk-doc
38# for xsltproc
39BuildRequires: libxslt
40Requires: dbus-glib
41
42%description
43The ModemManager service manages WWAN modems and provides a consistent API for
44interacting with these devices to client applications.
45
46
47%package        devel
48Summary:        Development tools for %{name}
49Summary(ja):    %{name} の開発環境
50Group:          Development/Libraries
51Requires:       %{name} = %{version}-%{release}
52Requires:       pkgconfig
53
54%description    devel
55Header files and libraries for building a extension library for the %{name}.
56
57
58%package        glib
59Summary:        Libraries for adding ModemManager support to applications that use glib.
60Summary(ja):    Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
61Group:          System Environment/Libraries
62Requires:       glib2 >= %{glib2_version}
63
64%description    glib
65This package contains the libraries that make it easier to use some ModemManager
66functionality from applications that use glib.
67
68
69%package        glib-devel
70Summary:        Development tools for %{name}-glib
71Summary(ja):    %{name}-glib の開発環境
72Group:          Development/Libraries
73Requires:       %{name}-glib = %{version}-%{release}
74Requires:       %{name}-devel = %{version}-%{release}
75Requires:       glib2-devel
76Requires:       pkgconfig
77
78%description    glib-devel
79Header files and libraries for building a extension library for the %{name}-glib.
80
81%prep
82%setup -q
83%patch0 -p1 -b .pty
84%patch1 -p1 -b .elogind
85
86%build
87autoreconf -vif
88#pppddir=`ls -1d %{_libdir}/pppd/2*`
89%configure \
90        --disable-static \
91        --enable-gtk-doc=yes \
92        --enable-vala=no \
93        --enable-more-warnings=yes \
94        --with-udev-base-dir=/lib/udev \
95        --without-mbim \
96        --without-qmi \
97        --with-dist-version=%{version}-%{release} \
98        --with-elogind-suspend-resume=yes
99
100
101make %{?_smp_mflags}
102
103%check
104make check
105
106%install
107make install DESTDIR=$RPM_BUILD_ROOT
108
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
110#rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
111
112%find_lang %{name}
113
114%post
115/sbin/ldconfig
116touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
117
118%postun
119/sbin/ldconfig
120if [ $1 -eq 0 ]; then
121  touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
122  gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
123fi
124
125%posttrans
126gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
127
128%post   glib -p /sbin/ldconfig
129%postun glib -p /sbin/ldconfig
130
131%files -f %{name}.lang
132%defattr(-,root, root,-)
133%doc COPYING README
134%{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
135%{_libdir}/girepository-1.0/ModemManager-1.0.typelib
136%{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
137%attr(0755,root,root) %{_sbindir}/ModemManager
138%attr(0755,root,root) %{_bindir}/mmcli
139%dir %{_libdir}/%{name}
140%attr(0755,root,root) %{_libdir}/%{name}/*.so*
141/lib/udev/rules.d/*
142%{_datadir}/dbus-1/interfaces/*.xml
143%{_datadir}/icons/hicolor/22x22/apps/*.png
144%{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
145%{_mandir}/man1/*
146%{_mandir}/man8/*
147%dir %{_datadir}/bash-completion
148%dir %{_datadir}/bash-completion/completions
149%{_datadir}/bash-completion/completions/*
150
151%files devel
152%defattr(-,root,root,-)
153%{_includedir}/ModemManager/*.h
154%dir %{_datadir}/gtk-doc/html/%{name}
155%{_datadir}/gir-1.0/ModemManager-1.0.gir
156%{_datadir}/gtk-doc/html/%{name}/*
157%{_libdir}/pkgconfig/%{name}.pc
158
159%files glib
160%defattr(-,root,root,-)
161%{_libdir}/libmm-glib.so.*
162
163%files glib-devel
164%defattr(-,root,root,-)
165%{_libdir}/libmm-glib.so
166%dir %{_includedir}/libmm-glib
167%{_includedir}/libmm-glib/*.h
168%{_libdir}/pkgconfig/mm-glib.pc
169%dir %{_datadir}/gtk-doc/html/libmm-glib
170%{_datadir}/gtk-doc/html/libmm-glib/*
171
172
173%changelog
174* Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
175- new upstream release.
176- added elogind support.
177
178* Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
179- new upstream release.
180
181* Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
182- new upstream release
183- change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
184
185* Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
186- fix spec file
187
188* Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
189- fix spec file
190
191* Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
192- new upstream release
193- add BuildRequires: gobject-introspection-devel, polkit-devel
194
195* Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
196- new upstream release
197
198* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
199- new upstream release
200
201* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
202- new upstream release
203
204* Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
205- new upstream release
206
207* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
208- new upstream release
209
210* Tue Oct  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
211- moved ModemManager-glib to System Environment/Libraries Group
212- removed BR: ppp, ppp-devel and dbus-glib-devel
213
214* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
215- new upstream release
216- remove Patch1 (ModemManager-1.0.0-git20130911.patch)
217
218* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
219- add Patch1 (ModemManager-1.0.0-git20130911.patch)
220
221* Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
222- new upstream release
223- update Patch0
224
225* Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
226- update to 0.7.991 snapshot
227- fix spec file based on FC package
228  * Fri Jun  7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
229  - Update to 0.7.991 snapshot
230  - Fix SMS validity parsing
231  - Allow registration changes to 'searching' without disconnecting
232  - Fix reading SMS messages from some QMI-based devices
233  - Increase connection timeout for Novatel E362
234  - Fix PIN retries checking when unlocking Ericsson devices
235  - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
236- add configure option (--enable-gtk-doc=yes, --without-qmi)
237
238* Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
239- new upstream release
240
241* Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
242- new upstream release
243
244* Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
245- delete Patch20
246
247* Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
248- update Patch20 (ModemManager-0.4-git20110428.patch)
249- delete Patch21,22
250
251* Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
252- update to 0.4
253- add Patch20 (ModemManager-0.4-git20100720.patch)
254- add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
255- add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
256
257* Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
258- initial build for Vine Linux
259
260* Sun May  2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
261- core: ignore some failures on disconnect (rh #578280)
262- core: add support for platform serial devices
263- gsm: better Blackberry DUN support
264- gsm: periodically poll access technology
265- cdma: prevent crash on modem removal (rh #571921)
266- mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
267- novatel: better signal strength reporting on CDMA cards
268- novatel: add access technology and mode preference support on GSM cards
269- zte: fix mode preference retrieval
270- longcheer: add support for Zoom modems (4595, 4596, etc)
271- longcheer: add access technology and mode preference support
272
273* Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
274- Silence %%post
275- Update scripts
276
277* Fri Apr  9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
278- gsm: fix parsing Blackberry supported character sets response
279
280* Thu Apr  8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
281- mbm: fix retrieval of current allowed mode
282- gsm: fix initialization issues with some devices (like Blackberries)
283
284* Mon Apr  5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
285- core: fix detection of some generic devices (rh #579247)
286- core: fix detection regression of some Huawei devices in 0.3-5
287- cdma: periodically poll registration state and signal quality
288- cdma: really fix registration detection on various devices (rh #569067)
289
290* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
291- core: fix PPC/SPARC/etc builds
292
293* Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
294- core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
295- cdma: handle signal quality requests while connected for more devices
296- cdma: handle serving system requests while connected for more devices
297- gsm: determine current access technology earlier
298- huawei: work around automatic registration issues on some devices
299
300* Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
301- core: ensure enabled modems are disabled when MM stops
302- core: better capability detection for Blackberry devices (rh #573510)
303- cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
304- gsm: don't block modem when it requires PIN2
305- option: fix access technology updates
306
307* Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
308- mbm: add device IDs for C3607w
309- mbm: fail earlier during connection failures
310- mbm: fix username/password authentication when checked by the network
311- hso: implement asynchronous signal quality updates
312- option: implement asynchronous signal quality updates
313- novatel: correctly handle CDMA signal quality
314- core: basic PolicyKit support
315- core: fix direct GSM registration information requests
316- core: general GSM PIN/PUK unlock fixes
317- core: poll GSM registration state internally for quicker status updates
318- core: implement GSM 2G/3G preference
319- core: implement GSM roaming allowed/disallowed preference
320- core: emit signals on access technology changes
321- core: better handling of disconnections
322- core: fix simple CDMA status requests
323
324* Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
325- core: startup speed improvements
326- core: GSM PIN checking improvements
327- huawei: fix EVDO-only connections on various devices (rh #553199)
328- longcheer: add support for more devices
329
330* Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
331- anydata: new plugin for AnyData CDMA modems (rh #547294)
332- core: fix crashes when devices are unplugged during operation (rh #553953)
333- cdma: prefer primary port for status/registration queries
334- core: fix probing/detection of some PIN-locked devices (rh #551376)
335- longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
336- gsm: fix Nokia N80 network scan parsing
337
338* Fri Jan  1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
339- core: fix apparent hangs by limiting retried serial writes
340- gsm: ensure modem state is reset when disabled
341
342* Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
343- sierra: fix CDMA registration detection in some cases (rh #547513)
344
345* Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
346- sierra: ensure CDMA device is powered up when trying to use it
347- cdma: better signal quality parsing (fixes ex Huawei EC168C)
348- zte: handle unsolicited messages better during probing
349
350* Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
351- cdma: fix signal strength reporting on some devices
352- cdma: better registration state detection when dialing (ex Sierra 5275)
353- option: always use the correct tty for dialing commands
354
355* Mon Dec  7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
356- core: fix reconnect after manual disconnect (rh #541314)
357- core: fix various segfaults during registration
358- core: fix probing of various modems on big-endian architectures (ie PPC)
359- core: implement modem states to avoid duplicate operations
360- hso: fix authentication for Icera-based devices like iCON 505
361- zte: use correct port for new devices
362- nozomi: fix detection
363
364* Thu Nov  5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
365- Update to latest git
366- core: fix pppd 2.4.5 errors about 'baudrate 0'
367- cdma: wait for network registration before trying to connect
368- gsm: add cell access technology reporting
369- gsm: allow longer-running network scans
370- mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
371- nokia: don't power down phones on disconnect
372- hso: fix disconnection/disable
373
374* Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
375- Fixes for Motorola and Ericsson devices
376- Fixes for CDMA "serving-system" command parsing
377
378* Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
379- Fix a typo in one of the udev rules files
380
381* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
382- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
383
384* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
385- Fix source repo location
386- Fix directory ownership
387
388* Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
389- Initial version
390
Note: See TracBrowser for help on using the repository browser.