source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 9506

Revision 9506, 29.5 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.9.1
5%define Patchlevel 1
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20URL: http://www.imagemagick.org/
21
22%if "%{Patchlevel}" != ""
23Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
24%else
25Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
26%endif
27#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: bzip2-devel
31BuildRequires: cairo-devel
32BuildRequires: pango-devel
33BuildRequires: freetype2-devel >= 2.1.7
34BuildRequires: fontconfig-devel
35BuildRequires: giflib-devel
36BuildRequires: graphviz-devel
37BuildRequires: lcms2-devel
38BuildRequires: libjpeg-turbo-devel
39BuildRequires: libpng-devel >= 1.2.5
40BuildRequires: librsvg2-devel
41BuildRequires: libtiff-devel
42BuildRequires: libxml2-devel
43BuildRequires: libSM-devel
44BuildRequires: libX11-devel
45BuildRequires: libXext-devel
46BuildRequires: OpenEXR-devel
47BuildRequires: perl
48BuildRequires: xorg-x11-server-utils
49BuildRequires: zlib-devel
50BuildRequires: libXt-devel
51BuildRequires: xz-devel
52BuildRequires: xz-lzma-compat
53BuildRequires: libtool-ltdl-devel
54
55Requires: bzip2
56Requires: freetype2
57Requires: giflib
58Requires: graphviz
59Requires: lcms2
60Requires: libjpeg-turbo
61Requires: libpng
62Requires: libtiff
63Requires: libxml2
64Requires: OpenEXR-libs
65Requires: xorg-x11-server-utils
66Requires: zlib
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: inagaki, iwamoto, Takemikaduchi
71
72%description
73ImageMagick(TM) is an image display and manipulation tool for the X
74Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
75and Photo CD image formats. It can resize, rotate, sharpen, color
76reduce, or add special effects to an image, and when finished you can
77either save the completed work in the original format or a different
78one. ImageMagick also includes command line programs for creating
79animated or transparent .gifs, creating composite images, creating
80thumbnail images, and more.
81
82ImageMagick is one of your choices if you need a program to manipulate
83and dis play images. If you want to develop your own applications
84which use ImageMagick code or APIs, you need to install
85ImageMagick-devel as well.
86
87
88%description -l ja
89ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
90ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
91イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
92出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
93オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
94また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
95サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
96
97画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
98も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
99アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
100インストールして下さい.
101
102%package devel
103Summary: Static libraries and header files for ImageMagick app development.
104Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
105Group: Development/Libraries
106Requires: ImageMagick = %{version}-%{release}
107
108%description devel
109Image-Magick-devel contains the static libraries and header files you'll
110need to develop ImageMagick applications. ImageMagick is an image
111manipulation program.
112
113If you want to create applications that will use ImageMagick code or
114APIs, you need to install ImageMagick-devel as well as ImageMagick.
115You do noy need to install it if you just want to use ImageMagick,
116however.
117
118%description devel -l ja
119ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
120これらは ImageMagick アプリケーションの開発の際に必要となります.
121ImageMagick は画像処理プログラムです.
122
123ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
124この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
125する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
126インストールする必要はありません.
127
128%package c++
129Summary: ImageMagick Magick++ library (C++ bindings)
130Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
131Group: System Environment/Libraries
132Requires: ImageMagick = %{version}-%{release}
133
134%description c++
135This package contains the Magick++ library, a C++ binding to the ImageMagick
136graphics manipulation library.
137
138Install ImageMagick-c++ if you want to use any applications that use Magick++.
139
140%description c++
141このパッケージには Magick++ ライブラリが収められています.
142Magick++ とは ImageMagick ライブラリの C++ バインディングです.
143
144Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
145パッケージをインストールして下さい.
146
147%package c++-devel
148Summary: C++ bindings for the ImageMagick library
149Summary(ja): ImageMagick ライブラリの C++ バインディング
150Group: Development/Libraries
151Requires: ImageMagick = %{version}-%{release}
152Requires: ImageMagick-c++ = %{version}-%{release}
153Requires: ImageMagick-devel = %{version}-%{release}
154
155%description c++-devel
156ImageMagick-devel contains the static libraries and header files you'll
157need to develop ImageMagick applications using the Magick++ C++ bindings.
158ImageMagick is an image manipulation program.
159
160If you want to create applications that will use Magick++ code
161or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
162ImageMagick.
163You don't need to install it if you just want to use ImageMagick, or if you
164want to develop/compile applications using the ImageMagick C interface,
165however.
166
167%description c++-devel -l ja
168ImageMagick-c++-devel には Magick++ C++ バインディングを使った
169ImageMagick アプリケーション開発に必要なスタティックライブラリと
170ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
171
172Magick++ コードや API を使ったアプリケーションを開発する場合は,
173ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
174インストールする必要があります.
175ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
176を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
177インストールする必要はありません.
178
179%package -n perl-Image-Magick
180Summary: ImageMagick perl bindings
181Summary(ja): ImageMagick の Perl バインディング
182Group: Development/Libraries
183Requires: ImageMagick = %{version}-%{release}
184Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
185Obsoletes: ImageMagick-perl < %{version}-%{release}
186Provides: ImageMagick-perl = %{version}-%{release}
187
188%description -n perl-Image-Magick
189Perl bindings to ImageMagick.
190
191Install ImageMagick-perl if you want to use any perl scripts that use
192ImageMagick.
193
194%description -n perl-Image-Magick -l ja
195このパッケージは ImageMagick の Perl バインディングです.
196
197ImageMagick を利用する perl スクリプトを使いたい場合は
198ImageMagick-perl パッケージをインストールして下さい.
199
200
201%prep
202%setup -q -n %{name}-%{VER}-%{Patchlevel}
203
204#patch1 -p1 -b .CVE-2006-5456
205
206%build
207%configure \
208    --enable-silent-rules \
209    --enable-shared \
210    --disable-static \
211    --with-modules \
212    --with-quantum-depth=16 \
213    --without-frozenpaths \
214    --with-x \
215    --without-dps \
216    --without-djvu \
217    --without-fftw \
218    --without-jbig \
219    --without-jp2 \
220    --with-lcms2 \
221    --without-wmf \
222    --with-perl \
223    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
224
225# Disable rpath
226sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
227sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
228
229make %{?_smp_mflags}
230
231%install
232rm -rf $RPM_BUILD_ROOT
233
234make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
235
236# perlmagick: fix perl path of demo files
237%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
238
239find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
240find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
241find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
242
243echo "%defattr(-,root,root)" > perl-pkg-files
244find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
245sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
246
247# remove duplicated doc files
248rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
249rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
250
251# remove files conflict with libtools
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
253rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
254
255# remove *.la files
256find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
257
258rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
259
260%clean
261rm -rf $RPM_BUILD_ROOT
262
263%post -p /sbin/ldconfig
264
265%post c++ -p /sbin/ldconfig
266
267%postun -p /sbin/ldconfig
268
269%postun c++ -p /sbin/ldconfig
270
271
272%files
273%defattr(-,root,root)
274%doc www images
275%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
276%dir %{_libdir}/%{name}-%{VER}
277%dir %{_libdir}/%{name}-%{VER}/config-Q16
278%dir %{_libdir}/%{name}-%{VER}/modules-Q16
279%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
280%{_sysconfdir}/%{name}-6/*.xml
281%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
282%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
283%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
284%{_libdir}/libMagickCore-6.Q16.so.*
285%{_libdir}/libMagickWand-6.Q16.so.*
286%{_bindir}/[a-z]*
287%{_datadir}/%{name}-6/*.xml
288%{_mandir}/man1/ImageMagick.*
289%{_mandir}/man1/[a-z]*
290
291%files devel
292%defattr(-,root,root)
293%{_bindir}/Magick-config
294%{_bindir}/Wand-config
295%{_bindir}/MagickCore-config
296%{_bindir}/MagickWand-config
297%{_libdir}/libMagickCore-6.Q16.so
298%{_libdir}/libMagickWand-6.Q16.so
299%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
300%{_libdir}/pkgconfig/ImageMagick.pc
301%{_libdir}/pkgconfig/Wand-6.Q16.pc
302%{_libdir}/pkgconfig/Wand.pc
303%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
304%{_libdir}/pkgconfig/MagickCore.pc
305%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
306%{_libdir}/pkgconfig/MagickWand.pc
307%{_includedir}/ImageMagick-6/magick
308%{_includedir}/ImageMagick-6/wand
309%{_mandir}/man1/Magick-config*
310%{_mandir}/man1/Wand-config*
311%{_mandir}/man1/MagickCore-config*
312%{_mandir}/man1/MagickWand-config*
313
314%files c++
315%defattr(-,root,root)
316%{_libdir}/libMagick++-6.Q16.so.*
317
318%files c++-devel
319%defattr(-,root,root)
320%{_bindir}/Magick++-config
321%{_includedir}/ImageMagick-6/Magick++
322%{_includedir}/ImageMagick-6/Magick++.h
323%{_libdir}/libMagick++-6.Q16.so
324%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
325%{_libdir}/pkgconfig/ImageMagick++.pc
326%{_libdir}/pkgconfig/Magick++-6.Q16.pc
327%{_libdir}/pkgconfig/Magick++.pc
328%{_mandir}/man1/Magick++-config*
329
330%files -n perl-Image-Magick -f perl-pkg-files
331%defattr(-,root,root)
332%{_mandir}/man3/*
333
334%changelog
335* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.1-1
336- new upstream release
337
338* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.9.0.0-1
339- new upstream release
340- built with OpenEXR 2.2.0
341
342* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
343- new upstream release
344
345* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
346- new upstream release
347
348* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
349- new upstream release
350
351* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
352- new upstream release
353
354* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
355- new upstream release
356
357* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
358- new upstream release
359
360* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
361- new upstream release
362
363* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
364- new upstream release
365
366* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
367- new upstream release
368
369* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
370- new upstream release
371
372* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
373- new upstream release
374- add BuildRequires: pango-devel
375- change BuildRequires: lcms2-devel instead of lcms-devel
376
377* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
378- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
379
380* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
381- built with perl-5.12.3
382- changed perl subpackage name
383
384* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
385- new upstream release
386
387* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
388- rebuilt with graphviz-2.26.3 again
389
390* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
391- new upstream release
392- rebuilt with graphviz-2.26.3
393
394* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
395- new upstream release
396
397* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
398- rebuild with rpm-4.8.1 for pkg-config file
399- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
400- change Requires: libjpeg-turbo instead of libjpeg
401
402* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
403- new upstream release
404- built with new toolchain
405- added --disable-static to %%configure, removed static libraries
406
407* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
408- added --without-djvu --without-fftw
409
410* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
411- new upstream release
412
413* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
414- new upstream release
415
416* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
417- new upstream release
418- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
419- add R: graphviz, OpenEXR-libs, ilmbase
420
421* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
422- new upstream release
423- added Packager tag
424
425* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
426- new upstream release
427
428* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
429- new upstream release
430- updated BuildRequires
431
432* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
433- enabled lcms as default.
434
435* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
436- new upstream release
437
438* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
439- new upstream release
440
441* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
442- new upstream release
443
444* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
445- new upstream release
446
447* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
448- new upstream release
449- spec in UTF-8
450
451* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
452- enabled to build with lcms (use '--with lcms' to enable).
453
454* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
455- new upstream release
456- rebuilt with perl-5.10.0
457
458* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
459- new upstream release
460- removed *.la files from devel packages
461
462* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
463- new upstream release
464- change files section to fit new release
465- build under new versioning policy
466
467* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
468- new upstream release
469
470* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
471- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
472- add BuildPrereq: librsvg2-devel
473- add %{?_smp_mflags} to make command arg
474
475* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
476- new upstream release
477- changed Group to Applications/Graphics
478
479* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
480- rebuilt for VineSeed
481
482* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
483- update patch1 for fix CVE-2007-0770
484
485* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
486- upstream release
487- add patch1 for fix CVE-2006-5456
488
489* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
490- rebuilt (for ppc) to resolve reference to invalid *la files
491
492* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
493- new upstream release
494
495* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
496- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
497
498* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
499- new upstream release
500- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
501- add --with-perl-options to configure option
502
503* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
504- new upstream release
505- build with XOrg-6.9.0
506
507* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
508- new upstream release
509- add %%{_mandir}/man1/ImageMagick.* to main package
510
511* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
512- source upgrade
513- remove patch1
514- update %%files
515
516* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
517- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
518  (CAN-2004-0981)
519
520* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
521- move $(pkglibdir)/modules-Q16/*/*.la to main package.
522
523* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
524- source upgrade
525- Patch: change default menu font so display can work without XOrg-75dpi-fonts
526- add missing docs
527- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
528- *.pc should be in -devel package
529- add missing pkg{lib,data}dirs to %%files
530
531* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
532- source upgrade
533- add --without-dot to %%configure option
534- update %%files section
535
536* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
537- source upgrade
538
539* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
540- source upgrade
541
542* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
543- add --without-jbig to %%configure option
544
545* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
546- add --without-lcms to %%configure option
547
548* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
549- source upgrade
550- remove commented lines
551
552* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
553- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
554
555* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
556- source upgrade
557- remove patch for freetype2, no need
558- remove commented lines
559- add --with-quantum-depth=16 --with-modules --enable-lzw
560  --without-frozenpaths to %%configure option
561- remove --with-threads --without-xml from %%configure option
562- update %%files
563
564* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
565- patch update
566- add --without-jp2 to configure option
567- change PerlMagick build method
568
569* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
570- rebuild without jasper-devel
571
572* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
573- source upgrade to 5.5.7-15
574
575* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
576- source upgrade to 5.5.7-13
577- add patch0 to build against freetype2-2.1.7
578
579* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
580- source upgrade to 5.5.7-11
581- clean up spec
582- build without previous package (do not require libMagick.so.0)
583
584* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
585- source upgrade to 5.5.7-9
586- revised name of pkgconfig files
587- remove BuildPrereq: freetype-devel
588
589* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
590- source upgrade to 5.5.7-6
591- disable all patches
592- revised %%files section
593- disable libtoolize and autotools
594- change PerlMagick build method
595- build without previous package (do not require libMagick.so.5)
596
597* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
598- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
599  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
600
601* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
602- rebuild
603
604* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
605- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
606- FIXME: rpm's macro problem?
607
608- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
609  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
610
611  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
612  - remove unnecessary duplicated %%doc files
613  - --without-xml instead of --without-ttf
614  - eliminate libungif(-devel) from BuildReq/Requires
615  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
616
617  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
618  - add delegetes.mgk (and %%{_libdir}/%%{name})
619
620  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
621  - 5.2.9-0vl4
622  - Sorry, the spec was in Shift_JIS. Fixed.
623
624  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
625  - 5.2.9-0vl3
626  - rebuilt with perl-5.6.1
627  - added Japanese summary and description :-P
628  - added --without-ttf in order to disable freetype2 (SeedPlus) support
629  - added --without-wmf in order to disable libwmf (SeedPlus) support
630
631  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
632  - 5.2.9-0vl2
633  - rebuild on Perl-5.6
634  - use %%{perl_sitearch}
635  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
636
637  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
638  - 5.2.9-0vl1
639  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
640
641* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
642- fix perl paths in file list
643
644* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
645- lib64'ize
646- don't throw stuff in /usr/X11R6, that's for X only
647- remove files we aren't shipping
648
649* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
650- rebuilt with gcc-3.2 (we hope)
651
652* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
653- build using gcc-3.2-0.1
654
655* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
656- fix non-cpp headers in -devel package
657- fix #62157 (wrong path for include files in ImageMagick-devel)
658- fix #63897 (use _target instead of _arch) in libtool workaround
659- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
660
661* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
662- update
663- fix localdoc patch
664- fix %%files section
665- disable nonroot patch
666- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
667- fix libtool workaround
668- moved Magick*-config into -devel package (#64249)
669
670* Sun May 26 2002 Tim Powers <timp@redhat.com>
671- automated rebuild
672
673* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
674- 5.4.6
675
676* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
677- Update to pl 11
678
679* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
680- Update to 5.4.3 pl5; this fixes #58080
681
682* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
683- Patchlevel 3
684
685* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
686- automated rebuild
687
688* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
689- Update to 5.4.2-2
690- Fix #57923, also don't hardcode netscape as html viewer
691
692* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
693- 5.4.1
694- Link against new libstdc++
695
696* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
697- 5.4.0.5
698- Make the error message when trying to display an hpgl file more
699  explicit (#55875)
700
701* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
702- 5.4.0.3
703- Fix names of man pages
704
705* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
706- 5.4.0
707- work around build system breakage causing applications to be named
708  %{_arch}-redhat-linux-foo rather than foo
709
710* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
711- 5.3.9
712
713* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
714- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
715  (#52611)
716
717* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
718- Remove Magick++ includes from -devel, they're already in -c++-devel
719  (#51590)
720
721* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
722- 5.3.8 (bugfix release)
723
724* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
725- fix to build Perlmagic on s390 s390x
726
727* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
728- Add delegates.mgk to the package (#50725)
729
730* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
731- 5.3.7
732- Fix build without previously installed ImageMagick-devel (#49816)
733- Move perl bindings to a separate package.
734
735* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
736- Fix build as non-root again
737- Shut up rpmlint
738
739* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
740- 5.3.6
741- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
742
743* Sat Jun 16 2001 Than Ngo <than@redhat.com>
744- update to 5.3.5
745- cleanup specfile
746
747* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
748- 5.3.3-respin, fixes #41196
749
750* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
751- 5.3.3
752- Add a desktop file for "display" (RFE#17417)
753
754* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
755- 5.3.2
756- work around bugs in ia64 glibc headers
757
758* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
759- remove patch for s390, it is not necessary
760
761* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
762- 5.2.7
763
764* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
765- 5.2.6
766
767* Mon Dec 18 2000 Than Ngo <than@redhat.com>
768- ported to s390
769
770* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
771- 5.2.4
772- Fix up and package the C++ bindings in the new c++/c++-devel packages.
773
774* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
775- rebuild against new libpng
776
777* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
778- include images with docs (#10312)
779
780* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
781- don't build with -ggdb, use -g instead.
782
783* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
784- automatic rebuild
785
786* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
787- update to 5.2.2 beta
788
789* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
790- update to 5.2.1, redone patches as they failed
791
792* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
793- remove hacks to move perl man pages
794- don't include the perl*/man stuff, these files go in /usr/share/man now.
795
796* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
797- disable optimization on Alpha and Sparc
798
799* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
800- update to 5.2.0
801- update URL
802- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
803
804* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
805- bootstrap rebuilt to nuke broken libbz2 deps
806- add Prefix: tag such that the FHS macros work properly
807
808* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
809- now compiles with bzip2 1.0
810- changed buildroot to include version
811
812* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
813- fix compilation with new perl
814
815* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
816- 5.1.1
817
818* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
819- Rebuild to get compressed man pages
820
821* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
822- ugly hack to print with lpr instead of lp
823
824* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
825- update to 4.2.9
826
827* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
828- update to 4.2.8
829
830* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
831- include the perl man pages as well
832
833* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
834- remove --enable-16bit because it damages interoperability
835
836* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
837- update to 4.2.2
838- change ChangeLog to refer to actual dates.
839- strip binaries
840
841* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
842- add more files. Oops.
843
844* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
845- auto rebuild in the new build environment (release 2)
846
847* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
848- version 4.2.1
849
850* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
851- changed group
852
853* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
854- hacks to make it work with the new perl
855- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
856- make sure the libraries have the x bit on
857
858* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
859- translations modified for de, fr
860
861* Thu May 07 1998 Prospector System <bugs@redhat.com>
862- translations modified for de, fr, tr
863
864* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
865- updated to 4.0.5
866
867* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
868- updated to 4.0.4
869- added BuildRoot
870
871* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
872- updated from 3.8.3 to 3.9.1
873- removed PNG patch (appears to be fixed)
874
875* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
876- build against new libpng
877
878* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
879- built against glibc
880
881* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
882- updated to version 3.8.3.
883- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.