source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 9560

Revision 9560, 29.7 KB checked in by Takemikaduchi, 9 years ago (diff)

ImageMagick?: new upstream release
others: remove *.la files

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.9.1
5%define Patchlevel 2
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20URL: http://www.imagemagick.org/
21
22%if "%{Patchlevel}" != ""
23Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
24%else
25Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.xz
26%endif
27#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
28
29Buildroot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: bzip2-devel
31BuildRequires: cairo-devel
32BuildRequires: pango-devel
33BuildRequires: freetype2-devel >= 2.1.7
34BuildRequires: fontconfig-devel
35BuildRequires: giflib-devel
36BuildRequires: graphviz-devel
37BuildRequires: lcms2-devel
38BuildRequires: libjpeg-turbo-devel
39BuildRequires: libpng-devel >= 1.2.5
40BuildRequires: librsvg2-devel
41BuildRequires: libtiff-devel
42BuildRequires: libxml2-devel
43BuildRequires: libSM-devel
44BuildRequires: libX11-devel
45BuildRequires: libXext-devel
46BuildRequires: OpenEXR-devel
47BuildRequires: perl
48BuildRequires: xorg-x11-server-utils
49BuildRequires: zlib-devel
50BuildRequires: libXt-devel
51BuildRequires: xz-devel
52BuildRequires: xz-lzma-compat
53BuildRequires: libtool-ltdl-devel
54
55Requires: bzip2
56Requires: freetype2
57Requires: giflib
58Requires: graphviz
59Requires: lcms2
60Requires: libjpeg-turbo
61Requires: libpng
62Requires: libtiff
63Requires: libxml2
64Requires: OpenEXR-libs
65Requires: xorg-x11-server-utils
66Requires: zlib
67
68Vendor: Project Vine
69Distribution: Vine Linux
70Packager: inagaki, iwamoto, Takemikaduchi
71
72%description
73ImageMagick(TM) is an image display and manipulation tool for the X
74Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
75and Photo CD image formats. It can resize, rotate, sharpen, color
76reduce, or add special effects to an image, and when finished you can
77either save the completed work in the original format or a different
78one. ImageMagick also includes command line programs for creating
79animated or transparent .gifs, creating composite images, creating
80thumbnail images, and more.
81
82ImageMagick is one of your choices if you need a program to manipulate
83and dis play images. If you want to develop your own applications
84which use ImageMagick code or APIs, you need to install
85ImageMagick-devel as well.
86
87
88%description -l ja
89ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
90ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
91イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
92出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
93オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
94また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
95サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
96
97画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
98も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
99アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
100インストールして下さい.
101
102%package devel
103Summary: Static libraries and header files for ImageMagick app development.
104Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
105Group: Development/Libraries
106Requires: ImageMagick = %{version}-%{release}
107
108%description devel
109Image-Magick-devel contains the static libraries and header files you'll
110need to develop ImageMagick applications. ImageMagick is an image
111manipulation program.
112
113If you want to create applications that will use ImageMagick code or
114APIs, you need to install ImageMagick-devel as well as ImageMagick.
115You do noy need to install it if you just want to use ImageMagick,
116however.
117
118%description devel -l ja
119ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
120これらは ImageMagick アプリケーションの開発の際に必要となります.
121ImageMagick は画像処理プログラムです.
122
123ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
124この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
125する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
126インストールする必要はありません.
127
128%package c++
129Summary: ImageMagick Magick++ library (C++ bindings)
130Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
131Group: System Environment/Libraries
132Requires: ImageMagick = %{version}-%{release}
133
134%description c++
135This package contains the Magick++ library, a C++ binding to the ImageMagick
136graphics manipulation library.
137
138Install ImageMagick-c++ if you want to use any applications that use Magick++.
139
140%description c++
141このパッケージには Magick++ ライブラリが収められています.
142Magick++ とは ImageMagick ライブラリの C++ バインディングです.
143
144Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
145パッケージをインストールして下さい.
146
147%package c++-devel
148Summary: C++ bindings for the ImageMagick library
149Summary(ja): ImageMagick ライブラリの C++ バインディング
150Group: Development/Libraries
151Requires: ImageMagick = %{version}-%{release}
152Requires: ImageMagick-c++ = %{version}-%{release}
153Requires: ImageMagick-devel = %{version}-%{release}
154
155%description c++-devel
156ImageMagick-devel contains the static libraries and header files you'll
157need to develop ImageMagick applications using the Magick++ C++ bindings.
158ImageMagick is an image manipulation program.
159
160If you want to create applications that will use Magick++ code
161or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
162ImageMagick.
163You don't need to install it if you just want to use ImageMagick, or if you
164want to develop/compile applications using the ImageMagick C interface,
165however.
166
167%description c++-devel -l ja
168ImageMagick-c++-devel には Magick++ C++ バインディングを使った
169ImageMagick アプリケーション開発に必要なスタティックライブラリと
170ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
171
172Magick++ コードや API を使ったアプリケーションを開発する場合は,
173ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
174インストールする必要があります.
175ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
176を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
177インストールする必要はありません.
178
179%package -n perl-Image-Magick
180Summary: ImageMagick perl bindings
181Summary(ja): ImageMagick の Perl バインディング
182Group: Development/Libraries
183Requires: ImageMagick = %{version}-%{release}
184Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
185Obsoletes: ImageMagick-perl < %{version}-%{release}
186Provides: ImageMagick-perl = %{version}-%{release}
187
188%description -n perl-Image-Magick
189Perl bindings to ImageMagick.
190
191Install ImageMagick-perl if you want to use any perl scripts that use
192ImageMagick.
193
194%description -n perl-Image-Magick -l ja
195このパッケージは ImageMagick の Perl バインディングです.
196
197ImageMagick を利用する perl スクリプトを使いたい場合は
198ImageMagick-perl パッケージをインストールして下さい.
199
200
201%prep
202%setup -q -n %{name}-%{VER}-%{Patchlevel}
203
204#patch1 -p1 -b .CVE-2006-5456
205
206%build
207%configure \
208    --enable-silent-rules \
209    --enable-shared \
210    --disable-static \
211    --with-modules \
212    --with-quantum-depth=16 \
213    --without-frozenpaths \
214    --with-x \
215    --without-dps \
216    --without-djvu \
217    --without-fftw \
218    --without-jbig \
219    --without-jp2 \
220    --with-lcms2 \
221    --without-wmf \
222    --with-perl \
223    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
224
225# Disable rpath
226sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
227sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
228
229make %{?_smp_mflags}
230
231%install
232rm -rf $RPM_BUILD_ROOT
233
234make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
235
236# perlmagick: fix perl path of demo files
237%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
238
239find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
240find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
241find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
242
243echo "%defattr(-,root,root)" > perl-pkg-files
244find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
245sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
246
247# remove duplicated doc files
248rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
249rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
250
251# remove files conflict with libtools
252rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
253rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
254
255# remove *.la files
256# remove only %{_libdir}/*.la
257# If you have removed module-*/*/*.la, it will fail to execute the command.
258find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
259
260rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
261
262%clean
263rm -rf $RPM_BUILD_ROOT
264
265%post -p /sbin/ldconfig
266
267%post c++ -p /sbin/ldconfig
268
269%postun -p /sbin/ldconfig
270
271%postun c++ -p /sbin/ldconfig
272
273
274%files
275%defattr(-,root,root)
276%doc www images
277%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt NEWS.txt index.html
278%dir %{_libdir}/%{name}-%{VER}
279%dir %{_libdir}/%{name}-%{VER}/config-Q16
280%dir %{_libdir}/%{name}-%{VER}/modules-Q16
281%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
282%{_sysconfdir}/%{name}-6/*.xml
283%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
284%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
285%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
286%{_libdir}/libMagickCore-6.Q16.so.*
287%{_libdir}/libMagickWand-6.Q16.so.*
288%{_bindir}/[a-z]*
289%{_datadir}/%{name}-6/*.xml
290%{_mandir}/man1/ImageMagick.*
291%{_mandir}/man1/[a-z]*
292
293%files devel
294%defattr(-,root,root)
295%{_bindir}/Magick-config
296%{_bindir}/Wand-config
297%{_bindir}/MagickCore-config
298%{_bindir}/MagickWand-config
299%{_libdir}/libMagickCore-6.Q16.so
300%{_libdir}/libMagickWand-6.Q16.so
301%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
302%{_libdir}/pkgconfig/ImageMagick.pc
303%{_libdir}/pkgconfig/Wand-6.Q16.pc
304%{_libdir}/pkgconfig/Wand.pc
305%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
306%{_libdir}/pkgconfig/MagickCore.pc
307%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
308%{_libdir}/pkgconfig/MagickWand.pc
309%{_includedir}/ImageMagick-6/magick
310%{_includedir}/ImageMagick-6/wand
311%{_mandir}/man1/Magick-config*
312%{_mandir}/man1/Wand-config*
313%{_mandir}/man1/MagickCore-config*
314%{_mandir}/man1/MagickWand-config*
315
316%files c++
317%defattr(-,root,root)
318%{_libdir}/libMagick++-6.Q16.so.*
319
320%files c++-devel
321%defattr(-,root,root)
322%{_bindir}/Magick++-config
323%{_includedir}/ImageMagick-6/Magick++
324%{_includedir}/ImageMagick-6/Magick++.h
325%{_libdir}/libMagick++-6.Q16.so
326%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
327%{_libdir}/pkgconfig/ImageMagick++.pc
328%{_libdir}/pkgconfig/Magick++-6.Q16.pc
329%{_libdir}/pkgconfig/Magick++.pc
330%{_mandir}/man1/Magick++-config*
331
332%files -n perl-Image-Magick -f perl-pkg-files
333%defattr(-,root,root)
334%{_mandir}/man3/*
335
336%changelog
337* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.2-1
338- new upstream release
339
340* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.1-1
341- new upstream release
342
343* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.9.0.0-1
344- new upstream release
345- built with OpenEXR 2.2.0
346
347* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
348- new upstream release
349
350* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
351- new upstream release
352
353* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
354- new upstream release
355
356* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
357- new upstream release
358
359* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
360- new upstream release
361
362* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
363- new upstream release
364
365* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
366- new upstream release
367
368* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
369- new upstream release
370
371* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
372- new upstream release
373
374* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
375- new upstream release
376
377* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
378- new upstream release
379- add BuildRequires: pango-devel
380- change BuildRequires: lcms2-devel instead of lcms-devel
381
382* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
383- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
384
385* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
386- built with perl-5.12.3
387- changed perl subpackage name
388
389* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
390- new upstream release
391
392* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
393- rebuilt with graphviz-2.26.3 again
394
395* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
396- new upstream release
397- rebuilt with graphviz-2.26.3
398
399* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
400- new upstream release
401
402* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
403- rebuild with rpm-4.8.1 for pkg-config file
404- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
405- change Requires: libjpeg-turbo instead of libjpeg
406
407* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
408- new upstream release
409- built with new toolchain
410- added --disable-static to %%configure, removed static libraries
411
412* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
413- added --without-djvu --without-fftw
414
415* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
416- new upstream release
417
418* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
419- new upstream release
420
421* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
422- new upstream release
423- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
424- add R: graphviz, OpenEXR-libs, ilmbase
425
426* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
427- new upstream release
428- added Packager tag
429
430* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
431- new upstream release
432
433* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
434- new upstream release
435- updated BuildRequires
436
437* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
438- enabled lcms as default.
439
440* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
441- new upstream release
442
443* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
444- new upstream release
445
446* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
447- new upstream release
448
449* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
450- new upstream release
451
452* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
453- new upstream release
454- spec in UTF-8
455
456* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
457- enabled to build with lcms (use '--with lcms' to enable).
458
459* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
460- new upstream release
461- rebuilt with perl-5.10.0
462
463* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
464- new upstream release
465- removed *.la files from devel packages
466
467* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
468- new upstream release
469- change files section to fit new release
470- build under new versioning policy
471
472* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
473- new upstream release
474
475* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
476- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
477- add BuildPrereq: librsvg2-devel
478- add %{?_smp_mflags} to make command arg
479
480* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
481- new upstream release
482- changed Group to Applications/Graphics
483
484* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
485- rebuilt for VineSeed
486
487* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
488- update patch1 for fix CVE-2007-0770
489
490* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
491- upstream release
492- add patch1 for fix CVE-2006-5456
493
494* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
495- rebuilt (for ppc) to resolve reference to invalid *la files
496
497* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
498- new upstream release
499
500* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
501- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
502
503* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
504- new upstream release
505- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
506- add --with-perl-options to configure option
507
508* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
509- new upstream release
510- build with XOrg-6.9.0
511
512* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
513- new upstream release
514- add %%{_mandir}/man1/ImageMagick.* to main package
515
516* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
517- source upgrade
518- remove patch1
519- update %%files
520
521* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
522- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
523  (CAN-2004-0981)
524
525* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
526- move $(pkglibdir)/modules-Q16/*/*.la to main package.
527
528* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
529- source upgrade
530- Patch: change default menu font so display can work without XOrg-75dpi-fonts
531- add missing docs
532- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
533- *.pc should be in -devel package
534- add missing pkg{lib,data}dirs to %%files
535
536* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
537- source upgrade
538- add --without-dot to %%configure option
539- update %%files section
540
541* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
542- source upgrade
543
544* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
545- source upgrade
546
547* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
548- add --without-jbig to %%configure option
549
550* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
551- add --without-lcms to %%configure option
552
553* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
554- source upgrade
555- remove commented lines
556
557* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
558- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
559
560* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
561- source upgrade
562- remove patch for freetype2, no need
563- remove commented lines
564- add --with-quantum-depth=16 --with-modules --enable-lzw
565  --without-frozenpaths to %%configure option
566- remove --with-threads --without-xml from %%configure option
567- update %%files
568
569* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
570- patch update
571- add --without-jp2 to configure option
572- change PerlMagick build method
573
574* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
575- rebuild without jasper-devel
576
577* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
578- source upgrade to 5.5.7-15
579
580* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
581- source upgrade to 5.5.7-13
582- add patch0 to build against freetype2-2.1.7
583
584* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
585- source upgrade to 5.5.7-11
586- clean up spec
587- build without previous package (do not require libMagick.so.0)
588
589* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
590- source upgrade to 5.5.7-9
591- revised name of pkgconfig files
592- remove BuildPrereq: freetype-devel
593
594* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
595- source upgrade to 5.5.7-6
596- disable all patches
597- revised %%files section
598- disable libtoolize and autotools
599- change PerlMagick build method
600- build without previous package (do not require libMagick.so.5)
601
602* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
603- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
604  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
605
606* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
607- rebuild
608
609* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
610- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
611- FIXME: rpm's macro problem?
612
613- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
614  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
615
616  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
617  - remove unnecessary duplicated %%doc files
618  - --without-xml instead of --without-ttf
619  - eliminate libungif(-devel) from BuildReq/Requires
620  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
621
622  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
623  - add delegetes.mgk (and %%{_libdir}/%%{name})
624
625  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
626  - 5.2.9-0vl4
627  - Sorry, the spec was in Shift_JIS. Fixed.
628
629  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
630  - 5.2.9-0vl3
631  - rebuilt with perl-5.6.1
632  - added Japanese summary and description :-P
633  - added --without-ttf in order to disable freetype2 (SeedPlus) support
634  - added --without-wmf in order to disable libwmf (SeedPlus) support
635
636  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
637  - 5.2.9-0vl2
638  - rebuild on Perl-5.6
639  - use %%{perl_sitearch}
640  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
641
642  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
643  - 5.2.9-0vl1
644  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
645
646* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
647- fix perl paths in file list
648
649* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
650- lib64'ize
651- don't throw stuff in /usr/X11R6, that's for X only
652- remove files we aren't shipping
653
654* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
655- rebuilt with gcc-3.2 (we hope)
656
657* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
658- build using gcc-3.2-0.1
659
660* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
661- fix non-cpp headers in -devel package
662- fix #62157 (wrong path for include files in ImageMagick-devel)
663- fix #63897 (use _target instead of _arch) in libtool workaround
664- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
665
666* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
667- update
668- fix localdoc patch
669- fix %%files section
670- disable nonroot patch
671- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
672- fix libtool workaround
673- moved Magick*-config into -devel package (#64249)
674
675* Sun May 26 2002 Tim Powers <timp@redhat.com>
676- automated rebuild
677
678* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
679- 5.4.6
680
681* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
682- Update to pl 11
683
684* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
685- Update to 5.4.3 pl5; this fixes #58080
686
687* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
688- Patchlevel 3
689
690* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
691- automated rebuild
692
693* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
694- Update to 5.4.2-2
695- Fix #57923, also don't hardcode netscape as html viewer
696
697* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
698- 5.4.1
699- Link against new libstdc++
700
701* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
702- 5.4.0.5
703- Make the error message when trying to display an hpgl file more
704  explicit (#55875)
705
706* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
707- 5.4.0.3
708- Fix names of man pages
709
710* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
711- 5.4.0
712- work around build system breakage causing applications to be named
713  %{_arch}-redhat-linux-foo rather than foo
714
715* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
716- 5.3.9
717
718* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
719- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
720  (#52611)
721
722* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
723- Remove Magick++ includes from -devel, they're already in -c++-devel
724  (#51590)
725
726* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
727- 5.3.8 (bugfix release)
728
729* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
730- fix to build Perlmagic on s390 s390x
731
732* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
733- Add delegates.mgk to the package (#50725)
734
735* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
736- 5.3.7
737- Fix build without previously installed ImageMagick-devel (#49816)
738- Move perl bindings to a separate package.
739
740* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
741- Fix build as non-root again
742- Shut up rpmlint
743
744* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
745- 5.3.6
746- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
747
748* Sat Jun 16 2001 Than Ngo <than@redhat.com>
749- update to 5.3.5
750- cleanup specfile
751
752* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
753- 5.3.3-respin, fixes #41196
754
755* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
756- 5.3.3
757- Add a desktop file for "display" (RFE#17417)
758
759* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
760- 5.3.2
761- work around bugs in ia64 glibc headers
762
763* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
764- remove patch for s390, it is not necessary
765
766* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
767- 5.2.7
768
769* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
770- 5.2.6
771
772* Mon Dec 18 2000 Than Ngo <than@redhat.com>
773- ported to s390
774
775* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
776- 5.2.4
777- Fix up and package the C++ bindings in the new c++/c++-devel packages.
778
779* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
780- rebuild against new libpng
781
782* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
783- include images with docs (#10312)
784
785* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
786- don't build with -ggdb, use -g instead.
787
788* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
789- automatic rebuild
790
791* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
792- update to 5.2.2 beta
793
794* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
795- update to 5.2.1, redone patches as they failed
796
797* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
798- remove hacks to move perl man pages
799- don't include the perl*/man stuff, these files go in /usr/share/man now.
800
801* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
802- disable optimization on Alpha and Sparc
803
804* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
805- update to 5.2.0
806- update URL
807- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
808
809* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
810- bootstrap rebuilt to nuke broken libbz2 deps
811- add Prefix: tag such that the FHS macros work properly
812
813* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
814- now compiles with bzip2 1.0
815- changed buildroot to include version
816
817* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
818- fix compilation with new perl
819
820* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
821- 5.1.1
822
823* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
824- Rebuild to get compressed man pages
825
826* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
827- ugly hack to print with lpr instead of lp
828
829* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
830- update to 4.2.9
831
832* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
833- update to 4.2.8
834
835* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
836- include the perl man pages as well
837
838* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
839- remove --enable-16bit because it damages interoperability
840
841* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
842- update to 4.2.2
843- change ChangeLog to refer to actual dates.
844- strip binaries
845
846* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
847- add more files. Oops.
848
849* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
850- auto rebuild in the new build environment (release 2)
851
852* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
853- version 4.2.1
854
855* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
856- changed group
857
858* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
859- hacks to make it work with the new perl
860- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
861- make sure the libraries have the x bit on
862
863* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
864- translations modified for de, fr
865
866* Thu May 07 1998 Prospector System <bugs@redhat.com>
867- translations modified for de, fr, tr
868
869* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
870- updated to 4.0.5
871
872* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
873- updated to 4.0.4
874- added BuildRoot
875
876* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
877- updated from 3.8.3 to 3.9.1
878- removed PNG patch (appears to be fixed)
879
880* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
881- build against new libpng
882
883* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
884- built against glibc
885
886* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
887- updated to version 3.8.3.
888- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.