source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 12555

Revision 12555, 30.3 KB checked in by tomop, 3 years ago (diff)

updated 7 packages

ImageMagick?-6.9.12.1-1

cmake-3.19.6-1

double-conversion-3.1.5-5

emacs-27.1-1

inkscape-1.0.2-1

potrace-1.16-1

pstoedit-3.75-2

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.9.12
5%define Patchlevel 1
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17Group: graphics
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: inagaki, iwamoto
21
22License: freeware
23URL: https://legacy.imagemagick.org/
24
25%if "%{Patchlevel}" != ""
26Source: https://imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
27%else
28Source: https://imagemagick.org/download/ImageMagick-%{version}.tar.xz
29%endif
30#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
31
32Buildroot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: bzip2-devel
34BuildRequires: cairo-devel
35BuildRequires: pango-devel
36BuildRequires: freetype2-devel >= 2.1.7
37BuildRequires: fontconfig-devel
38BuildRequires: giflib-devel
39BuildRequires: graphviz-devel
40BuildRequires: lcms2-devel
41BuildRequires: libjpeg-turbo-devel
42BuildRequires: libpng-devel >= 1.2.5
43BuildRequires: librsvg2-devel
44BuildRequires: libtiff-devel
45BuildRequires: libwebp-devel
46BuildRequires: libxml2-devel
47BuildRequires: libSM-devel
48BuildRequires: libX11-devel
49BuildRequires: libXext-devel
50BuildRequires: OpenEXR-devel
51BuildRequires: perl
52BuildRequires: xorg-x11-server-utils
53BuildRequires: zlib-devel
54BuildRequires: libXt-devel
55BuildRequires: xz-devel
56BuildRequires: xz-lzma-compat
57BuildRequires: libtool-ltdl-devel
58
59Requires: bzip2
60Requires: freetype2
61Requires: giflib
62Requires: graphviz
63Requires: lcms2
64Requires: libjpeg-turbo
65Requires: libpng
66Requires: libtiff
67Requires: libxml2
68Requires: OpenEXR-libs
69Requires: xorg-x11-server-utils
70Requires: zlib
71
72%description
73ImageMagick(TM) is an image display and manipulation tool for the X
74Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
75and Photo CD image formats. It can resize, rotate, sharpen, color
76reduce, or add special effects to an image, and when finished you can
77either save the completed work in the original format or a different
78one. ImageMagick also includes command line programs for creating
79animated or transparent .gifs, creating composite images, creating
80thumbnail images, and more.
81
82ImageMagick is one of your choices if you need a program to manipulate
83and dis play images. If you want to develop your own applications
84which use ImageMagick code or APIs, you need to install
85ImageMagick-devel as well.
86
87%description -l ja
88ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
89ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
90イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
91出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
92オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
93また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
94サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
95
96画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
97も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
98アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
99インストールして下さい.
100
101
102%package devel
103Summary: Static libraries and header files for ImageMagick app development.
104Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
105Group: programming
106Requires: ImageMagick = %{version}-%{release}
107
108%description devel
109Image-Magick-devel contains the static libraries and header files you'll
110need to develop ImageMagick applications. ImageMagick is an image
111manipulation program.
112
113If you want to create applications that will use ImageMagick code or
114APIs, you need to install ImageMagick-devel as well as ImageMagick.
115You do noy need to install it if you just want to use ImageMagick,
116however.
117
118%description devel -l ja
119ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
120これらは ImageMagick アプリケーションの開発の際に必要となります.
121ImageMagick は画像処理プログラムです.
122
123ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
124この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
125する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
126インストールする必要はありません.
127
128
129%package c++
130Summary: ImageMagick Magick++ library (C++ bindings)
131Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
132Group: system
133Requires: ImageMagick = %{version}-%{release}
134
135%description c++
136This package contains the Magick++ library, a C++ binding to the ImageMagick
137graphics manipulation library.
138
139Install ImageMagick-c++ if you want to use any applications that use Magick++.
140
141%description c++ -l ja
142このパッケージには Magick++ ライブラリが収められています.
143Magick++ とは ImageMagick ライブラリの C++ バインディングです.
144
145Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
146パッケージをインストールして下さい.
147
148
149%package c++-devel
150Summary: C++ bindings for the ImageMagick library
151Summary(ja): ImageMagick ライブラリの C++ バインディング
152Group: programming
153Requires: ImageMagick = %{version}-%{release}
154Requires: ImageMagick-c++ = %{version}-%{release}
155Requires: ImageMagick-devel = %{version}-%{release}
156
157%description c++-devel
158ImageMagick-devel contains the static libraries and header files you'll
159need to develop ImageMagick applications using the Magick++ C++ bindings.
160ImageMagick is an image manipulation program.
161
162If you want to create applications that will use Magick++ code
163or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
164ImageMagick.
165You don't need to install it if you just want to use ImageMagick, or if you
166want to develop/compile applications using the ImageMagick C interface,
167however.
168
169%description c++-devel -l ja
170ImageMagick-c++-devel には Magick++ C++ バインディングを使った
171ImageMagick アプリケーション開発に必要なスタティックライブラリと
172ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
173
174Magick++ コードや API を使ったアプリケーションを開発する場合は,
175ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
176インストールする必要があります.
177ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
178を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
179インストールする必要はありません.
180
181
182%package -n perl-Image-Magick
183Summary: ImageMagick perl bindings
184Summary(ja): ImageMagick の Perl バインディング
185Group: programming
186Requires: ImageMagick = %{version}-%{release}
187Requires: perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
188Obsoletes: ImageMagick-perl < %{version}-%{release}
189Provides: ImageMagick-perl = %{version}-%{release}
190
191%description -n perl-Image-Magick
192Perl bindings to ImageMagick.
193
194Install ImageMagick-perl if you want to use any perl scripts that use
195ImageMagick.
196
197%description -n perl-Image-Magick -l ja
198このパッケージは ImageMagick の Perl バインディングです.
199
200ImageMagick を利用する perl スクリプトを使いたい場合は
201ImageMagick-perl パッケージをインストールして下さい.
202
203
204%debug_package
205
206
207%prep
208%setup -q -n %{name}-%{VER}-%{Patchlevel}
209
210#patch1 -p1 -b .CVE-2006-5456
211
212
213%build
214%configure \
215    --enable-silent-rules \
216    --enable-shared \
217    --disable-static \
218    --with-modules \
219    --with-quantum-depth=16 \
220    --without-frozenpaths \
221    --with-x \
222    --without-dps \
223    --without-djvu \
224    --without-fftw \
225    --without-jbig \
226    --without-jp2 \
227    --with-lcms2 \
228    --without-wmf \
229    --with-perl \
230    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
231
232# Disable rpath
233sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
234sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
235
236make %{?_smp_mflags}
237
238
239%install
240rm -rf $RPM_BUILD_ROOT
241
242make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
243
244# perlmagick: fix perl path of demo files
245%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
246
247find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
248find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
249find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
250
251echo "%defattr(-,root,root)" > perl-pkg-files
252find $RPM_BUILD_ROOT%{_libdir}/perl?/vendor_perl/* -type d -name Image >> perl-pkg-files.orig
253sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
254
255# remove duplicated doc files
256rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
257rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
258
259# remove files conflict with libtools
260rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
261rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
262
263# remove *.la files
264# remove only %{_libdir}/*.la
265# If you have removed module-*/*/*.la, it will fail to execute the command.
266find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
267
268rm -rf $RPM_BUILD_ROOT%{_docdir}/ImageMagick-6
269
270
271%clean
272rm -rf $RPM_BUILD_ROOT
273
274
275%ldconfig_scriptlets
276%ldconfig_scriptlets c++
277
278
279%files
280%defattr(-,root,root)
281%license LICENSE
282%doc www images
283%doc ChangeLog NOTICE QuickStart.txt README* NEWS.txt index.html
284%dir %{_libdir}/%{name}-%{VER}
285%dir %{_libdir}/%{name}-%{VER}/config-Q16
286%dir %{_libdir}/%{name}-%{VER}/modules-Q16
287%dir %{_libdir}/%{name}-%{VER}/modules-Q16/*
288%{_sysconfdir}/%{name}-6/*.xml
289%{_libdir}/%{name}-%{VER}/config-Q16/configure.xml
290%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.so
291%{_libdir}/%{name}-%{VER}/modules-Q16/*/*.la
292%{_libdir}/libMagickCore-6.Q16.so.*
293%{_libdir}/libMagickWand-6.Q16.so.*
294%{_bindir}/[a-z]*
295%{_datadir}/%{name}-6/*.xml
296%{_mandir}/man1/ImageMagick.*
297%{_mandir}/man1/[a-z]*
298
299%files devel
300%defattr(-,root,root)
301%{_bindir}/Magick-config
302%{_bindir}/Wand-config
303%{_bindir}/MagickCore-config
304%{_bindir}/MagickWand-config
305%{_libdir}/libMagickCore-6.Q16.so
306%{_libdir}/libMagickWand-6.Q16.so
307%{_libdir}/pkgconfig/ImageMagick-6.Q16.pc
308%{_libdir}/pkgconfig/ImageMagick.pc
309%{_libdir}/pkgconfig/Wand-6.Q16.pc
310%{_libdir}/pkgconfig/Wand.pc
311%{_libdir}/pkgconfig/MagickCore-6.Q16.pc
312%{_libdir}/pkgconfig/MagickCore.pc
313%{_libdir}/pkgconfig/MagickWand-6.Q16.pc
314%{_libdir}/pkgconfig/MagickWand.pc
315%{_includedir}/ImageMagick-6/magick
316%{_includedir}/ImageMagick-6/wand
317%{_mandir}/man1/Magick-config*
318%{_mandir}/man1/Wand-config*
319%{_mandir}/man1/MagickCore-config*
320%{_mandir}/man1/MagickWand-config*
321
322%files c++
323%defattr(-,root,root)
324%{_libdir}/libMagick++-6.Q16.so.*
325
326%files c++-devel
327%defattr(-,root,root)
328%{_bindir}/Magick++-config
329%{_includedir}/ImageMagick-6/Magick++
330%{_includedir}/ImageMagick-6/Magick++.h
331%{_libdir}/libMagick++-6.Q16.so
332%{_libdir}/pkgconfig/ImageMagick++-6.Q16.pc
333%{_libdir}/pkgconfig/ImageMagick++.pc
334%{_libdir}/pkgconfig/Magick++-6.Q16.pc
335%{_libdir}/pkgconfig/Magick++.pc
336%{_mandir}/man1/Magick++-config*
337
338%files -n perl-Image-Magick -f perl-pkg-files
339%defattr(-,root,root)
340%{_mandir}/man3/*
341
342
343%changelog
344* Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.12.1-1
345- new upstream release.
346
347* Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.11.48-1
348- new upstream release.
349
350* Sat Oct 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.10.69-1
351- new upstream release.
352
353* Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.8-2
354- rebuild with gcc-5.4.0
355
356* Thu Jun  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.9.4.8-1
357- new upstream release.
358
359* Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.4.0-1
360- new upstream release
361  (including security fix for CVE-2016-3714,3715,3716,3717,3718,4562,4563,4564)
362
363* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.4-1
364- new upstream release
365
366* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.2-1
367- new upstream release
368
369* Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.9.1.1-1
370- new upstream release
371
372* Thu Dec 18 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.9.0.0-1
373- new upstream release
374- built with OpenEXR 2.2.0
375
376* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.7-1
377- new upstream release
378
379* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.9.5-1
380- new upstream release
381
382* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.8.0-1
383- new upstream release
384
385* Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.8-1
386- new upstream release
387
388* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.7.5-1
389- new upstream release
390
391* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.8.6.8-1
392- new upstream release
393
394* Sat Sep 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.9.3-1
395- new upstream release
396
397* Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.8.3-1
398- new upstream release
399
400* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.7.6-1
401- new upstream release
402
403* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.6.8-1
404- new upstream release
405
406* Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.7.5.10-1
407- new upstream release
408- add BuildRequires: pango-devel
409- change BuildRequires: lcms2-devel instead of lcms-devel
410
411* Sun Mar 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.8.5-3
412- add BuildRequires: libXt-devel, xz-devel, xz-lzma-compat, libtool-ltdl-devel
413
414* Sat Mar 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-2
415- built with perl-5.12.3
416- changed perl subpackage name
417
418* Sat Mar 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.8.5-1
419- new upstream release
420
421* Sun Oct 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.4.9-2
422- rebuilt with graphviz-2.26.3 again
423
424* Sat Oct  9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.9-1
425- new upstream release
426- rebuilt with graphviz-2.26.3
427
428* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
429- new upstream release
430
431* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
432- rebuild with rpm-4.8.1 for pkg-config file
433- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
434- change Requires: libjpeg-turbo instead of libjpeg
435
436* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
437- new upstream release
438- built with new toolchain
439- added --disable-static to %%configure, removed static libraries
440
441* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
442- added --without-djvu --without-fftw
443
444* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
445- new upstream release
446
447* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
448- new upstream release
449
450* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
451- new upstream release
452- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
453- add R: graphviz, OpenEXR-libs, ilmbase
454
455* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
456- new upstream release
457- added Packager tag
458
459* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
460- new upstream release
461
462* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
463- new upstream release
464- updated BuildRequires
465
466* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
467- enabled lcms as default.
468
469* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
470- new upstream release
471
472* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
473- new upstream release
474
475* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
476- new upstream release
477
478* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
479- new upstream release
480
481* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
482- new upstream release
483- spec in UTF-8
484
485* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
486- enabled to build with lcms (use '--with lcms' to enable).
487
488* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
489- new upstream release
490- rebuilt with perl-5.10.0
491
492* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
493- new upstream release
494- removed *.la files from devel packages
495
496* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
497- new upstream release
498- change files section to fit new release
499- build under new versioning policy
500
501* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
502- new upstream release
503
504* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
505- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
506- add BuildPrereq: librsvg2-devel
507- add %{?_smp_mflags} to make command arg
508
509* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
510- new upstream release
511- changed Group to Applications/Graphics
512
513* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
514- rebuilt for VineSeed
515
516* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
517- update patch1 for fix CVE-2007-0770
518
519* Thu Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
520- upstream release
521- add patch1 for fix CVE-2006-5456
522
523* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
524- rebuilt (for ppc) to resolve reference to invalid *la files
525
526* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
527- new upstream release
528
529* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
530- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
531
532* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
533- new upstream release
534- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
535- add --with-perl-options to configure option
536
537* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
538- new upstream release
539- build with XOrg-6.9.0
540
541* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
542- new upstream release
543- add %%{_mandir}/man1/ImageMagick.* to main package
544
545* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
546- source upgrade
547- remove patch1
548- update %%files
549
550* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
551- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
552  (CAN-2004-0981)
553
554* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
555- move $(pkglibdir)/modules-Q16/*/*.la to main package.
556
557* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
558- source upgrade
559- Patch: change default menu font so display can work without XOrg-75dpi-fonts
560- add missing docs
561- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
562- *.pc should be in -devel package
563- add missing pkg{lib,data}dirs to %%files
564
565* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
566- source upgrade
567- add --without-dot to %%configure option
568- update %%files section
569
570* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
571- source upgrade
572
573* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
574- source upgrade
575
576* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
577- add --without-jbig to %%configure option
578
579* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
580- add --without-lcms to %%configure option
581
582* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
583- source upgrade
584- remove commented lines
585
586* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
587- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
588
589* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
590- source upgrade
591- remove patch for freetype2, no need
592- remove commented lines
593- add --with-quantum-depth=16 --with-modules --enable-lzw
594  --without-frozenpaths to %%configure option
595- remove --with-threads --without-xml from %%configure option
596- update %%files
597
598* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
599- patch update
600- add --without-jp2 to configure option
601- change PerlMagick build method
602
603* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
604- rebuild without jasper-devel
605
606* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
607- source upgrade to 5.5.7-15
608
609* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
610- source upgrade to 5.5.7-13
611- add patch0 to build against freetype2-2.1.7
612
613* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
614- source upgrade to 5.5.7-11
615- clean up spec
616- build without previous package (do not require libMagick.so.0)
617
618* Mon Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
619- source upgrade to 5.5.7-9
620- revised name of pkgconfig files
621- remove BuildPrereq: freetype-devel
622
623* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
624- source upgrade to 5.5.7-6
625- disable all patches
626- revised %%files section
627- disable libtoolize and autotools
628- change PerlMagick build method
629- build without previous package (do not require libMagick.so.5)
630
631* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
632- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
633  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
634
635* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
636- rebuild
637
638* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
639- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
640- FIXME: rpm's macro problem?
641
642- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
643  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
644
645  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
646  - remove unnecessary duplicated %%doc files
647  - --without-xml instead of --without-ttf
648  - eliminate libungif(-devel) from BuildReq/Requires
649  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
650
651  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
652  - add delegetes.mgk (and %%{_libdir}/%%{name})
653
654  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
655  - 5.2.9-0vl4
656  - Sorry, the spec was in Shift_JIS. Fixed.
657
658  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
659  - 5.2.9-0vl3
660  - rebuilt with perl-5.6.1
661  - added Japanese summary and description :-P
662  - added --without-ttf in order to disable freetype2 (SeedPlus) support
663  - added --without-wmf in order to disable libwmf (SeedPlus) support
664
665  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
666  - 5.2.9-0vl2
667  - rebuild on Perl-5.6
668  - use %%{perl_sitearch}
669  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
670
671  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
672  - 5.2.9-0vl1
673  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
674
675* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
676- fix perl paths in file list
677
678* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
679- lib64'ize
680- don't throw stuff in /usr/X11R6, that's for X only
681- remove files we aren't shipping
682
683* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
684- rebuilt with gcc-3.2 (we hope)
685
686* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
687- build using gcc-3.2-0.1
688
689* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
690- fix non-cpp headers in -devel package
691- fix #62157 (wrong path for include files in ImageMagick-devel)
692- fix #63897 (use _target instead of _arch) in libtool workaround
693- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
694
695* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
696- update
697- fix localdoc patch
698- fix %%files section
699- disable nonroot patch
700- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
701- fix libtool workaround
702- moved Magick*-config into -devel package (#64249)
703
704* Sun May 26 2002 Tim Powers <timp@redhat.com>
705- automated rebuild
706
707* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
708- 5.4.6
709
710* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
711- Update to pl 11
712
713* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
714- Update to 5.4.3 pl5; this fixes #58080
715
716* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
717- Patchlevel 3
718
719* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
720- automated rebuild
721
722* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
723- Update to 5.4.2-2
724- Fix #57923, also don't hardcode netscape as html viewer
725
726* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
727- 5.4.1
728- Link against new libstdc++
729
730* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
731- 5.4.0.5
732- Make the error message when trying to display an hpgl file more
733  explicit (#55875)
734
735* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
736- 5.4.0.3
737- Fix names of man pages
738
739* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
740- 5.4.0
741- work around build system breakage causing applications to be named
742  %{_arch}-redhat-linux-foo rather than foo
743
744* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
745- 5.3.9
746
747* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
748- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
749  (#52611)
750
751* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
752- Remove Magick++ includes from -devel, they're already in -c++-devel
753  (#51590)
754
755* Sat Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
756- 5.3.8 (bugfix release)
757
758* Fri Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
759- fix to build Perlmagic on s390 s390x
760
761* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
762- Add delegates.mgk to the package (#50725)
763
764* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
765- 5.3.7
766- Fix build without previously installed ImageMagick-devel (#49816)
767- Move perl bindings to a separate package.
768
769* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
770- Fix build as non-root again
771- Shut up rpmlint
772
773* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
774- 5.3.6
775- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
776
777* Sat Jun 16 2001 Than Ngo <than@redhat.com>
778- update to 5.3.5
779- cleanup specfile
780
781* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
782- 5.3.3-respin, fixes #41196
783
784* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
785- 5.3.3
786- Add a desktop file for "display" (RFE#17417)
787
788* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
789- 5.3.2
790- work around bugs in ia64 glibc headers
791
792* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
793- remove patch for s390, it is not necessary
794
795* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
796- 5.2.7
797
798* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
799- 5.2.6
800
801* Mon Dec 18 2000 Than Ngo <than@redhat.com>
802- ported to s390
803
804* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
805- 5.2.4
806- Fix up and package the C++ bindings in the new c++/c++-devel packages.
807
808* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
809- rebuild against new libpng
810
811* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
812- include images with docs (#10312)
813
814* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
815- don't build with -ggdb, use -g instead.
816
817* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
818- automatic rebuild
819
820* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
821- update to 5.2.2 beta
822
823* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
824- update to 5.2.1, redone patches as they failed
825
826* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
827- remove hacks to move perl man pages
828- don't include the perl*/man stuff, these files go in /usr/share/man now.
829
830* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
831- disable optimization on Alpha and Sparc
832
833* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
834- update to 5.2.0
835- update URL
836- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
837
838* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
839- bootstrap rebuilt to nuke broken libbz2 deps
840- add Prefix: tag such that the FHS macros work properly
841
842* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
843- now compiles with bzip2 1.0
844- changed buildroot to include version
845
846* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
847- fix compilation with new perl
848
849* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
850- 5.1.1
851
852* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
853- Rebuild to get compressed man pages
854
855* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
856- ugly hack to print with lpr instead of lp
857
858* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
859- update to 4.2.9
860
861* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
862- update to 4.2.8
863
864* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
865- include the perl man pages as well
866
867* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
868- remove --enable-16bit because it damages interoperability
869
870* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
871- update to 4.2.2
872- change ChangeLog to refer to actual dates.
873- strip binaries
874
875* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
876- add more files. Oops.
877
878* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
879- auto rebuild in the new build environment (release 2)
880
881* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
882- version 4.2.1
883
884* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
885- changed group
886
887* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
888- hacks to make it work with the new perl
889- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
890- make sure the libraries have the x bit on
891
892* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
893- translations modified for de, fr
894
895* Thu May 07 1998 Prospector System <bugs@redhat.com>
896- translations modified for de, fr, tr
897
898* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
899- updated to 4.0.5
900
901* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
902- updated to 4.0.4
903- added BuildRoot
904
905* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
906- updated from 3.8.3 to 3.9.1
907- removed PNG patch (appears to be fixed)
908
909* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
910- build against new libpng
911
912* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
913- built against glibc
914
915* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
916- updated to version 3.8.3.
917- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.