source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 1987

Revision 1987, 27.3 KB checked in by inagaki, 14 years ago (diff)

update: ImageMagick?, calibre, dvdauthor, inkscape, koffice, pstoedit, xine-lib, self-build-xine-lib-extras

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.4
5%define Patchlevel 8
6
7Name: ImageMagick
8Summary: X application for displaying and manipulating images.
9Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel
30BuildRequires: cairo-devel
31BuildRequires: freetype2-devel >= 2.1.7
32BuildRequires: fontconfig-devel
33BuildRequires: giflib-devel
34BuildRequires: graphviz-devel
35BuildRequires: lcms-devel
36BuildRequires: libjpeg-turbo-devel
37BuildRequires: libpng-devel >= 1.2.5
38BuildRequires: librsvg2-devel
39BuildRequires: libtiff-devel
40BuildRequires: libxml2-devel
41BuildRequires: libSM-devel
42BuildRequires: libX11-devel
43BuildRequires: libXext-devel
44BuildRequires: libXext-devel
45BuildRequires: OpenEXR-devel
46BuildRequires: perl
47BuildRequires: xorg-x11-server-utils
48BuildRequires: zlib-devel
49
50Requires: bzip2
51Requires: freetype2
52Requires: giflib
53Requires: graphviz
54Requires: lcms
55Requires: libjpeg-turbo
56Requires: libpng
57Requires: libtiff
58Requires: libxml2
59Requires: OpenEXR-libs
60Requires: xorg-x11-server-utils
61Requires: zlib
62
63Vendor: Project Vine
64Distribution: Vine Linux
65Packager: inagaki, iwamoto
66
67%description
68ImageMagick(TM) is an image display and manipulation tool for the X
69Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
70and Photo CD image formats. It can resize, rotate, sharpen, color
71reduce, or add special effects to an image, and when finished you can
72either save the completed work in the original format or a different
73one. ImageMagick also includes command line programs for creating
74animated or transparent .gifs, creating composite images, creating
75thumbnail images, and more.
76
77ImageMagick is one of your choices if you need a program to manipulate
78and dis play images. If you want to develop your own applications
79which use ImageMagick code or APIs, you need to install
80ImageMagick-devel as well.
81
82
83%description -l ja
84ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
85ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
86イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
87出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
88オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
89また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
90サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
91
92画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
93も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
94アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
95インストールして下さい.
96
97%package devel
98Summary: Static libraries and header files for ImageMagick app development.
99Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
100Group: Development/Libraries
101Requires: ImageMagick = %{version}-%{release}
102
103%description devel
104Image-Magick-devel contains the static libraries and header files you'll
105need to develop ImageMagick applications. ImageMagick is an image
106manipulation program.
107
108If you want to create applications that will use ImageMagick code or
109APIs, you need to install ImageMagick-devel as well as ImageMagick.
110You do noy need to install it if you just want to use ImageMagick,
111however.
112
113%description devel -l ja
114ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
115これらは ImageMagick アプリケーションの開発の際に必要となります.
116ImageMagick は画像処理プログラムです.
117
118ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
119この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
120する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
121インストールする必要はありません.
122
123%package perl
124Summary: ImageMagick perl bindings
125Summary(ja): ImageMagick の Perl バインディング
126Group: Development/Libraries
127Requires: ImageMagick = %{version}-%{release}
128Requires: perl >= 5.8.0
129
130%description perl
131Perl bindings to ImageMagick.
132
133Install ImageMagick-perl if you want to use any perl scripts that use
134ImageMagick.
135
136%description perl -l ja
137このパッケージは ImageMagick の Perl バインディングです.
138
139ImageMagick を利用する perl スクリプトを使いたい場合は
140ImageMagick-perl パッケージをインストールして下さい.
141
142
143%package c++
144Summary: ImageMagick Magick++ library (C++ bindings)
145Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
146Group: System Environment/Libraries
147Requires: ImageMagick = %{version}-%{release}
148
149%description c++
150This package contains the Magick++ library, a C++ binding to the ImageMagick
151graphics manipulation library.
152
153Install ImageMagick-c++ if you want to use any applications that use Magick++.
154
155%description c++
156このパッケージには Magick++ ライブラリが収められています.
157Magick++ とは ImageMagick ライブラリの C++ バインディングです.
158
159Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
160パッケージをインストールして下さい.
161
162%package c++-devel
163Summary: C++ bindings for the ImageMagick library
164Summary(ja): ImageMagick ライブラリの C++ バインディング
165Group: Development/Libraries
166Requires: ImageMagick = %{version}-%{release}
167Requires: ImageMagick-c++ = %{version}-%{release}
168Requires: ImageMagick-devel = %{version}-%{release}
169
170%description c++-devel
171ImageMagick-devel contains the static libraries and header files you'll
172need to develop ImageMagick applications using the Magick++ C++ bindings.
173ImageMagick is an image manipulation program.
174
175If you want to create applications that will use Magick++ code
176or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
177ImageMagick.
178You don't need to install it if you just want to use ImageMagick, or if you
179want to develop/compile applications using the ImageMagick C interface,
180however.
181
182%description c++-devel -l ja
183ImageMagick-c++-devel には Magick++ C++ バインディングを使った
184ImageMagick アプリケーション開発に必要なスタティックライブラリと
185ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
186
187Magick++ コードや API を使ったアプリケーションを開発する場合は,
188ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
189インストールする必要があります.
190ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
191を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
192インストールする必要はありません.
193
194
195%prep
196%setup -q -n %{name}-%{VER}-%{Patchlevel}
197
198#patch1 -p1 -b .CVE-2006-5456
199
200%build
201%configure \
202    --enable-silent-rules \
203    --enable-shared \
204    --disable-static \
205    --with-modules \
206    --with-quantum-depth=16 \
207    --without-frozenpaths \
208    --with-x \
209    --without-djvu \
210    --without-fftw \
211    --without-jbig \
212    --without-jp2 \
213    --without-lcms2 \
214    --without-wmf \
215    --with-perl \
216    --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
217
218# Disable rpath
219sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
220sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
221
222make %{?_smp_mflags}
223
224%install
225rm -rf $RPM_BUILD_ROOT
226
227make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
228
229# perlmagick: fix perl path of demo files
230%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
231
232# get the perl file list. We know what we need, so this is easy
233perlver=`perl -v |grep built |sed -e "s,.*v,,;s, .*,,"`
234perlmajor=`echo $perlver |sed -e "s,\..*,,"`
235
236find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
237find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
238find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
239
240echo "%defattr(-,root,root)" > perl-pkg-files
241find $RPM_BUILD_ROOT%{_libdir}/perl$perlmajor/vendor_perl/$perlver -type d -name Image >> perl-pkg-files.orig
242sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
243
244# remove duplicated doc files
245rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
246
247# remove files conflict with libtools
248rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
249rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
250
251# remove *.la files
252find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
253
254%clean
255rm -rf $RPM_BUILD_ROOT
256
257%post -p /sbin/ldconfig
258
259%post c++ -p /sbin/ldconfig
260
261%postun -p /sbin/ldconfig
262
263%postun c++ -p /sbin/ldconfig
264
265
266%files
267%defattr(-,root,root)
268%doc www images
269%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
270%dir %{_libdir}/ImageMagick-%{VER}
271%{_libdir}/ImageMagick-%{VER}/config
272%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
273%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
274%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
275%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
276%{_libdir}/libMagickCore.so.*
277%{_libdir}/libMagickWand.so.*
278%{_bindir}/[a-z]*
279%dir %{_datadir}/ImageMagick-%{VER}
280%dir %{_datadir}/ImageMagick-%{VER}/config
281%{_datadir}/ImageMagick-%{VER}/config/*.xml
282%{_datadir}/ImageMagick-%{VER}/config/*.icm
283%{_mandir}/man1/ImageMagick.*
284%{_mandir}/man1/[a-z]*
285
286%files devel
287%defattr(-,root,root)
288%{_bindir}/Magick-config
289%{_bindir}/Wand-config
290%{_bindir}/MagickCore-config
291%{_bindir}/MagickWand-config
292#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
293#{_libdir}/libMagickCore.a
294%{_libdir}/libMagickCore.so
295#{_libdir}/libMagickWand.a
296%{_libdir}/libMagickWand.so
297%{_libdir}/pkgconfig/ImageMagick.pc
298%{_libdir}/pkgconfig/Wand.pc
299%{_libdir}/pkgconfig/MagickCore.pc
300%{_libdir}/pkgconfig/MagickWand.pc
301%{_includedir}/ImageMagick/magick
302%{_includedir}/ImageMagick/wand
303%{_mandir}/man1/Magick-config*
304%{_mandir}/man1/Wand-config*
305%{_mandir}/man1/MagickCore-config*
306%{_mandir}/man1/MagickWand-config*
307
308%files c++
309%defattr(-,root,root)
310%{_libdir}/libMagick++.so.*
311
312%files c++-devel
313%defattr(-,root,root)
314%{_bindir}/Magick++-config
315%{_includedir}/ImageMagick/Magick++
316%{_includedir}/ImageMagick/Magick++.h
317#{_libdir}/libMagick++.a
318%{_libdir}/libMagick++.so
319%{_libdir}/pkgconfig/ImageMagick++.pc
320%{_libdir}/pkgconfig/Magick++.pc
321%{_mandir}/man1/Magick++-config*
322
323%files perl -f perl-pkg-files
324%defattr(-,root,root)
325%{_mandir}/man3/*
326
327%changelog
328* Sat Oct  2 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.4.8-1
329- new upstream release
330
331* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
332- rebuild with rpm-4.8.1 for pkg-config file
333- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
334- change Requires: libjpeg-turbo instead of libjpeg
335
336* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
337- new upstream release
338- built with new toolchain
339- added --disable-static to %%configure, removed static libraries
340
341* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
342- added --without-djvu --without-fftw
343
344* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
345- new upstream release
346
347* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
348- new upstream release
349
350* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
351- new upstream release
352- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
353- add R: graphviz, OpenEXR-libs, ilmbase
354
355* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
356- new upstream release
357- added Packager tag
358
359* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
360- new upstream release
361
362* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
363- new upstream release
364- updated BuildRequires
365
366* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
367- enabled lcms as default.
368
369* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
370- new upstream release
371
372* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
373- new upstream release
374
375* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
376- new upstream release
377
378* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
379- new upstream release
380
381* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
382- new upstream release
383- spec in UTF-8
384
385* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
386- enabled to build with lcms (use '--with lcms' to enable).
387
388* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
389- new upstream release
390- rebuilt with perl-5.10.0
391
392* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
393- new upstream release
394- removed *.la files from devel packages
395
396* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
397- new upstream release
398- change files section to fit new release
399- build under new versioning policy
400
401* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
402- new upstream release
403
404* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
405- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
406- add BuildPrereq: librsvg2-devel
407- add %{?_smp_mflags} to make command arg
408
409* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
410- new upstream release
411- changed Group to Applications/Graphics
412
413* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
414- rebuilt for VineSeed
415
416* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
417- update patch1 for fix CVE-2007-0770
418
419* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
420- upstream release
421- add patch1 for fix CVE-2006-5456
422
423* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
424- rebuilt (for ppc) to resolve reference to invalid *la files
425
426* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
427- new upstream release
428
429* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
430- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
431
432* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
433- new upstream release
434- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
435- add --with-perl-options to configure option
436
437* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
438- new upstream release
439- build with XOrg-6.9.0
440
441* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
442- new upstream release
443- add %%{_mandir}/man1/ImageMagick.* to main package
444
445* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
446- source upgrade
447- remove patch1
448- update %%files
449
450* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
451- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
452  (CAN-2004-0981)
453
454* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
455- move $(pkglibdir)/modules-Q16/*/*.la to main package.
456
457* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
458- source upgrade
459- Patch: change default menu font so display can work without XOrg-75dpi-fonts
460- add missing docs
461- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
462- *.pc should be in -devel package
463- add missing pkg{lib,data}dirs to %%files
464
465* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
466- source upgrade
467- add --without-dot to %%configure option
468- update %%files section
469
470* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
471- source upgrade
472
473* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
474- source upgrade
475
476* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
477- add --without-jbig to %%configure option
478
479* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
480- add --without-lcms to %%configure option
481
482* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
483- source upgrade
484- remove commented lines
485
486* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
487- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
488
489* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
490- source upgrade
491- remove patch for freetype2, no need
492- remove commented lines
493- add --with-quantum-depth=16 --with-modules --enable-lzw
494  --without-frozenpaths to %%configure option
495- remove --with-threads --without-xml from %%configure option
496- update %%files
497
498* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
499- patch update
500- add --without-jp2 to configure option
501- change PerlMagick build method
502
503* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
504- rebuild without jasper-devel
505
506* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
507- source upgrade to 5.5.7-15
508
509* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
510- source upgrade to 5.5.7-13
511- add patch0 to build against freetype2-2.1.7
512
513* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
514- source upgrade to 5.5.7-11
515- clean up spec
516- build without previous package (do not require libMagick.so.0)
517
518* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
519- source upgrade to 5.5.7-9
520- revised name of pkgconfig files
521- remove BuildPrereq: freetype-devel
522
523* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
524- source upgrade to 5.5.7-6
525- disable all patches
526- revised %%files section
527- disable libtoolize and autotools
528- change PerlMagick build method
529- build without previous package (do not require libMagick.so.5)
530
531* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
532- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
533  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
534
535* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
536- rebuild
537
538* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
539- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
540- FIXME: rpm's macro problem?
541
542- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
543  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
544
545  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
546  - remove unnecessary duplicated %%doc files
547  - --without-xml instead of --without-ttf
548  - eliminate libungif(-devel) from BuildReq/Requires
549  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
550
551  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
552  - add delegetes.mgk (and %%{_libdir}/%%{name})
553
554  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
555  - 5.2.9-0vl4
556  - Sorry, the spec was in Shift_JIS. Fixed.
557
558  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
559  - 5.2.9-0vl3
560  - rebuilt with perl-5.6.1
561  - added Japanese summary and description :-P
562  - added --without-ttf in order to disable freetype2 (SeedPlus) support
563  - added --without-wmf in order to disable libwmf (SeedPlus) support
564
565  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
566  - 5.2.9-0vl2
567  - rebuild on Perl-5.6
568  - use %%{perl_sitearch}
569  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
570
571  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
572  - 5.2.9-0vl1
573  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
574
575* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
576- fix perl paths in file list
577
578* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
579- lib64'ize
580- don't throw stuff in /usr/X11R6, that's for X only
581- remove files we aren't shipping
582
583* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
584- rebuilt with gcc-3.2 (we hope)
585
586* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
587- build using gcc-3.2-0.1
588
589* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
590- fix non-cpp headers in -devel package
591- fix #62157 (wrong path for include files in ImageMagick-devel)
592- fix #63897 (use _target instead of _arch) in libtool workaround
593- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
594
595* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
596- update
597- fix localdoc patch
598- fix %%files section
599- disable nonroot patch
600- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
601- fix libtool workaround
602- moved Magick*-config into -devel package (#64249)
603
604* Sun May 26 2002 Tim Powers <timp@redhat.com>
605- automated rebuild
606
607* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
608- 5.4.6
609
610* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
611- Update to pl 11
612
613* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
614- Update to 5.4.3 pl5; this fixes #58080
615
616* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
617- Patchlevel 3
618
619* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
620- automated rebuild
621
622* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
623- Update to 5.4.2-2
624- Fix #57923, also don't hardcode netscape as html viewer
625
626* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
627- 5.4.1
628- Link against new libstdc++
629
630* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
631- 5.4.0.5
632- Make the error message when trying to display an hpgl file more
633  explicit (#55875)
634
635* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
636- 5.4.0.3
637- Fix names of man pages
638
639* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
640- 5.4.0
641- work around build system breakage causing applications to be named
642  %{_arch}-redhat-linux-foo rather than foo
643
644* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
645- 5.3.9
646
647* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
648- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
649  (#52611)
650
651* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
652- Remove Magick++ includes from -devel, they're already in -c++-devel
653  (#51590)
654
655* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
656- 5.3.8 (bugfix release)
657
658* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
659- fix to build Perlmagic on s390 s390x
660
661* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
662- Add delegates.mgk to the package (#50725)
663
664* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
665- 5.3.7
666- Fix build without previously installed ImageMagick-devel (#49816)
667- Move perl bindings to a separate package.
668
669* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
670- Fix build as non-root again
671- Shut up rpmlint
672
673* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
674- 5.3.6
675- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
676
677* Sat Jun 16 2001 Than Ngo <than@redhat.com>
678- update to 5.3.5
679- cleanup specfile
680
681* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
682- 5.3.3-respin, fixes #41196
683
684* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
685- 5.3.3
686- Add a desktop file for "display" (RFE#17417)
687
688* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
689- 5.3.2
690- work around bugs in ia64 glibc headers
691
692* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
693- remove patch for s390, it is not necessary
694
695* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
696- 5.2.7
697
698* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
699- 5.2.6
700
701* Mon Dec 18 2000 Than Ngo <than@redhat.com>
702- ported to s390
703
704* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
705- 5.2.4
706- Fix up and package the C++ bindings in the new c++/c++-devel packages.
707
708* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
709- rebuild against new libpng
710
711* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
712- include images with docs (#10312)
713
714* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
715- don't build with -ggdb, use -g instead.
716
717* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
718- automatic rebuild
719
720* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
721- update to 5.2.2 beta
722
723* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
724- update to 5.2.1, redone patches as they failed
725
726* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
727- remove hacks to move perl man pages
728- don't include the perl*/man stuff, these files go in /usr/share/man now.
729
730* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
731- disable optimization on Alpha and Sparc
732
733* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
734- update to 5.2.0
735- update URL
736- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
737
738* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
739- bootstrap rebuilt to nuke broken libbz2 deps
740- add Prefix: tag such that the FHS macros work properly
741
742* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
743- now compiles with bzip2 1.0
744- changed buildroot to include version
745
746* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
747- fix compilation with new perl
748
749* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
750- 5.1.1
751
752* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
753- Rebuild to get compressed man pages
754
755* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
756- ugly hack to print with lpr instead of lp
757
758* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
759- update to 4.2.9
760
761* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
762- update to 4.2.8
763
764* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
765- include the perl man pages as well
766
767* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
768- remove --enable-16bit because it damages interoperability
769
770* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
771- update to 4.2.2
772- change ChangeLog to refer to actual dates.
773- strip binaries
774
775* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
776- add more files. Oops.
777
778* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
779- auto rebuild in the new build environment (release 2)
780
781* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
782- version 4.2.1
783
784* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
785- changed group
786
787* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
788- hacks to make it work with the new perl
789- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
790- make sure the libraries have the x bit on
791
792* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
793- translations modified for de, fr
794
795* Thu May 07 1998 Prospector System <bugs@redhat.com>
796- translations modified for de, fr, tr
797
798* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
799- updated to 4.0.5
800
801* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
802- updated to 4.0.4
803- added BuildRoot
804
805* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
806- updated from 3.8.3 to 3.9.1
807- removed PNG patch (appears to be fixed)
808
809* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
810- build against new libpng
811
812* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
813- built against glibc
814
815* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
816- updated to version 3.8.3.
817- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.