source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 1901

Revision 1901, 27.0 KB checked in by Takemikaduchi, 14 years ago (diff)

rebuild with rpm-4.8.1

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.1
5%define Patchlevel 5
6
7Summary: X application for displaying and manipulating images.
8Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
9Name: ImageMagick
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 2%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel, libjpeg-turbo-devel
30BuildRequires: libtiff-devel, giflib-devel, zlib-devel, perl
31BuildRequires: freetype2-devel >= 2.1.7, libpng-devel >= 1.2.5
32BuildRequires: libX11-devel, libXext-devel
33BuildRequires: xorg-x11-server-utils
34BuildRequires: libxml2-devel, librsvg2-devel
35BuildRequires: lcms-devel
36BuildRequires: graphviz-devel, OpenEXR-devel, ilmbase-devel
37BuildRequires: fontconfig-devel
38
39Requires: bzip2, freetype2, libjpeg-turbo, libpng, libtiff, libungif, zlib
40Requires: xorg-x11-server-utils
41Requires: libxml2
42Requires: lcms
43Requires: graphviz, OpenEXR-libs, ilmbase
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: inagaki, iwamoto
48
49%description
50ImageMagick(TM) is an image display and manipulation tool for the X
51Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
52and Photo CD image formats. It can resize, rotate, sharpen, color
53reduce, or add special effects to an image, and when finished you can
54either save the completed work in the original format or a different
55one. ImageMagick also includes command line programs for creating
56animated or transparent .gifs, creating composite images, creating
57thumbnail images, and more.
58
59ImageMagick is one of your choices if you need a program to manipulate
60and dis play images. If you want to develop your own applications
61which use ImageMagick code or APIs, you need to install
62ImageMagick-devel as well.
63
64
65%description -l ja
66ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
67ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
68イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
69出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
70オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
71また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
72サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
73
74画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
75も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
76アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
77インストールして下さい.
78
79%package devel
80Summary: Static libraries and header files for ImageMagick app development.
81Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
82Group: Development/Libraries
83Requires: ImageMagick = %{version}-%{release}
84
85%description devel
86Image-Magick-devel contains the static libraries and header files you'll
87need to develop ImageMagick applications. ImageMagick is an image
88manipulation program.
89
90If you want to create applications that will use ImageMagick code or
91APIs, you need to install ImageMagick-devel as well as ImageMagick.
92You do noy need to install it if you just want to use ImageMagick,
93however.
94
95%description devel -l ja
96ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
97これらは ImageMagick アプリケーションの開発の際に必要となります.
98ImageMagick は画像処理プログラムです.
99
100ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
101この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
102する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
103インストールする必要はありません.
104
105%package perl
106Summary: ImageMagick perl bindings
107Summary(ja): ImageMagick の Perl バインディング
108Group: Development/Libraries
109Requires: ImageMagick = %{version}-%{release}, perl >= 5.8.0
110
111%description perl
112Perl bindings to ImageMagick.
113
114Install ImageMagick-perl if you want to use any perl scripts that use
115ImageMagick.
116
117%description perl -l ja
118このパッケージは ImageMagick の Perl バインディングです.
119
120ImageMagick を利用する perl スクリプトを使いたい場合は
121ImageMagick-perl パッケージをインストールして下さい.
122
123
124%package c++
125Summary: ImageMagick Magick++ library (C++ bindings)
126Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
127Group: System Environment/Libraries
128Requires: ImageMagick = %{version}-%{release}
129
130%description c++
131This package contains the Magick++ library, a C++ binding to the ImageMagick
132graphics manipulation library.
133
134Install ImageMagick-c++ if you want to use any applications that use Magick++.
135
136%description c++
137このパッケージには Magick++ ライブラリが収められています.
138Magick++ とは ImageMagick ライブラリの C++ バインディングです.
139
140Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
141パッケージをインストールして下さい.
142
143%package c++-devel
144Summary: C++ bindings for the ImageMagick library
145Summary(ja): ImageMagick ライブラリの C++ バインディング
146Group: Development/Libraries
147Requires: ImageMagick = %{version}-%{release}
148Requires: ImageMagick-c++ = %{version}-%{release}
149Requires: ImageMagick-devel = %{version}-%{release}
150
151%description c++-devel
152ImageMagick-devel contains the static libraries and header files you'll
153need to develop ImageMagick applications using the Magick++ C++ bindings.
154ImageMagick is an image manipulation program.
155
156If you want to create applications that will use Magick++ code
157or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
158ImageMagick.
159You don't need to install it if you just want to use ImageMagick, or if you
160want to develop/compile applications using the ImageMagick C interface,
161however.
162
163%description c++-devel -l ja
164ImageMagick-c++-devel には Magick++ C++ バインディングを使った
165ImageMagick アプリケーション開発に必要なスタティックライブラリと
166ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
167
168Magick++ コードや API を使ったアプリケーションを開発する場合は,
169ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
170インストールする必要があります.
171ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
172を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
173インストールする必要はありません.
174
175
176%prep
177%setup -q -n %{name}-%{VER}-%{Patchlevel}
178
179#patch1 -p1 -b .CVE-2006-5456
180
181%build
182%configure --enable-shared \
183           --disable-static \
184           --with-x \
185           --with-quantum-depth=16 \
186           --with-modules --enable-lzw \
187           --without-frozenpaths \
188           --with-perl \
189           --without-wmf \
190           --without-jp2 \
191           --without-jbig \
192           --without-djvu \
193           --without-fftw \
194           --with-lcms \
195           --without-dot \
196           --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
197
198# Disable rpath
199sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
200sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
201
202make %{?_smp_mflags}
203
204%install
205rm -rf $RPM_BUILD_ROOT
206
207make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
208
209# perlmagick: fix perl path of demo files
210%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
211
212# get the perl file list. We know what we need, so this is easy
213perlver=`perl -v |grep built |sed -e "s,.*v,,;s, .*,,"`
214perlmajor=`echo $perlver |sed -e "s,\..*,,"`
215
216find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
217find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
218find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
219
220echo "%defattr(-,root,root)" > perl-pkg-files
221find $RPM_BUILD_ROOT%{_libdir}/perl$perlmajor/vendor_perl/$perlver -type d -name Image >> perl-pkg-files.orig
222sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
223
224# remove duplicated doc files
225rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
226
227# remove files conflict with libtools
228rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
229rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
230
231# remove *.la files
232find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
233
234%clean
235rm -rf $RPM_BUILD_ROOT
236
237%post -p /sbin/ldconfig
238
239%post c++ -p /sbin/ldconfig
240
241%postun -p /sbin/ldconfig
242
243%postun c++ -p /sbin/ldconfig
244
245
246%files
247%defattr(-,root,root)
248%doc www images
249%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
250%dir %{_libdir}/ImageMagick-%{VER}
251%{_libdir}/ImageMagick-%{VER}/config
252%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
253%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
254%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
255%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
256%{_libdir}/libMagickCore.so.*
257%{_libdir}/libMagickWand.so.*
258%{_bindir}/[a-z]*
259%dir %{_datadir}/ImageMagick-%{VER}
260%dir %{_datadir}/ImageMagick-%{VER}/config
261%{_datadir}/ImageMagick-%{VER}/config/*.xml
262%{_datadir}/ImageMagick-%{VER}/config/*.icm
263%{_mandir}/man1/ImageMagick.*
264%{_mandir}/man1/[a-z]*
265
266%files devel
267%defattr(-,root,root)
268%{_bindir}/Magick-config
269%{_bindir}/Wand-config
270%{_bindir}/MagickCore-config
271%{_bindir}/MagickWand-config
272#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
273#{_libdir}/libMagickCore.a
274%{_libdir}/libMagickCore.so
275#{_libdir}/libMagickWand.a
276%{_libdir}/libMagickWand.so
277%{_libdir}/pkgconfig/ImageMagick.pc
278%{_libdir}/pkgconfig/Wand.pc
279%{_libdir}/pkgconfig/MagickCore.pc
280%{_libdir}/pkgconfig/MagickWand.pc
281%{_includedir}/ImageMagick/magick
282%{_includedir}/ImageMagick/wand
283%{_mandir}/man1/Magick-config*
284%{_mandir}/man1/Wand-config*
285%{_mandir}/man1/MagickCore-config*
286%{_mandir}/man1/MagickWand-config*
287
288%files c++
289%defattr(-,root,root)
290%{_libdir}/libMagick++.so.*
291
292%files c++-devel
293%defattr(-,root,root)
294%{_bindir}/Magick++-config
295%{_includedir}/ImageMagick/Magick++
296%{_includedir}/ImageMagick/Magick++.h
297#{_libdir}/libMagick++.a
298%{_libdir}/libMagick++.so
299%{_libdir}/pkgconfig/ImageMagick++.pc
300%{_libdir}/pkgconfig/Magick++.pc
301%{_mandir}/man1/Magick++-config*
302
303%files perl -f perl-pkg-files
304%defattr(-,root,root)
305%{_mandir}/man3/*
306
307%changelog
308* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.6.1.5-2
309- rebuild with rpm-4.8.1 for pkg-config file
310- change BuildRequires: libjpeg-turbo-devel instead of libjpeg-devel
311- change Requires: libjpeg-turbo instead of libjpeg
312
313* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
314- new upstream release
315- built with new toolchain
316- added --disable-static to %%configure, removed static libraries
317
318* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
319- added --without-djvu --without-fftw
320
321* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
322- new upstream release
323
324* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
325- new upstream release
326
327* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
328- new upstream release
329- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
330- add R: graphviz, OpenEXR-libs, ilmbase
331
332* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
333- new upstream release
334- added Packager tag
335
336* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
337- new upstream release
338
339* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
340- new upstream release
341- updated BuildRequires
342
343* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
344- enabled lcms as default.
345
346* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
347- new upstream release
348
349* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
350- new upstream release
351
352* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
353- new upstream release
354
355* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
356- new upstream release
357
358* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
359- new upstream release
360- spec in UTF-8
361
362* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
363- enabled to build with lcms (use '--with lcms' to enable).
364
365* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
366- new upstream release
367- rebuilt with perl-5.10.0
368
369* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
370- new upstream release
371- removed *.la files from devel packages
372
373* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
374- new upstream release
375- change files section to fit new release
376- build under new versioning policy
377
378* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
379- new upstream release
380
381* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
382- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
383- add BuildPrereq: librsvg2-devel
384- add %{?_smp_mflags} to make command arg
385
386* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
387- new upstream release
388- changed Group to Applications/Graphics
389
390* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
391- rebuilt for VineSeed
392
393* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
394- update patch1 for fix CVE-2007-0770
395
396* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
397- upstream release
398- add patch1 for fix CVE-2006-5456
399
400* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
401- rebuilt (for ppc) to resolve reference to invalid *la files
402
403* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
404- new upstream release
405
406* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
407- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
408
409* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
410- new upstream release
411- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
412- add --with-perl-options to configure option
413
414* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
415- new upstream release
416- build with XOrg-6.9.0
417
418* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
419- new upstream release
420- add %%{_mandir}/man1/ImageMagick.* to main package
421
422* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
423- source upgrade
424- remove patch1
425- update %%files
426
427* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
428- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
429  (CAN-2004-0981)
430
431* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
432- move $(pkglibdir)/modules-Q16/*/*.la to main package.
433
434* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
435- source upgrade
436- Patch: change default menu font so display can work without XOrg-75dpi-fonts
437- add missing docs
438- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
439- *.pc should be in -devel package
440- add missing pkg{lib,data}dirs to %%files
441
442* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
443- source upgrade
444- add --without-dot to %%configure option
445- update %%files section
446
447* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
448- source upgrade
449
450* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
451- source upgrade
452
453* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
454- add --without-jbig to %%configure option
455
456* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
457- add --without-lcms to %%configure option
458
459* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
460- source upgrade
461- remove commented lines
462
463* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
464- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
465
466* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
467- source upgrade
468- remove patch for freetype2, no need
469- remove commented lines
470- add --with-quantum-depth=16 --with-modules --enable-lzw
471  --without-frozenpaths to %%configure option
472- remove --with-threads --without-xml from %%configure option
473- update %%files
474
475* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
476- patch update
477- add --without-jp2 to configure option
478- change PerlMagick build method
479
480* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
481- rebuild without jasper-devel
482
483* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
484- source upgrade to 5.5.7-15
485
486* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
487- source upgrade to 5.5.7-13
488- add patch0 to build against freetype2-2.1.7
489
490* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
491- source upgrade to 5.5.7-11
492- clean up spec
493- build without previous package (do not require libMagick.so.0)
494
495* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
496- source upgrade to 5.5.7-9
497- revised name of pkgconfig files
498- remove BuildPrereq: freetype-devel
499
500* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
501- source upgrade to 5.5.7-6
502- disable all patches
503- revised %%files section
504- disable libtoolize and autotools
505- change PerlMagick build method
506- build without previous package (do not require libMagick.so.5)
507
508* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
509- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
510  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
511
512* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
513- rebuild
514
515* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
516- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
517- FIXME: rpm's macro problem?
518
519- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
520  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
521
522  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
523  - remove unnecessary duplicated %%doc files
524  - --without-xml instead of --without-ttf
525  - eliminate libungif(-devel) from BuildReq/Requires
526  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
527
528  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
529  - add delegetes.mgk (and %%{_libdir}/%%{name})
530
531  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
532  - 5.2.9-0vl4
533  - Sorry, the spec was in Shift_JIS. Fixed.
534
535  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
536  - 5.2.9-0vl3
537  - rebuilt with perl-5.6.1
538  - added Japanese summary and description :-P
539  - added --without-ttf in order to disable freetype2 (SeedPlus) support
540  - added --without-wmf in order to disable libwmf (SeedPlus) support
541
542  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
543  - 5.2.9-0vl2
544  - rebuild on Perl-5.6
545  - use %%{perl_sitearch}
546  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
547
548  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
549  - 5.2.9-0vl1
550  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
551
552* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
553- fix perl paths in file list
554
555* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
556- lib64'ize
557- don't throw stuff in /usr/X11R6, that's for X only
558- remove files we aren't shipping
559
560* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
561- rebuilt with gcc-3.2 (we hope)
562
563* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
564- build using gcc-3.2-0.1
565
566* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
567- fix non-cpp headers in -devel package
568- fix #62157 (wrong path for include files in ImageMagick-devel)
569- fix #63897 (use _target instead of _arch) in libtool workaround
570- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
571
572* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
573- update
574- fix localdoc patch
575- fix %%files section
576- disable nonroot patch
577- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
578- fix libtool workaround
579- moved Magick*-config into -devel package (#64249)
580
581* Sun May 26 2002 Tim Powers <timp@redhat.com>
582- automated rebuild
583
584* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
585- 5.4.6
586
587* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
588- Update to pl 11
589
590* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
591- Update to 5.4.3 pl5; this fixes #58080
592
593* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
594- Patchlevel 3
595
596* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
597- automated rebuild
598
599* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
600- Update to 5.4.2-2
601- Fix #57923, also don't hardcode netscape as html viewer
602
603* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
604- 5.4.1
605- Link against new libstdc++
606
607* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
608- 5.4.0.5
609- Make the error message when trying to display an hpgl file more
610  explicit (#55875)
611
612* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
613- 5.4.0.3
614- Fix names of man pages
615
616* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
617- 5.4.0
618- work around build system breakage causing applications to be named
619  %{_arch}-redhat-linux-foo rather than foo
620
621* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
622- 5.3.9
623
624* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
625- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
626  (#52611)
627
628* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
629- Remove Magick++ includes from -devel, they're already in -c++-devel
630  (#51590)
631
632* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
633- 5.3.8 (bugfix release)
634
635* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
636- fix to build Perlmagic on s390 s390x
637
638* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
639- Add delegates.mgk to the package (#50725)
640
641* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
642- 5.3.7
643- Fix build without previously installed ImageMagick-devel (#49816)
644- Move perl bindings to a separate package.
645
646* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
647- Fix build as non-root again
648- Shut up rpmlint
649
650* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
651- 5.3.6
652- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
653
654* Sat Jun 16 2001 Than Ngo <than@redhat.com>
655- update to 5.3.5
656- cleanup specfile
657
658* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
659- 5.3.3-respin, fixes #41196
660
661* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
662- 5.3.3
663- Add a desktop file for "display" (RFE#17417)
664
665* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
666- 5.3.2
667- work around bugs in ia64 glibc headers
668
669* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
670- remove patch for s390, it is not necessary
671
672* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
673- 5.2.7
674
675* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
676- 5.2.6
677
678* Mon Dec 18 2000 Than Ngo <than@redhat.com>
679- ported to s390
680
681* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
682- 5.2.4
683- Fix up and package the C++ bindings in the new c++/c++-devel packages.
684
685* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
686- rebuild against new libpng
687
688* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
689- include images with docs (#10312)
690
691* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
692- don't build with -ggdb, use -g instead.
693
694* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
695- automatic rebuild
696
697* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
698- update to 5.2.2 beta
699
700* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
701- update to 5.2.1, redone patches as they failed
702
703* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
704- remove hacks to move perl man pages
705- don't include the perl*/man stuff, these files go in /usr/share/man now.
706
707* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
708- disable optimization on Alpha and Sparc
709
710* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
711- update to 5.2.0
712- update URL
713- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
714
715* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
716- bootstrap rebuilt to nuke broken libbz2 deps
717- add Prefix: tag such that the FHS macros work properly
718
719* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
720- now compiles with bzip2 1.0
721- changed buildroot to include version
722
723* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
724- fix compilation with new perl
725
726* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
727- 5.1.1
728
729* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
730- Rebuild to get compressed man pages
731
732* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
733- ugly hack to print with lpr instead of lp
734
735* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
736- update to 4.2.9
737
738* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
739- update to 4.2.8
740
741* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
742- include the perl man pages as well
743
744* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
745- remove --enable-16bit because it damages interoperability
746
747* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
748- update to 4.2.2
749- change ChangeLog to refer to actual dates.
750- strip binaries
751
752* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
753- add more files. Oops.
754
755* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
756- auto rebuild in the new build environment (release 2)
757
758* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
759- version 4.2.1
760
761* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
762- changed group
763
764* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
765- hacks to make it work with the new perl
766- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
767- make sure the libraries have the x bit on
768
769* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
770- translations modified for de, fr
771
772* Thu May 07 1998 Prospector System <bugs@redhat.com>
773- translations modified for de, fr, tr
774
775* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
776- updated to 4.0.5
777
778* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
779- updated to 4.0.4
780- added BuildRoot
781
782* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
783- updated from 3.8.3 to 3.9.1
784- removed PNG patch (appears to be fixed)
785
786* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
787- build against new libpng
788
789* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
790- built against glibc
791
792* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
793- updated to version 3.8.3.
794- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.