source: projects/specs/trunk/I/ImageMagick/ImageMagick-vl.spec @ 941

Revision 941, 26.8 KB checked in by inagaki, 14 years ago (diff)

updated: ImageMagicj?, libfprint, dvdauthor, inkscape, koffice, pstoedit, xine-lib

Line 
1# ImageMagick has adopted a new Version.Patchlevel version numbering system...
2# 6.2.9.7 is actually version 6.2.9, Patchlevel 0.
3
4%define VER 6.6.1
5%define Patchlevel 5
6
7Summary: X application for displaying and manipulating images.
8Summary(ja): 画像ファイルの表示/処理を行う X のアプリケーション
9Name: ImageMagick
10
11%if "%{Patchlevel}" != ""
12Version: %{VER}.%{Patchlevel}
13%else
14Version: %{VER}
15%endif
16Release: 1%{?_dist_release}
17
18License: freeware
19Group: Applications/Graphics
20%if "%{Patchlevel}" != ""
21Source: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%{VER}-%{Patchlevel}.tar.bz2
22%else
23Source: ftp://ftp.ImageMagick.org/ImageMagick/ImageMagick-%{version}.tar.bz2
24%endif
25#Patch1: ImageMagick-6.2.9-CVE-2006-5456_2007-0770.patch
26URL: http://www.imagemagick.org/
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: bzip2-devel, libjpeg-devel
30BuildRequires: libtiff-devel, giflib-devel, zlib-devel, perl
31BuildRequires: freetype2-devel >= 2.1.7, libpng-devel >= 1.2.5
32BuildRequires: libX11-devel, libXext-devel
33BuildRequires: xorg-x11-server-utils
34BuildRequires: libxml2-devel, librsvg2-devel
35BuildRequires: lcms-devel
36BuildRequires: graphviz-devel, OpenEXR-devel, ilmbase-devel
37BuildRequires: fontconfig-devel
38
39Requires: bzip2, freetype2, libjpeg, libpng, libtiff, libungif, zlib
40Requires: xorg-x11-server-utils
41Requires: libxml2
42Requires: lcms
43Requires: graphviz, OpenEXR-libs, ilmbase
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: inagaki, iwamoto
48
49%description
50ImageMagick(TM) is an image display and manipulation tool for the X
51Window System. ImageMagick can read and write JPEG, TIFF, PNM, GIF,
52and Photo CD image formats. It can resize, rotate, sharpen, color
53reduce, or add special effects to an image, and when finished you can
54either save the completed work in the original format or a different
55one. ImageMagick also includes command line programs for creating
56animated or transparent .gifs, creating composite images, creating
57thumbnail images, and more.
58
59ImageMagick is one of your choices if you need a program to manipulate
60and dis play images. If you want to develop your own applications
61which use ImageMagick code or APIs, you need to install
62ImageMagick-devel as well.
63
64
65%description -l ja
66ImageMagick(TM) は X ウィンドウシステム用の画像表示/処理ツールです.
67ImageMagick が読み書き出来る画像形式には JPEG, TIFF, PNM, GIF, Photo CD
68イメージ型式等があります.また画像のリサイズ,回転,シャープ化,減色が
69出来ますし,画像に対してイフェクトをかけることも出来ます.変更した画像は
70オリジナルと同じ画像形式ででも,異なる画像形式にでも保存することが出来ます.
71また ImageMagick にはアニメーション GIF や透過 GIF の作成,画像の合成,
72サムネール画像の作成 等々を行うコマンドラインプログラムも含まれています.
73
74画像ファイルの表示/処理を行う為の幾多のプログラムが必要ならば,ImageMagick
75も選択肢の一つとなるでしょう.また,ImageMagick のコードや API を使った
76アプリケーションを開発したい場合は,ImageMagick-devel パッケージも同時に
77インストールして下さい.
78
79%package devel
80Summary: Static libraries and header files for ImageMagick app development.
81Summary(ja): ImageMagick アプリケーション開発用ライブラリ/ヘッダファイル
82Group: Development/Libraries
83Requires: ImageMagick = %{version}-%{release}
84
85%description devel
86Image-Magick-devel contains the static libraries and header files you'll
87need to develop ImageMagick applications. ImageMagick is an image
88manipulation program.
89
90If you want to create applications that will use ImageMagick code or
91APIs, you need to install ImageMagick-devel as well as ImageMagick.
92You do noy need to install it if you just want to use ImageMagick,
93however.
94
95%description devel -l ja
96ImageMagick-devel にはスタティックライブラリとヘッダファイルが収められており,
97これらは ImageMagick アプリケーションの開発の際に必要となります.
98ImageMagick は画像処理プログラムです.
99
100ImageMagick のコードや API を使ったアプリケーションを作りたい場合には,
101この ImageMagick-devel パッケージを ImageMagick パッケージと共にインストール
102する必要があります.単に ImageMagick を使いたいだけならば,devel パッケージは
103インストールする必要はありません.
104
105%package perl
106Summary: ImageMagick perl bindings
107Summary(ja): ImageMagick の Perl バインディング
108Group: Development/Libraries
109Requires: ImageMagick = %{version}-%{release}, perl >= 5.8.0
110
111%description perl
112Perl bindings to ImageMagick.
113
114Install ImageMagick-perl if you want to use any perl scripts that use
115ImageMagick.
116
117%description perl -l ja
118このパッケージは ImageMagick の Perl バインディングです.
119
120ImageMagick を利用する perl スクリプトを使いたい場合は
121ImageMagick-perl パッケージをインストールして下さい.
122
123
124%package c++
125Summary: ImageMagick Magick++ library (C++ bindings)
126Summary(ja): ImageMagick Magick++ ライブラリ (C++ バインディング)
127Group: System Environment/Libraries
128Requires: ImageMagick = %{version}-%{release}
129
130%description c++
131This package contains the Magick++ library, a C++ binding to the ImageMagick
132graphics manipulation library.
133
134Install ImageMagick-c++ if you want to use any applications that use Magick++.
135
136%description c++
137このパッケージには Magick++ ライブラリが収められています.
138Magick++ とは ImageMagick ライブラリの C++ バインディングです.
139
140Magick++ を使ったアプリケーションを利用する際には ImageMagick-c++
141パッケージをインストールして下さい.
142
143%package c++-devel
144Summary: C++ bindings for the ImageMagick library
145Summary(ja): ImageMagick ライブラリの C++ バインディング
146Group: Development/Libraries
147Requires: ImageMagick = %{version}-%{release}
148Requires: ImageMagick-c++ = %{version}-%{release}
149Requires: ImageMagick-devel = %{version}-%{release}
150
151%description c++-devel
152ImageMagick-devel contains the static libraries and header files you'll
153need to develop ImageMagick applications using the Magick++ C++ bindings.
154ImageMagick is an image manipulation program.
155
156If you want to create applications that will use Magick++ code
157or APIs, you'll need to install ImageMagick-c++-devel, ImageMagick-devel and
158ImageMagick.
159You don't need to install it if you just want to use ImageMagick, or if you
160want to develop/compile applications using the ImageMagick C interface,
161however.
162
163%description c++-devel -l ja
164ImageMagick-c++-devel には Magick++ C++ バインディングを使った
165ImageMagick アプリケーション開発に必要なスタティックライブラリと
166ヘッダファイルが収められています.ImageMagick とは画像処理プログラムです.
167
168Magick++ コードや API を使ったアプリケーションを開発する場合は,
169ImageMagick-c++-devel, ImageMagick-devel, ImageMagick パッケージを
170インストールする必要があります.
171ImageMagick プログラムを使うだけの場合,あるいは ImageMagick C インタフェース
172を使ってアプリケーション開発を行う場合は,ImageMagick-c++-devel パッケージは
173インストールする必要はありません.
174
175
176%prep
177%setup -q -n %{name}-%{VER}-%{Patchlevel}
178
179#patch1 -p1 -b .CVE-2006-5456
180
181%build
182%configure --enable-shared \
183           --disable-static \
184           --with-x \
185           --with-quantum-depth=16 \
186           --with-modules --enable-lzw \
187           --without-frozenpaths \
188           --with-perl \
189           --without-wmf \
190           --without-jp2 \
191           --without-jbig \
192           --without-djvu \
193           --without-fftw \
194           --with-lcms \
195           --without-dot \
196           --with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'"
197
198# Disable rpath
199sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
200sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
201
202make %{?_smp_mflags}
203
204%install
205rm -rf $RPM_BUILD_ROOT
206
207make install DESTDIR=$RPM_BUILD_ROOT HTML_INSTALL_DATA_TARGETS=
208
209# perlmagick: fix perl path of demo files
210%{__perl} -MExtUtils::MakeMaker -e 'MY->fixin(@ARGV)' PerlMagick/demo/*.pl
211
212# get the perl file list. We know what we need, so this is easy
213perlver=`perl -v |grep built |sed -e "s,.*v,,;s, .*,,"`
214perlmajor=`echo $perlver |sed -e "s,\..*,,"`
215
216find $RPM_BUILD_ROOT -name "*.bs" |xargs rm -f
217find $RPM_BUILD_ROOT -name ".packlist" |xargs rm -f
218find $RPM_BUILD_ROOT -name "perllocal.pod" |xargs rm -f
219
220echo "%defattr(-,root,root)" > perl-pkg-files
221find $RPM_BUILD_ROOT%{_libdir}/perl$perlmajor/vendor_perl/$perlver -type d -name Image >> perl-pkg-files.orig
222sed -e s,$RPM_BUILD_ROOT,, perl-pkg-files.orig > perl-pkg-files
223
224# remove duplicated doc files
225rm -f `find $RPM_BUILD_ROOT%{_datadir}/%{name}-%{VER} -maxdepth 1 -type f`
226
227# remove files conflict with libtools
228rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*a
229rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.so*
230
231# remove *.la files
232find $RPM_BUILD_ROOT%{_libdir} -name "lib*.la" |xargs rm -f
233
234%clean
235rm -rf $RPM_BUILD_ROOT
236
237%post -p /sbin/ldconfig
238
239%post c++ -p /sbin/ldconfig
240
241%postun -p /sbin/ldconfig
242
243%postun c++ -p /sbin/ldconfig
244
245
246%files
247%defattr(-,root,root)
248%doc www images
249%doc ChangeLog LICENSE NOTICE QuickStart.txt README.txt index.html
250%dir %{_libdir}/ImageMagick-%{VER}
251%{_libdir}/ImageMagick-%{VER}/config
252%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16
253%dir %{_libdir}/ImageMagick-%{VER}/modules-Q16/*
254%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.so
255%{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.la
256%{_libdir}/libMagickCore.so.*
257%{_libdir}/libMagickWand.so.*
258%{_bindir}/[a-z]*
259%dir %{_datadir}/ImageMagick-%{VER}
260%dir %{_datadir}/ImageMagick-%{VER}/config
261%{_datadir}/ImageMagick-%{VER}/config/*.xml
262%{_datadir}/ImageMagick-%{VER}/config/*.icm
263%{_mandir}/man1/ImageMagick.*
264%{_mandir}/man1/[a-z]*
265
266%files devel
267%defattr(-,root,root)
268%{_bindir}/Magick-config
269%{_bindir}/Wand-config
270%{_bindir}/MagickCore-config
271%{_bindir}/MagickWand-config
272#{_libdir}/ImageMagick-%{VER}/modules-Q16/*/*.a
273#{_libdir}/libMagickCore.a
274%{_libdir}/libMagickCore.so
275#{_libdir}/libMagickWand.a
276%{_libdir}/libMagickWand.so
277%{_libdir}/pkgconfig/ImageMagick.pc
278%{_libdir}/pkgconfig/Wand.pc
279%{_libdir}/pkgconfig/MagickCore.pc
280%{_libdir}/pkgconfig/MagickWand.pc
281%{_includedir}/ImageMagick/magick
282%{_includedir}/ImageMagick/wand
283%{_mandir}/man1/Magick-config*
284%{_mandir}/man1/Wand-config*
285%{_mandir}/man1/MagickCore-config*
286%{_mandir}/man1/MagickWand-config*
287
288%files c++
289%defattr(-,root,root)
290%{_libdir}/libMagick++.so.*
291
292%files c++-devel
293%defattr(-,root,root)
294%{_bindir}/Magick++-config
295%{_includedir}/ImageMagick/Magick++
296%{_includedir}/ImageMagick/Magick++.h
297#{_libdir}/libMagick++.a
298%{_libdir}/libMagick++.so
299%{_libdir}/pkgconfig/ImageMagick++.pc
300%{_libdir}/pkgconfig/Magick++.pc
301%{_mandir}/man1/Magick++-config*
302
303%files perl -f perl-pkg-files
304%defattr(-,root,root)
305%{_mandir}/man3/*
306
307%changelog
308* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6.1.5-1
309- new upstream release
310- built with new toolchain
311- added --disable-static to %%configure, removed static libraries
312
313* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-2
314- added --without-djvu --without-fftw
315
316* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.7.3-1
317- new upstream release
318
319* Tue Aug  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.8-1
320- new upstream release
321
322* Sat Jul  4 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.5.4.2-1
323- new upstream release
324- add BR: graphviz-devel, OpenEXR-devel, ilmbase-devel
325- add R: graphviz, OpenEXR-libs, ilmbase
326
327* Sat Jun  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.3.2-1
328- new upstream release
329- added Packager tag
330
331* Sun Apr 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.6-1
332- new upstream release
333
334* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.5.1.0-1
335- new upstream release
336- updated BuildRequires
337
338* Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.4.9.2-2
339- enabled lcms as default.
340
341* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.9.2-1
342- new upstream release
343
344* Fri Jan  2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.8.3-1
345- new upstream release
346
347* Tue Oct 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.4.6-1
348- new upstream release
349
350* Fri Aug  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.2.5-1
351- new upstream release
352
353* Tue May 27 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.3-1
354- new upstream release
355- spec in UTF-8
356
357* Mon May 19 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 6.4.1.0-2
358- enabled to build with lcms (use '--with lcms' to enable).
359
360* Tue May  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.1.0-1
361- new upstream release
362- rebuilt with perl-5.10.0
363
364* Mon Apr 28 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4.0.11-1
365- new upstream release
366- removed *.la files from devel packages
367
368* Sat Mar 22 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.9.10-1
369- new upstream release
370- change files section to fit new release
371- build under new versioning policy
372
373* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.3.7.4-0vl1
374- new upstream release
375
376* Fri Sep 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.5.10-0vl1
377- new upstream release with security fixes (CVE-2007-4985,4986,4987,4988)
378- add BuildPrereq: librsvg2-devel
379- add %{?_smp_mflags} to make command arg
380
381* Thu Aug  9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.5.6-0vl1
382- new upstream release
383- changed Group to Applications/Graphics
384
385* Wed Jun 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3.0.1-0vl2
386- rebuilt for VineSeed
387
388* Mon Feb 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1.1
389- update patch1 for fix CVE-2007-0770
390
391* Wed Nov 2 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.3.0.1-0vl1
392- upstream release
393- add patch1 for fix CVE-2006-5456
394
395* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 6.2.9.7-0vl2
396- rebuilt (for ppc) to resolve reference to invalid *la files
397
398* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.7-0vl1
399- new upstream release
400
401* Wed Aug 16 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.9.0-0vl1
402- new upstream release (Security: http://www.overflow.pl/adv/imsgiheap.txt)
403
404* Mon Mar  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.6.3-0vl1
405- new upstream release
406- delete duplicated docs under %%{_datadir}/%%{name}-%%{VER}
407- add --with-perl-options to configure option
408
409* Sun Dec 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2.5.4-0vl1
410- new upstream release
411- build with XOrg-6.9.0
412
413* Fri Apr 15 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.2.1.4-0vl1
414- new upstream release
415- add %%{_mandir}/man1/ImageMagick.* to main package
416
417* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.1.5.8-0vl1
418- source upgrade
419- remove patch1
420- update %%files
421
422* Thu Dec  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.8.3-0vl3
423- add patch1 from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=278401
424  (CAN-2004-0981)
425
426* Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.8.3-0vl2
427- move $(pkglibdir)/modules-Q16/*/*.la to main package.
428
429* Fri Oct  8 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 6.0.8.3-0vl1
430- source upgrade
431- Patch: change default menu font so display can work without XOrg-75dpi-fonts
432- add missing docs
433- move $(pkglibdir)/modules-Q16/*/*.(a|la) to devel
434- *.pc should be in -devel package
435- add missing pkg{lib,data}dirs to %%files
436
437* Thu Sep 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.7.4-0vl1
438- source upgrade
439- add --without-dot to %%configure option
440- update %%files section
441
442* Sun Jun 20 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.2.7-0vl1
443- source upgrade
444
445* Fri Jun  4 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.1.4-0vl1
446- source upgrade
447
448* Thu May 13 2004 Satoshi MACHINO <machino@vinelinux.org> 6.0.0.7-0vl3
449- add --without-jbig to %%configure option
450
451* Sun May  2 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl2
452- add --without-lcms to %%configure option
453
454* Sat May  1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.7-0vl1
455- source upgrade
456- remove commented lines
457
458* Sun Apr 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl2
459- add BuildPrereq: XOrg-devel libxml2-devel and Requires: libxml2
460
461* Thu Apr 15 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 6.0.0.2-0vl1
462- source upgrade
463- remove patch for freetype2, no need
464- remove commented lines
465- add --with-quantum-depth=16 --with-modules --enable-lzw
466  --without-frozenpaths to %%configure option
467- remove --with-threads --without-xml from %%configure option
468- update %%files
469
470* Wed Jan  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl3
471- patch update
472- add --without-jp2 to configure option
473- change PerlMagick build method
474
475* Wed Dec 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl2
476- rebuild without jasper-devel
477
478* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.15-0vl1
479- source upgrade to 5.5.7-15
480
481* Tue Nov 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.13-0vl1
482- source upgrade to 5.5.7-13
483- add patch0 to build against freetype2-2.1.7
484
485* Thu Oct  2 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.11-0vl1
486- source upgrade to 5.5.7-11
487- clean up spec
488- build without previous package (do not require libMagick.so.0)
489
490* Sun Jun  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.9-0vl1
491- source upgrade to 5.5.7-9
492- revised name of pkgconfig files
493- remove BuildPrereq: freetype-devel
494
495* Sun Jun  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.5.7.6-0vl1
496- source upgrade to 5.5.7-6
497- disable all patches
498- revised %%files section
499- disable libtoolize and autotools
500- change PerlMagick build method
501- build without previous package (do not require libMagick.so.5)
502
503* Thu May  1 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 5.4.7-6vl4
504- rebuild with libpng-1.2.5 (BuildPrereq: libpng-devel >= 1.2.5)
505  and perl-5.8.0 (Requires: perl >= 5.8.0 for ImageMagick-perl)
506
507* Mon Apr  7 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 5.4.7-6vl3
508- rebuild
509
510* Sun Dec  8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 5.4.7-6vl2
511- rename $arch-vine-linux-foo to foo, same as $arch-vine-linux-gnu-foo.
512- FIXME: rpm's macro problem?
513
514- based on 5.4.7-6vl1 from Rawhide and modified for Vine Linux
515  previous Vine version was 5.2.9-0vl6: Vine-specific changelog was:
516
517  - Wed Mar 13 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl6
518  - remove unnecessary duplicated %%doc files
519  - --without-xml instead of --without-ttf
520  - eliminate libungif(-devel) from BuildReq/Requires
521  - use freetype2(-devel), instead of freetype1(-devel) for BuildReq/Requires
522
523  - Sat Mar 02 2002 Toru Sagami <sagami@vinelinux.org> 5.2.9-0vl5
524  - add delegetes.mgk (and %%{_libdir}/%%{name})
525
526  - Mon Jun 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
527  - 5.2.9-0vl4
528  - Sorry, the spec was in Shift_JIS. Fixed.
529
530  - Sat Jun 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
531  - 5.2.9-0vl3
532  - rebuilt with perl-5.6.1
533  - added Japanese summary and description :-P
534  - added --without-ttf in order to disable freetype2 (SeedPlus) support
535  - added --without-wmf in order to disable libwmf (SeedPlus) support
536
537  - Sat Jun 16 2001 Yasuhide OMORI <dasen@icntv.ne.jp>
538  - 5.2.9-0vl2
539  - rebuild on Perl-5.6
540  - use %%{perl_sitearch}
541  - install headers into /usr/X11R6/include/magick [VineSeed:04131]
542
543  - Tue Feb 20 2001 Jun Nishii <jun@vinelinux.org>
544  - 5.2.9-0vl1
545  - remove version number of BuildPrereq: freetype-devel >= 2.0.1
546
547* Fri Nov 22 2002 Tim Powers <timp@redhat.com>
548- fix perl paths in file list
549
550* Thu Nov 21 2002 Tim Powers <timp@redhat.com>
551- lib64'ize
552- don't throw stuff in /usr/X11R6, that's for X only
553- remove files we aren't shipping
554
555* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
556- rebuilt with gcc-3.2 (we hope)
557
558* Tue Jul 23 2002 Tim Powers <timp@redhat.com> 5.4.7-4
559- build using gcc-3.2-0.1
560
561* Wed Jul 03 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-3
562- fix non-cpp headers in -devel package
563- fix #62157 (wrong path for include files in ImageMagick-devel)
564- fix #63897 (use _target instead of _arch) in libtool workaround
565- fix #65860, #65780 (tiff2ps) expands images to >10 MB Postscript files.
566
567* Mon Jul 01 2002 Karsten Hopp <karsten@redhat.de> 5.4.7-1
568- update
569- fix localdoc patch
570- fix %%files section
571- disable nonroot patch
572- fix #62100,55950,62162,63136 (display doesn't start form gnome menu)
573- fix libtool workaround
574- moved Magick*-config into -devel package (#64249)
575
576* Sun May 26 2002 Tim Powers <timp@redhat.com>
577- automated rebuild
578
579* Mon May  6 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.6-1
580- 5.4.6
581
582* Thu Mar 14 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.11-1
583- Update to pl 11
584
585* Fri Feb 22 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.3.5-1
586- Update to 5.4.3 pl5; this fixes #58080
587
588* Thu Jan 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.3-1
589- Patchlevel 3
590
591* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
592- automated rebuild
593
594* Fri Jan  4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.2.2-1
595- Update to 5.4.2-2
596- Fix #57923, also don't hardcode netscape as html viewer
597
598* Wed Dec  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.1-1
599- 5.4.1
600- Link against new libstdc++
601
602* Fri Nov  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.5-1
603- 5.4.0.5
604- Make the error message when trying to display an hpgl file more
605  explicit (#55875)
606
607* Mon Nov  5 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0.3-1
608- 5.4.0.3
609- Fix names of man pages
610
611* Mon Oct 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.4.0-1
612- 5.4.0
613- work around build system breakage causing applications to be named
614  %{_arch}-redhat-linux-foo rather than foo
615
616* Wed Sep 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.9-1
617- 5.3.9
618
619* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-3
620- Add delegates.mgk back, got lost during the update to 5.3.8 (Makefile bug)
621  (#52611)
622
623* Mon Aug 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-2
624- Remove Magick++ includes from -devel, they're already in -c++-devel
625  (#51590)
626
627* Sun Jul 28 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.8-1
628- 5.3.8 (bugfix release)
629
630* Sat Jul 27 2001 Than Ngo <than@redhat.com> 5.3.7-3
631- fix to build Perlmagic on s390 s390x
632
633* Thu Jul 26 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-2
634- Add delegates.mgk to the package (#50725)
635
636* Tue Jul 24 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.7-1
637- 5.3.7
638- Fix build without previously installed ImageMagick-devel (#49816)
639- Move perl bindings to a separate package.
640
641* Mon Jul  9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-2
642- Fix build as non-root again
643- Shut up rpmlint
644
645* Tue Jul  3 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.6-1
646- 5.3.6
647- Get rid of the ia64 patch, it's no longer needed since glibc was fixed
648
649* Sat Jun 16 2001 Than Ngo <than@redhat.com>
650- update to 5.3.5
651- cleanup specfile
652
653* Sat May 19 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-2
654- 5.3.3-respin, fixes #41196
655
656* Tue May  1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 5.3.3-1
657- 5.3.3
658- Add a desktop file for "display" (RFE#17417)
659
660* Sun Apr 15 2001 Bernhard Rosenkraenzer <bero@redhat.com>
661- 5.3.2
662- work around bugs in ia64 glibc headers
663
664* Mon Jan 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
665- remove patch for s390, it is not necessary
666
667* Mon Jan  1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
668- 5.2.7
669
670* Wed Dec 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
671- 5.2.6
672
673* Mon Dec 18 2000 Than Ngo <than@redhat.com>
674- ported to s390
675
676* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
677- 5.2.4
678- Fix up and package the C++ bindings in the new c++/c++-devel packages.
679
680* Wed Aug  2 2000 Matt Wilson <msw@redhat.com>
681- rebuild against new libpng
682
683* Wed Jul 19 2000 Nalin Dahyabhai <nalin@redhat.com>
684- include images with docs (#10312)
685
686* Thu Jul 13 2000 Matt Wilson <msw@redhat.com>
687- don't build with -ggdb, use -g instead.
688
689* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
690- automatic rebuild
691
692* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
693- update to 5.2.2 beta
694
695* Mon Jul  3 2000 Florian La Roche <laroche@redhat.com>
696- update to 5.2.1, redone patches as they failed
697
698* Fri Jun 30 2000 Matt Wilson <msw@redhat.com>
699- remove hacks to move perl man pages
700- don't include the perl*/man stuff, these files go in /usr/share/man now.
701
702* Thu Jun 15 2000 Nalin Dahyabhai <nalin@redhat.com>
703- disable optimization on Alpha and Sparc
704
705* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
706- update to 5.2.0
707- update URL
708- remove redundant CXXFLAGS=$RPM_OPT_FLAGS
709
710* Thu Jun  1 2000 Matt Wilson <msw@redhat.com>
711- bootstrap rebuilt to nuke broken libbz2 deps
712- add Prefix: tag such that the FHS macros work properly
713
714* Wed May 17 2000 Trond Eivind Glomsr <teg@redhat.com>
715- now compiles with bzip2 1.0
716- changed buildroot to include version
717
718* Fri May  5 2000 Bill Nottingham <notting@redhat.com>
719- fix compilation with new perl
720
721* Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
722- 5.1.1
723
724* Thu Feb  3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
725- Rebuild to get compressed man pages
726
727* Thu Nov 18 1999 Michael K. Johnson <johnsonm@redhat.com>
728- ugly hack to print with lpr instead of lp
729
730* Mon Aug 30 1999 Bill Nottingham <notting@redhat.com>
731- update to 4.2.9
732
733* Tue Aug 17 1999 Bill Nottingham <notting@redhat.com>
734- update to 4.2.8
735
736* Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
737- include the perl man pages as well
738
739* Tue Apr 06 1999 Michael K. Johnson <johnsonm@redhat.com>
740- remove --enable-16bit because it damages interoperability
741
742* Mon Apr  5 1999 Bill Nottingham <notting@redhat.com>
743- update to 4.2.2
744- change ChangeLog to refer to actual dates.
745- strip binaries
746
747* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
748- add more files. Oops.
749
750* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
751- auto rebuild in the new build environment (release 2)
752
753* Wed Mar 10 1999 Bill Nottingham <notting@redhat.com>
754- version 4.2.1
755
756* Tue Jan 19 1999 Michael K. Johnson <johnsonm@redhat.com>
757- changed group
758
759* Tue Jan 19 1999 Cristian Gafton <gafton@redhat.com>
760- hacks to make it work with the new perl
761- version 4.1.0 (actually installs the sonames as 4.0.10... doh!)
762- make sure the libraries have the x bit on
763
764* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
765- translations modified for de, fr
766
767* Thu May 07 1998 Prospector System <bugs@redhat.com>
768- translations modified for de, fr, tr
769
770* Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
771- updated to 4.0.5
772
773* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
774- updated to 4.0.4
775- added BuildRoot
776
777* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
778- updated from 3.8.3 to 3.9.1
779- removed PNG patch (appears to be fixed)
780
781* Wed Oct 15 1997 Erik Troan <ewt@redhat.com>
782- build against new libpng
783
784* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
785- built against glibc
786
787* Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
788- updated to version 3.8.3.
789- updated source and url tags.
Note: See TracBrowser for help on using the repository browser.