source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 8084

Revision 8084, 15.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.8
4%define orbit2_version 2.14.19
5%define glib2_version 2.32.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 3.2.6
13Release: 2%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/3.2/GConf-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk3-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Obsoletes:      %{name}-gtk < 3.2.6
32Provides:       %{name}-gtk = %{version}
33
34Patch0: GConf-2.18.0.1-reload.patch
35# http://bugzilla.gnome.org/show_bug.cgi?id=568845
36Patch1: GConf-gettext.patch
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: Takemikaduchi
41
42
43%description
44GConf is a process-transparent configuration database API used to
45store user preferences. It has pluggable backends and features to
46support workgroup administration.
47
48%description -l ja
49GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
50ベースの API です。バックエンドに接続しワークグループ管理をサポー
51トする機能を持っています。
52
53%package devel
54Summary: Headers and libraries for GConf development
55Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
56Group: Development/Libraries
57Requires: %{name} = %{version}
58Requires: ORBit2-devel >= %{orbit2_version}
59Requires: glib2-devel >= %{glib2_version}
60
61%description devel
62GConf development package. Contains files needed for doing
63development using GConf.
64
65%description -l ja devel
66GConf 開発パッケージです。GConf を使って開発するために必要なファ
67イルが含まれています。
68
69
70%if %{build_compat32}
71#######################################################################
72# compat32
73%package -n compat32-%{name}
74Summary: A process-transparent configuration system
75Summary(ja): プロセス透過型設定システム
76Group: System Environment/Base
77Requires: compat32-glib2 >= %{glib2_version}
78
79%description -n compat32-%{name}
80GConf is a process-transparent configuration database API used to
81store user preferences. It has pluggable backends and features to
82support workgroup administration.
83
84%description -l ja -n compat32-%{name}
85GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
86ベースの API です。バックエンドに接続しワークグループ管理をサポー
87トする機能を持っています。
88
89%package -n compat32-%{name}-devel
90Summary: Headers and libraries for GConf development
91Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
92Group: Development/Libraries
93Requires: compat32-%{name} = %{version}
94Requires: %{name} = %{version}
95Requires: compat32-glib2 >= %{glib2_version}
96
97%description -n compat32-%{name}-devel
98GConf development package. Contains files needed for doing
99development using GConf.
100
101%description -l ja -n compat32-%{name}-devel
102GConf 開発パッケージです。GConf を使って開発するために必要なファ
103イルが含まれています。
104
105%endif
106
107%prep
108%setup -q -n GConf-%{version}
109
110%patch0 -p1 -b .reload
111%patch1 -p1 -b .gettext
112
113%build
114%configure --disable-gtk-doc --disable-static --enable-defaults-service --with-gtk=3.0
115%__make %{?_smp_mflags}
116
117%install
118rm -fr $RPM_BUILD_ROOT
119%__make install DESTDIR=$RPM_BUILD_ROOT
120
121mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
122mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
123
124rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
125rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
126rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
127
128%find_lang %name
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post
134/sbin/ldconfig
135if [ $1 -gt 1 ]; then
136    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
137        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
138    fi
139fi
140   
141%postun -p /sbin/ldconfig
142
143%files -f %{name}.lang
144%defattr(-, root, root)
145%doc COPYING ChangeLog NEWS README backends/README.evoldap
146%config %{_sysconfdir}/gconf/2/path
147%config %{_sysconfdir}/gconf/2/evoldap.conf
148%dir %{_sysconfdir}/gconf
149%dir %{_sysconfdir}/gconf/2
150%dir %{_sysconfdir}/gconf/gconf.xml.defaults
151%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
152%dir %{_sysconfdir}/gconf/gconf.xml.system
153%dir %{_sysconfdir}/gconf/schemas
154%{_bindir}/*
155%{_libexecdir}/*
156%{_libdir}/*.so.*
157%dir %{_libdir}/GConf
158%dir %{_libdir}/GConf/2
159%{_libdir}/GConf/2/*.so
160%{_libdir}/girepository-1.0
161%{_mandir}/man1/*
162%{_datadir}/sgml/gconf/gconf-1.0.dtd
163%{_datadir}/GConf
164%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
165%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
166%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
167%{_datadir}/dbus-1/services/org.gnome.GConf.service
168%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
169%{_libdir}/gio/modules/libgsettingsgconfbackend.so
170
171%files devel
172%defattr(-, root, root)
173%{_libdir}/*.so
174%{_includedir}/gconf
175%{_datadir}/aclocal/*.m4
176%{_datadir}/gtk-doc
177%{_datadir}/gir-1.0
178%{_libdir}/pkgconfig/*
179
180
181%if %{build_compat32}
182%files -n compat32-%{name}
183%defattr(-,root,root,-)
184%{_libdir}/*.so.*
185%dir %{_libdir}/GConf
186%dir %{_libdir}/GConf/2
187%{_libdir}/GConf/2/*.so
188%{_libdir}/girepository-1.0
189%{_libdir}/gio/modules/libgsettingsgconfbackend.so
190
191%files -n compat32-%{name}-devel
192%defattr(-, root, root)
193%{_libdir}/*.so
194
195%endif
196
197%changelog
198* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-2
199- rebuild with VineSeed environment
200
201* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
202- update to 3.2.6
203- remove %%{name}-gtk subpackage
204
205* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
206- remove *.pc from compat32-%{name}-devel
207
208* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
209- new upstream release
210
211* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
212- new upstream release
213
214* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
215- new upstream release
216
217* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
218- new upstream release
219
220* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
221- new upstream release
222
223* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
224- new upstream release
225
226* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.6-1
227- new upstream release
228- remove Patch2
229
230* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
231- new upstream release
232- change configure option (from --with-gtk=2.0 to --with-gtk=3.0)
233- replace Patch2 (GConf2-3.1.4-gsettings-data-convert.patch)
234- delete Patch3,4
235
236* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
237- add gtk subpackage to include gconf-sanity-check-2
238- add --with-gtk=2.0
239
240* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
241- new upstream release
242
243* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
244- new upstream release
245- add BuildRequires: gobject-introspection-devel
246- create compat32-%{name} package
247
248* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
249- build with rpm-4.8.1-1 for pkg-config file
250
251* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
252- new upstream release
253- drop Patch2, Patch3, Patch4
254
255* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
256- import upstream patches from fedora
257  - Patch1: gettext fix
258  - Patch2: avoid crash wen gconftool-2 cant read the db
259  - Patch3: make the defaults mechanism use the right polkit actions
260  - Patch4: donot catch segv etc. let abrt catch them
261- build with polkit, add BR: polkit-devel
262
263* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
264- new upstream release
265
266* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
267- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
268
269* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
270- new upstream release
271
272* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
273- drop obsolete patch1
274
275* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
276- rebuilt with openldap-2.4.11
277
278* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
279- new upstream release
280
281* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
282- new upstream release
283
284* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
285- new upstream release
286
287* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
288- spec in UTF-8
289
290* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
291- new upstream release
292
293* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
294- new upstream release
295- removed Prereq: install-info
296
297* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
298- rebuild with new environment
299
300* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
301- new upstream release
302
303* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
304- add BuildRequires: gtk2-devel
305
306* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
307- rebuilt with openldap-2.3.27-0vl1
308
309* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
310- rebuilt with openldap-2.3.24-0vl1
311
312* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
313- add BuildRequires: openldap-devel
314
315* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
316- new upstream release
317
318* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
319- reload gconf2 when schema is added/removed (patch0 from mdk)
320- only sync db once when installing multiple schemas. (patch1 from fc)
321
322* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
323- new upstream release
324
325* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
326- new upstream release
327
328* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
329- new upstream release
330
331* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
332- new upstream release
333
334* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
335- new upstream release
336
337* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
338- new upstream version
339
340* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
341- add Japanese summaries and descriptions.
342  thanks to spec file translation project.
343
344* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
345- new upstream release
346
347* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
348- new upstream release
349
350* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
351- new upstream release
352
353* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
354- new upstream release
355
356* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
357- new upstream release
358- fix specfile kanjicode
359
360* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
361- new upstream release
362
363* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
364- new upstream release
365
366* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
367- build for Vine Linux
368
369* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
370- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
371
372* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
373- add dialog to offer to delete gconf locks
374
375* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
376- 1.2.1
377- include libexecdir stuff
378
379* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
380- move .pc fle to -devel package
381
382* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
383- automated rebuild
384
385* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
386- automated rebuild
387
388* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
389- fix warning on gnome-panel install
390
391* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
392- 1.2.0
393- own libdir/GConf/2 directory
394- include gtk-doc docs
395- don't include static lib for backend modules
396
397* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
398- rebuild in different environment
399
400* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
401- 1.1.11
402- remove AUTHORS for rpmlint
403
404* Sun May 26 2002 Tim Powers <timp@redhat.com>
405- automated rebuild
406
407* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
408- rebuild in different environment
409
410* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
411- rebuild in different environment
412
413* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
414- 1.1.10
415
416* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
417- 1.1.9
418
419* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
420- 1.1.8
421- remove .la files
422
423* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
424- Version 1.1.6
425- Rebuild for dependencies
426
427* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
428- automated rebuild
429
430* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
431- 1.1.5.93 snap with important bugfix so gconf actually works
432
433* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
434- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
435
436* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
437- 1.1.5.91 snap with gconf.m4 fix for libgnome
438
439* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
440- since every other build seems to avoid libglib-1.3.so.11,
441  rebuild and hope
442
443* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
444- cvs snap 1.1.5.90
445
446* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
447- GConf 1.1.5, glib 1.3.11
448
449* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
450- rebuild for glib 1.3.10
451
452* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
453- 1.1.3
454
455* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
456- cvs snap, remove bonobo-activation deps
457
458* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
459- update to new CVS snap, rebuild
460
461* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
462- create gconf2 rpm based on gconf1, comment out pofiles
463- include .pc files
464
465* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
466- fix description/summary
467
468* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
469- Add po files from sources.redhat.com
470
471* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
472- Add po files from sources.redhat.com
473
474* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
475- upgrade to 1.0.4 release I just made
476- fixes #51223, syslog spew
477
478* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
479- move gconf-config to devel RPM
480
481* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
482- how many releases of GConf can I make before it works?
483
484* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
485- Upgrade to 1.0.2 (which contains only bugfixes that
486  I reviewed and/or wrote myself)
487
488* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
489- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
490
491* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
492- Install the .la files in the devel package.
493
494* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
495- Use %%{_tmppath}
496- Move the .so files to the devel subpackage
497- langify
498- Move changelog to the end, where it should be :)
499- Don't specify (a bad) doc directory
500- Don't define name, version and release and use it in the rpm headers later
501- Remove "Packager:"
502- s/Copyright/License/
503
504* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
505- add --direct option to gconftool to avoid spawning oafd,
506  then commented out gconftool entirely since it checks
507  whether gconfd is running and that spawns oafd anyhow.
508  oafd simply needs to exit when unused.
509
510* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
511- Fix post, pointed out by Bill
512
513* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
514- Upgrade to 1.0.1
515
516* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
517- Import to Red Hat build system.
518
519* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
520
521- Created the .spec file
Note: See TracBrowser for help on using the repository browser.