source: projects/specs/trunk/G/GConf2/GConf2-vl.spec @ 7633

Revision 7633, 15.6 KB checked in by Takemikaduchi, 11 years ago (diff)

GNOME-3.8.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define libxml2_version 2.7.8
4%define orbit2_version 2.14.19
5%define glib2_version 2.32.0
6%define dbus_version 1.4.0
7%define dbus_glib_version 0.88
8
9Summary: A process-transparent configuration system
10Summary(ja): プロセス透過型設定システム
11Name: GConf2
12Version: 3.2.6
13Release: 1%{?_dist_release}
14License: LGPL
15Group: System Environment/Base
16Source: http://ftp.gnome.org/pub/GNOME/sources/GConf/3.2/GConf-%{version}.tar.xz
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18URL: http://www.gnome.org
19BuildRequires: libxml2-devel >= %{libxml2_version}
20BuildRequires: ORBit2-devel >= %{orbit2_version}
21BuildRequires: glib2-devel >= %{glib2_version}
22BuildRequires: dbus-devel >= %{dbus_version}
23BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
24BuildRequires: gtk3-devel
25BuildRequires: openldap-devel
26BuildRequires: gtk-doc >= 0.9
27BuildRequires: polkit-devel >= 0.99
28BuildRequires: gobject-introspection-devel
29Requires: dbus
30
31Obsoletes:      %{name}-gtk < 3.2.6
32Provides:       %{name}-gtk = %{version}
33
34Patch0: GConf-2.18.0.1-reload.patch
35# http://bugzilla.gnome.org/show_bug.cgi?id=568845
36Patch1: GConf-gettext.patch
37
38Vendor: Project Vine
39Distribution: Vine Linux
40Packager: Takemikaduchi
41
42
43%description
44GConf is a process-transparent configuration database API used to
45store user preferences. It has pluggable backends and features to
46support workgroup administration.
47
48%description -l ja
49GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
50ベースの API です。バックエンドに接続しワークグループ管理をサポー
51トする機能を持っています。
52
53%package devel
54Summary: Headers and libraries for GConf development
55Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
56Group: Development/Libraries
57Requires: %{name} = %{version}
58Requires: ORBit2-devel >= %{orbit2_version}
59Requires: glib2-devel >= %{glib2_version}
60
61%description devel
62GConf development package. Contains files needed for doing
63development using GConf.
64
65%description -l ja devel
66GConf 開発パッケージです。GConf を使って開発するために必要なファ
67イルが含まれています。
68
69
70%if %{build_compat32}
71#######################################################################
72# compat32
73%package -n compat32-%{name}
74Summary: A process-transparent configuration system
75Summary(ja): プロセス透過型設定システム
76Group: System Environment/Base
77Requires: compat32-glib2 >= %{glib2_version}
78
79%description -n compat32-%{name}
80GConf is a process-transparent configuration database API used to
81store user preferences. It has pluggable backends and features to
82support workgroup administration.
83
84%description -l ja -n compat32-%{name}
85GConf は、ユーザの設定を保存するためのプロセス透過型の設定データ
86ベースの API です。バックエンドに接続しワークグループ管理をサポー
87トする機能を持っています。
88
89%package -n compat32-%{name}-devel
90Summary: Headers and libraries for GConf development
91Summary(ja): GConf を使って開発するためのヘッダーファイルとライブラリ
92Group: Development/Libraries
93Requires: compat32-%{name} = %{version}
94Requires: %{name} = %{version}
95Requires: compat32-glib2 >= %{glib2_version}
96
97%description -n compat32-%{name}-devel
98GConf development package. Contains files needed for doing
99development using GConf.
100
101%description -l ja -n compat32-%{name}-devel
102GConf 開発パッケージです。GConf を使って開発するために必要なファ
103イルが含まれています。
104
105%endif
106
107%prep
108%setup -q -n GConf-%{version}
109
110%patch0 -p1 -b .reload
111%patch1 -p1 -b .gettext
112
113%build
114%configure --disable-gtk-doc --disable-static --enable-defaults-service --with-gtk=3.0
115%__make %{?_smp_mflags}
116
117%install
118rm -fr $RPM_BUILD_ROOT
119%__make install DESTDIR=$RPM_BUILD_ROOT
120
121mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/schemas
122mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.system
123
124rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
125rm -f $RPM_BUILD_ROOT/%{_libdir}/GConf/2/*.la
126rm -f $RPM_BUILD_ROOT/%{_libdir}/gio/modules/*.la
127
128%find_lang %name
129
130%clean
131rm -rf $RPM_BUILD_ROOT
132
133%post
134/sbin/ldconfig
135if [ $1 -gt 1 ]; then
136    if ! fgrep -q gconf.xml.system %{_sysconfdir}/gconf/2/path; then
137        sed -i -e 's@xml:readwrite:$(HOME)/.gconf@&\n\n# Location for system-wide settings.\nxml:readonly:/etc/gconf/gconf.xml.system@' %{_sysconfdir}/gconf/2/path
138    fi
139fi
140   
141%postun -p /sbin/ldconfig
142
143%files -f %{name}.lang
144%defattr(-, root, root)
145%doc COPYING ChangeLog NEWS README backends/README.evoldap
146%config %{_sysconfdir}/gconf/2/path
147%config %{_sysconfdir}/gconf/2/evoldap.conf
148%dir %{_sysconfdir}/gconf
149%dir %{_sysconfdir}/gconf/2
150%dir %{_sysconfdir}/gconf/gconf.xml.defaults
151%dir %{_sysconfdir}/gconf/gconf.xml.mandatory
152%dir %{_sysconfdir}/gconf/gconf.xml.system
153%dir %{_sysconfdir}/gconf/schemas
154%{_bindir}/*
155%{_libexecdir}/*
156%{_libdir}/*.so.*
157%dir %{_libdir}/GConf
158%dir %{_libdir}/GConf/2
159%{_libdir}/GConf/2/*.so
160%{_libdir}/girepository-1.0
161%{_mandir}/man1/*
162%{_datadir}/sgml/gconf/gconf-1.0.dtd
163%{_datadir}/GConf
164%{_sysconfdir}/dbus-1/system.d/org.gnome.GConf.Defaults.conf
165%{_datadir}/polkit-1/actions/org.gnome.gconf.defaults.policy
166%{_datadir}/dbus-1/system-services/org.gnome.GConf.Defaults.service
167%{_datadir}/dbus-1/services/org.gnome.GConf.service
168%{_sysconfdir}/xdg/autostart/gsettings-data-convert.desktop
169%{_libdir}/gio/modules/libgsettingsgconfbackend.so
170
171%files devel
172%defattr(-, root, root)
173%{_libdir}/*.so
174%{_includedir}/gconf
175%{_datadir}/aclocal/*.m4
176%{_datadir}/gtk-doc
177%{_datadir}/gir-1.0
178%{_libdir}/pkgconfig/*
179
180
181%if %{build_compat32}
182%files -n compat32-%{name}
183%defattr(-,root,root,-)
184%{_libdir}/*.so.*
185%dir %{_libdir}/GConf
186%dir %{_libdir}/GConf/2
187%{_libdir}/GConf/2/*.so
188%{_libdir}/girepository-1.0
189%{_libdir}/gio/modules/libgsettingsgconfbackend.so
190
191%files -n compat32-%{name}-devel
192%defattr(-, root, root)
193%{_libdir}/*.so
194
195%endif
196
197%changelog
198* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
199- update to 3.2.6
200- remove %%{name}-gtk subpackage
201
202* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
203- remove *.pc from compat32-%{name}-devel
204
205* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
206- new upstream release
207
208* Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
209- new upstream release
210
211* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
212- new upstream release
213
214* Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
215- new upstream release
216
217* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
218- new upstream release
219
220* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.90-1
221- new upstream release
222
223* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.6-1
224- new upstream release
225- remove Patch2
226
227* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
228- new upstream release
229- change configure option (from --with-gtk=2.0 to --with-gtk=3.0)
230- replace Patch2 (GConf2-3.1.4-gsettings-data-convert.patch)
231- delete Patch3,4
232
233* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.32.1-2
234- add gtk subpackage to include gconf-sanity-check-2
235- add --with-gtk=2.0
236
237* Sat Feb 26 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
238- new upstream release
239
240* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
241- new upstream release
242- add BuildRequires: gobject-introspection-devel
243- create compat32-%{name} package
244
245* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.28.1-2
246- build with rpm-4.8.1-1 for pkg-config file
247
248* Sun Apr 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
249- new upstream release
250- drop Patch2, Patch3, Patch4
251
252* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
253- import upstream patches from fedora
254  - Patch1: gettext fix
255  - Patch2: avoid crash wen gconftool-2 cant read the db
256  - Patch3: make the defaults mechanism use the right polkit actions
257  - Patch4: donot catch segv etc. let abrt catch them
258- build with polkit, add BR: polkit-devel
259
260* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-1
261- new upstream release
262
263* Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
264- add BR: dbus-devel, dbus-glib-devel (<BTS:0700>)
265
266* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
267- new upstream release
268
269* Wed May 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
270- drop obsolete patch1
271
272* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-2
273- rebuilt with openldap-2.4.11
274
275* Thu Mar 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
276- new upstream release
277
278* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
279- new upstream release
280
281* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.23.2-1
282- new upstream release
283
284* Tue Jul 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.22.0-2
285- spec in UTF-8
286
287* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
288- new upstream release
289
290* Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
291- new upstream release
292- removed Prereq: install-info
293
294* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl2
295- rebuild with new environment
296
297* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0.1-0vl1
298- new upstream release
299
300* Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.14.0-0vl5
301- add BuildRequires: gtk2-devel
302
303* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.14.0-0vl4
304- rebuilt with openldap-2.3.27-0vl1
305
306* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 2.14.0-0vl3
307- rebuilt with openldap-2.3.24-0vl1
308
309* Tue May 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
310- add BuildRequires: openldap-devel
311
312* Sun Mar 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
313- new upstream release
314
315* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl2
316- reload gconf2 when schema is added/removed (patch0 from mdk)
317- only sync db once when installing multiple schemas. (patch1 from fc)
318
319* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.5-0vl1
320- new upstream release
321
322* Wed Jan 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
323- new upstream release
324
325* Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
326- new upstream release
327
328* Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.92-0vl1
329- new upstream release
330
331* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.90-0vl1
332- new upstream release
333
334* Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
335- new upstream version
336
337* Thu Nov 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
338- add Japanese summaries and descriptions.
339  thanks to spec file translation project.
340
341* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
342- new upstream release
343
344* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0.1-0vl1
345- new upstream release
346
347* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
348- new upstream release
349
350* Tue Sep 02 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.3-0vl1
351- new upstream release
352
353* Tue Jun 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
354- new upstream release
355- fix specfile kanjicode
356
357* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
358- new upstream release
359
360* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.90-0vl1
361- new upstream release
362
363* Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
364- build for Vine Linux
365
366* Fri Aug 30 2002 Havoc Pennington <hp@redhat.com>
367- add GCONF_LOCAL_LOCKS mode, and syslog encoding patch from tagoh
368
369* Wed Aug 21 2002 Havoc Pennington <hp@redhat.com>
370- add dialog to offer to delete gconf locks
371
372* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
373- 1.2.1
374- include libexecdir stuff
375
376* Wed Jul 31 2002 Havoc Pennington <hp@redhat.com>
377- move .pc fle to -devel package
378
379* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
380- automated rebuild
381
382* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
383- automated rebuild
384
385* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
386- fix warning on gnome-panel install
387
388* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
389- 1.2.0
390- own libdir/GConf/2 directory
391- include gtk-doc docs
392- don't include static lib for backend modules
393
394* Thu Jun 06 2002 Havoc Pennington <hp@redhat.com>
395- rebuild in different environment
396
397* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
398- 1.1.11
399- remove AUTHORS for rpmlint
400
401* Sun May 26 2002 Tim Powers <timp@redhat.com>
402- automated rebuild
403
404* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
405- rebuild in different environment
406
407* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
408- rebuild in different environment
409
410* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
411- 1.1.10
412
413* Thu Apr  4 2002 Jeremy Katz <katzj@redhat.com>
414- 1.1.9
415
416* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
417- 1.1.8
418- remove .la files
419
420* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
421- Version 1.1.6
422- Rebuild for dependencies
423
424* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
425- automated rebuild
426
427* Fri Jan  4 2002 Havoc Pennington <hp@redhat.com>
428- 1.1.5.93 snap with important bugfix so gconf actually works
429
430* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
431- 1.1.5.92 snap with GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
432
433* Thu Jan  3 2002 Havoc Pennington <hp@redhat.com>
434- 1.1.5.91 snap with gconf.m4 fix for libgnome
435
436* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
437- since every other build seems to avoid libglib-1.3.so.11,
438  rebuild and hope
439
440* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
441- cvs snap 1.1.5.90
442
443* Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
444- GConf 1.1.5, glib 1.3.11
445
446* Sat Oct 27 2001 Havoc Pennington <hp@redhat.com>
447- rebuild for glib 1.3.10
448
449* Sun Oct 14 2001 Havoc Pennington <hp@redhat.com>
450- 1.1.3
451
452* Fri Oct  5 2001 Havoc Pennington <hp@redhat.com>
453- cvs snap, remove bonobo-activation deps
454
455* Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
456- update to new CVS snap, rebuild
457
458* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
459- create gconf2 rpm based on gconf1, comment out pofiles
460- include .pc files
461
462* Fri Sep 14 2001 Havoc Pennington <hp@redhat.com>
463- fix description/summary
464
465* Fri Aug 31 2001 Havoc Pennington <hp@redhat.com>
466- Add po files from sources.redhat.com
467
468* Mon Aug 27 2001 Havoc Pennington <hp@redhat.com>
469- Add po files from sources.redhat.com
470
471* Wed Aug 15 2001 Havoc Pennington <hp@redhat.com>
472- upgrade to 1.0.4 release I just made
473- fixes #51223, syslog spew
474
475* Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
476- move gconf-config to devel RPM
477
478* Mon Jul 23 2001 Havoc Pennington <hp@redhat.com>
479- how many releases of GConf can I make before it works?
480
481* Sun Jul 22 2001 Havoc Pennington <hp@redhat.com>
482- Upgrade to 1.0.2 (which contains only bugfixes that
483  I reviewed and/or wrote myself)
484
485* Wed Jul 18 2001 Havoc Pennington <hp@redhat.com>
486- create the %{_sysconfdir}/gconf/gconf.xml.defaults directory
487
488* Fri Jul  6 2001 Alexander Larsson <alexl@redhat.com>
489- Install the .la files in the devel package.
490
491* Fri Jul  6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
492- Use %%{_tmppath}
493- Move the .so files to the devel subpackage
494- langify
495- Move changelog to the end, where it should be :)
496- Don't specify (a bad) doc directory
497- Don't define name, version and release and use it in the rpm headers later
498- Remove "Packager:"
499- s/Copyright/License/
500
501* Fri Jun 22 2001 Havoc Pennington <hp@redhat.com>
502- add --direct option to gconftool to avoid spawning oafd,
503  then commented out gconftool entirely since it checks
504  whether gconfd is running and that spawns oafd anyhow.
505  oafd simply needs to exit when unused.
506
507* Tue May 15 2001 Havoc Pennington <hp@redhat.com>
508- Fix post, pointed out by Bill
509
510* Mon May 14 2001 Havoc Pennington <hp@redhat.com>
511- Upgrade to 1.0.1
512
513* Tue Apr 17 2001 Jonathan Blandford <jrb@redhat.com>
514- Import to Red Hat build system.
515
516* Sun Jun 11 2000  Eskil Heyn Olsen <deity@eazel.com>
517
518- Created the .spec file
Note: See TracBrowser for help on using the repository browser.