source: projects/specs/tags/6_0_REL/t/thunderbird/thunderbird-vl.spec @ 4360

Revision 4360, 26.5 KB checked in by daisuke, 13 years ago (diff)

thunderbird: add --enable-install-strip to strip libxul.so

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 5.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 2%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-miramar
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal 5.0
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.8
22%define nss_version 3.12.6
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vineseed 0
29%define build_vine5 0
30
31%if "%{?_dist_release}" == "vl6"
32%define build_vineseed 1
33%endif
34%if "%{?_dist_release}" == "vl5"
35%define build_vine5 1
36%endif
37
38
39Summary:        Thunderbird Community Edition, Mail/newsgroup client
40Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
41Name:           thunderbird
42Version:        %{tbversion}
43Release:        %{tbrelease}
44URL:            http://www.mozilla.org/projects/thunderbird/
45License:        MPL
46Group:          Applications/Internet
47
48Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
49Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
50Source1010:     mozconfig-thunderbird-vine5
51Source1020:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55Source30:       thunderbird-open-browser.sh
56Source40:       thunderbird-unofficial-brandig-tb-brand.properties
57Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
58Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
59Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
60Source100:      find-external-requires
61
62# locale sources
63#%define MOZ_BUILD_LOCALES "ja"
64# get from mercurial repository with command,
65# mkdir l10n
66# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
67#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
68
69
70# upstream patch
71
72# Fix for version issues
73Patch0:         thunderbird-version.patch
74
75# customization patches
76Patch1:        firefox-1.5-default-a4-paper.patch
77
78BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
79BuildRequires:  pango-devel
80BuildRequires:  cairo-devel >= %{cairo_version}
81%if %{build_vineseed}
82BuildRequires:  nspr-devel >= %{nspr_version}
83BuildRequires:  nss-devel >= %{nss_version}
84BuildRequires:  hunspell-devel
85%endif
86BuildRequires:  pixman-devel
87BuildRequires:  libpng-devel
88%if %{build_vine5}
89BuildRequires:  libjpeg-devel
90%else
91BuildRequires:  libjpeg-turbo-devel
92%endif
93BuildRequires:  gtk2-devel
94BuildRequires:  zlib-devel, gzip, zip, unzip
95BuildRequires:  libIDL-devel
96BuildRequires:  freetype2-devel >= %{freetype_version}
97## disabled libnotify support
98## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
99BuildRequires:  libnotify-devel >= %{libnotify_version}
100BuildRequires:  bzip2-devel
101BuildRequires:  gnome-vfs2-devel
102BuildRequires:  libgnome-devel
103BuildRequires:  libgnomeui-devel
104BuildRequires:  krb5-devel
105BuildRequires:  pango-devel
106BuildRequires:  libXt-devel
107BuildRequires:  libXrender-devel
108# hunspell is in plus category for vine
109#BuildRequires: hunspell-devel
110BuildRequires:  sqlite3-devel >= %{sqlite_version}
111BuildRequires:  startup-notification-devel
112BuildRequires:  desktop-file-utils
113BuildRequires:  alsa-lib-devel
114BuildRequires:  yasm
115Requires:       sqlite3 >= %{sqlite_version}
116Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
117Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
118
119Obsoletes:      MozillaThunderbird
120Provides:       MozillaThunderbird = %{version}
121
122Packager:       daisuke, ryoichi, kazutaka
123
124AutoProv: 0
125%define _use_internal_dependency_generator 0
126%define __find_requires %{SOURCE100}
127
128%description
129Thunderbird is a standalone mail and newsgroup client.
130
131%description -l ja
132Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
133
134#===============================================================================
135
136%prep
137%setup -q %{name}-%{version} -c
138cd %{tarballdir}
139
140# Fix for version issue
141sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
142    > version.patch
143%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
144
145cd mozilla
146%patch1 -p1 -b .default-a4
147
148cd -
149%{__rm} -f .mozconfig
150%if %{build_vine5}
151%{__cp} %{SOURCE1010} .mozconfig
152%endif
153%if %{build_vineseed}
154%{__cp} %{SOURCE1020} .mozconfig
155%endif
156
157# setup unofficial branding name
158%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
159%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
160
161#===============================================================================
162
163%build
164cd %{tarballdir}
165
166INTERNAL_GECKO=%{version_internal}
167MOZ_APP_DIR=%{mozappdir}
168
169
170#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
171MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
172export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
173export CFLAGS="$RPM_OPT_FLAGS"
174export CXXFLAGS="$CFLAGS"
175export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
176
177%ifarch ppc ppc64 s390 s390x
178%define moz_make_flags -j1
179%else
180%define moz_make_flags %{?_smp_mflags}
181%endif
182
183export PREFIX='%{_prefix}'
184export LIBDIR='%{_libdir}'
185
186export LDFLAGS="-Wl,-rpath,%{mozappdir}"
187export MAKE="gmake %{moz_make_flags}"
188%{__make} -f client.mk build
189
190## build locales
191#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
192#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
193#for dir in $LOCALEDIRS
194#do
195#  for lang in %{MOZ_BUILD_LOCALES} ; do
196#    make -C $dir/locales AB_CD=$lang
197#  done
198#done
199
200#===============================================================================
201
202%install
203%{__rm} -rf $RPM_BUILD_ROOT
204cd %{tarballdir}
205
206INTERNAL_GECKO=%{version_internal}
207
208INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
209MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
210
211cd %{moz_objdir}
212DESTDIR=$RPM_BUILD_ROOT make install
213
214# install unofficial icons
215cd -
216
217%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
218%{__cp} mail/branding/unofficial/mailicon16.png \
219        $RPM_BUILD_ROOT/%{mozappdir}/icons/
220%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
221%{__cp} mail/branding/unofficial/mailicon16.png \
222        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
223%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
224%{__cp} mail/branding/unofficial/mailicon22.png \
225        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
226%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
227%{__cp} mail/branding/unofficial//mailicon24.png \
228        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
229%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
230%{__cp} mail/branding/unofficial/mailicon32.png \
231        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
232%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
233%{__cp} mail/branding/unofficial/mailicon48.png \
234        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
235%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
236%{__cp} mail/branding/unofficial/mailicon256.png \
237        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
238
239desktop-file-install --vendor vine \
240  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
241
242# set up the thunderbird start script
243rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
244%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
245  $RPM_BUILD_ROOT%{_bindir}/thunderbird
246%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
247
248install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
249%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
250
251%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
252                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
253        $RPM_BUILD_ROOT/vine-default-prefs
254%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
255%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
256%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
257
258%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
259
260# own mozilla plugin dir (#135050)
261%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
262
263# own extension directories
264%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
265%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
266
267# install locales
268#for lang in %{MOZ_BUILD_LOCALES} ; do
269#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
270#done
271
272# install ja.xpi to langpacks directory
273%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
274unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
275# also setup unofficial branding name
276%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
277%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
278
279
280%clean
281%{__rm} -rf $RPM_BUILD_ROOT
282
283#===============================================================================
284
285%post
286update-desktop-database &> /dev/null || :
287touch --no-create %{_datadir}/icons/hicolor
288if [ -x %{_bindir}/gtk-update-icon-cache ]; then
289  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
290fi
291
292%postun
293update-desktop-database &> /dev/null || :
294touch --no-create %{_datadir}/icons/hicolor
295if [ -x %{_bindir}/gtk-update-icon-cache ]; then
296  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
297fi
298
299
300%files
301%defattr(-,root,root,-)
302%attr(755,root,root) %{_bindir}/thunderbird
303%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
304%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
305%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
306%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
307%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
308%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
309%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
310%{mozappdir}
311#%{_libdir}/mozilla
312%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
313%exclude %{_datadir}/idl/%{name}-%{version_internal}
314%exclude %{_includedir}/%{name}-%{version_internal}
315%exclude %{_libdir}/%{name}-devel-%{version_internal}
316
317#===============================================================================
318
319%changelog
320* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
321- enable-install-strip
322
323* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
324- new upstream release
325- drop obsolete patch and renumber patch26 to patch1
326- add BuildRequires: yasm
327- enable libnotify support
328- add --disable-updater and --disable-installer to mozconfig
329- use ja.xpi instead of l10n source
330- update Source21: add step to setup langpack plugin
331- update Source20: add japanese translation
332- add Source42 & Source43 for localized branding
333- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
334  for mozconfig-thunderbird-vine5
335
336* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
337- new upstream release with security fix
338
339* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
340- new upstream release with security fix
341
342* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
343- new upstream release with security fix
344
345* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
346- new upstream release with security fix
347- add patch5 to fix build failure
348
349* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
350- new upstream release
351
352* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
353- new upstream release with security fix
354- add Patch1030 to fix compilation error
355
356* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
357- change mozconfig (Source1030 & 1040): add --enable-jsd
358
359* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
360- new upstream release
361
362* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
363- new upstream release with security fix
364- add Patch0 from fedora development: fix version issue
365- remove BuildRequires: hunspell-devel
366- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
367
368* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
369- add BuildRequires: alsa-lib-devel
370- remove BuildRequires: libnotify-devel
371  (workaround for known bug)
372- update mozconfig to add --disable-libnotify option
373
374* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
375- new upstream release
376- update spec entirely
377- import patches from fedora (Patch1, 2 & 4)
378- drop outdated patches (Patch22, 24)
379- update Sources:
380  - mozconfig (Source1030 & Source1040)
381  - default prefs.js (Source12)
382  - unofficial branding (Source40 & Source41)
383  - japanese translation (Source1000)
384- update Patch1000 (sjis-alias)
385
386* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
387- new upstream release
388
389* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
390- new upstream release
391
392* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
393- don't install official branding logos
394
395* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
396- add necessary icons in %%{tbdir}/chrome/icons/default
397- add Packager tag
398
399* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
400- new upstream release
401
402* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
403- new upstream release
404
405* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
406- new upstream release
407
408* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
409- new upstream release
410
411* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
412- rebuilt for VineSeed
413
414* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
415- new upstream release
416
417* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
418- new upstream release
419- built for Vine Linux 4.x
420- dropped Patch1020 (merged into upstream)
421
422* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
423- added Patch1020 for workaround gcc visibility hidden bugs
424
425* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
426- build with new environment/toolchain
427- add build options to build with external nss/nspr libraries
428    ac_add_options --with-system-nspr
429    ac_add_options --with-system-nss
430
431* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
432- new upstream release
433
434* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
435- new upstream release
436
437* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
438- new upstream release
439
440* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
441- new upstream release
442
443* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
444- new upstream release
445- merge changes from firefox
446  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
447
448* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
449- new upstream release
450- build en-US locale
451- merge changes from firefox
452  - add upstream patches
453  - disable pango rendering by default
454    (workaround fix slow rendering in some page)
455
456* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
457- initial build for Vine Linux based on FC package
458- update to 1.5RC2
459
460* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
461- Fix issue with popup dialogs and other actions causing lockups
462
463* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
464- Update to 1.5 rc1
465
466* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
467- Update to 1.5 beta2
468
469* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
470- Update to 1.5 beta1
471- Bring the install phase of the spec file up to speed
472
473* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
474- Rebuild
475
476* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
477- Add patch to make file chooser dialog modal
478
479* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
480- Update to 1.0.6
481
482* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
483- 1.0.6 Release Candidate
484
485* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
486- Use system NSPR
487- Fix crash on 64bit platforms (#160330)
488
489* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
490- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
491  references, fixing the "no fonts" problem.
492
493* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
494- Change the Exec line in the desktop file to `thunderbird`
495
496* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
497- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
498
499* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
500- Add temporary workaround to not create files in the user's $HOME (#149664)
501
502* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
503- Don't have downloads "disappear" when downloading to desktop (#139015)
504- Fix for some more cursor issues in textareas (149991, 150002, 152089)
505- Add upstream patch to fix bidi justification of pango
506- Add patch to fix launching of helper applications
507- Add patch to properly link against libgfxshared_s.a
508- Fix multilib conflicts
509
510* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
511- correct confusing PANGO vars in startup script
512
513* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
514- Thunderbird 1.0.2
515
516* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
517- Add patch to compile against new fortified glibc macros
518
519* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
520- Rebuild against GCC 4.0
521- Add execshield patches
522- Minor specfile cleanup
523
524* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
525- Rebuild
526
527* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
528- Add RPM version to useragent
529
530* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
531- Port over pango patches from firefox
532
533* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
534- Thunderbird 1.0
535
536* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
537- Fix advanced prefs
538
539* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
540- Make this run on s390(x) now for real
541
542* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
543- Update to 1.0 rc1
544
545* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
546- Add patches to build and run on s390(x)
547
548* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
549- Rebuild to fix file chooser
550
551* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
552- Update to 0.9
553
554* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
555- Prevent inlining of stack direction detection (#135255)
556
557* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
558- More file chooser fixes (same as in firefox)
559- Fix for upstream 28327.
560
561* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
562- Update the pango patch
563
564* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
565- Pull over patches from firefox build:
566  - disable default application dialog
567  - don't include software update since it doesn't work
568  - make external app support work
569
570* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
571- Use pango for rendering
572
573* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
574- Fix for 64 bit crash at startup (b.m.o #256603)
575
576* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
577- Add patches to fix xremote (#135036)
578
579* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
580- Add patch to fix button focus issues (#133507)
581- Add patch for fix IMAP race issues (bmo #246439)
582
583* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
584- filter out library Provides: and internal Requires:
585
586* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
587- Backport the GTK+ File Chooser.
588- Add fix for JS math on x86_64 systems
589- Add pkgconfig patch
590
591* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
592- Update to 0.8.0
593- Remove enigmail
594- Update BuildRequires
595- Remove gcc34 and extension manager patches -- they are upstreamed.
596- Fix for gnome-vfs2 error at component registration
597
598* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
599- Build with --disable-xprint
600
601* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
602- remove all Xvfb-related hacks
603
604* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
605- actually apply psfonts
606- add mozilla gnome-uriloader patch to prevent build failure
607
608* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
609- rawhide import
610- apply NetBSD's freetype 2.1.8 patch
611- apply psfonts patch
612- remove BR on /usr/bin/ex, breaks beehive
613
614* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
615- oops, fix %%install
616
617* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
618- update to Thunderbird 0.7.3 and Enigmail 0.85.0
619- remove XUL.mfasl on startup, add Debian enigmail patches
620- add Xvfb hack for -install-global-extension
621
622* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
623- update to 0.7.2, just because it's there
624- update gcc-3.4 patch (Kaj Niemi)
625- add EM registration patch and remove instdir hack
626
627* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
628- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
629
630* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
631- update to 0.7.1
632- remove Enigmail
633
634* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
635- re-enable Enigmail 0.84.1
636- add gcc-3.4 patch (Kaj Niemi)
637- use official branding (with permission)
638
639* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
640- update to 0.7
641- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
642- specify libdir, change BR for apt (V. Skytt辰, #1617)
643
644* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
645- temporary workaround for enigmail skin "modern" bug
646
647* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
648- update to Enigmail 0.84.0
649- update launch script
650
651* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
652- installation directory now versioned
653- allow root to run the program (for installing extensions)
654- remove unnecessary %%pre and %%post
655- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
656
657* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
658- include Enigmail, re-add release notes
659- delete %{_libdir}/thunderbird in %%pre
660
661* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
662- update to Thunderbird 0.6
663
664* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
665- update to Thunderbird 0.6 RC1
666- add new icon, remove release notes
667
668* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
669- update to latest CVS, update mozconfig and %%build accordingly
670- update to Enigmail 0.83.6
671- remove x-remote and x86_64 patches
672- build with -Os
673
674* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
675- update x-remote patch
676- more startup script fixes
677
678* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
679- startup script fixes, and a minor cleanup
680
681* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
682- Minor cleanups
683
684* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
685- minor improvements to open-browser.sh and startup script
686- update to latest version of Blizzard's x-remote patch
687
688* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
689- update open-browser.sh, startup script, and BuildRequires
690
691* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
692- update open-browser script, modify BuildRequires (Warren)
693- add Blizzard's x-remote patch
694- initial attempt at x-remote-enabled startup script
695
696* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
697- refuse to run with excessive privileges
698
699* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
700- add Mozilla x86_64 patch (Oliver Sontag)
701- Enigmail source filenames now include the version
702- modify BuildRoot
703
704* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
705- use the updated official tarball
706
707* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
708- fix %%prep script
709
710* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
711- update Enigmail to 0.83.3
712- use official source tarball (after removing the CRLFs)
713- package renamed to thunderbird
714
715* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
716- update to 0.5
717- check for lockfile before launching
718
719* Fri Feb 06 2004 David Hill <djh[at]ii.net>
720- update to latest cvs
721- update to Enigmail 0.83.2
722
723* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
724- update to Enigmail 0.83.1
725- removed Mozilla/Firebird script patching
726
727* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
728- add startup notification to .desktop file
729
730* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
731- open-browser.sh release 3
732- patch broken /usr/bin/mozilla script during install
733- dir ownership
734- XXX: Source fails build on x86_64... fix later
735
736* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
737- update to Enigmail 0.82.5
738- add Warren's open-browser.sh (#1113)
739
740* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
741- use Thunderbird's mozilla-xremote-client to launch browser
742
743* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
744- update to 0.4
745- make hyperlinks work (with recent versions of Firebird/Mozilla)
746
747* Thu Dec 04 2003 David Hill <djh[at]ii.net>
748- update to 0.4rc2
749
750* Wed Dec 03 2003 David Hill <djh[at]ii.net>
751- update to 0.4rc1 and Enigmail 0.82.4
752
753* Thu Nov 27 2003 David Hill <djh[at]ii.net>
754- update to latest CVS and Enigmail 0.82.3
755
756* Sun Nov 16 2003 David Hill <djh[at]ii.net>
757- update to latest CVS (0.4a)
758- update Enigmail to 0.82.2
759- alter mozconfig for new build requirements
760- add missing BuildReq (#987)
761
762* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
763- update to 0.3
764
765* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
766- update to 0.3rc3
767- update Enigmail to 0.81.7
768
769* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
770- update to 0.3rc2
771
772* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
773- simplify startup script
774
775* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
776- add GPG support (Enigmail 0.81.6)
777- specfile fixes (#679)
778
779* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
780- update to 0.2
781
782* Mon Sep 01 2003 David Hill <djh[at]ii.net>
783- initial RPM
784  (based on the fedora MozillaFirebird-0.6.1 specfile)
785
Note: See TracBrowser for help on using the repository browser.