source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 4341

Revision 4341, 26.4 KB checked in by kazutaka, 13 years ago (diff)

update to 5.0

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 5.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 1%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-miramar
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal 5.0
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.8
22%define nss_version 3.12.6
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vineseed 0
29%define build_vine5 0
30
31%if "%{?_dist_release}" == "vl6"
32%define build_vineseed 1
33%endif
34%if "%{?_dist_release}" == "vl5"
35%define build_vine5 1
36%endif
37
38
39Summary:        Thunderbird Community Edition, Mail/newsgroup client
40Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
41Name:           thunderbird
42Version:        %{tbversion}
43Release:        %{tbrelease}
44URL:            http://www.mozilla.org/projects/thunderbird/
45License:        MPL
46Group:          Applications/Internet
47
48Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
49Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
50Source1010:     mozconfig-thunderbird-vine5
51Source1020:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55Source30:       thunderbird-open-browser.sh
56Source40:       thunderbird-unofficial-brandig-tb-brand.properties
57Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
58Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
59Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
60Source100:      find-external-requires
61
62# locale sources
63#%define MOZ_BUILD_LOCALES "ja"
64# get from mercurial repository with command,
65# mkdir l10n
66# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
67#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
68
69
70# upstream patch
71
72# Fix for version issues
73Patch0:         thunderbird-version.patch
74
75# customization patches
76Patch1:        firefox-1.5-default-a4-paper.patch
77
78BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
79BuildRequires:  pango-devel
80BuildRequires:  cairo-devel >= %{cairo_version}
81%if %{build_vineseed}
82BuildRequires:  nspr-devel >= %{nspr_version}
83BuildRequires:  nss-devel >= %{nss_version}
84%endif
85BuildRequires:  pixman-devel
86BuildRequires:  libpng-devel
87%if %{build_vine5}
88BuildRequires:  libjpeg-devel
89%else
90BuildRequires:  libjpeg-turbo-devel
91%endif
92BuildRequires:  gtk2-devel
93BuildRequires:  zlib-devel, gzip, zip, unzip
94BuildRequires:  libIDL-devel
95BuildRequires:  freetype2-devel >= %{freetype_version}
96## disabled libnotify support
97## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
98BuildRequires:  libnotify-devel >= %{libnotify_version}
99BuildRequires:  bzip2-devel
100BuildRequires:  gnome-vfs2-devel
101BuildRequires:  libgnome-devel
102BuildRequires:  libgnomeui-devel
103BuildRequires:  krb5-devel
104BuildRequires:  pango-devel
105BuildRequires:  libXt-devel
106BuildRequires:  libXrender-devel
107# hunspell is in plus category for vine
108#BuildRequires: hunspell-devel
109BuildRequires:  sqlite3-devel >= %{sqlite_version}
110BuildRequires:  startup-notification-devel
111BuildRequires:  desktop-file-utils
112BuildRequires:  alsa-lib-devel
113BuildRequires:  yasm
114Requires:       sqlite3 >= %{sqlite_version}
115Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
116Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
117
118Obsoletes:      MozillaThunderbird
119Provides:       MozillaThunderbird = %{version}
120
121Packager:       daisuke, ryoichi, kazutaka
122
123AutoProv: 0
124%define _use_internal_dependency_generator 0
125%define __find_requires %{SOURCE100}
126
127%description
128Thunderbird is a standalone mail and newsgroup client.
129
130%description -l ja
131Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
132
133#===============================================================================
134
135%prep
136%setup -q %{name}-%{version} -c
137cd %{tarballdir}
138
139# Fix for version issue
140sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
141    > version.patch
142%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
143
144cd mozilla
145%patch1 -p1 -b .default-a4
146
147cd -
148%{__rm} -f .mozconfig
149%if %{build_vine5}
150%{__cp} %{SOURCE1010} .mozconfig
151%endif
152%if %{build_vineseed}
153%{__cp} %{SOURCE1020} .mozconfig
154%endif
155
156# setup unofficial branding name
157%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
158%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
159
160#===============================================================================
161
162%build
163cd %{tarballdir}
164
165INTERNAL_GECKO=%{version_internal}
166MOZ_APP_DIR=%{mozappdir}
167
168
169#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
170MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
171export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
172export CFLAGS="$RPM_OPT_FLAGS"
173export CXXFLAGS="$CFLAGS"
174export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
175
176%ifarch ppc ppc64 s390 s390x
177%define moz_make_flags -j1
178%else
179%define moz_make_flags %{?_smp_mflags}
180%endif
181
182export PREFIX='%{_prefix}'
183export LIBDIR='%{_libdir}'
184
185export LDFLAGS="-Wl,-rpath,%{mozappdir}"
186export MAKE="gmake %{moz_make_flags}"
187%{__make} -f client.mk build
188
189## build locales
190#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
191#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
192#for dir in $LOCALEDIRS
193#do
194#  for lang in %{MOZ_BUILD_LOCALES} ; do
195#    make -C $dir/locales AB_CD=$lang
196#  done
197#done
198
199#===============================================================================
200
201%install
202%{__rm} -rf $RPM_BUILD_ROOT
203cd %{tarballdir}
204
205INTERNAL_GECKO=%{version_internal}
206
207INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
208MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
209
210cd %{moz_objdir}
211DESTDIR=$RPM_BUILD_ROOT make install
212
213# install unofficial icons
214cd -
215
216%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
217%{__cp} mail/branding/unofficial/mailicon16.png \
218        $RPM_BUILD_ROOT/%{mozappdir}/icons/
219%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
220%{__cp} mail/branding/unofficial/mailicon16.png \
221        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
222%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
223%{__cp} mail/branding/unofficial/mailicon22.png \
224        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
225%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
226%{__cp} mail/branding/unofficial//mailicon24.png \
227        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
228%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
229%{__cp} mail/branding/unofficial/mailicon32.png \
230        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
231%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
232%{__cp} mail/branding/unofficial/mailicon48.png \
233        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
234%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
235%{__cp} mail/branding/unofficial/mailicon256.png \
236        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
237
238desktop-file-install --vendor vine \
239  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
240
241# set up the thunderbird start script
242rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
243%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
244  $RPM_BUILD_ROOT%{_bindir}/thunderbird
245%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
246
247install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
248%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
249
250%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
251                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
252        $RPM_BUILD_ROOT/vine-default-prefs
253%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
254%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
255%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
256
257%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
258
259# own mozilla plugin dir (#135050)
260%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
261
262# own extension directories
263%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
264%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
265
266# install locales
267#for lang in %{MOZ_BUILD_LOCALES} ; do
268#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
269#done
270
271# install ja.xpi to langpacks directory
272%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
273unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
274# also setup unofficial branding name
275%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
276%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
277
278
279%clean
280%{__rm} -rf $RPM_BUILD_ROOT
281
282#===============================================================================
283
284%post
285update-desktop-database &> /dev/null || :
286touch --no-create %{_datadir}/icons/hicolor
287if [ -x %{_bindir}/gtk-update-icon-cache ]; then
288  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
289fi
290
291%postun
292update-desktop-database &> /dev/null || :
293touch --no-create %{_datadir}/icons/hicolor
294if [ -x %{_bindir}/gtk-update-icon-cache ]; then
295  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
296fi
297
298
299%files
300%defattr(-,root,root,-)
301%attr(755,root,root) %{_bindir}/thunderbird
302%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
303%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
304%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
305%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
306%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
307%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
308%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
309%{mozappdir}
310#%{_libdir}/mozilla
311%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
312%exclude %{_datadir}/idl/%{name}-%{version_internal}
313%exclude %{_includedir}/%{name}-%{version_internal}
314%exclude %{_libdir}/%{name}-devel-%{version_internal}
315
316#===============================================================================
317
318%changelog
319* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
320- new upstream release
321- drop obsolete patch and renumber patch26 to patch1
322- add BuildRequires: yasm
323- enable libnotify support
324- add --disable-updater and --disable-installer to mozconfig
325- use ja.xpi instead of l10n source
326- update Source21: add step to setup langpack plugin
327- update Source20: add japanese translation
328- add Source42 & Source43 for localized branding
329- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
330  for mozconfig-thunderbird-vine5
331
332* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
333- new upstream release with security fix
334
335* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
336- new upstream release with security fix
337
338* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
339- new upstream release with security fix
340
341* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
342- new upstream release with security fix
343- add patch5 to fix build failure
344
345* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
346- new upstream release
347
348* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
349- new upstream release with security fix
350- add Patch1030 to fix compilation error
351
352* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
353- change mozconfig (Source1030 & 1040): add --enable-jsd
354
355* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
356- new upstream release
357
358* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
359- new upstream release with security fix
360- add Patch0 from fedora development: fix version issue
361- remove BuildRequires: hunspell-devel
362- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
363
364* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
365- add BuildRequires: alsa-lib-devel
366- remove BuildRequires: libnotify-devel
367  (workaround for known bug)
368- update mozconfig to add --disable-libnotify option
369
370* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
371- new upstream release
372- update spec entirely
373- import patches from fedora (Patch1, 2 & 4)
374- drop outdated patches (Patch22, 24)
375- update Sources:
376  - mozconfig (Source1030 & Source1040)
377  - default prefs.js (Source12)
378  - unofficial branding (Source40 & Source41)
379  - japanese translation (Source1000)
380- update Patch1000 (sjis-alias)
381
382* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
383- new upstream release
384
385* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
386- new upstream release
387
388* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
389- don't install official branding logos
390
391* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
392- add necessary icons in %%{tbdir}/chrome/icons/default
393- add Packager tag
394
395* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
396- new upstream release
397
398* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
399- new upstream release
400
401* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
402- new upstream release
403
404* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
405- new upstream release
406
407* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
408- rebuilt for VineSeed
409
410* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
411- new upstream release
412
413* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
414- new upstream release
415- built for Vine Linux 4.x
416- dropped Patch1020 (merged into upstream)
417
418* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
419- added Patch1020 for workaround gcc visibility hidden bugs
420
421* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
422- build with new environment/toolchain
423- add build options to build with external nss/nspr libraries
424    ac_add_options --with-system-nspr
425    ac_add_options --with-system-nss
426
427* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
428- new upstream release
429
430* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
431- new upstream release
432
433* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
434- new upstream release
435
436* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
437- new upstream release
438
439* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
440- new upstream release
441- merge changes from firefox
442  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
443
444* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
445- new upstream release
446- build en-US locale
447- merge changes from firefox
448  - add upstream patches
449  - disable pango rendering by default
450    (workaround fix slow rendering in some page)
451
452* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
453- initial build for Vine Linux based on FC package
454- update to 1.5RC2
455
456* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
457- Fix issue with popup dialogs and other actions causing lockups
458
459* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
460- Update to 1.5 rc1
461
462* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
463- Update to 1.5 beta2
464
465* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
466- Update to 1.5 beta1
467- Bring the install phase of the spec file up to speed
468
469* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
470- Rebuild
471
472* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
473- Add patch to make file chooser dialog modal
474
475* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
476- Update to 1.0.6
477
478* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
479- 1.0.6 Release Candidate
480
481* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
482- Use system NSPR
483- Fix crash on 64bit platforms (#160330)
484
485* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
486- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
487  references, fixing the "no fonts" problem.
488
489* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
490- Change the Exec line in the desktop file to `thunderbird`
491
492* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
493- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
494
495* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
496- Add temporary workaround to not create files in the user's $HOME (#149664)
497
498* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
499- Don't have downloads "disappear" when downloading to desktop (#139015)
500- Fix for some more cursor issues in textareas (149991, 150002, 152089)
501- Add upstream patch to fix bidi justification of pango
502- Add patch to fix launching of helper applications
503- Add patch to properly link against libgfxshared_s.a
504- Fix multilib conflicts
505
506* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
507- correct confusing PANGO vars in startup script
508
509* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
510- Thunderbird 1.0.2
511
512* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
513- Add patch to compile against new fortified glibc macros
514
515* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
516- Rebuild against GCC 4.0
517- Add execshield patches
518- Minor specfile cleanup
519
520* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
521- Rebuild
522
523* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
524- Add RPM version to useragent
525
526* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
527- Port over pango patches from firefox
528
529* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
530- Thunderbird 1.0
531
532* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
533- Fix advanced prefs
534
535* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
536- Make this run on s390(x) now for real
537
538* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
539- Update to 1.0 rc1
540
541* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
542- Add patches to build and run on s390(x)
543
544* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
545- Rebuild to fix file chooser
546
547* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
548- Update to 0.9
549
550* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
551- Prevent inlining of stack direction detection (#135255)
552
553* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
554- More file chooser fixes (same as in firefox)
555- Fix for upstream 28327.
556
557* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
558- Update the pango patch
559
560* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
561- Pull over patches from firefox build:
562  - disable default application dialog
563  - don't include software update since it doesn't work
564  - make external app support work
565
566* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
567- Use pango for rendering
568
569* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
570- Fix for 64 bit crash at startup (b.m.o #256603)
571
572* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
573- Add patches to fix xremote (#135036)
574
575* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
576- Add patch to fix button focus issues (#133507)
577- Add patch for fix IMAP race issues (bmo #246439)
578
579* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
580- filter out library Provides: and internal Requires:
581
582* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
583- Backport the GTK+ File Chooser.
584- Add fix for JS math on x86_64 systems
585- Add pkgconfig patch
586
587* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
588- Update to 0.8.0
589- Remove enigmail
590- Update BuildRequires
591- Remove gcc34 and extension manager patches -- they are upstreamed.
592- Fix for gnome-vfs2 error at component registration
593
594* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
595- Build with --disable-xprint
596
597* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
598- remove all Xvfb-related hacks
599
600* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
601- actually apply psfonts
602- add mozilla gnome-uriloader patch to prevent build failure
603
604* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
605- rawhide import
606- apply NetBSD's freetype 2.1.8 patch
607- apply psfonts patch
608- remove BR on /usr/bin/ex, breaks beehive
609
610* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
611- oops, fix %%install
612
613* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
614- update to Thunderbird 0.7.3 and Enigmail 0.85.0
615- remove XUL.mfasl on startup, add Debian enigmail patches
616- add Xvfb hack for -install-global-extension
617
618* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
619- update to 0.7.2, just because it's there
620- update gcc-3.4 patch (Kaj Niemi)
621- add EM registration patch and remove instdir hack
622
623* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
624- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
625
626* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
627- update to 0.7.1
628- remove Enigmail
629
630* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
631- re-enable Enigmail 0.84.1
632- add gcc-3.4 patch (Kaj Niemi)
633- use official branding (with permission)
634
635* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
636- update to 0.7
637- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
638- specify libdir, change BR for apt (V. Skytt辰, #1617)
639
640* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
641- temporary workaround for enigmail skin "modern" bug
642
643* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
644- update to Enigmail 0.84.0
645- update launch script
646
647* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
648- installation directory now versioned
649- allow root to run the program (for installing extensions)
650- remove unnecessary %%pre and %%post
651- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
652
653* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
654- include Enigmail, re-add release notes
655- delete %{_libdir}/thunderbird in %%pre
656
657* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
658- update to Thunderbird 0.6
659
660* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
661- update to Thunderbird 0.6 RC1
662- add new icon, remove release notes
663
664* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
665- update to latest CVS, update mozconfig and %%build accordingly
666- update to Enigmail 0.83.6
667- remove x-remote and x86_64 patches
668- build with -Os
669
670* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
671- update x-remote patch
672- more startup script fixes
673
674* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
675- startup script fixes, and a minor cleanup
676
677* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
678- Minor cleanups
679
680* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
681- minor improvements to open-browser.sh and startup script
682- update to latest version of Blizzard's x-remote patch
683
684* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
685- update open-browser.sh, startup script, and BuildRequires
686
687* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
688- update open-browser script, modify BuildRequires (Warren)
689- add Blizzard's x-remote patch
690- initial attempt at x-remote-enabled startup script
691
692* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
693- refuse to run with excessive privileges
694
695* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
696- add Mozilla x86_64 patch (Oliver Sontag)
697- Enigmail source filenames now include the version
698- modify BuildRoot
699
700* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
701- use the updated official tarball
702
703* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
704- fix %%prep script
705
706* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
707- update Enigmail to 0.83.3
708- use official source tarball (after removing the CRLFs)
709- package renamed to thunderbird
710
711* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
712- update to 0.5
713- check for lockfile before launching
714
715* Fri Feb 06 2004 David Hill <djh[at]ii.net>
716- update to latest cvs
717- update to Enigmail 0.83.2
718
719* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
720- update to Enigmail 0.83.1
721- removed Mozilla/Firebird script patching
722
723* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
724- add startup notification to .desktop file
725
726* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
727- open-browser.sh release 3
728- patch broken /usr/bin/mozilla script during install
729- dir ownership
730- XXX: Source fails build on x86_64... fix later
731
732* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
733- update to Enigmail 0.82.5
734- add Warren's open-browser.sh (#1113)
735
736* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
737- use Thunderbird's mozilla-xremote-client to launch browser
738
739* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
740- update to 0.4
741- make hyperlinks work (with recent versions of Firebird/Mozilla)
742
743* Thu Dec 04 2003 David Hill <djh[at]ii.net>
744- update to 0.4rc2
745
746* Wed Dec 03 2003 David Hill <djh[at]ii.net>
747- update to 0.4rc1 and Enigmail 0.82.4
748
749* Thu Nov 27 2003 David Hill <djh[at]ii.net>
750- update to latest CVS and Enigmail 0.82.3
751
752* Sun Nov 16 2003 David Hill <djh[at]ii.net>
753- update to latest CVS (0.4a)
754- update Enigmail to 0.82.2
755- alter mozconfig for new build requirements
756- add missing BuildReq (#987)
757
758* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
759- update to 0.3
760
761* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
762- update to 0.3rc3
763- update Enigmail to 0.81.7
764
765* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
766- update to 0.3rc2
767
768* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
769- simplify startup script
770
771* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
772- add GPG support (Enigmail 0.81.6)
773- specfile fixes (#679)
774
775* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
776- update to 0.2
777
778* Mon Sep 01 2003 David Hill <djh[at]ii.net>
779- initial RPM
780  (based on the fedora MozillaFirebird-0.6.1 specfile)
781
Note: See TracBrowser for help on using the repository browser.