source: projects/specs/trunk/t/thunderbird/thunderbird-vl.spec @ 4616

Revision 4616, 26.6 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1# do not include minor version number in MOZILLA_FIVE_HOME
2%define tbmajor 5.0
3#%define tbversion %{tbmajor}.10
4%define tbversion %{tbmajor}
5%define tbrelease 3%{?_dist_release}
6
7# The tarball is pretty inconsistent with directory structure.
8# Sometimes there is a top level directory.  That goes here.
9#
10# IMPORTANT: If there is no top level directory, this should be
11# set to the cwd, ie: '.'
12#%define tarballdir .
13%define tarballdir comm-miramar
14
15%define mozappdir %{_libdir}/%{name}-%{version_internal}
16%define moz_objdir objdir-tb
17%define version_internal 5.0
18%define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
19
20%define desktop_file_utils_version 0.6
21%define nspr_version 4.8
22%define nss_version 3.12.6
23%define cairo_version 1.6.0
24%define freetype_version 2.1.9
25%define sqlite_version 3.6.14
26%define libnotify_version 0.4
27
28%define build_vineseed 0
29%define build_vine5 0
30
31%if "%{?_dist_release}" >= "vl6"
32%define build_vineseed 1
33%endif
34%if "%{?_dist_release}" == "vl5"
35%define build_vine5 1
36%endif
37
38
39Summary:        Thunderbird Community Edition, Mail/newsgroup client
40Summary(ja):    Thunderbirdコミュニティエディション, メール・ニュースクライアント
41Name:           thunderbird
42Version:        %{tbversion}
43Release:        %{tbrelease}
44URL:            http://www.mozilla.org/projects/thunderbird/
45License:        MPL
46Group:          Applications/Internet
47
48Source0:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
49Source1:        ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/linux-x86_64/xpi/ja.xpi
50Source1010:     mozconfig-thunderbird-vine5
51Source1020:     mozconfig-thunderbird-vine6
52Source12:       thunderbird-vine-default-prefs.js
53Source20:       thunderbird.desktop
54Source21:       thunderbird.vine.sh.in
55Source30:       thunderbird-open-browser.sh
56Source40:       thunderbird-unofficial-brandig-tb-brand.properties
57Source41:       thunderbird-unofficial-brandig-tb-brand.dtd
58Source42:       thunderbird-unofficial-brandig-tb-ja-brand.properties
59Source43:       thunderbird-unofficial-brandig-tb-ja-brand.dtd
60Source100:      find-external-requires
61
62# locale sources
63#%define MOZ_BUILD_LOCALES "ja"
64# get from mercurial repository with command,
65# mkdir l10n
66# hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
67#Source1000:     thunderbird-%{tbversion}-ja.tar.bz2
68
69
70# upstream patch
71
72# Fix for version issues
73Patch0:         thunderbird-version.patch
74
75# customization patches
76Patch1:        firefox-1.5-default-a4-paper.patch
77
78BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
79BuildRequires:  pango-devel
80BuildRequires:  cairo-devel >= %{cairo_version}
81%if %{build_vineseed}
82BuildRequires:  nspr-devel >= %{nspr_version}
83BuildRequires:  nss-devel >= %{nss_version}
84BuildRequires:  hunspell-devel
85%endif
86BuildRequires:  pixman-devel
87BuildRequires:  libpng-devel
88%if %{build_vine5}
89BuildRequires:  libjpeg-devel
90%else
91BuildRequires:  libjpeg-turbo-devel
92%endif
93BuildRequires:  gtk2-devel
94BuildRequires:  zlib-devel, gzip, zip, unzip
95BuildRequires:  libIDL-devel
96BuildRequires:  freetype2-devel >= %{freetype_version}
97## disabled libnotify support
98## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
99BuildRequires:  libnotify-devel >= %{libnotify_version}
100BuildRequires:  bzip2-devel
101BuildRequires:  gnome-vfs2-devel
102BuildRequires:  libgnome-devel
103BuildRequires:  libgnomeui-devel
104BuildRequires:  krb5-devel
105BuildRequires:  pango-devel
106BuildRequires:  libXt-devel
107BuildRequires:  libXrender-devel
108# hunspell is in plus category for vine
109#BuildRequires: hunspell-devel
110BuildRequires:  sqlite3-devel >= %{sqlite_version}
111BuildRequires:  startup-notification-devel
112BuildRequires:  desktop-file-utils
113BuildRequires:  alsa-lib-devel
114BuildRequires:  yasm
115Requires:       sqlite3 >= %{sqlite_version}
116Requires(post):         desktop-file-utils >= %{desktop_file_utils_version}
117Requires(postun):       desktop-file-utils >= %{desktop_file_utils_version}
118
119Obsoletes:      MozillaThunderbird
120Provides:       MozillaThunderbird = %{version}
121
122Vendor:         Project Vine
123Distribution:   Vine Linux
124Packager:       daisuke, ryoichi, kazutaka
125
126AutoProv: 0
127%define _use_internal_dependency_generator 0
128%define __find_requires %{SOURCE100}
129
130%description
131Thunderbird is a standalone mail and newsgroup client.
132
133%description -l ja
134Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
135
136#===============================================================================
137
138%prep
139%setup -q %{name}-%{version} -c
140cd %{tarballdir}
141
142# Fix for version issue
143sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
144    > version.patch
145%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
146
147cd mozilla
148%patch1 -p1 -b .default-a4
149
150cd -
151%{__rm} -f .mozconfig
152%if %{build_vine5}
153%{__cp} %{SOURCE1010} .mozconfig
154%endif
155%if %{build_vineseed}
156%{__cp} %{SOURCE1020} .mozconfig
157%endif
158
159# setup unofficial branding name
160%{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
161%{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
162
163#===============================================================================
164
165%build
166cd %{tarballdir}
167
168INTERNAL_GECKO=%{version_internal}
169MOZ_APP_DIR=%{mozappdir}
170
171
172#MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
173MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
174export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
175export CFLAGS="$RPM_OPT_FLAGS"
176export CXXFLAGS="$CFLAGS"
177export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
178
179%ifarch ppc ppc64 s390 s390x
180%define moz_make_flags -j1
181%else
182%define moz_make_flags %{?_smp_mflags}
183%endif
184
185export PREFIX='%{_prefix}'
186export LIBDIR='%{_libdir}'
187
188export LDFLAGS="-Wl,-rpath,%{mozappdir}"
189export MAKE="gmake %{moz_make_flags}"
190%{__make} -f client.mk build
191
192## build locales
193#LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
194#            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
195#for dir in $LOCALEDIRS
196#do
197#  for lang in %{MOZ_BUILD_LOCALES} ; do
198#    make -C $dir/locales AB_CD=$lang
199#  done
200#done
201
202#===============================================================================
203
204%install
205%{__rm} -rf $RPM_BUILD_ROOT
206cd %{tarballdir}
207
208INTERNAL_GECKO=%{version_internal}
209
210INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
211MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
212
213cd %{moz_objdir}
214DESTDIR=$RPM_BUILD_ROOT make install
215
216# install unofficial icons
217cd -
218
219%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/icons
220%{__cp} mail/branding/unofficial/mailicon16.png \
221        $RPM_BUILD_ROOT/%{mozappdir}/icons/
222%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
223%{__cp} mail/branding/unofficial/mailicon16.png \
224        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
225%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
226%{__cp} mail/branding/unofficial/mailicon22.png \
227        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
228%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
229%{__cp} mail/branding/unofficial//mailicon24.png \
230        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
231%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
232%{__cp} mail/branding/unofficial/mailicon32.png \
233        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
234%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
235%{__cp} mail/branding/unofficial/mailicon48.png \
236        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
237%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
238%{__cp} mail/branding/unofficial/mailicon256.png \
239        $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
240
241desktop-file-install --vendor vine \
242  --dir $RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE20}
243
244# set up the thunderbird start script
245rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
246%{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
247  $RPM_BUILD_ROOT%{_bindir}/thunderbird
248%{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
249
250install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
251%{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
252
253%{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
254                                -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
255        $RPM_BUILD_ROOT/vine-default-prefs
256%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
257%{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
258%{__rm} $RPM_BUILD_ROOT/vine-default-prefs
259
260%{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
261
262# own mozilla plugin dir (#135050)
263%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
264
265# own extension directories
266%{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
267%{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
268
269# install locales
270#for lang in %{MOZ_BUILD_LOCALES} ; do
271#  %{__install} -p -D -m 664 %{moz_objdir}/objdir-tb/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
272#done
273
274# install ja.xpi to langpacks directory
275%{__mkdir_p} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
276unzip %{SOURCE1} -d $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org
277# also setup unofficial branding name
278%{__cp} %{SOURCE42} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.properties
279%{__cp} %{SOURCE43} $RPM_BUILD_ROOT/%{mozappdir}/langpacks/langpack-ja@thunderbird.mozilla.org/chrome/ja/locale/ja/branding/brand.dtd
280
281
282%clean
283%{__rm} -rf $RPM_BUILD_ROOT
284
285#===============================================================================
286
287%post
288update-desktop-database &> /dev/null || :
289touch --no-create %{_datadir}/icons/hicolor
290if [ -x %{_bindir}/gtk-update-icon-cache ]; then
291  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
292fi
293
294%postun
295update-desktop-database &> /dev/null || :
296touch --no-create %{_datadir}/icons/hicolor
297if [ -x %{_bindir}/gtk-update-icon-cache ]; then
298  %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
299fi
300
301
302%files
303%defattr(-,root,root,-)
304%attr(755,root,root) %{_bindir}/thunderbird
305%attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
306%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
307%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
308%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
309%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
310%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
311%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
312%{mozappdir}
313#%{_libdir}/mozilla
314%exclude %{_libdir}/%{name}-%{version_internal}/removed-files
315%exclude %{_datadir}/idl/%{name}-%{version_internal}
316%exclude %{_includedir}/%{name}-%{version_internal}
317%exclude %{_libdir}/%{name}-devel-%{version_internal}
318
319#===============================================================================
320
321%changelog
322* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0-3
323- rebuild with libnotify-0.7
324
325* Wed Jul 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0-2
326- enable-install-strip
327
328* Wed Jul 06 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 5.0-1
329- new upstream release
330- drop obsolete patch and renumber patch26 to patch1
331- add BuildRequires: yasm
332- enable libnotify support
333- add --disable-updater and --disable-installer to mozconfig
334- use ja.xpi instead of l10n source
335- update Source21: add step to setup langpack plugin
336- update Source20: add japanese translation
337- add Source42 & Source43 for localized branding
338- add --disable-system-cairo and ac_add_options --disable-libjpeg-turbo
339  for mozconfig-thunderbird-vine5
340
341* Mon May 16 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.10-1
342- new upstream release with security fix
343
344* Wed Dec 22 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.7-1
345- new upstream release with security fix
346
347* Fri Oct 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.6-1
348- new upstream release with security fix
349
350* Thu Oct 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.5-1
351- new upstream release with security fix
352- add patch5 to fix build failure
353
354* Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
355- new upstream release
356
357* Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
358- new upstream release with security fix
359- add Patch1030 to fix compilation error
360
361* Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
362- change mozconfig (Source1030 & 1040): add --enable-jsd
363
364* Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
365- new upstream release
366
367* Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
368- new upstream release with security fix
369- add Patch0 from fedora development: fix version issue
370- remove BuildRequires: hunspell-devel
371- update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
372
373* Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
374- add BuildRequires: alsa-lib-devel
375- remove BuildRequires: libnotify-devel
376  (workaround for known bug)
377- update mozconfig to add --disable-libnotify option
378
379* Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
380- new upstream release
381- update spec entirely
382- import patches from fedora (Patch1, 2 & 4)
383- drop outdated patches (Patch22, 24)
384- update Sources:
385  - mozconfig (Source1030 & Source1040)
386  - default prefs.js (Source12)
387  - unofficial branding (Source40 & Source41)
388  - japanese translation (Source1000)
389- update Patch1000 (sjis-alias)
390
391* Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
392- new upstream release
393
394* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
395- new upstream release
396
397* Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
398- don't install official branding logos
399
400* Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
401- add necessary icons in %%{tbdir}/chrome/icons/default
402- add Packager tag
403
404* Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
405- new upstream release
406
407* Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
408- new upstream release
409
410* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
411- new upstream release
412
413* Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
414- new upstream release
415
416* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
417- rebuilt for VineSeed
418
419* Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
420- new upstream release
421
422* Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
423- new upstream release
424- built for Vine Linux 4.x
425- dropped Patch1020 (merged into upstream)
426
427* Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
428- added Patch1020 for workaround gcc visibility hidden bugs
429
430* Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
431- build with new environment/toolchain
432- add build options to build with external nss/nspr libraries
433    ac_add_options --with-system-nspr
434    ac_add_options --with-system-nss
435
436* Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
437- new upstream release
438
439* Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
440- new upstream release
441
442* Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
443- new upstream release
444
445* Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
446- new upstream release
447
448* Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
449- new upstream release
450- merge changes from firefox
451  - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
452
453* Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
454- new upstream release
455- build en-US locale
456- merge changes from firefox
457  - add upstream patches
458  - disable pango rendering by default
459    (workaround fix slow rendering in some page)
460
461* Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
462- initial build for Vine Linux based on FC package
463- update to 1.5RC2
464
465* Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
466- Fix issue with popup dialogs and other actions causing lockups
467
468* Sat Nov  5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
469- Update to 1.5 rc1
470
471* Sat Oct  8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
472- Update to 1.5 beta2
473
474* Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
475- Update to 1.5 beta1
476- Bring the install phase of the spec file up to speed
477
478* Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
479- Rebuild
480
481* Sat Aug  6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
482- Add patch to make file chooser dialog modal
483
484* Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
485- Update to 1.0.6
486
487* Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
488- 1.0.6 Release Candidate
489
490* Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
491- Use system NSPR
492- Fix crash on 64bit platforms (#160330)
493
494* Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com>  1.0.2-7
495- Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
496  references, fixing the "no fonts" problem.
497
498* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
499- Change the Exec line in the desktop file to `thunderbird`
500
501* Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
502- Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
503
504* Mon May  9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
505- Add temporary workaround to not create files in the user's $HOME (#149664)
506
507* Wed May  4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
508- Don't have downloads "disappear" when downloading to desktop (#139015)
509- Fix for some more cursor issues in textareas (149991, 150002, 152089)
510- Add upstream patch to fix bidi justification of pango
511- Add patch to fix launching of helper applications
512- Add patch to properly link against libgfxshared_s.a
513- Fix multilib conflicts
514
515* Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
516- correct confusing PANGO vars in startup script
517
518* Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
519- Thunderbird 1.0.2
520
521* Tue Mar  8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
522- Add patch to compile against new fortified glibc macros
523
524* Sat Mar  5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
525- Rebuild against GCC 4.0
526- Add execshield patches
527- Minor specfile cleanup
528
529* Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
530- Rebuild
531
532* Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
533- Add RPM version to useragent
534
535* Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
536- Port over pango patches from firefox
537
538* Wed Dec  8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
539- Thunderbird 1.0
540
541* Mon Dec  6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
542- Fix advanced prefs
543
544* Fri Dec  3 2004 Christopher Aillon <caillon@redhat.com>
545- Make this run on s390(x) now for real
546
547* Wed Dec  1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
548- Update to 1.0 rc1
549
550* Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
551- Add patches to build and run on s390(x)
552
553* Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
554- Rebuild to fix file chooser
555
556* Fri Nov  5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
557- Update to 0.9
558
559* Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
560- Prevent inlining of stack direction detection (#135255)
561
562* Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
563- More file chooser fixes (same as in firefox)
564- Fix for upstream 28327.
565
566* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
567- Update the pango patch
568
569* Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
570- Pull over patches from firefox build:
571  - disable default application dialog
572  - don't include software update since it doesn't work
573  - make external app support work
574
575* Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
576- Use pango for rendering
577
578* Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
579- Fix for 64 bit crash at startup (b.m.o #256603)
580
581* Sat Oct  9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
582- Add patches to fix xremote (#135036)
583
584* Fri Oct  8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
585- Add patch to fix button focus issues (#133507)
586- Add patch for fix IMAP race issues (bmo #246439)
587
588* Fri Oct  1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
589- filter out library Provides: and internal Requires:
590
591* Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
592- Backport the GTK+ File Chooser.
593- Add fix for JS math on x86_64 systems
594- Add pkgconfig patch
595
596* Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
597- Update to 0.8.0
598- Remove enigmail
599- Update BuildRequires
600- Remove gcc34 and extension manager patches -- they are upstreamed.
601- Fix for gnome-vfs2 error at component registration
602
603* Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
604- Build with --disable-xprint
605
606* Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
607- remove all Xvfb-related hacks
608
609* Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
610- actually apply psfonts
611- add mozilla gnome-uriloader patch to prevent build failure
612
613* Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
614- rawhide import
615- apply NetBSD's freetype 2.1.8 patch
616- apply psfonts patch
617- remove BR on /usr/bin/ex, breaks beehive
618
619* Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
620- oops, fix %%install
621
622* Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
623- update to Thunderbird 0.7.3 and Enigmail 0.85.0
624- remove XUL.mfasl on startup, add Debian enigmail patches
625- add Xvfb hack for -install-global-extension
626
627* Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
628- update to 0.7.2, just because it's there
629- update gcc-3.4 patch (Kaj Niemi)
630- add EM registration patch and remove instdir hack
631
632* Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
633- re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
634
635* Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
636- update to 0.7.1
637- remove Enigmail
638
639* Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
640- re-enable Enigmail 0.84.1
641- add gcc-3.4 patch (Kaj Niemi)
642- use official branding (with permission)
643
644* Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
645- update to 0.7
646- temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
647- specify libdir, change BR for apt (V. Skytt辰, #1617)
648
649* Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
650- temporary workaround for enigmail skin "modern" bug
651
652* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
653- update to Enigmail 0.84.0
654- update launch script
655
656* Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
657- installation directory now versioned
658- allow root to run the program (for installing extensions)
659- remove unnecessary %%pre and %%post
660- remove separators, update mozconfig and launch script (M. Schwendt, #1460)
661
662* Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
663- include Enigmail, re-add release notes
664- delete %{_libdir}/thunderbird in %%pre
665
666* Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
667- update to Thunderbird 0.6
668
669* Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
670- update to Thunderbird 0.6 RC1
671- add new icon, remove release notes
672
673* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
674- update to latest CVS, update mozconfig and %%build accordingly
675- update to Enigmail 0.83.6
676- remove x-remote and x86_64 patches
677- build with -Os
678
679* Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
680- update x-remote patch
681- more startup script fixes
682
683* Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
684- startup script fixes, and a minor cleanup
685
686* Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
687- Minor cleanups
688
689* Sun Apr 04 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.8
690- minor improvements to open-browser.sh and startup script
691- update to latest version of Blizzard's x-remote patch
692
693* Thu Mar 25 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.7
694- update open-browser.sh, startup script, and BuildRequires
695
696* Sun Mar 14 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.6
697- update open-browser script, modify BuildRequires (Warren)
698- add Blizzard's x-remote patch
699- initial attempt at x-remote-enabled startup script
700
701* Sun Mar 07 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.5
702- refuse to run with excessive privileges
703
704* Fri Feb 27 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.4
705- add Mozilla x86_64 patch (Oliver Sontag)
706- Enigmail source filenames now include the version
707- modify BuildRoot
708
709* Thu Feb 26 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.3
710- use the updated official tarball
711
712* Wed Feb 18 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.2
713- fix %%prep script
714
715* Mon Feb 16 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.1
716- update Enigmail to 0.83.3
717- use official source tarball (after removing the CRLFs)
718- package renamed to thunderbird
719
720* Mon Feb 09 2004 David Hill <djh[at]ii.net>    0:0.5-0.fdr.0
721- update to 0.5
722- check for lockfile before launching
723
724* Fri Feb 06 2004 David Hill <djh[at]ii.net>
725- update to latest cvs
726- update to Enigmail 0.83.2
727
728* Thu Jan 29 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.5
729- update to Enigmail 0.83.1
730- removed Mozilla/Firebird script patching
731
732* Sat Jan 03 2004 David Hill <djh[at]ii.net>    0:0.4-0.fdr.4
733- add startup notification to .desktop file
734
735* Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
736- open-browser.sh release 3
737- patch broken /usr/bin/mozilla script during install
738- dir ownership
739- XXX: Source fails build on x86_64... fix later
740
741* Tue Dec 23 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.2
742- update to Enigmail 0.82.5
743- add Warren's open-browser.sh (#1113)
744
745* Tue Dec 09 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.1
746- use Thunderbird's mozilla-xremote-client to launch browser
747
748* Sun Dec 07 2003 David Hill <djh[at]ii.net>    0:0.4-0.fdr.0
749- update to 0.4
750- make hyperlinks work (with recent versions of Firebird/Mozilla)
751
752* Thu Dec 04 2003 David Hill <djh[at]ii.net>
753- update to 0.4rc2
754
755* Wed Dec 03 2003 David Hill <djh[at]ii.net>
756- update to 0.4rc1 and Enigmail 0.82.4
757
758* Thu Nov 27 2003 David Hill <djh[at]ii.net>
759- update to latest CVS and Enigmail 0.82.3
760
761* Sun Nov 16 2003 David Hill <djh[at]ii.net>
762- update to latest CVS (0.4a)
763- update Enigmail to 0.82.2
764- alter mozconfig for new build requirements
765- add missing BuildReq (#987)
766
767* Thu Oct 16 2003 David Hill <djh[at]ii.net>    0:0.3-0.fdr.0
768- update to 0.3
769
770* Sun Oct 12 2003 David Hill <djh[at]ii.net>    0:0.3rc3-0.fdr.0
771- update to 0.3rc3
772- update Enigmail to 0.81.7
773
774* Thu Oct 02 2003 David Hill <djh[at]ii.net>    0:0.3rc2-0.fdr.0
775- update to 0.3rc2
776
777* Wed Sep 17 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.2
778- simplify startup script
779
780* Wed Sep 10 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.1
781- add GPG support (Enigmail 0.81.6)
782- specfile fixes (#679)
783
784* Thu Sep 04 2003 David Hill <djh[at]ii.net>    0:0.2-0.fdr.0
785- update to 0.2
786
787* Mon Sep 01 2003 David Hill <djh[at]ii.net>
788- initial RPM
789  (based on the fedora MozillaFirebird-0.6.1 specfile)
790
Note: See TracBrowser for help on using the repository browser.