source: projects/specs/tags/6_0_REL/lib/libt/libtiff/libtiff-vl.spec @ 3697

Revision 3697, 11.5 KB checked in by iwamoto, 13 years ago (diff)

libtiff: new upstream release with security fix 3.9.5

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 3.9.5
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12# Patch1: libtiff-acversion.patch
13# Patch2: libtiff-mantypo.patch
14# Patch3: libtiff-scanlinesize.patch
15# Patch4: libtiff-getimage-64bit.patch
16# Patch5: libtiff-ycbcr-clamp.patch
17# Patch6: libtiff-3samples.patch
18# Patch7: libtiff-subsampling.patch
19# Patch8: libtiff-unknown-fix.patch
20# Patch9: libtiff-checkbytecount.patch
21# Patch10: libtiff-tiffdump.patch
22# Patch11: libtiff-CVE-2011-0192.patch
23# Patch12: libtiff-CVE-2011-1167.patch
24# Patch13: libtiff-CVE-2009-5022.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: zlib-devel zlib libjpeg-devel libjpeg
28Requires: zlib libjpeg
29%define LIBVER %(echo %{version} | cut -f-2 -d.)
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35The libtiff package contains a library of functions for manipulating
36TIFF (Tagged Image File Format) image format files.  TIFF is a widely
37used file format for bitmapped images.  TIFF files usually end in the
38.tif extension and they are often quite large.
39
40The libtiff package should be installed if you need to manipulate TIFF
41format image files.
42
43%description -l ja
44libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
45扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
46広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
47拡張子が使われ,サイズは概して大きめです.
48
49TIFF 形式の画像ファイルを扱う必要があるならば,
50libtiff パッケージを是非インストールして下さい.
51
52
53%package devel
54Summary: Development tools for programs which will use the libtiff library.
55Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
56Group: Development/Libraries
57Requires: libtiff = %{version}
58
59
60%description devel
61This package contains the header files and static libraries for
62developing programs which will manipulate TIFF format image files
63using the libtiff library.
64
65If you need to develop programs which will manipulate TIFF format
66image files, you should install this package.  You'll also need to
67install the libtiff package.
68
69#'
70%description devel -l ja
71このパッケージには,libtiff ライブラリを使って TIFF 形式の
72画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
73スタティックライブラリが収められています.
74
75TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
76このパッケージをインストールして下さい.libtiff パッケージも同時に
77インストールする必要があります.
78
79## to build compat32 for x86_64 architecture support
80%package -n compat32-%{name}
81Summary: A library of functions for manipulating TIFF format image files.
82Group: System Environment/Libraries
83Requires: zlib libjpeg
84Requires: %{name} = %{version}
85%description -n compat32-%{name}
86The libtiff package contains a library of functions for manipulating
87TIFF (Tagged Image File Format) image format files.  TIFF is a widely
88used file format for bitmapped images.  TIFF files usually end in the
89.tif extension and they are often quite large.
90
91The libtiff package should be installed if you need to manipulate TIFF
92format image files.
93
94%package -n compat32-%{name}-devel
95Summary: Development tools for programs which will use the libtiff library.
96Group: Development/Libraries
97Requires: compat32-%{name} = %{version}
98%description -n compat32-%{name}-devel
99This package contains the header files and static libraries for
100developing programs which will manipulate TIFF format image files
101using the libtiff library.
102
103If you need to develop programs which will manipulate TIFF format
104image files, you should install this package.  You'll also need to
105install the libtiff package.
106
107#'
108%prep
109%setup -q -n tiff-%{version}
110
111# %patch1 -p1 -b .acversion
112# %patch2 -p1 -b .mantypo
113# %patch3 -p1 -b .scanlinesize
114# %patch4 -p1
115# %patch5 -p1
116# %patch6 -p1
117# %patch7 -p1
118# %patch8 -p1
119# %patch9 -p1
120# %patch10 -p1
121# %patch11 -p1
122# %patch12 -p1
123# %patch13 -p1
124
125%build
126%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
127%__make %{?_smp_mflags}
128%__make clean
129
130
131%install
132rm -fr $RPM_BUILD_ROOT
133%makeinstall
134rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
135
136# fix libdir in .la
137perl -pi -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
138
139
140%post -p /sbin/ldconfig
141
142%postun -p /sbin/ldconfig
143
144%if %{build_compat32}
145%post -n compat32-%{name} -p /sbin/ldconfig
146%postun -n compat32-%{name} -p /sbin/ldconfig
147%endif
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(-,root,root)
154%doc COPYRIGHT README RELEASE-DATE VERSION
155%{_bindir}/*
156%{_libdir}/libtiff*.so.*
157%{_mandir}/man1/*
158
159
160%files devel
161%defattr(-,root,root)
162%doc TODO html ChangeLog
163%{_includedir}/*
164%{_libdir}/libtiff*.so
165%{_libdir}/libtiff*.a
166# %{_libdir}/libtiff*.la
167%{_mandir}/man3/*
168
169## to build compat32 for x86_64 architecture support
170%if %{build_compat32}
171%files -n compat32-%{name}
172%defattr(-,root,root)
173%{_libdir}/libtiff.so.*
174
175%files -n compat32-%{name}-devel
176%defattr(-,root,root)
177%{_libdir}/libtiff.so
178%{_libdir}/libtiff.a
179# %{_libdir}/libtiff.la
180%endif
181
182
183%changelog
184* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
185- new upstream release
186- drop all patches (are included in new release)
187- remove if-endif for Vine 4.x
188- add Vendor/Distri tags
189
190* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
191- add some patches from RHEL6 3.9.4-1.el6_0.3
192 - fix for CVE-2011-0192 (Patch11)
193 - fix for CVE-2011-1167 (Patch12)
194 - fix for CVE-2009-5022 (Patch13)
195
196* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
197- rebuilt with rpm-4.8.1-3
198
199* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
200- new upstream release
201- add patch4-10 from fedora
202
203* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
204- new upstream release
205- remove BC: freeglut-devel
206- add patch1,2,4,5 from fedora
207- drop obsolete patches
208
209* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
210- change if-endif to make both i386 and compat32 packages
211
212* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
213- add patch5 for fix CVE-2009-2347 (Integer Overflow)
214
215* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
216- add patch4 for fix lzw underflow security issue
217- add if branch Vine4/5 in devel files section (*.la are included or not)
218
219* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
220- removed *.la
221- spec in utf-8
222
223* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
224- fix changelog typo (3.8.4 -> 3.8.2)
225- new versioning policy
226- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
227
228* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
229- fix libdir in libtiff.la
230- add BuildConflicts: freeglut-devel
231
232* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
233- rebuilt without glut-devel
234
235* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
236- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
237
238* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
239- new upstream release
240- remove obsolete patches
241- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
242- delete duped docs
243- add --disable-cxx to configure option
244- add *.la to devel package
245
246* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
247- added compat32-* packages for x86_64 architecture support
248- added --with-jpeg-lib-dir=%{_libdir} to configure
249
250* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
251- new upstream release
252- remove obsolete patches
253- cleanup specs
254
255* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
256- rebuild for Vine3.1
257
258* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
259- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
260- update URL
261
262* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
263- build for Vine2.6
264
265* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
266- fix changelog: proper name
267
268* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
269- add symlink to shared lib by running ldconfig at compile time
270
271* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
272- add patch8-13 from Fedora Core
273--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
274--- fix some integer and buffer overflows (#134853, #134848)
275- add patch14 from SUSE LINUX
276--* Wed Oct 20 2004 - meissner@suse.de
277--- Do not crash if we are using unsupported codecs (like OJPEG).
278
279* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
280- rebuild with new toolchains
281- to use License instead of Copyright
282
283* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
284- 3.5.7-6vl1
285- based on 3.5.7-6 from Rawhide
286
287* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
288- 3.5.5-8vl1
289- based on 3.5.5-8 from Rawhide
290- added Japanese summary and description
291
292* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
293- rebuild
294
295* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
296- added a tiff-to-ps.fpi filter for printing
297
298* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
299- automatic rebuild
300
301* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
302- apply Peter Skarpetis's fix for the 32-bit conversion
303
304* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
305- make man pages non-executable (#12811)
306
307* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
308- remove CVS repo info from data directories
309
310* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
311- fix build rooting
312- fix syntax error in configure script
313- move man pages to %{_mandir}
314
315* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
316- rebuild for an errata release
317
318* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
319- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
320
321* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
322- fix fax2ps swapping height and width in the bounding box
323
324* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
325- move man pages from devel package to the regular one
326- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
327  of libtiff)
328- fix fax2ps breakage (bug #8345)
329
330* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
331- set MANDIR=man3 to make multifunction man pages friendlier
332
333* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
334- fix URLs
335
336* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
337- link shared library against libjpeg and libz
338
339* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
340- enable zip and jpeg codecs
341- change defattr in normal package to 0755
342- add defattr to -devel package
343
344* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
345- update to 3.5.4
346
347* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
348- auto rebuild in the new build environment (release 6)
349
350* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
351- build for glibc 2.1
352
353* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
354- translations modified for de
355
356* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
357- rebuilt against fixed jpeg libs (libjpeg-6b)
358
359* Thu May 07 1998 Prospector System <bugs@redhat.com>
360- translations modified for de, fr, tr
361
362* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
363- new version to replace the one from libgr
364- patched for glibc
365- added shlib support
Note: See TracBrowser for help on using the repository browser.