source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 3683

Revision 3683, 11.3 KB checked in by iwaim, 13 years ago (diff)

libtiff-3.9.4-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 3.9.4
7Release: 3%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12Patch1: libtiff-acversion.patch
13Patch2: libtiff-mantypo.patch
14Patch3: libtiff-scanlinesize.patch
15Patch4: libtiff-getimage-64bit.patch
16Patch5: libtiff-ycbcr-clamp.patch
17Patch6: libtiff-3samples.patch
18Patch7: libtiff-subsampling.patch
19Patch8: libtiff-unknown-fix.patch
20Patch9: libtiff-checkbytecount.patch
21Patch10: libtiff-tiffdump.patch
22Patch11: libtiff-CVE-2011-0192.patch
23Patch12: libtiff-CVE-2011-1167.patch
24Patch13: libtiff-CVE-2009-5022.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: zlib-devel zlib libjpeg-devel libjpeg
28Requires: zlib libjpeg
29%define LIBVER %(echo %{version} | cut -f-2 -d.)
30
31
32%description
33The libtiff package contains a library of functions for manipulating
34TIFF (Tagged Image File Format) image format files.  TIFF is a widely
35used file format for bitmapped images.  TIFF files usually end in the
36.tif extension and they are often quite large.
37
38The libtiff package should be installed if you need to manipulate TIFF
39format image files.
40
41%description -l ja
42libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
43扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
44広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
45拡張子が使われ,サイズは概して大きめです.
46
47TIFF 形式の画像ファイルを扱う必要があるならば,
48libtiff パッケージを是非インストールして下さい.
49
50
51%package devel
52Summary: Development tools for programs which will use the libtiff library.
53Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
54Group: Development/Libraries
55Requires: libtiff = %{version}
56
57
58%description devel
59This package contains the header files and static libraries for
60developing programs which will manipulate TIFF format image files
61using the libtiff library.
62
63If you need to develop programs which will manipulate TIFF format
64image files, you should install this package.  You'll also need to
65install the libtiff package.
66
67#'
68%description devel -l ja
69このパッケージには,libtiff ライブラリを使って TIFF 形式の
70画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
71スタティックライブラリが収められています.
72
73TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
74このパッケージをインストールして下さい.libtiff パッケージも同時に
75インストールする必要があります.
76
77## to build compat32 for x86_64 architecture support
78%package -n compat32-%{name}
79Summary: A library of functions for manipulating TIFF format image files.
80Group: System Environment/Libraries
81Requires: zlib libjpeg
82Requires: %{name} = %{version}
83%description -n compat32-%{name}
84The libtiff package contains a library of functions for manipulating
85TIFF (Tagged Image File Format) image format files.  TIFF is a widely
86used file format for bitmapped images.  TIFF files usually end in the
87.tif extension and they are often quite large.
88
89The libtiff package should be installed if you need to manipulate TIFF
90format image files.
91
92%package -n compat32-%{name}-devel
93Summary: Development tools for programs which will use the libtiff library.
94Group: Development/Libraries
95Requires: compat32-%{name} = %{version}
96%description -n compat32-%{name}-devel
97This package contains the header files and static libraries for
98developing programs which will manipulate TIFF format image files
99using the libtiff library.
100
101If you need to develop programs which will manipulate TIFF format
102image files, you should install this package.  You'll also need to
103install the libtiff package.
104
105#'
106%prep
107%setup -q -n tiff-%{version}
108%patch1 -p1 -b .acversion
109%patch2 -p1 -b .mantypo
110%patch3 -p1 -b .scanlinesize
111%patch4 -p1
112%patch5 -p1
113%patch6 -p1
114%patch7 -p1
115%patch8 -p1
116%patch9 -p1
117%patch10 -p1
118%patch11 -p1
119%patch12 -p1
120%patch13 -p1
121
122%build
123%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
124%__make %{?_smp_mflags}
125%__make clean
126
127
128%install
129rm -fr $RPM_BUILD_ROOT
130%makeinstall
131rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
132
133# fix libdir in .la
134perl -pi -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
135
136
137%post -p /sbin/ldconfig
138
139
140%postun -p /sbin/ldconfig
141
142%if %{build_compat32}
143%post -n compat32-%{name} -p /sbin/ldconfig
144%postun -n compat32-%{name} -p /sbin/ldconfig
145%endif
146
147%clean
148rm -rf $RPM_BUILD_ROOT
149
150%files
151%defattr(-,root,root)
152%doc COPYRIGHT README RELEASE-DATE VERSION
153%{_bindir}/*
154%{_libdir}/libtiff*.so.*
155%{_mandir}/man1/*
156
157
158%files devel
159%defattr(-,root,root)
160%doc TODO html ChangeLog
161%{_includedir}/*
162%{_libdir}/libtiff*.so
163%{_libdir}/libtiff*.a
164%if %{_dist_release}=="vl4"
165# for Vine 4.x
166%{_libdir}/libtiff*.la
167%endif
168%{_mandir}/man3/*
169
170## to build compat32 for x86_64 architecture support
171%if %{build_compat32}
172%files -n compat32-%{name}
173%defattr(-,root,root)
174%{_libdir}/libtiff.so.*
175
176%files -n compat32-%{name}-devel
177%defattr(-,root,root)
178%{_libdir}/libtiff.so
179%{_libdir}/libtiff.a
180# %{_libdir}/libtiff.la
181%endif
182
183
184%changelog
185* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
186- add some patches from RHEL6 3.9.4-1.el6_0.3
187 - fix for CVE-2011-0192 (Patch11)
188 - fix for CVE-2011-1167 (Patch12)
189 - fix for CVE-2009-5022 (Patch13)
190
191* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
192- rebuilt with rpm-4.8.1-3
193
194* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
195- new upstream release
196- add patch4-10 from fedora
197
198* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
199- new upstream release
200- remove BC: freeglut-devel
201- add patch1,2,4,5 from fedora
202- drop obsolete patches
203
204* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
205- change if-endif to make both i386 and compat32 packages
206
207* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
208- add patch5 for fix CVE-2009-2347 (Integer Overflow)
209
210* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
211- add patch4 for fix lzw underflow security issue
212- add if branch Vine4/5 in devel files section (*.la are included or not)
213
214* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
215- removed *.la
216- spec in utf-8
217
218* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
219- fix changelog typo (3.8.4 -> 3.8.2)
220- new versioning policy
221- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
222
223* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
224- fix libdir in libtiff.la
225- add BuildConflicts: freeglut-devel
226
227* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
228- rebuilt without glut-devel
229
230* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
231- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
232
233* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
234- new upstream release
235- remove obsolete patches
236- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
237- delete duped docs
238- add --disable-cxx to configure option
239- add *.la to devel package
240
241* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
242- added compat32-* packages for x86_64 architecture support
243- added --with-jpeg-lib-dir=%{_libdir} to configure
244
245* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
246- new upstream release
247- remove obsolete patches
248- cleanup specs
249
250* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
251- rebuild for Vine3.1
252
253* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
254- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
255- update URL
256
257* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
258- build for Vine2.6
259
260* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
261- fix changelog: proper name
262
263* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
264- add symlink to shared lib by running ldconfig at compile time
265
266* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
267- add patch8-13 from Fedora Core
268--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
269--- fix some integer and buffer overflows (#134853, #134848)
270- add patch14 from SUSE LINUX
271--* Wed Oct 20 2004 - meissner@suse.de
272--- Do not crash if we are using unsupported codecs (like OJPEG).
273
274* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
275- rebuild with new toolchains
276- to use License instead of Copyright
277
278* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
279- 3.5.7-6vl1
280- based on 3.5.7-6 from Rawhide
281
282* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
283- 3.5.5-8vl1
284- based on 3.5.5-8 from Rawhide
285- added Japanese summary and description
286
287* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
288- rebuild
289
290* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
291- added a tiff-to-ps.fpi filter for printing
292
293* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
294- automatic rebuild
295
296* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
297- apply Peter Skarpetis's fix for the 32-bit conversion
298
299* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
300- make man pages non-executable (#12811)
301
302* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
303- remove CVS repo info from data directories
304
305* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
306- fix build rooting
307- fix syntax error in configure script
308- move man pages to %{_mandir}
309
310* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
311- rebuild for an errata release
312
313* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
314- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
315
316* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
317- fix fax2ps swapping height and width in the bounding box
318
319* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
320- move man pages from devel package to the regular one
321- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
322  of libtiff)
323- fix fax2ps breakage (bug #8345)
324
325* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
326- set MANDIR=man3 to make multifunction man pages friendlier
327
328* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
329- fix URLs
330
331* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
332- link shared library against libjpeg and libz
333
334* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
335- enable zip and jpeg codecs
336- change defattr in normal package to 0755
337- add defattr to -devel package
338
339* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
340- update to 3.5.4
341
342* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
343- auto rebuild in the new build environment (release 6)
344
345* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
346- build for glibc 2.1
347
348* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
349- translations modified for de
350
351* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
352- rebuilt against fixed jpeg libs (libjpeg-6b)
353
354* Thu May 07 1998 Prospector System <bugs@redhat.com>
355- translations modified for de, fr, tr
356
357* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
358- new version to replace the one from libgr
359- patched for glibc
360- added shlib support
Note: See TracBrowser for help on using the repository browser.