source: projects/specs/trunk/lib/libt/libtiff/libtiff-vl.spec @ 6185

Revision 6185, 11.0 KB checked in by daisuke, 12 years ago (diff)

update to 4.0.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A library of functions for manipulating TIFF format image files.
4Summary(ja): TIFF フォーマットの画像ファイルを扱うライブラリ
5Name: libtiff
6Version: 4.0.1
7Release: 1%{_dist_release}
8License: distributable
9Group: System Environment/Libraries
10Source0: http://www.libtiff.org/tiff-%{version}.tar.gz
11URL: http://www.remotesensing.org/libtiff/
12Patch1: libtiff-CVE-2012-1173.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: zlib-devel libjpeg-devel
16%define LIBVER %(echo %{version} | cut -f-2 -d.)
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: daisuke, iwamoto
21
22%description
23The libtiff package contains a library of functions for manipulating
24TIFF (Tagged Image File Format) image format files.  TIFF is a widely
25used file format for bitmapped images.  TIFF files usually end in the
26.tif extension and they are often quite large.
27
28The libtiff package should be installed if you need to manipulate TIFF
29format image files.
30
31%description -l ja
32libtiff パッケージには TIFF (Tagged Image File Format) 画像ファイルを
33扱う各種ライブラリが収められています.TIFF はビットマップ画像を扱う際に
34広く使われているフォーマットです.TIFF ファイルは通常 .tif のファイル
35拡張子が使われ,サイズは概して大きめです.
36
37TIFF 形式の画像ファイルを扱う必要があるならば,
38libtiff パッケージを是非インストールして下さい.
39
40
41%package devel
42Summary: Development tools for programs which will use the libtiff library.
43Summary(ja): libtiff ライブラリを使うプログラム向け開発ツール
44Group: Development/Libraries
45Requires: libtiff = %{version}
46
47
48%description devel
49This package contains the header files and static libraries for
50developing programs which will manipulate TIFF format image files
51using the libtiff library.
52
53If you need to develop programs which will manipulate TIFF format
54image files, you should install this package.  You'll also need to
55install the libtiff package.
56
57#'
58%description devel -l ja
59このパッケージには,libtiff ライブラリを使って TIFF 形式の
60画像ファイルを扱うプログラムを開発する際に必要なヘッダファイルや
61スタティックライブラリが収められています.
62
63TIFF 形式画像ファイルを扱うプログラムを開発する必要がある場合は
64このパッケージをインストールして下さい.libtiff パッケージも同時に
65インストールする必要があります.
66
67## to build compat32 for x86_64 architecture support
68%package -n compat32-%{name}
69Summary: A library of functions for manipulating TIFF format image files.
70Group: System Environment/Libraries
71Requires: zlib libjpeg
72Requires: %{name} = %{version}
73%description -n compat32-%{name}
74The libtiff package contains a library of functions for manipulating
75TIFF (Tagged Image File Format) image format files.  TIFF is a widely
76used file format for bitmapped images.  TIFF files usually end in the
77.tif extension and they are often quite large.
78
79The libtiff package should be installed if you need to manipulate TIFF
80format image files.
81
82%package -n compat32-%{name}-devel
83Summary: Development tools for programs which will use the libtiff library.
84Group: Development/Libraries
85Requires: compat32-%{name} = %{version}
86%description -n compat32-%{name}-devel
87This package contains the header files and static libraries for
88developing programs which will manipulate TIFF format image files
89using the libtiff library.
90
91If you need to develop programs which will manipulate TIFF format
92image files, you should install this package.  You'll also need to
93install the libtiff package.
94
95#'
96%prep
97%setup -q -n tiff-%{version}
98
99%patch1 -p1 -b .CVE-2012-1173
100
101%build
102%configure --with-jpeg-lib-dir=%{_libdir} --disable-cxx
103%__make %{?_smp_mflags}
104%__make clean
105
106
107%install
108rm -fr $RPM_BUILD_ROOT
109%makeinstall
110rm -rf $RPM_BUILD_ROOT/usr/share/doc/tiff-%{version}
111
112# fix libdir in .la
113perl -pi -e "s,$RPM_BUILD_ROOT,,g" $RPM_BUILD_ROOT%{_libdir}/libtiff*.la
114
115
116%post -p /sbin/ldconfig
117
118%postun -p /sbin/ldconfig
119
120%if %{build_compat32}
121%post -n compat32-%{name} -p /sbin/ldconfig
122%postun -n compat32-%{name} -p /sbin/ldconfig
123%endif
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%files
129%defattr(-,root,root)
130%doc COPYRIGHT README RELEASE-DATE VERSION
131%{_bindir}/*
132%{_libdir}/libtiff*.so.*
133%{_mandir}/man1/*
134
135
136%files devel
137%defattr(-,root,root)
138%doc TODO html ChangeLog
139%{_includedir}/*
140%{_libdir}/libtiff*.so
141%{_libdir}/libtiff*.a
142%{_mandir}/man3/*
143
144## to build compat32 for x86_64 architecture support
145%if %{build_compat32}
146%files -n compat32-%{name}
147%defattr(-,root,root)
148%{_libdir}/libtiff.so.*
149
150%files -n compat32-%{name}-devel
151%defattr(-,root,root)
152%{_libdir}/libtiff.so
153%{_libdir}/libtiff.a
154%endif
155
156
157%changelog
158* Fri May 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
159- new upstream release
160- add patch1 to fix CVE-2012-1173
161
162* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.9.5-1
163- new upstream release
164- drop all patches (are included in new release)
165- remove if-endif for Vine 4.x
166- add Vendor/Distri tags
167
168* Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 3.9.4-3
169- add some patches from RHEL6 3.9.4-1.el6_0.3
170 - fix for CVE-2011-0192 (Patch11)
171 - fix for CVE-2011-1167 (Patch12)
172 - fix for CVE-2009-5022 (Patch13)
173
174* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 3.9.4-2
175- rebuilt with rpm-4.8.1-3
176
177* Mon Jul 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.4-1
178- new upstream release
179- add patch4-10 from fedora
180
181* Thu Feb 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9.2-1
182- new upstream release
183- remove BC: freeglut-devel
184- add patch1,2,4,5 from fedora
185- drop obsolete patches
186
187* Fri Jul 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-9
188- change if-endif to make both i386 and compat32 packages
189
190* Wed Jul 15 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-8
191- add patch5 for fix CVE-2009-2347 (Integer Overflow)
192
193* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 3.8.2-7
194- add patch4 for fix lzw underflow security issue
195- add if branch Vine4/5 in devel files section (*.la are included or not)
196
197* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.8.2-6vl4
198- removed *.la
199- spec in utf-8
200
201* Tue Sep 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.8.2-5vl4
202- fix changelog typo (3.8.4 -> 3.8.2)
203- new versioning policy
204- add patch3 for fix CVE-2008-2327 (LZW Data Decoding Buffer Underflow)
205
206* Mon Sep 25 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl4
207- fix libdir in libtiff.la
208- add BuildConflicts: freeglut-devel
209
210* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.8.2-0vl3
211- rebuilt without glut-devel
212
213* Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.2-0vl2
214- add Patch2 to fix multiple vulnerabilities (CVE-2006-346[012345])
215
216* Fri Jun  9 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.8.2-0vl1
217- new upstream release
218- remove obsolete patches
219- add Patch0 and Patch1 from Debian (CVE-2006-2193, CVE-2006-2656)
220- delete duped docs
221- add --disable-cxx to configure option
222- add *.la to devel package
223
224* Sun Feb 12 2006 Shu KONNO <owa@bg.wakwak.com> 3.7.1-0vl2
225- added compat32-* packages for x86_64 architecture support
226- added --with-jpeg-lib-dir=%{_libdir} to configure
227
228* Wed Feb 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1-0vl1
229- new upstream release
230- remove obsolete patches
231- cleanup specs
232
233* Fri Jan 21 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl7
234- rebuild for Vine3.1
235
236* Wed Jan 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl6
237- add Patch15-16 from Red Hat (CAN-2004-1183) (CAN-2004-1308)
238- update URL
239
240* Sun Oct 31 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl1.1
241- build for Vine2.6
242
243* Fri Oct 29 2004 IWAI, Masaharu <iwai@alib.jp> 3.5.7-6vl5
244- fix changelog: proper name
245
246* Wed Oct 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl4
247- add symlink to shared lib by running ldconfig at compile time
248
249* Tue Oct 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-6vl3
250- add patch8-13 from Fedora Core
251--* Thu Oct 07 2004 Matthias Clasen <mclasen@redhat.com>
252--- fix some integer and buffer overflows (#134853, #134848)
253- add patch14 from SUSE LINUX
254--* Wed Oct 20 2004 - meissner@suse.de
255--- Do not crash if we are using unsupported codecs (like OJPEG).
256
257* Sun Jan 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.7-6vl2
258- rebuild with new toolchains
259- to use License instead of Copyright
260
261* Fri Jul 05 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
262- 3.5.7-6vl1
263- based on 3.5.7-6 from Rawhide
264
265* Mon Jan 08 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
266- 3.5.5-8vl1
267- based on 3.5.5-8 from Rawhide
268- added Japanese summary and description
269
270* Tue Dec 19 2000 Philipp Knirsch <pknirsch@redhat.de>
271- rebuild
272
273* Tue Aug  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
274- added a tiff-to-ps.fpi filter for printing
275
276* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
277- automatic rebuild
278
279* Thu Jul 13 2000 Nalin Dahyabhai <nalin@redhat.com>
280- apply Peter Skarpetis's fix for the 32-bit conversion
281
282* Mon Jul  3 2000 Nalin Dahyabhai <nalin@redhat.com>
283- make man pages non-executable (#12811)
284
285* Mon Jun 12 2000 Nalin Dahyabhai <nalin@redhat.com>
286- remove CVS repo info from data directories
287
288* Thu May 18 2000 Nalin Dahyabhai <nalin@redhat.com>
289- fix build rooting
290- fix syntax error in configure script
291- move man pages to %{_mandir}
292
293* Wed May 17 2000 Nalin Dahyabhai <nalin@redhat.com>
294- rebuild for an errata release
295
296* Wed Mar 29 2000 Nalin Dahyabhai <nalin@redhat.com>
297- update to 3.5.5, which integrates our fax2ps fixes and the glibc fix
298
299* Tue Mar 28 2000 Nalin Dahyabhai <nalin@redhat.com>
300- fix fax2ps swapping height and width in the bounding box
301
302* Mon Mar 27 2000 Nalin Dahyabhai <nalin@redhat.com>
303- move man pages from devel package to the regular one
304- integrate Frank Warmerdam's fixed .fax handling code (keep until next release
305  of libtiff)
306- fix fax2ps breakage (bug #8345)
307
308* Sat Feb 05 2000 Nalin Dahyabhai <nalin@redhat.com>
309- set MANDIR=man3 to make multifunction man pages friendlier
310
311* Mon Jan 31 2000 Nalin Dahyabhai <nalin@redhat.com>
312- fix URLs
313
314* Fri Jan 28 2000 Nalin Dahyabhai <nalin@redhat.com>
315- link shared library against libjpeg and libz
316
317* Tue Jan 18 2000 Nalin Dahyabhai <nalin@redhat.com>
318- enable zip and jpeg codecs
319- change defattr in normal package to 0755
320- add defattr to -devel package
321
322* Wed Dec 22 1999 Bill Nottingham <notting@redhat.com>
323- update to 3.5.4
324
325* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
326- auto rebuild in the new build environment (release 6)
327
328* Wed Jan 13 1999 Cristian Gafton <gafton@redhat.com>
329- build for glibc 2.1
330
331* Wed Jun 10 1998 Prospector System <bugs@redhat.com>
332- translations modified for de
333
334* Wed Jun 10 1998 Michael Fulbright <msf@redhat.com>
335- rebuilt against fixed jpeg libs (libjpeg-6b)
336
337* Thu May 07 1998 Prospector System <bugs@redhat.com>
338- translations modified for de, fr, tr
339
340* Mon Oct 13 1997 Donnie Barnes <djb@redhat.com>
341- new version to replace the one from libgr
342- patched for glibc
343- added shlib support
Note: See TracBrowser for help on using the repository browser.