source: projects/specs/branches/6/t/tracker/tracker-vl.spec @ 3801

Revision 3801, 9.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME packages: new upstream release, bogofilter: fix perl requirements, perl-modules: new package

Line 
1Summary: An object database, tag/metadata database, search tool and indexer
2Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
3Name: tracker
4Version: 0.8.18
5Release: 1%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://www.gnome.org/projects/tracker/
9
10Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/tracker-%{version}.tar.bz2
11
12Patch0: tracker-0.8.18-tracker_spawn.patch
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: glib2-devel >= 2.24.0
16BuildRequires: gtk2-devel >= 2.20.0
17BuildRequires: gnome-panel-devel
18BuildRequires: gmime-devel >= 2.4
19BuildRequires: poppler-devel
20BuildRequires: gettext
21BuildRequires: file
22BuildRequires: gnome-desktop-devel, gamin-devel
23BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
24BuildRequires: gstreamer-devel
25BuildRequires: desktop-file-utils, intltool
26BuildRequires: raptor-devel >= 1.4.18
27BuildRequires: sqlite3-devel
28BuildRequires: dbus-devel >= 1.0
29BuildRequires: dbus-glib-devel >= 0.78
30BuildRequires: libgnome-devel >= 2.13.2
31BuildRequires: libgnomeui-devel >= 2.13.7
32BuildRequires: libSM-devel
33BuildRequires: libnotify-devel >= 0.4.3
34BuildRequires: libuuid-devel
35BuildRequires: vala-devel
36BuildRequires: libgee-devel
37BuildRequires: upower-devel
38BuildRequires: gnome-applets
39BuildRequires: libgee-devel >= 0.3
40BuildRequires: nautilus-devel
41## BuildRequires: autoconf, automake
42
43%description
44Tracker is a powerful desktop-neutral first class object database,
45tag/metadata database, search tool and indexer.
46
47It consists of a common object database that allows entities to have an
48almost infinte number of properties, metadata (both embedded/harvested as
49well as user definable), a comprehensive database of keywords/tags and
50links to other entities.
51
52It provides additional features for file based objects including context
53linking and audit trails for a file object.
54
55It has the ability to index, store, harvest metadata. retrieve and search 
56all types of files and other first class objects
57
58%package devel
59Summary: Headers for developing programs that will use %{name}
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: pkgconfig
63Requires: dbus-glib-devel
64
65%description devel
66This package contains the static libraries and header files needed for
67developing with tracker
68
69%package search-tool
70Summary: Tracker search tool(s)
71Group: User Interface/Desktops
72Requires: %{name} = %{version}-%{release}
73
74%description search-tool
75Graphical frontend to tracker search facilities. This has dependencies on
76GNOME libraries
77
78%prep
79%setup -q
80%patch0 -p1 -b .spawn
81
82# remove shebangs from the python files as none should be executable scripts
83## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
84
85%build
86## libtoolize --force --copy
87## intltoolize --copy --force
88## autoreconf -i -f
89%configure --disable-static \
90           --enable-video-extractor=external \
91           --enable-tracker-search-tool=yes \
92           --enable-tracker-search-bar=yes
93
94# Disable rpath
95sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
96sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
97
98make %{?_smp_mflags}
99
100                                                                               
101%install
102rm -rf %{buildroot}
103make DESTDIR=%{buildroot} install
104
105mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
106echo "%{_libdir}/tracker-0.8"   \
107        > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
108
109desktop-file-install --delete-original               \
110        --vendor=""                             \
111        --dir=%{buildroot}%{_datadir}/applications   \
112        %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
113
114rm -rf %{buildroot}%{_libdir}/*.{a,la}
115rm -f  %{buildroot}%{_libdir}/nautilus/extensions-*/*.la
116rm -rf %{buildroot}%{_datadir}/tracker-tests
117
118%find_lang %{name}
119
120%clean
121rm -rf %{buildroot}
122
123%post
124/sbin/ldconfig
125touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
126
127%posttrans
128gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
129 
130%postun
131/sbin/ldconfig
132if [ $1 -eq 0 ] ; then
133    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
134    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
135fi
136 
137%files -f %{name}.lang
138%defattr(-, root, root, -)
139%doc AUTHORS ChangeLog COPYING NEWS README
140### %doc %{_datadir}/gtk-doc/html/libtracker-common/
141### %doc %{_datadir}/gtk-doc/html/libtracker-module/
142%{_bindir}/tracker*
143%exclude %{_bindir}/tracker-search-tool
144%exclude %{_bindir}/tracker-preferences
145### %exclude %{_bindir}/tracker-applet
146%{_libexecdir}/tracker*
147%{_libdir}/*.so.*
148%{_libdir}/tracker-0.8/
149%{_datadir}/tracker/
150%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
151%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
152%{_sysconfdir}/xdg/autostart/tracker*.desktop
153%{_mandir}/*/tracker*.gz
154%exclude %{_mandir}/man1/tracker-search-bar.1.gz
155%exclude %{_mandir}/man1/tracker-preferences.1.gz
156%exclude %{_mandir}/man1/tracker-search-tool.1.gz
157
158%files devel
159%defattr(-, root, root, -)
160%{_includedir}/tracker-0.8/
161### %{_includedir}/libtracker-gtk/*
162%{_libdir}/*.so
163%{_libdir}/pkgconfig/*.pc
164%{_datadir}/vala/vapi/tracker*.vapi
165%{_datadir}/vala/vapi/tracker*.deps
166
167%files search-tool
168%defattr(-, root, root, -)
169%{_bindir}/tracker-search-tool
170%{_bindir}/tracker-preferences
171%{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
172%{_libdir}/nautilus/extensions-2.0/*.so
173%{_datadir}/icons/*/*/apps/tracker.*
174%{_datadir}/applications/*.desktop
175%{_mandir}/man1/tracker-search-bar.1.gz
176%{_mandir}/man1/tracker-preferences.1.gz
177%{_mandir}/man1/tracker-search-tool.1.gz
178
179
180%changelog
181* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
182- new upstream release
183- add Patch0 (tracker-0.8.18-tracker_spawn.patch)
184- delete Patch1
185
186* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
187- rebuilt with poppler-0.16.3
188
189* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
190- rebuild with poppler-0.14.2
191
192* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
193- new upstream release
194- add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
195- add configure option (--enable-tracker-search-bar)
196
197* Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
198- new upstream release
199
200* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
201- new upstream release
202- fix URL of Source0
203
204* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
205- new upstream release
206
207* Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
208- new upstream release
209
210* Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
211- new upstream release
212- fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
213
214* Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
215- new upstream release
216
217* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
218- new upstream release
219- add BuildRequires: upower-devel, gnome-applets
220- change BuildRequires: dbus-glib -> dbus-glib-devel
221
222* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
223- new upstream release
224- add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
225- fix BuildRequires: gmime-devel >= 2.4
226- add configure option (--enable-tracker-search-tool)
227
228* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
229- new upstream release
230
231* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
232- rebuild with poppler-0.10.2
233- spec in UTF-8
234
235* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
236- new upstream release
237- update Patch1
238- drop Patch10 (no more necessary)
239- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
240- remove --enable-external-sqlite option (no more bundled sqlite exist)
241- apply new versioning policy
242
243* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
244- new upstream release
245
246* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
247- add Patch10 to fix selecting video-extractor
248- use external video extractor(totem) instead of gstreamer/xine
249
250* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
251- initial build for Vine Linux
252
253* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
254- Ship both autostart desktop files in the main package (BZ #233323)
255
256* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
257- Package the deskbar plugin properly (BZ #228308)
258
259* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
260- Split out tracker-search-tool sub-packages, for the GUI facility
261- Add proper requires for the -devel subpackage
262- Deal with the rpmlint complaints on rpath
263
264* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
265- Update to 0.5.4
266
267* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
268- Update to 0.5.3
269
270* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
271- Apply patch on Makefile.am instead of Makefile.in
272- Add libtool to BR
273
274* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
275- Update to 0.5.2
276
277* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
278- Update to new version
279
280* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
281- Have the devel subpackage require pkgconfig
282- Make the description field not have more than 76 characters on a line
283- Fix up the RPM group
284
285* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
286- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
287
288* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
289- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
290
291* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
292- Add autostart desktop file.
293- Edit the package description as suggested in review
294
295* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
296- More cleaups to the spec file.
297
298* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
299- Add needed BRs
300
301* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
302- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.