source: projects/specs/trunk/t/tracker/tracker-vl.spec @ 2998

Revision 2998, 9.6 KB checked in by inagaki, 13 years ago (diff)

update: calibre, evince, epdfview, gimp, gambas{2,3}, gnome-commander, inkscape, poppler, pypopper, rcairo, ruby-gnome2, tracker

Line 
1Summary: An object database, tag/metadata database, search tool and indexer
2Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
3Name: tracker
4Version: 0.8.16
5Release: 3%{?_dist_release}
6License: GPL
7Group: Applications/System
8URL: http://www.gnome.org/projects/tracker/
9
10Source0: http://ftp.gnome.org/pub/GNOME/sources/tracker/0.8/tracker-%{version}.tar.bz2
11
12Patch0: tracker-ldfind.patch
13Patch1: tracker-0.8.16-poppler-0.15.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: glib2-devel >= 2.24.0
17BuildRequires: gtk2-devel >= 2.20.0
18BuildRequires: gnome-panel-devel
19BuildRequires: gmime-devel >= 2.4
20BuildRequires: poppler-devel
21BuildRequires: gettext
22BuildRequires: file
23BuildRequires: gnome-desktop-devel, gamin-devel
24BuildRequires: libexif-devel, libgsf-devel, totem-pl-parser-devel
25BuildRequires: gstreamer-devel
26BuildRequires: desktop-file-utils, intltool
27BuildRequires: raptor-devel >= 1.4.18
28BuildRequires: sqlite3-devel
29BuildRequires: dbus-devel >= 1.0
30BuildRequires: dbus-glib-devel >= 0.78
31BuildRequires: libgnome-devel >= 2.13.2
32BuildRequires: libgnomeui-devel >= 2.13.7
33BuildRequires: libSM-devel
34BuildRequires: libnotify-devel >= 0.4.3
35BuildRequires: libuuid-devel
36BuildRequires: vala-devel
37BuildRequires: libgee-devel
38BuildRequires: upower-devel
39BuildRequires: gnome-applets
40BuildRequires: libgee-devel >= 0.3
41BuildRequires: nautilus-devel
42## BuildRequires: autoconf, automake
43
44%description
45Tracker is a powerful desktop-neutral first class object database,
46tag/metadata database, search tool and indexer.
47
48It consists of a common object database that allows entities to have an
49almost infinte number of properties, metadata (both embedded/harvested as
50well as user definable), a comprehensive database of keywords/tags and
51links to other entities.
52
53It provides additional features for file based objects including context
54linking and audit trails for a file object.
55
56It has the ability to index, store, harvest metadata. retrieve and search 
57all types of files and other first class objects
58
59%package devel
60Summary: Headers for developing programs that will use %{name}
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63Requires: pkgconfig
64Requires: dbus-glib-devel
65
66%description devel
67This package contains the static libraries and header files needed for
68developing with tracker
69
70%package search-tool
71Summary: Tracker search tool(s)
72Group: User Interface/Desktops
73Requires: %{name} = %{version}-%{release}
74
75%description search-tool
76Graphical frontend to tracker search facilities. This has dependencies on
77GNOME libraries
78
79%prep
80%setup -q
81%patch1 -p1 -b .poppler
82
83# remove shebangs from the python files as none should be executable scripts
84## sed -e '/^#!\//,1 d' -i python/deskbar-handler/*.py
85
86%build
87## libtoolize --force --copy
88## intltoolize --copy --force
89## autoreconf -i -f
90%configure --disable-static \
91           --enable-video-extractor=external \
92           --enable-tracker-search-tool=yes \
93           --enable-tracker-search-bar=yes
94
95# Disable rpath
96sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
97sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
98
99make %{?_smp_mflags}
100
101                                                                               
102%install
103rm -rf %{buildroot}
104make DESTDIR=%{buildroot} install
105
106mkdir -p %{buildroot}%{_sysconfdir}/ld.so.conf.d
107echo "%{_libdir}/tracker-0.8"   \
108        > %{buildroot}%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
109
110desktop-file-install --delete-original               \
111        --vendor=""                             \
112        --dir=%{buildroot}%{_datadir}/applications   \
113        %{buildroot}%{_datadir}/applications/%{name}-search-tool.desktop
114
115rm -rf %{buildroot}%{_libdir}/*.{a,la}
116rm -f  %{buildroot}%{_libdir}/nautilus/extensions-*/*.la
117rm -rf %{buildroot}%{_datadir}/tracker-tests
118
119%find_lang %{name}
120
121%clean
122rm -rf %{buildroot}
123
124%post
125/sbin/ldconfig
126touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
127
128%posttrans
129gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
130 
131%postun
132/sbin/ldconfig
133if [ $1 -eq 0 ] ; then
134    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
135    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
136fi
137 
138%files -f %{name}.lang
139%defattr(-, root, root, -)
140%doc AUTHORS ChangeLog COPYING NEWS README
141### %doc %{_datadir}/gtk-doc/html/libtracker-common/
142### %doc %{_datadir}/gtk-doc/html/libtracker-module/
143%{_bindir}/tracker*
144%exclude %{_bindir}/tracker-search-tool
145%exclude %{_bindir}/tracker-preferences
146### %exclude %{_bindir}/tracker-applet
147%{_libexecdir}/tracker*
148%{_libdir}/*.so.*
149%{_libdir}/tracker-0.8/
150%{_datadir}/tracker/
151%{_datadir}/dbus-1/services/org.freedesktop.Tracker*
152%{_sysconfdir}/ld.so.conf.d/tracker-%{_arch}.conf
153%{_sysconfdir}/xdg/autostart/tracker*.desktop
154%{_mandir}/*/tracker*.gz
155%exclude %{_mandir}/man1/tracker-search-bar.1.gz
156%exclude %{_mandir}/man1/tracker-preferences.1.gz
157%exclude %{_mandir}/man1/tracker-search-tool.1.gz
158
159%files devel
160%defattr(-, root, root, -)
161%{_includedir}/tracker-0.8/
162### %{_includedir}/libtracker-gtk/*
163%{_libdir}/*.so
164%{_libdir}/pkgconfig/*.pc
165%{_datadir}/vala/vapi/tracker*.vapi
166%{_datadir}/vala/vapi/tracker*.deps
167
168%files search-tool
169%defattr(-, root, root, -)
170%{_bindir}/tracker-search-tool
171%{_bindir}/tracker-preferences
172%{_libdir}/bonobo/servers/GNOME_Search_Bar_Applet.server
173%{_libdir}/nautilus/extensions-2.0/*.so
174%{_datadir}/icons/*/*/apps/tracker.*
175%{_datadir}/applications/*.desktop
176%{_mandir}/man1/tracker-search-bar.1.gz
177%{_mandir}/man1/tracker-preferences.1.gz
178%{_mandir}/man1/tracker-search-tool.1.gz
179
180
181%changelog
182* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
183- rebuilt with poppler-0.16.3
184
185* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
186- rebuild with poppler-0.14.2
187
188* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
189- new upstream release
190- add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
191- add configure option (--enable-tracker-search-bar)
192
193* Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
194- new upstream release
195
196* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
197- new upstream release
198- fix URL of Source0
199
200* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
201- new upstream release
202
203* Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
204- new upstream release
205
206* Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
207- new upstream release
208- fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
209
210* Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
211- new upstream release
212
213* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
214- new upstream release
215- add BuildRequires: upower-devel, gnome-applets
216- change BuildRequires: dbus-glib -> dbus-glib-devel
217
218* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
219- new upstream release
220- add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
221- fix BuildRequires: gmime-devel >= 2.4
222- add configure option (--enable-tracker-search-tool)
223
224* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
225- new upstream release
226
227* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
228- rebuild with poppler-0.10.2
229- spec in UTF-8
230
231* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
232- new upstream release
233- update Patch1
234- drop Patch10 (no more necessary)
235- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
236- remove --enable-external-sqlite option (no more bundled sqlite exist)
237- apply new versioning policy
238
239* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
240- new upstream release
241
242* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
243- add Patch10 to fix selecting video-extractor
244- use external video extractor(totem) instead of gstreamer/xine
245
246* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
247- initial build for Vine Linux
248
249* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
250- Ship both autostart desktop files in the main package (BZ #233323)
251
252* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
253- Package the deskbar plugin properly (BZ #228308)
254
255* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
256- Split out tracker-search-tool sub-packages, for the GUI facility
257- Add proper requires for the -devel subpackage
258- Deal with the rpmlint complaints on rpath
259
260* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
261- Update to 0.5.4
262
263* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
264- Update to 0.5.3
265
266* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
267- Apply patch on Makefile.am instead of Makefile.in
268- Add libtool to BR
269
270* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
271- Update to 0.5.2
272
273* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
274- Update to new version
275
276* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
277- Have the devel subpackage require pkgconfig
278- Make the description field not have more than 76 characters on a line
279- Fix up the RPM group
280
281* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
282- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
283
284* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
285- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
286
287* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
288- Add autostart desktop file.
289- Edit the package description as suggested in review
290
291* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
292- More cleaups to the spec file.
293
294* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
295- Add needed BRs
296
297* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
298- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.