source: projects/specs/trunk/t/tracker/tracker-vl.spec @ 12386

Revision 12386, 13.9 KB checked in by tomop, 4 years ago (diff)

updated 15 packages

epiphany-3.30.5-3

evolution-data-server-3.30.5-3

harfbuzz-2.6.4-2

icu-67.1-1

libvisio-0.1.7-3

php74-7.4.5-2

postfix-3.5.1-2

qt5-qtbase-5.12.8-2

qt5-qtlocation-5.12.8-2

qt5-qtwebengine-5.12.8-2

samba-4.12.1-2

tracker-miners-2.3.3-2

tracker-2.3.4-1

webkitgtk4-2.28.1-1

xfsprogs-5.6.0-1

RevLine 
[12386]1%bcond_with systemd
2
[11376]3%define _unpackaged_files_terminate_build 1
4
[521]5Summary: An object database, tag/metadata database, search tool and indexer
6Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
7Name: tracker
[12386]8Version: 2.3.4
9Release: 1%{?_dist_release}%{?with_systemd:.systemd}
[521]10Group: Applications/System
[12386]11Vendor: Project Vine
12Distribution: Vine Linux
[521]13
[12386]14License: GPL
15URL: https://gnome.pages.gitlab.gnome.org/tracker/
[12158]16%define major_minor %(echo %{version} | sed -e 's/\.[0-9]*$//')
[12386]17Source0: https://download.gnome.org/sources/tracker/%{major_minor}/tracker-%{version}.tar.xz
[521]18
[2998]19BuildRoot: %{_tmppath}/%{name}-%{version}-root
[12158]20BuildRequires:  meson
[12005]21BuildRequires:  graphviz
22BuildRequires:  gtk-doc
23BuildRequires:  intltool
24BuildRequires:  libappstream-glib
25BuildRequires:  vala
26BuildRequires:  pkgconfig(gobject-introspection-1.0)
27BuildRequires:  pkgconfig(icu-i18n)
28BuildRequires:  pkgconfig(icu-uc)
29BuildRequires:  pkgconfig(json-glib-1.0)
30BuildRequires:  pkgconfig(libnm)
31BuildRequires:  pkgconfig(libsoup-2.4)
32BuildRequires:  pkgconfig(libxml-2.0)
33BuildRequires:  pkgconfig(sqlite3)
34BuildRequires:  libuuid-devel
[12386]35%if %{with systemd}
36BuildRequires:  systemd
37%endif
38%if %{with systemd}
39%global systemd_units tracker-store.service
40%{?systemd_requires}
41%endif
[521]42
[12005]43Obsoletes: %{name}-libs < 2.0.0
44Obsoletes: %{name}-search-tool < 2.0.0
45Provides: %{name}-libs = %{version}-%{release}
46Provides: %{name}-search-tool = %{version}-%{release}
[6817]47
[521]48%description
49Tracker is a powerful desktop-neutral first class object database,
50tag/metadata database, search tool and indexer.
51
52It consists of a common object database that allows entities to have an
53almost infinte number of properties, metadata (both embedded/harvested as
54well as user definable), a comprehensive database of keywords/tags and
55links to other entities.
56
57It provides additional features for file based objects including context
58linking and audit trails for a file object.
59
60It has the ability to index, store, harvest metadata. retrieve and search 
61all types of files and other first class objects
62
63%package devel
64Summary: Headers for developing programs that will use %{name}
65Group: Development/Libraries
[12005]66Requires: %{name} = %{version}-%{release}
[521]67
68%description devel
69This package contains the static libraries and header files needed for
70developing with tracker
71
[9475]72
[7633]73%package docs
[4881]74Summary: Documentation for tracker
75Group: Documentation
[7633]76Obsoletes: %{name}-doc < 0.15.0
77Provides: %{name}-doc = 0.15.0
[4881]78BuildArch: noarch
79
[7633]80%description docs
[4881]81This package contains documentation for tracker.
82
[9475]83
[521]84%prep
85%setup -q
86
87%build
[12158]88%meson \
89        -Dstemmer=disabled \
[12386]90%if %{with systemd}
91        -Dsystemd_user_services=%{_userunitdir} \
92%endif
[12158]93        -Ddocs=true
94
[12005]95%meson_build
[521]96
97
98%install
99rm -rf %{buildroot}
[12005]100export LANG=ja_JP.UTF-8
101%meson_install
[521]102
[912]103rm -rf %{buildroot}%{_datadir}/tracker-tests
[521]104
105%find_lang %{name}
106
[12386]107%if !%{with systemd}
[11376]108rm -rf %{buildroot}/usr/lib/systemd
[12386]109%endif
[11376]110
[12386]111
[521]112%clean
113rm -rf %{buildroot}
114
[12386]115
[521]116%post
[12005]117/sbin/ldconfig
[2998]118touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
[12386]119%if %{with systemd}
120%systemd_user_post %{systemd_units}
121%endif
[2998]122
123%posttrans
124gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
[4812]125glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[12386]126
127%if %{with systemd}
128%preun
129%systemd_user_preun %{systemd_units}
130%endif
[521]131 
132%postun
[12005]133/sbin/ldconfig
[2998]134if [ $1 -eq 0 ] ; then
135    touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
136    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
[4812]137    glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
[521]138fi
[12386]139%if %{with systemd}
140%systemd_user_postun_with_restart %{systemd_units}
141%endif
[6817]142
143
[521]144%files -f %{name}.lang
145%defattr(-, root, root, -)
[12005]146%license COPYING
[12158]147%doc AUTHORS NEWS README.md
[12005]148%{_bindir}/tracker
149%{_libexecdir}/tracker-store
[6817]150%{_datadir}/tracker/
[12005]151%{_datadir}/dbus-1/services/org.freedesktop.Tracker1.service
152%{_libdir}/libtracker*-2.0.so.*
153%{_libdir}/tracker-2.0/
154%dir %{_libdir}/girepository-1.0
155%{_libdir}/girepository-1.0/Tracker-2.0.typelib
156%{_libdir}/girepository-1.0/TrackerControl-2.0.typelib
157%{_libdir}/girepository-1.0/TrackerMiner-2.0.typelib
[521]158%{_mandir}/*/tracker*.gz
[12005]159%config(noreplace) %{_sysconfdir}/xdg/autostart/tracker-store.desktop
160%dir %{_datadir}/bash-completion
161%dir %{_datadir}/bash-completion/completions
162%{_datadir}/bash-completion/completions/tracker
163%{_datadir}/glib-2.0/schemas/*
[12386]164%if %{with systemd}
165%{_userunitdir}/tracker-store.service
166%endif
[521]167
168%files devel
169%defattr(-, root, root, -)
[12005]170%{_includedir}/tracker-2.0/
[521]171%{_libdir}/*.so
172%{_libdir}/pkgconfig/*.pc
[12005]173%dir %{_datadir}/vala
174%dir %{_datadir}/vala/vapi
175%{_datadir}/vala/vapi/*
176%dir %{_datadir}/gir-1.0
177%{_datadir}/gir-1.0/*
[521]178
[7633]179%files docs
[4881]180%defattr(-, root, root, -)
[8353]181%{_datadir}/gtk-doc/html/libtracker-control
[4881]182%{_datadir}/gtk-doc/html/libtracker-miner
183%{_datadir}/gtk-doc/html/libtracker-sparql
[12005]184%{_datadir}/gtk-doc/html/ontology/
[4881]185
[521]186
[6817]187%changelog
[12386]188* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
189- new upstream release.
190- built with icu-67.
191
[12344]192* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-3
193- rebuilt with icu-66.
194
[12264]195* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-2
196- rebuilt with icu-65.
197
[12158]198* Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-1
199- new upstream release.
200- dropped Patch0.
201
[12005]202* Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
203- new upstream release.
204- dropped all patches.
205- added Patch0.
206- dropped subpackages "libs" and "search-tool".
207
[11376]208* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.4-1
209- new upstream release.
210
[10716]211* Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
212- new upstream release
[10467]213
[9876]214* Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
215- new upstream release
216
[9791]217* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
218- new upstream release
219
[9724]220* Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
221- new upstream release
222
[9559]223* Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-2
224- remove *.la files
225
[9475]226* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
227- new upstream release
228- add BuildRequires: libmediaart-devel, libvorbis-devel, flac-devel
229
[9178]230* Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.5-1
231- new upstream release
232
[9091]233* Sun Nov 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
[9073]234- new upstream release
235- add Patch1 (tracker-1.2.3-revert-error_message.patch)
236
[8962]237* Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
238- rebuild with upower-0.99.1
239
[8949]240* Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
241- new upstream release
242
[8924]243* Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
244- new upstream release
245
[8771]246* Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-3
247- rebuild with poppler-0.26.2
248
[8758]249* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
250- rebuild with libarchive-3.1.2
251
[8447]252* Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
253- new upstream release
254
[8412]255* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
256- rebuild with poppler-0.24.5
257
[8353]258* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
259- new upstream release
260
[8084]261* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-2
262- rebuild with VineSeed environment
263
[8011]264* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-1
265- new upstream release
266
[7978]267* Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.3-1
268- new upstream release
269
[7938]270* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-2
271- rebuild with icu-51.2
272
[7756]273* Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-1
274- new upstream release
275
[7681]276* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
277- new upstream release
278
[7633]279* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
280- new upstream release
281- remove BuildRequires: gnome-panel-devel, gnome-applets
282- change BuildRequires: gstreamer1-devel instead of gstreamer-devel
283- add BuildRequires: libjpeg-turbo-devel, giflib-devel, libtiff-devel, exempi-devel, enca-devel, taglib-devel, libgxps-devel
284- change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
285- change to %%{name}-docs subpackage from %%{name}-docs
286
[7474]287* Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.5-1
288- new upstream release
289
[7062]290* Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.4-1
291- new upstream release
292
[7018]293* Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.3-1
294- new upstream release
295
[6817]296* Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-2
297- create -libs subpackage
298- add BuildRequires: firefox, thunderbird
[805]299
[6537]300* Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
301- new upstream release
302
[6141]303* Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
304- new upstream release
305
[6011]306* Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
307- new upstream release
308
[5335]309* Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.9-1
310- new upstream release
311
[5094]312* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
313- new upstream release
314
[4881]315* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
316- new upstream release
317- create %%{name}-doc sub package
318
[4850]319* Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
320- new upstream release
321- add Patch0 (tracker-0.12.3-sched.patch)
322
[4812]323* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
324- new upstream release
325- add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, NetworkManager-glib-devel
326- drop Patch0
327
[4704]328* Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.25-1
329- new upstream release
330
[4650]331* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
332- new upstream release
333
[4616]334* Wed Jul 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.22-1
335- new upstream release
336- add BuildRequires: libicu-devel
337
[3801]338* Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
339- new upstream release
340- add Patch0 (tracker-0.8.18-tracker_spawn.patch)
341- delete Patch1
342
[2998]343* Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
344- rebuilt with poppler-0.16.3
345
[2041]346* Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
347- rebuild with poppler-0.14.2
348
[1638]349* Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
350- new upstream release
351- add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
352- add configure option (--enable-tracker-search-bar)
353
[1387]354* Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
355- new upstream release
356
[1251]357* Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
358- new upstream release
359- fix URL of Source0
360
[1231]361* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
362- new upstream release
363
[1198]364* Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
365- new upstream release
366
[1099]367* Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
368- new upstream release
369- fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
370
[1018]371* Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
372- new upstream release
373
[912]374* Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
375- new upstream release
376- add BuildRequires: upower-devel, gnome-applets
377- change BuildRequires: dbus-glib -> dbus-glib-devel
378
[805]379* Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
380- new upstream release
381- add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
382- fix BuildRequires: gmime-devel >= 2.4
383- add configure option (--enable-tracker-search-tool)
384
[521]385* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
386- new upstream release
387
388* Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
389- rebuild with poppler-0.10.2
390- spec in UTF-8
391
392* Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
393- new upstream release
394- update Patch1
395- drop Patch10 (no more necessary)
396- add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
397- remove --enable-external-sqlite option (no more bundled sqlite exist)
398- apply new versioning policy
399
400* Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
401- new upstream release
402
403* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
404- add Patch10 to fix selecting video-extractor
405- use external video extractor(totem) instead of gstreamer/xine
406
407* Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
408- initial build for Vine Linux
409
410* Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
411- Ship both autostart desktop files in the main package (BZ #233323)
412
413* Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
414- Package the deskbar plugin properly (BZ #228308)
415
416* Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
417- Split out tracker-search-tool sub-packages, for the GUI facility
418- Add proper requires for the -devel subpackage
419- Deal with the rpmlint complaints on rpath
420
421* Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
422- Update to 0.5.4
423
424* Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
425- Update to 0.5.3
426
427* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
428- Apply patch on Makefile.am instead of Makefile.in
429- Add libtool to BR
430
431* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
432- Update to 0.5.2
433
434* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
435- Update to new version
436
437* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
438- Have the devel subpackage require pkgconfig
439- Make the description field not have more than 76 characters on a line
440- Fix up the RPM group
441
442* Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
443- Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
444
445* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
446- Remove unneeded BRs (gnome-utils-devel and openssl-devel)
447
448* Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
449- Add autostart desktop file.
450- Edit the package description as suggested in review
451
452* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
453- More cleaups to the spec file.
454
455* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
456- Add needed BRs
457
458* Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
459- Initial packaging for Fedora Extras
Note: See TracBrowser for help on using the repository browser.