source: projects/specs/branches/6/t/tk/tk-vl.spec @ 3599

Revision 3599, 8.7 KB checked in by tomop, 13 years ago (diff)

tk-8.4.19-4

Line 
1%define majorver        8.4
2%define minorver        19
3Summary: A Tcl/Tk development environment: tk
4Summary(ja): Tcl/Tk 開発環境: tk
5Name: tk
6Version: %{majorver}.%{minorver}
7Release: 4%{?_dist_release}
8Group: Development/Languages
9License: BSD
10URL: http://tcl.sourceforge.net/
11Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
12Patch2: tk-8.4.12-lib-perm.patch
13Patch3: tk-8.4-lastevent.patch
14Patch4: tk-8.4.18-tkBind.patch 
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: tcl = %{version}, autoconf
18BuildRequires: libX11-devel
19BuildRequires: imake
20Requires: tcl >= %{majorver}
21Provides: libtk%{majorver}.so
22Vendor: Project Vine
23Distribution: Vine Linux
24
25
26%description
27Tk is a X Windows widget set designed to work closely with the tcl
28scripting language. It allows you to write simple programs with full
29featured GUI's in only a little more time then it takes to write a
30text based interface. Tcl/Tk applications can also be run on Windows
31and Macintosh platforms.
32
33%description -l ja
34Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
35System のウィジェットセットです。 テキストベースのインターフェースを
36採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
37ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
38のプラットフォームで実行することもできます。
39
40
41%prep
42%setup -n %{name}%{version} -q
43%patch2 -p1 -b .rolib
44%patch3 -p0 -b .lastevent
45#%%patch4 -p1 -b .tkbind
46cd unix
47autoconf
48
49
50%build
51cd unix
52%configure \
53        --with-tcl=%{_libdir} --enable-shared \
54        --enable-threads --enable-64bit --with-x
55
56make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/tk%{majorver}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60make install -C unix INSTALL_ROOT=%{buildroot} TK_LIBRARY=%{_datadir}/tk%{majorver}
61ln -s wish%{majorver} %{buildroot}%{_bindir}/wish
62
63# for linking with -ltk
64ln -s libtk%{majorver}.so %{buildroot}%{_libdir}/libtk.so
65
66mkdirhier %buildroot/%{_includedir}/tk-private/{generic,unix}
67cp -p generic/{default,tkInt,tkIntDecls,tkPort}.h %buildroot/%{_includedir}/tk-private/generic
68cp -p unix/tkUnix{Default,Port}.h %buildroot/%{_includedir}/tk-private/unix
69
70# Fix up the include files.
71cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/generic
72cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/unix
73
74# remove buildroot traces
75perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tk-private|" %buildroot/%{_libdir}/tkConfig.sh
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%post
81/sbin/ldconfig
82
83%postun
84/sbin/ldconfig
85
86%files
87%defattr(-,root,root,-)
88%doc
89%{_bindir}/wish*
90%{_datadir}/tk%{majorver}
91%{_libdir}/libtk%{majorver}.so
92%{_libdir}/tk%{majorver}
93%{_libdir}/tkConfig.sh
94%{_mandir}/man1/*
95%{_includedir}/*
96%{_libdir}/libtk.so
97%{_libdir}/libtkstub%{majorver}.a
98%{_mandir}/man3/*
99%{_mandir}/mann/*
100
101%changelog
102* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
103- added "BuildRequires: imake".
104
105* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
106- rebuilt with rpm-4.8.1-3
107
108* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
109- rebuilt with tcl-8.4.19-2
110- dropt Patch4: tk-8.4.18-tkBind.patch
111
112* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
113- new upstream release
114- add Patch3,4 to fix bug (broken if built with xproto-7.x)
115
116* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
117- spec in utf-8
118
119* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
120- rebuild with xorg-x11-7.3
121  - remove Requires: XFree86-libs
122  - add BuildRequires: libX11-devel
123- use autoconf instead of autoconf217
124
125* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
126- updated tk to 8.4.18
127- included CVE-2008-0553
128
129* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
130- updated tk to 8.4.16
131
132* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
133- updated tk to 8.4.15
134- rebuilt with new toolchain
135
136* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
137- updated tk to 8.4.13
138
139* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
140- updated tk to 8.4.12
141- updated tk-%%{version}-lib-perm.patch
142
143* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
144- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
145- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
146- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
147- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
148
149* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
150- added tk-8.4.6-tkUnixWm.patch
151
152* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
153- updated tk to 8.4.6
154
155* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
156- syncd with fedora
157  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
158  - add private header files needed to build tix in /usr/include/tk-private
159
160  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
161  - removed rpath (patch 3)
162
163  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
164  - new package split out from tcltk
165  - update to tk 8.4.5 (#88429)
166  - filtered changelog for tk
167  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
168  - remove build remnants from tkConfig.sh
169
170* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
171- fix buildrequires and requires section
172
173* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
174- update based on BitWalk's tcltk-8.4.2-83bw
175
176* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
177- splite source package
178- add include files
179
180* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
181- expand some macros.. (FIXME)
182
183* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
184- use %configure macros
185- add Patch 47,50
186
187* Thu May 31 2001 <sagami@vinelinux.org>
188- 8.0.5_jp-10
189- unexpand old %%{configure}, new one causes build failure
190- fixed missing libtkx.so libtclx.so symlink in /usr/lib
191- install manpages into %%{_mandir} and mode 644
192
193* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
194- 8.0.5_jp-9
195- modified %install section to handle compressed man pages
196- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
197
198* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
199- changed default fonts
200
201* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
202- added defattr
203
204* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
205- added some symlinks, such as libtcl8.0.so.
206- obsoletes version number using _jp, now 8.0.5-31vl1
207
208* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
209- Apply Tcl/Tk 8.0 Japanese Patch 1.7
210
211* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
212- fix tclX symlinks.
213- compile on systems where SIGPWR == SIGLOST.
214
215* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
216- update tcl/tk to 8.0.5.
217- avoid "containing" in Tix (#2332).
218
219* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
220- use /usr/bin/write in kibitz (#1320).
221- use cirrus.sprl.umich.edu in weather (#1926).
222
223* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
224- auto rebuild in the new build environment (release 28)
225
226* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
227- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
228
229* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
230- expect does unaligned access on alpha (#989)
231- upgrade tcl/tk/tclX to 8.0.4
232- upgrade expect to 5.28.
233- add itcl 3.0.1
234
235* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
236- call libtoolize to allow building on the arm
237- build for glibc 2.1
238- strip binaries
239
240* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
241- update tcl/tk/tclX to 8.0.3, expect is updated also.
242
243* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
244- expect: mkpasswd needs delay before sending password (problem #576)
245
246* Thu May 07 1998 Prospector System <bugs@redhat.com>
247- translations modified for de, fr, tr
248
249* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
250- fixed expect binaries exec permissions
251
252* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
253- updated to Tix 4.1.0.006
254- updated version numbers of tcl/tk to relflect includsion of p2
255
256* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
257- updated tcl/tk to patch level 2
258- updated tclX to 8.0.2
259
260* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
261- fixed filelist for tix... replacing path to the expect binary in scripts
262  was leaving junk files around.
263
264* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
265- added patch to remove libieee test in configure.in for tcl and tk.
266  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
267  solution for all systems
268- fixed src urls
269
270* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
271- removed version numbers from descriptions
272
273* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
274- updated to tcl/tk 8.0 and related versions of packages
275
276* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
277- built against glibc
278- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.