source: projects/specs/trunk/t/tk/tk-vl.spec @ 7289

Revision 7289, 9.6 KB checked in by iwaim, 11 years ago (diff)

tk 8.5.7-1

Line 
1%define majorver        8.5
2%define minorver        7
3Summary: A Tcl/Tk development environment: tk
4Summary(ja): Tcl/Tk 開発環境: tk
5Name: tk
6Version: %{majorver}.%{minorver}
7Release: 1%{?_dist_release}
8Group: Development/Languages
9License: TCL
10URL: http://tcl.sourceforge.net/
11Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
12# patches from Red Hat Enterprise Linux tk-8.5.7-6.el6
13Patch101: tk8.5-make.patch
14Patch102: tk8.5-conf.patch
15# this patch isn't needed since tk8.6b1
16Patch103: tk-seg_input.patch
17# this patch is tracked in tk tracker
18Patch104: tk-8.5.7-color.patch
19# fixes sigsegv if there is no font seen by fontconfig (#606671)
20Patch105: tk-8.5.7-nofont-sigsegv.patch
21
22Buildroot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: tcl = %{version}, autoconf
24BuildRequires: libX11-devel
25BuildRequires: imake
26Requires: tcl >= %{majorver}
27Provides: libtk%{majorver}.so
28Vendor: Project Vine
29Distribution: Vine Linux
30
31
32%description
33Tk is a X Windows widget set designed to work closely with the tcl
34scripting language. It allows you to write simple programs with full
35featured GUI's in only a little more time then it takes to write a
36text based interface. Tcl/Tk applications can also be run on Windows
37and Macintosh platforms.
38
39%description -l ja
40Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
41System のウィジェットセットです。 テキストベースのインターフェースを
42採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
43ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
44のプラットフォームで実行することもできます。
45
46
47%prep
48%setup -n %{name}%{version} -q
49
50%patch101 -p1 -b .make
51%patch102 -p1 -b .conf
52%patch103 -p1 -b .seg
53%patch104 -p1 -b .color
54%patch105 -p1 -b .nofont-sigsegv
55
56%build
57cd unix
58autoconf
59%configure
60make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64
65make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TK_LIBRARY=%{_datadir}/%{name}%{majorver}
66
67ln -s wish%{majorver} $RPM_BUILD_ROOT%{_bindir}/wish
68
69# for linking with -l%{name}
70ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
71
72mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic/ttk,unix}
73find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
74( cd $RPM_BUILD_ROOT/%{_includedir}
75  for i in *.h ; do
76    [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
77  done
78)
79
80# remove buildroot traces
81sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
82rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tkAppInit.c
83rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/prolog.ps
84
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post
90/sbin/ldconfig
91
92%postun
93/sbin/ldconfig
94
95%files
96%defattr(-,root,root,-)
97%doc README changes license.terms
98%{_bindir}/wish*
99%{_datadir}/tk%{majorver}
100%{_libdir}/libtk%{majorver}.so
101%{_libdir}/tk%{majorver}
102%{_libdir}/tkConfig.sh
103%{_mandir}/man1/*
104%{_includedir}/*
105%{_libdir}/libtk.so
106%{_libdir}/libtkstub%{majorver}.a
107%{_mandir}/man3/*
108%{_mandir}/mann/*
109
110%changelog
111* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
112- update to 5.8.7: sync Red Hat Enterprise Linux 6 tk-8.4.19-4vl6
113- update License: TCL
114- drop obsolete patches
115 - lib-perm patch (Patch2)
116 - lastevent patch (Patch3)
117 - tkBind patch (Patch4)
118- add some patches from RHEL tk-8.5.7-6.el6
119 - make patch (Patch101)
120 - conf patch (Patch102)
121 - seg_input patch (Patch103)
122 - color patch (Patch104)
123 - nofont sigsegv patch (Patch105)
124- add some documents
125- update build and install section: sync RHEL tk-8.5.7-6.el6
126
127* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
128- added "BuildRequires: imake".
129
130* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
131- rebuilt with rpm-4.8.1-3
132
133* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
134- rebuilt with tcl-8.4.19-2
135- dropt Patch4: tk-8.4.18-tkBind.patch
136
137* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
138- new upstream release
139- add Patch3,4 to fix bug (broken if built with xproto-7.x)
140
141* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
142- spec in utf-8
143
144* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
145- rebuild with xorg-x11-7.3
146  - remove Requires: XFree86-libs
147  - add BuildRequires: libX11-devel
148- use autoconf instead of autoconf217
149
150* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
151- updated tk to 8.4.18
152- included CVE-2008-0553
153
154* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
155- updated tk to 8.4.16
156
157* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
158- updated tk to 8.4.15
159- rebuilt with new toolchain
160
161* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
162- updated tk to 8.4.13
163
164* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
165- updated tk to 8.4.12
166- updated tk-%%{version}-lib-perm.patch
167
168* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
169- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
170- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
171- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
172- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
173
174* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
175- added tk-8.4.6-tkUnixWm.patch
176
177* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
178- updated tk to 8.4.6
179
180* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
181- syncd with fedora
182  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
183  - add private header files needed to build tix in /usr/include/tk-private
184
185  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
186  - removed rpath (patch 3)
187
188  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
189  - new package split out from tcltk
190  - update to tk 8.4.5 (#88429)
191  - filtered changelog for tk
192  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
193  - remove build remnants from tkConfig.sh
194
195* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
196- fix buildrequires and requires section
197
198* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
199- update based on BitWalk's tcltk-8.4.2-83bw
200
201* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
202- splite source package
203- add include files
204
205* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
206- expand some macros.. (FIXME)
207
208* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
209- use %configure macros
210- add Patch 47,50
211
212* Thu May 31 2001 <sagami@vinelinux.org>
213- 8.0.5_jp-10
214- unexpand old %%{configure}, new one causes build failure
215- fixed missing libtkx.so libtclx.so symlink in /usr/lib
216- install manpages into %%{_mandir} and mode 644
217
218* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
219- 8.0.5_jp-9
220- modified %install section to handle compressed man pages
221- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
222
223* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
224- changed default fonts
225
226* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
227- added defattr
228
229* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
230- added some symlinks, such as libtcl8.0.so.
231- obsoletes version number using _jp, now 8.0.5-31vl1
232
233* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
234- Apply Tcl/Tk 8.0 Japanese Patch 1.7
235
236* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
237- fix tclX symlinks.
238- compile on systems where SIGPWR == SIGLOST.
239
240* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
241- update tcl/tk to 8.0.5.
242- avoid "containing" in Tix (#2332).
243
244* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
245- use /usr/bin/write in kibitz (#1320).
246- use cirrus.sprl.umich.edu in weather (#1926).
247
248* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
249- auto rebuild in the new build environment (release 28)
250
251* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
252- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
253
254* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
255- expect does unaligned access on alpha (#989)
256- upgrade tcl/tk/tclX to 8.0.4
257- upgrade expect to 5.28.
258- add itcl 3.0.1
259
260* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
261- call libtoolize to allow building on the arm
262- build for glibc 2.1
263- strip binaries
264
265* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
266- update tcl/tk/tclX to 8.0.3, expect is updated also.
267
268* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
269- expect: mkpasswd needs delay before sending password (problem #576)
270
271* Thu May 07 1998 Prospector System <bugs@redhat.com>
272- translations modified for de, fr, tr
273
274* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
275- fixed expect binaries exec permissions
276
277* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
278- updated to Tix 4.1.0.006
279- updated version numbers of tcl/tk to relflect includsion of p2
280
281* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
282- updated tcl/tk to patch level 2
283- updated tclX to 8.0.2
284
285* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
286- fixed filelist for tix... replacing path to the expect binary in scripts
287  was leaving junk files around.
288
289* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
290- added patch to remove libieee test in configure.in for tcl and tk.
291  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
292  solution for all systems
293- fixed src urls
294
295* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
296- removed version numbers from descriptions
297
298* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
299- updated to tcl/tk 8.0 and related versions of packages
300
301* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
302- built against glibc
303- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.