source: projects/specs/trunk/t/tk/tk-vl.spec @ 3506

Revision 3506, 8.6 KB checked in by owa, 13 years ago (diff)

rebuild main

Line 
1%define majorver        8.4
2%define minorver        19
3Summary: A Tcl/Tk development environment: tk
4Summary(ja): Tcl/Tk 開発環境: tk
5Name: tk
6Version: %{majorver}.%{minorver}
7Release: 3%{?_dist_release}
8Group: Development/Languages
9License: BSD
10URL: http://tcl.sourceforge.net/
11Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
12Patch2: tk-8.4.12-lib-perm.patch
13Patch3: tk-8.4-lastevent.patch
14Patch4: tk-8.4.18-tkBind.patch 
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: tcl = %{version}, autoconf
18BuildRequires: libX11-devel
19Requires: tcl >= %{majorver}
20Provides: libtk%{majorver}.so
21Vendor: Project Vine
22Distribution: Vine Linux
23
24
25%description
26Tk is a X Windows widget set designed to work closely with the tcl
27scripting language. It allows you to write simple programs with full
28featured GUI's in only a little more time then it takes to write a
29text based interface. Tcl/Tk applications can also be run on Windows
30and Macintosh platforms.
31
32%description -l ja
33Tk は tcl スクリプト言語と密接に動作するようにデザインされた X Window
34System のウィジェットセットです。 テキストベースのインターフェースを
35採用してるので、あらゆる特徴をもった GUI を少ない時間で、簡単なプログラ
36ムで書くことができます。Tcl/Tk アプリケーションは Windows や Macintosh
37のプラットフォームで実行することもできます。
38
39
40%prep
41%setup -n %{name}%{version} -q
42%patch2 -p1 -b .rolib
43%patch3 -p0 -b .lastevent
44#%%patch4 -p1 -b .tkbind
45cd unix
46autoconf
47
48
49%build
50cd unix
51%configure \
52        --with-tcl=%{_libdir} --enable-shared \
53        --enable-threads --enable-64bit --with-x
54
55make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/tk%{majorver}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59make install -C unix INSTALL_ROOT=%{buildroot} TK_LIBRARY=%{_datadir}/tk%{majorver}
60ln -s wish%{majorver} %{buildroot}%{_bindir}/wish
61
62# for linking with -ltk
63ln -s libtk%{majorver}.so %{buildroot}%{_libdir}/libtk.so
64
65mkdirhier %buildroot/%{_includedir}/tk-private/{generic,unix}
66cp -p generic/{default,tkInt,tkIntDecls,tkPort}.h %buildroot/%{_includedir}/tk-private/generic
67cp -p unix/tkUnix{Default,Port}.h %buildroot/%{_includedir}/tk-private/unix
68
69# Fix up the include files.
70cp generic/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/generic
71cp unix/*.h $RPM_BUILD_ROOT%{_includedir}/tk-private/unix
72
73# remove buildroot traces
74perl -pi -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/tk-private|" %buildroot/%{_libdir}/tkConfig.sh
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post
80/sbin/ldconfig
81
82%postun
83/sbin/ldconfig
84
85%files
86%defattr(-,root,root,-)
87%doc
88%{_bindir}/wish*
89%{_datadir}/tk%{majorver}
90%{_libdir}/libtk%{majorver}.so
91%{_libdir}/tk%{majorver}
92%{_libdir}/tkConfig.sh
93%{_mandir}/man1/*
94%{_includedir}/*
95%{_libdir}/libtk.so
96%{_libdir}/libtkstub%{majorver}.a
97%{_mandir}/man3/*
98%{_mandir}/mann/*
99
100%changelog
101* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
102- rebuilt with rpm-4.8.1-3
103
104* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
105- rebuilt with tcl-8.4.19-2
106- dropt Patch4: tk-8.4.18-tkBind.patch
107
108* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
109- new upstream release
110- add Patch3,4 to fix bug (broken if built with xproto-7.x)
111
112* Mon Jun 08 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-2
113- spec in utf-8
114
115* Mon May 12 2008 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
116- rebuild with xorg-x11-7.3
117  - remove Requires: XFree86-libs
118  - add BuildRequires: libX11-devel
119- use autoconf instead of autoconf217
120
121* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
122- updated tk to 8.4.18
123- included CVE-2008-0553
124
125* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
126- updated tk to 8.4.16
127
128* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
129- updated tk to 8.4.15
130- rebuilt with new toolchain
131
132* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
133- updated tk to 8.4.13
134
135* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
136- updated tk to 8.4.12
137- updated tk-%%{version}-lib-perm.patch
138
139* Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.11-0vl1
140- dropped tk-8.3.5-tclm4-soname.patch (fixed tcl.m4)
141- replaced tk-8.4.4-lib-perm.patch with tk-8.4.11-lib-perm.patch
142- dropped tk-8.4.5-no_rpath.patch (fixed tcl.m4)
143- dropped tk-8.4.6-tkUnixWm.patch (fixed invalid 118n title)
144
145* Sat Jun 11 2005 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl2
146- added tk-8.4.6-tkUnixWm.patch
147
148* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
149- updated tk to 8.4.6
150
151* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
152- syncd with fedora
153  * Fri Dec 12 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-3
154  - add private header files needed to build tix in /usr/include/tk-private
155
156  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-2
157  - removed rpath (patch 3)
158
159  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
160  - new package split out from tcltk
161  - update to tk 8.4.5 (#88429)
162  - filtered changelog for tk
163  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
164  - remove build remnants from tkConfig.sh
165
166* Tue Apr 01 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl2
167- fix buildrequires and requires section
168
169* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
170- update based on BitWalk's tcltk-8.4.2-83bw
171
172* Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
173- splite source package
174- add include files
175
176* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
177- expand some macros.. (FIXME)
178
179* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
180- use %configure macros
181- add Patch 47,50
182
183* Thu May 31 2001 <sagami@vinelinux.org>
184- 8.0.5_jp-10
185- unexpand old %%{configure}, new one causes build failure
186- fixed missing libtkx.so libtclx.so symlink in /usr/lib
187- install manpages into %%{_mandir} and mode 644
188
189* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
190- 8.0.5_jp-9
191- modified %install section to handle compressed man pages
192- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
193
194* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
195- changed default fonts
196
197* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
198- added defattr
199
200* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
201- added some symlinks, such as libtcl8.0.so.
202- obsoletes version number using _jp, now 8.0.5-31vl1
203
204* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
205- Apply Tcl/Tk 8.0 Japanese Patch 1.7
206
207* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
208- fix tclX symlinks.
209- compile on systems where SIGPWR == SIGLOST.
210
211* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
212- update tcl/tk to 8.0.5.
213- avoid "containing" in Tix (#2332).
214
215* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
216- use /usr/bin/write in kibitz (#1320).
217- use cirrus.sprl.umich.edu in weather (#1926).
218
219* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
220- auto rebuild in the new build environment (release 28)
221
222* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
223- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
224
225* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
226- expect does unaligned access on alpha (#989)
227- upgrade tcl/tk/tclX to 8.0.4
228- upgrade expect to 5.28.
229- add itcl 3.0.1
230
231* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
232- call libtoolize to allow building on the arm
233- build for glibc 2.1
234- strip binaries
235
236* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
237- update tcl/tk/tclX to 8.0.3, expect is updated also.
238
239* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
240- expect: mkpasswd needs delay before sending password (problem #576)
241
242* Thu May 07 1998 Prospector System <bugs@redhat.com>
243- translations modified for de, fr, tr
244
245* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
246- fixed expect binaries exec permissions
247
248* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
249- updated to Tix 4.1.0.006
250- updated version numbers of tcl/tk to relflect includsion of p2
251
252* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
253- updated tcl/tk to patch level 2
254- updated tclX to 8.0.2
255
256* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
257- fixed filelist for tix... replacing path to the expect binary in scripts
258  was leaving junk files around.
259
260* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
261- added patch to remove libieee test in configure.in for tcl and tk.
262  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
263  solution for all systems
264- fixed src urls
265
266* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
267- removed version numbers from descriptions
268
269* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
270- updated to tcl/tk 8.0 and related versions of packages
271
272* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
273- built against glibc
274- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.