source: projects/specs/branches/6/t/texlive-common/texlive-common-vl.spec @ 3944

Revision 3944, 6.6 KB checked in by munepi, 13 years ago (diff)

updated texlive and its related packages: ready for Vine Linux 6 release

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%if %{?_dist_release} == "vl6"
5Provides:    jadetex
6Obsoletes:   jadetex tetex dvipdfmx xdvik xdvik-motif
7%endif
8%if %{?_dist_release} == "vl5"
9Provides:    jadetex
10Conflicts:   tetex dvipdfmx xdvik xdvik-motif jvf
11%endif
12Obsoletes:   tetex-latex tetex-afm tetex-type1 tetex-devel
13Obsoletes:   pTeX pLaTeX2e pLaTeX2e_Macros dvipsk
14Obsoletes:   dvipdfm texmacro-aps
15Obsoletes:   makejvf <= 1.1a
16Conflicts:   task-texmacro-phys < 1.1
17
18%define tex_destdir     %{_datadir}
19%define texmf           %{tex_destdir}/texmf
20%define texlive_src     %{tex_destdir}/texlive-sources
21%define build_tex_destdir       %{buildroot}%{tex_destdir}
22%define build_texmf     %{buildroot}%{texmf}
23
24%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
25%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
26%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
27## NOTE: For only texlive-common, if %exec_fmtutil fails,
28## we show the STDERR of %exec_fmtutil.
29%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
30%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
31%define vartexfonts %{_var}/lib/texmf
32
33%define __find_provides %{nil}
34%define __find_requires %{nil}
35%define __perl_provides %{nil}
36%define __perl_requires %{nil}
37
38Autoreq: 0
39
40Summary: Common base for all TeX Live packages
41Summary(ja): TeX Live パッケージの共通ベース
42Name: texlive-common
43Version: 2009
44Release: 6%{?_dist_release}
45License: distributable
46Group: Applications/Publishing
47URL: http://www.tug.org/texlive/
48
49Requires: texlive = %{version}
50Requires(pre,post): texlive = %{version}
51Requires: texlive-collection-basic = %{version}
52Requires(post): texlive-collection-basic = %{version}
53Requires: texlive-collection-latex = %{version}
54Requires(post): texlive-collection-latex = %{version}
55Requires: texlive-collection-latexrecommended = %{version}
56Requires(post): texlive-collection-latexrecommended = %{version}
57Requires: texlive-collection-fontsrecommended = %{version}
58Requires(post): texlive-collection-fontsrecommended = %{version}
59
60#### $ pdftex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
61## dehypht-x-2009-06-19.tex
62Requires: texlive-collection-langgerman = %{version}
63Requires(post): texlive-collection-langgerman = %{version}
64## catkoi
65Requires: texlive-collection-langcyrillic = %{version}
66Requires(post): texlive-collection-langcyrillic = %{version}
67
68#### $ xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini
69## unicode-letters
70Requires: texlive-collection-xetex = %{version}
71Requires(post): texlive-collection-xetex = %{version}
72
73BuildArch:      noarch
74Buildroot:    %{_tmppath}/%{name}-%{version}-root
75
76Vendor:       Project Vine
77Distribution: Vine Linux
78Packager:     munepi
79
80
81%description
82The TeX Live software distribution offers a complete TeX system for a
83variety of Unix, Macintosh, Windows and other platforms. It
84encompasses programs for editing, typesetting, previewing and printing
85of TeX documents in many different languages, and a large collection
86of TeX macros and font libraries.
87
88The distribution includes extensive general documentation about TeX,
89as well as the documentation for the included software packages.
90
91This package is a virtual package
92to provide a common base for all TeX Live packages.
93
94
95%description -l ja
96TeX Live ソフトウェアディストリビューションは、
97さまざまな Unix, Macintosh, Windows、および
98他のプラットホームに対して完全な TeX システムを提供します。
99多くの異なった言語を含む TeX ドキュメントの
100編集、組版、閲覧、印刷するためのプログラム、
101そして、TeX マクロやフォントライブラリの大きなコレクションを
102同梱しています。
103
104このディストリビューションは
105同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
106TeX に関するたくさんの一般的なドキュメントを含んでいます。
107
108このパッケージは TeX Live パッケージの共通ベースを
109提供ための仮想パッケージです。
110
111
112%files
113
114
115%post
116%{exec_texhash}
117
118updmap_lock=%{texmf}/updmap.lock
119# The packages required texlive-common contained the following maps.
120(cat<<EOF
121MixedMap cm.map
122MixedMap cmextra.map
123MixedMap cyrillic.map
124Map euler.map
125MixedMap latxfont.map
126MixedMap symbols.map
127MixedMap cmtext-bsr-interpolated.map
128MixedMap mflogo.map
129Map charter.map
130Map fpls.map
131Map pazo.map
132Map utopia.map
133Map zpeu.map
134MixedMap eurosym.map
135Map lm.map
136Map marvosym.map
137Map pxfonts.map
138MixedMap rsfs.map
139Map qag.map
140Map qbk.map
141Map qcr.map
142Map qcs.map
143Map qhv.map
144Map qpl.map
145Map qtm.map
146Map qzc.map
147MixedMap tipa.map
148Map txfonts.map
149MixedMap wasy.map
150Map cmcyr.map
151EOF
152) | while read maptype map; do
153%{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! ${maptype} ${map}" && \
154    echo -n "    " && \
155    echo -n "Running updmap: enable ${map} ... " && \
156    %{exec_updmap} --nomkmap --enable ${maptype} ${map} >/dev/null 2>&1 && \
157    echo "done." && \
158    touch ${updmap_lock}
159done
160
161echo -n "    "
162echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
163rm -f %{texmf}/updmap.lock
164echo -n "    "
165echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
166
167exit 0
168
169
170# %postun
171# %{exec_texhash}
172# echo -n "    "
173# echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
174# echo -n "    "
175# echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
176
177exit 0
178
179
180%changelog
181* Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
182- added Requires(post): for all requirements of texlive-collection-*
183- added Requires: texlive
184
185* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
186- improved %%post
187  - checked the maps containing Require(post) dependencies
188
189* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
190- added Requires(post): texlive
191- changed Requires(pre): -> Requires(post): for all requirements
192
193* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
194- added to remove %%{texmf}/updmap.lock in %%post
195  - When texlive-common is installed, this lock generating
196    texlive-collection-* leaves.
197- dropped %%postun
198- added some comments for the definition of %%exec_fmtutil
199
200* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
201- changed Requires: -> Requires(pre): for all requirements
202- merged dependencies of Provides:/Obsoletes: tags from texlive-vl.spec
203
204* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
205- TeX Live 2009
Note: See TracBrowser for help on using the repository browser.