source: projects/specs/trunk/t/texlive-common/texlive-common-vl.spec @ 5207

Revision 5207, 7.0 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4Provides:    jadetex
5Obsoletes:   texlive-common < %{version}
6Obsoletes:   jadetex tetex dvipdfmx xdvik xdvik-motif
7Obsoletes:   tetex-latex tetex-afm tetex-type1 tetex-devel
8Obsoletes:   pTeX pLaTeX2e pLaTeX2e_Macros dvipsk
9Obsoletes:   dvipdfm texmacro-aps
10Obsoletes:   makejvf <= 1.1a
11Conflicts:   task-texmacro-phys < 1.1
12
13%global _use_internal_dependency_generator 0
14%global __find_provides %{nil}
15%global __find_requires %{nil}
16
17%define tex_destdir     %{_datadir}
18%define texmf           %{tex_destdir}/texmf
19%define texlive_src     %{tex_destdir}/texlive-sources
20%define build_tex_destdir       %{buildroot}%{tex_destdir}
21%define build_texmf     %{buildroot}%{texmf}
22
23%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
24%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
25%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
26## NOTE: For only texlive-common, if %exec_fmtutil fails,
27## we show the STDERR of %exec_fmtutil.
28%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
29%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
30%define vartexfonts %{_var}/lib/texmf/fonts
31
32Summary: Common base for all TeX Live packages
33Summary(ja): TeX Live パッケージの共通ベース
34Name: texlive-common
35Version: 2011
36Release: 1%{?_dist_release}
37License: distributable
38Group: Applications/Publishing
39URL: http://www.tug.org/texlive/
40
41Requires: texlive = %{version}
42Requires(pre,post): texlive = %{version}
43Requires: texlive-collection-basic = %{version}
44Requires(post): texlive-collection-basic = %{version}
45Requires: texlive-collection-latex = %{version}
46Requires(post): texlive-collection-latex = %{version}
47Requires: texlive-collection-latexrecommended = %{version}
48Requires(post): texlive-collection-latexrecommended = %{version}
49Requires: texlive-collection-fontsrecommended = %{version}
50Requires(post): texlive-collection-fontsrecommended = %{version}
51
52#### $ pdftex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
53## dehypht-x-2009-06-19.tex
54Requires: texlive-collection-langgerman = %{version}
55Requires(post): texlive-collection-langgerman = %{version}
56## catkoi
57Requires: texlive-collection-langcyrillic = %{version}
58Requires(post): texlive-collection-langcyrillic = %{version}
59
60#### $ xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini
61## unicode-letters
62Requires: texlive-collection-xetex = %{version}
63Requires(post): texlive-collection-xetex = %{version}
64
65Requires: texlive-collection-langcjk = %{version}
66Requires(pre,post): texlive-collection-langcjk = %{version}
67
68BuildArch:      noarch
69Buildroot:    %{_tmppath}/%{name}-%{version}-root
70
71Vendor:       Project Vine
72Distribution: Vine Linux
73Packager:     munepi
74
75
76%description
77The TeX Live software distribution offers a complete TeX system for a
78variety of Unix, Macintosh, Windows and other platforms. It
79encompasses programs for editing, typesetting, previewing and printing
80of TeX documents in many different languages, and a large collection
81of TeX macros and font libraries.
82
83The distribution includes extensive general documentation about TeX,
84as well as the documentation for the included software packages.
85
86This package is a virtual package
87to provide a common base for all TeX Live packages.
88
89
90%description -l ja
91TeX Live ソフトウェアディストリビューションは、
92さまざまな Unix, Macintosh, Windows、および
93他のプラットホームに対して完全な TeX システムを提供します。
94多くの異なった言語を含む TeX ドキュメントの
95編集、組版、閲覧、印刷するためのプログラム、
96そして、TeX マクロやフォントライブラリの大きなコレクションを
97同梱しています。
98
99このディストリビューションは
100同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
101TeX に関するたくさんの一般的なドキュメントを含んでいます。
102
103このパッケージは TeX Live パッケージの共通ベースを
104提供ための仮想パッケージです。
105
106
107%files
108
109
110%posttrans
111%{exec_texhash}
112
113updmap_lock=%{texmf}/updmap.lock
114# The packages required texlive-common contained the following maps.
115(cat<<EOF
116MixedMap cm.map
117MixedMap cmextra.map
118MixedMap cyrillic.map
119Map euler.map
120MixedMap latxfont.map
121MixedMap symbols.map
122MixedMap cmtext-bsr-interpolated.map
123MixedMap mflogo.map
124Map mathpple.map
125Map charter.map
126Map fpls.map
127Map pazo.map
128Map utopia.map
129MixedMap cm-super-t1.map
130MixedMap cm-super-t2a.map
131MixedMap cm-super-t2b.map
132MixedMap cm-super-t2c.map
133MixedMap cm-super-ts1.map
134MixedMap cm-super-x2.map
135MixedMap eurosym.map
136Map lm.map
137Map marvosym.map
138Map pxfonts.map
139MixedMap rsfs.map
140Map qag.map
141Map qbk.map
142Map qcr.map
143Map qcs.map
144Map qhv.map
145Map qpl.map
146Map qtm.map
147Map qzc.map
148MixedMap tipa.map
149Map txfonts.map
150MixedMap wasy.map
151Map cmcyr.map
152Map bkaiu.map
153Map bsmiu.map
154Map gbsnu.map
155Map gkaiu.map
156Map garuda-c90.map
157Map norasi-c90.map
158Map umj.map
159Map dgj.map
160Map dmj.map
161Map mc2j.map
162Map mcj.map
163Map mr2j.map
164Map mrj.map
165EOF
166) | while read maptype map; do
167%{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! ${maptype} ${map}" && \
168    echo -n "    " && \
169    echo -n "Running updmap: enable ${map} ... " && \
170    %{exec_updmap} --nomkmap --enable ${maptype} ${map} >/dev/null 2>&1 && \
171    echo "done." && \
172    touch ${updmap_lock}
173done
174
175
176
177echo -n "    "
178echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
179rm -f %{texmf}/updmap.lock
180echo -n "    "
181echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
182
183exit 0
184
185
186# %postun
187# %{exec_texhash}
188# echo -n "    "
189# echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
190# echo -n "    "
191# echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
192
193exit 0
194
195
196%changelog
197* Sat Nov 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
198- TeX Live 2011
199
200* Mon May 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
201- added Requires(post): for all requirements of texlive-collection-*
202- added Requires: texlive
203
204* Sat Apr 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
205- improved %%post
206  - checked the maps containing Require(post) dependencies
207
208* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
209- added Requires(post): texlive
210- changed Requires(pre): -> Requires(post): for all requirements
211
212* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
213- added to remove %%{texmf}/updmap.lock in %%post
214  - When texlive-common is installed, this lock generating
215    texlive-collection-* leaves.
216- dropped %%postun
217- added some comments for the definition of %%exec_fmtutil
218
219* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
220- changed Requires: -> Requires(pre): for all requirements
221- merged dependencies of Provides:/Obsoletes: tags from texlive-vl.spec
222
223* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
224- TeX Live 2009
Note: See TracBrowser for help on using the repository browser.