source: projects/specs/trunk/t/texlive-common/texlive-common-vl.spec @ 3150

Revision 3150, 5.0 KB checked in by munepi, 13 years ago (diff)

updated texlive-vl.spec, texlive-common-vl.spec task-texlive-vl.spec

Line 
1## -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%if %{?_dist_release} == "vl6"
5Provides:    jadetex
6Obsoletes:   jadetex tetex dvipdfmx xdvik xdvik-motif
7%endif
8%if %{?_dist_release} == "vl5"
9Provides:    jadetex
10Conflicts:   tetex dvipdfmx xdvik xdvik-motif jvf
11%endif
12Obsoletes:   tetex-latex tetex-afm tetex-type1 tetex-devel
13Obsoletes:   pTeX pLaTeX2e pLaTeX2e_Macros dvipsk
14Obsoletes:   dvipdfm texmacro-aps
15Obsoletes:   makejvf <= 1.1a
16Conflicts:   task-texmacro-phys < 1.1
17
18%define tex_destdir     %{_datadir}
19%define texmf           %{tex_destdir}/texmf
20%define texlive_src     %{tex_destdir}/texlive-sources
21%define build_tex_destdir       %{buildroot}%{tex_destdir}
22%define build_texmf     %{buildroot}%{texmf}
23
24%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
25%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
26%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
27## NOTE: For only texlive-common, if %exec_fmtutil fails,
28## we show the STDERR of %exec_fmtutil.
29%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
30%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
31%define vartexfonts %{_var}/lib/texmf
32
33%define __find_provides %{nil}
34%define __find_requires %{nil}
35%define __perl_provides %{nil}
36%define __perl_requires %{nil}
37
38Autoreq: 0
39
40Summary: Common base for all TeX Live packages
41Summary(ja): TeX Live パッケージの共通ベース
42Name: texlive-common
43Version: 2009
44Release: 4%{?_dist_release}
45License: distributable
46Group: Applications/Publishing
47URL: http://www.tug.org/texlive/
48
49Requires(post): texlive = %{version}
50Requires(post): texlive-collection-basic = %{version}
51Requires(post): texlive-collection-latex = %{version}
52Requires(post): texlive-collection-latexrecommended = %{version}
53Requires(post): texlive-collection-fontsrecommended = %{version}
54
55#### $ pdftex -ini  -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
56## dehypht-x-2009-06-19.tex
57Requires(post): texlive-collection-langgerman = %{version}
58## catkoi
59Requires(post): texlive-collection-langcyrillic = %{version}
60
61#### $ xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini
62## unicode-letters
63Requires(post): texlive-collection-xetex = %{version}
64
65BuildArch:      noarch
66Buildroot:    %{_tmppath}/%{name}-%{version}-root
67
68Vendor:       Project Vine
69Distribution: Vine Linux
70Packager:     munepi
71
72
73%description
74The TeX Live software distribution offers a complete TeX system for a
75variety of Unix, Macintosh, Windows and other platforms. It
76encompasses programs for editing, typesetting, previewing and printing
77of TeX documents in many different languages, and a large collection
78of TeX macros and font libraries.
79
80The distribution includes extensive general documentation about TeX,
81as well as the documentation for the included software packages.
82
83This package is a virtual package
84to provide a common base for all TeX Live packages.
85
86
87%description -l ja
88TeX Live ソフトウェアディストリビューションは、
89さまざまな Unix, Macintosh, Windows、および
90他のプラットホームに対して完全な TeX システムを提供します。
91多くの異なった言語を含む TeX ドキュメントの
92編集、組版、閲覧、印刷するためのプログラム、
93そして、TeX マクロやフォントライブラリの大きなコレクションを
94同梱しています。
95
96このディストリビューションは
97同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
98TeX に関するたくさんの一般的なドキュメントを含んでいます。
99
100このパッケージは TeX Live パッケージの共通ベースを
101提供ための仮想パッケージです。
102
103
104%files
105
106
107%post
108%{exec_texhash}
109echo -n "    "
110echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
111rm -f %{texmf}/updmap.lock
112echo -n "    "
113echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
114
115exit 0
116
117
118# %postun
119# %{exec_texhash}
120# echo -n "    "
121# echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
122# echo -n "    "
123# echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
124
125exit 0
126
127
128%changelog
129* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
130- added Requires(post): texlive
131- changed Requires(pre): -> Requires(post): for all requirements
132
133* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
134- added to remove %%{texmf}/updmap.lock in %%post
135  - When texlive-common is installed, this lock generating
136    texlive-collection-* leaves.
137- dropped %%postun
138- added some comments for the definition of %%exec_fmtutil
139
140* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
141- changed Requires: -> Requires(pre): for all requirements
142- merged dependencies of Provides:/Obsoletes: tags from texlive-vl.spec
143
144* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
145- TeX Live 2009
Note: See TracBrowser for help on using the repository browser.