source: projects/specs/branches/6/t/texlive-collection-langhebrew/texlive-collection-langhebrew-vl.spec @ 2505

Revision 2505, 8.0 KB checked in by munepi, 13 years ago (diff)

updated all texlive-collection-* packages: improved %%post

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-3:
3## tlpdb2rpmspec collection-langhebrew
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Hebrew
28Summary(ja): TeX Live: Hebrew
29Name: texlive-collection-langhebrew
30Version: 2009
31Release: 3%{?_dist_release}
32License: LPPL
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Hebrew:
61Support for typesetting Hebrew.
62
63This package contains the following CTAN packages:
64cjhebrew: Typeset Hebrew with LaTeX.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Hebrew:
81Support for typesetting Hebrew.
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84cjhebrew: Typeset Hebrew with LaTeX.
85
86%package doc
87Summary: TeX Live: Documentation files of %{name}
88Group: Applications/Publishing
89Requires: %{name} = %{version}-%{release}
90
91%description doc
92This package contains documentation files of %{name}.
93
94%prep
95
96%build
97
98%install
99[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
100
101PREF=%{buildroot}%{tex_destdir}
102
103manifest=(
104texmf-dist/doc/fonts/cjhebrew/cjhebtst.tex
105texmf-dist/doc/fonts/cjhebrew/manual.pdf
106texmf-dist/fonts/afm/public/cjhebrew/cjheblsm.afm
107texmf-dist/fonts/afm/public/cjhebrew/cjhebltx.afm
108texmf-dist/fonts/enc/dvips/cjhebrew/cjhebltx.enc
109texmf-dist/fonts/map/dvips/cjhebrew/cjhebrew.map
110texmf-dist/fonts/tfm/public/cjhebrew/cjhblsm.tfm
111texmf-dist/fonts/tfm/public/cjhebrew/cjhbltx.tfm
112texmf-dist/fonts/tfm/public/cjhebrew/cjheblsm.tfm
113texmf-dist/fonts/tfm/public/cjhebrew/cjhebltx.tfm
114texmf-dist/fonts/tfm/public/cjhebrew/rcjhblsm.tfm
115texmf-dist/fonts/tfm/public/cjhebrew/rcjhbltx.tfm
116texmf-dist/fonts/type1/public/cjhebrew/cjheblsm.pfb
117texmf-dist/fonts/type1/public/cjhebrew/cjhebltx.pfb
118texmf-dist/fonts/vf/public/cjhebrew/cjhblsm.vf
119texmf-dist/fonts/vf/public/cjhebrew/cjhbltx.vf
120texmf-dist/tex/latex/cjhebrew/cjhebrew.sty
121)
122
123%__mkdir_p ${PREF}/texmf-dist
124for i in "${manifest[@]}"; do
125    %__install -D %{texlive_src}/$i ${PREF}/$i
126done
127
128## info
129%__rm -f %{buildroot}%{_infodir}/dir
130%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
131
132## man
133## man t1* files are provided by t1utils
134for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
135    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
136done
137
138## man some files are provided by psutils
139for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
140    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
141done
142
143## fix perl path
144for i in source/metapost/expressg/expressg.dtx \
145         doc/metapost/expressg/n2mpsprl.prl \
146         doc/latex/songbook/contrib/crd2sb/crd2sb; do
147    [ -f %{build_texmf}-dist/${i} ] && \
148        %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
149done
150
151## remove asymptote directries, which provides asymptote package
152find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
153# find %{buildroot} -name "Makefile" | xargs %__rm -f
154
155# ## remove xindy
156# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
157
158# ## remove tex4ht
159# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
160
161## remove arch dependent binaries
162%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
163
164## remove unpackaging files
165find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
166find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
167
168## Files list
169find %{buildroot} -type f -or -type l | \
170    %__sed -e "s|%{buildroot}||g" > filelist.full
171
172find %{buildroot}%{texmf}-dist -type d | \
173    %__sed -e "s|^%{buildroot}|%dir |" \
174           -e "s|$|/|"             >> filelist.full
175
176## subpackages
177grep "/texmf-dist/doc/" filelist.full > filelist.doc
178cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
179%__mv -f filelist.tmp filelist.full
180
181%clean
182%__rm -rf %{buildroot}
183
184%post
185%{exec_texhash}
186
187[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
188
189updmap_lock=%{texmf}/updmap.lock
190%{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! Map cjhebrew.map" && \
191    echo -n "    " && \
192    echo -n "Running updmap: enable cjhebrew.map ... " && \
193    %{exec_updmap} --nomkmap --enable Map cjhebrew.map >/dev/null 2>&1 && \
194    echo "done." && \
195    touch ${updmap_lock}
196
197rpm -q --quiet texlive-common || exit 0
198
199[ -f ${updmap_lock} ] && \
200    echo -n "    " && \
201    echo -n "Running updmap: recreate map files ... " && \
202    %{exec_updmap} >/dev/null 2>&1 && \
203    echo "done." && \
204    rm -f ${updmap_lock}
205
206exit 0
207
208
209%postun
210if [ "$1" = 0 ]; then
211    %{exec_texhash}
212
213    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
214
215    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^Map cjhebrew.map" && \
216        echo -n "    " && \
217        echo -n "Running updmap: disable cjhebrew.map ... " && \
218        %{exec_updmap} --nomkmap --disable cjhebrew.map >/dev/null 2>&1 && \
219        echo "done."
220    echo -n "    " && \
221        echo -n "Running updmap: recreate map files ... " && \
222        %{exec_updmap} >/dev/null 2>&1 && \
223        echo "done."
224
225fi
226
227exit 0
228
229%files -f filelist.full
230%defattr(-,root,root)
231
232%files -f filelist.doc doc
233%defattr(-,root,root)
234
235%changelog
236* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
237- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langhebrew
238- improved %%post
239
240* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
241- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langhebrew
242- removed arch dependent binaries (texlive-collection-latexextra)
243- fixed perl path
244- improved updmap process in %%post and %%postun
245
246* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
247- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langhebrew
Note: See TracBrowser for help on using the repository browser.