source: projects/specs/trunk/t/texlive-collection-langhebrew/texlive-collection-langhebrew-vl.spec @ 5207

Revision 5207, 15.4 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
3## tlpdb2rpmspec collection-langhebrew
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
22%define vartexfonts %{_var}/lib/texmf/fonts
23
24Summary: TeX Live: Hebrew
25Summary(ja): TeX Live: Hebrew
26Name: texlive-collection-langhebrew
27Version: 2011
28Release: 1%{?_dist_release}
29License: LPPL
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34Requires: texlive-collection-basic = %{version}
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Hebrew:
58Support for typesetting Hebrew.
59
60This package contains the following CTAN packages:
61cjhebrew: Typeset Hebrew with LaTeX.
62
63%description -l ja
64TeX Live ソフトウェアディストリビューションは、
65さまざまな Unix, Macintosh, Windows、および
66他のプラットホームに対して完全な TeX システムを提供します。
67多くの異なった言語を含む TeX ドキュメントの
68編集、組版、閲覧、印刷するためのプログラム、
69そして、TeX マクロやフォントライブラリの大きなコレクションを
70同梱しています。
71
72このディストリビューションは
73同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
74TeX に関するたくさんの一般的なドキュメントを含んでいます。
75
76このパッケージは以下のようなパッケージ集です。
77Hebrew:
78Support for typesetting Hebrew.
79
80このパッケージは以下の CTAN パッケージを含んでいます:
81cjhebrew: Typeset Hebrew with LaTeX.
82
83%package doc
84Summary: TeX Live: Documentation files of %{name}
85Group: Applications/Publishing
86Requires: %{name} = %{version}-%{release}
87
88%description doc
89This package contains documentation files of %{name}.
90
91%prep
92
93%build
94
95%install
96[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
97
98PREF=%{buildroot}%{tex_destdir}
99
100manifest=(
101texmf-dist/doc/fonts/cjhebrew/cjhebtst.tex
102texmf-dist/doc/fonts/cjhebrew/manual.pdf
103texmf-dist/fonts/afm/public/cjhebrew/cjheblsm.afm
104texmf-dist/fonts/afm/public/cjhebrew/cjhebltx.afm
105texmf-dist/fonts/enc/dvips/cjhebrew/cjhebltx.enc
106texmf-dist/fonts/map/dvips/cjhebrew/cjhebrew.map
107texmf-dist/fonts/tfm/public/cjhebrew/cjhblsm.tfm
108texmf-dist/fonts/tfm/public/cjhebrew/cjhbltx.tfm
109texmf-dist/fonts/tfm/public/cjhebrew/cjheblsm.tfm
110texmf-dist/fonts/tfm/public/cjhebrew/cjhebltx.tfm
111texmf-dist/fonts/tfm/public/cjhebrew/rcjhblsm.tfm
112texmf-dist/fonts/tfm/public/cjhebrew/rcjhbltx.tfm
113texmf-dist/fonts/type1/public/cjhebrew/cjheblsm.pfb
114texmf-dist/fonts/type1/public/cjhebrew/cjhebltx.pfb
115texmf-dist/fonts/vf/public/cjhebrew/cjhblsm.vf
116texmf-dist/fonts/vf/public/cjhebrew/cjhbltx.vf
117texmf-dist/tex/latex/cjhebrew/cjhebrew.sty
118)
119
120%__mkdir_p ${PREF}/texmf-dist
121for i in "${manifest[@]}"; do
122    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
123done
124## make symlinks of core script utils
125mk_symlinks=(
126texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
127texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
128texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
129texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
130texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
131texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
132texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
133texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
134texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
135texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
136texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
137texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
138texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
139texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
140texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
141texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
142texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
143texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
144texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
145texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
146texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
147texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
148texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
149texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
150texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
151texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
152texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
153texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
154texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
155texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
156texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
157texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
158texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
159texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
160texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
161texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
162texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
163texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
164texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
165texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
166texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
167texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
168texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
169texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
170texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
171texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
172texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
173texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
174texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
175texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
176texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
177texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
178texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
179texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
180texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
181texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
182texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
183texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
184texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
185texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
186texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
187texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
188texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
189texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
190texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
191texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
192texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
193texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
194texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
195texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
196texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
197texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
198texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
199texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
200texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
201texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
202texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
203texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
204texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
205texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
206texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
207texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
208)
209%__mkdir_p %{buildroot}%{_bindir}
210pushd %{buildroot}%{_bindir}
211    for i in "${mk_symlinks[@]}"; do
212        tlc=$(echo $i | cut -f 1 -d",")
213        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
214        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
215
216        [ "%{name}" = "$tlc" ] || continue
217        [ -f $rlnk ] || exit 1
218        %__ln_s $rlnk $lnk || exit 1
219    done
220popd
221## Files list
222find %{buildroot} -type f -or -type l | \
223    %__sed -e "s|%{buildroot}||g" > filelist.full
224
225find %{buildroot}%{texmf}-dist -type d | \
226    %__sed -e "s|^%{buildroot}|%dir |" \
227           -e "s|$|/|"             >> filelist.full
228
229## subpackages
230grep "/texmf-dist/doc/" filelist.full > filelist.doc
231cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
232%__mv -f filelist.tmp filelist.full
233
234%clean
235%__rm -rf %{buildroot}
236
237%post
238%{exec_texhash}
239
240[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
241
242updmap_lock=%{texmf}/updmap.lock
243%{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! Map cjhebrew.map" && \
244    echo -n "    " && \
245    echo -n "Running updmap: enable cjhebrew.map ... " && \
246    %{exec_updmap} --nomkmap --enable Map cjhebrew.map >/dev/null 2>&1 && \
247    echo "done." && \
248    touch ${updmap_lock}
249
250rpm -q --quiet texlive-common || exit 0
251
252[ -f ${updmap_lock} ] && \
253    echo -n "    " && \
254    echo -n "Running updmap: recreate map files ... " && \
255    %{exec_updmap} >/dev/null 2>&1 && \
256    echo "done." && \
257    rm -f ${updmap_lock}
258
259exit 0
260
261
262%postun
263if [ "$1" = 0 ]; then
264    %{exec_texhash}
265
266    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
267
268    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^Map cjhebrew.map" && \
269        echo -n "    " && \
270        echo -n "Running updmap: disable cjhebrew.map ... " && \
271        %{exec_updmap} --nomkmap --disable cjhebrew.map >/dev/null 2>&1 && \
272        echo "done."
273    echo -n "    " && \
274        echo -n "Running updmap: recreate map files ... " && \
275        %{exec_updmap} >/dev/null 2>&1 && \
276        echo "done."
277
278fi
279
280exit 0
281
282%files -f filelist.full
283%defattr(-,root,root,-)
284
285%files -f filelist.doc doc
286%defattr(-,root,root,-)
287
288%changelog
289* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
290- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-langhebrew
291
292* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
293- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-langhebrew
294- make symlinks of core script utils (texlive-collection-binextra,
295  texlive-collection-context, texlive-collection-fontutils,
296  texlive-collection-langgreek, texlive-collection-langindic,
297  texlive-collection-latex, texlive-collection-latexextra,
298  texlive-collection-latexrecommended, texlive-collection-pictures,
299  texlive-collection-pstricks, texlive-collection-science)
300
301* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
302- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-langhebrew
303- improved %%post
304
305* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
306- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langhebrew
307- removed arch dependent binaries (texlive-collection-latexextra)
308- fixed perl path
309- improved updmap process in %%post and %%postun
310
311* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
312- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langhebrew
Note: See TracBrowser for help on using the repository browser.