source: projects/specs/trunk/t/texlive-collection-langhebrew/texlive-collection-langhebrew-vl.spec @ 1974

Revision 1974, 7.7 KB checked in by munepi, 14 years ago (diff)

updated all texlive-collection packages: generated by tlpdb2rpmspec 2009-2; removed arch dependent binaries (for rpm-4.8.1); fixed perl path (for rpm-4.8.1); improved updmap process in %%post and %%postun

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
3## tlpdb2rpmspec collection-langhebrew
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Hebrew
28Summary(ja): TeX Live: Hebrew
29Name: texlive-collection-langhebrew
30Version: 2009
31Release: 2%{?_dist_release}
32License: LPPL
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Hebrew:
61Support for typesetting Hebrew.
62
63This package contains the following CTAN packages:
64cjhebrew: Typeset Hebrew with LaTeX.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Hebrew:
81Support for typesetting Hebrew.
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84cjhebrew: Typeset Hebrew with LaTeX.
85
86%package doc
87Summary: TeX Live: Documentation files of %{name}
88Group: Applications/Publishing
89Requires: %{name} = %{version}-%{release}
90
91%description doc
92This package contains documentation files of %{name}.
93
94%prep
95
96%build
97
98%install
99[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
100
101PREF=%{buildroot}%{tex_destdir}
102
103manifest=(
104texmf-dist/doc/fonts/cjhebrew/cjhebtst.tex
105texmf-dist/doc/fonts/cjhebrew/manual.pdf
106texmf-dist/fonts/afm/public/cjhebrew/cjheblsm.afm
107texmf-dist/fonts/afm/public/cjhebrew/cjhebltx.afm
108texmf-dist/fonts/enc/dvips/cjhebrew/cjhebltx.enc
109texmf-dist/fonts/map/dvips/cjhebrew/cjhebrew.map
110texmf-dist/fonts/tfm/public/cjhebrew/cjhblsm.tfm
111texmf-dist/fonts/tfm/public/cjhebrew/cjhbltx.tfm
112texmf-dist/fonts/tfm/public/cjhebrew/cjheblsm.tfm
113texmf-dist/fonts/tfm/public/cjhebrew/cjhebltx.tfm
114texmf-dist/fonts/tfm/public/cjhebrew/rcjhblsm.tfm
115texmf-dist/fonts/tfm/public/cjhebrew/rcjhbltx.tfm
116texmf-dist/fonts/type1/public/cjhebrew/cjheblsm.pfb
117texmf-dist/fonts/type1/public/cjhebrew/cjhebltx.pfb
118texmf-dist/fonts/vf/public/cjhebrew/cjhblsm.vf
119texmf-dist/fonts/vf/public/cjhebrew/cjhbltx.vf
120texmf-dist/tex/latex/cjhebrew/cjhebrew.sty
121)
122
123%__mkdir_p ${PREF}/texmf-dist
124for i in "${manifest[@]}"; do
125    %__install -D %{texlive_src}/$i ${PREF}/$i
126done
127
128## info
129%__rm -f %{buildroot}%{_infodir}/dir
130%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
131
132## man
133## man t1* files are provided by t1utils
134for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
135    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
136done
137
138## man some files are provided by psutils
139for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
140    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
141done
142
143## fix perl path
144for i in source/metapost/expressg/expressg.dtx          doc/metapost/expressg/n2mpsprl.prl          doc/latex/songbook/contrib/crd2sb/crd2sb; do
145    [ -f %{build_texmf}-dist/${i} ] &&         %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
146done
147
148## remove asymptote directries, which provides asymptote package
149find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
150# find %{buildroot} -name "Makefile" | xargs %__rm -f
151
152# ## remove xindy
153# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
154
155# ## remove tex4ht
156# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
157
158## remove arch dependent binaries
159%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
160
161## remove unpackaging files
162find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
163find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
164
165## Files list
166find %{buildroot} -type f -or -type l | \
167    %__sed -e "s|%{buildroot}||g" > filelist.full
168
169find %{buildroot}%{texmf}-dist -type d | \
170    %__sed -e "s|^%{buildroot}|%dir |" \
171           -e "s|$|/|"             >> filelist.full
172
173## subpackages
174grep "/texmf-dist/doc/" filelist.full > filelist.doc
175cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
176%__mv -f filelist.tmp filelist.full
177
178%clean
179%__rm -rf %{buildroot}
180
181%post
182%{exec_texhash}
183
184[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
185
186    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! Map cjhebrew.map" && \
187        echo -n "    " && \
188        echo -n "Running updmap: enable cjhebrew.map ... " && \
189        %{exec_updmap} --nomkmap --enable Map cjhebrew.map >/dev/null 2>&1 && \
190        echo "done."
191echo -n "    " && \
192    echo -n "Running updmap: recreate map files ... " && \
193    %{exec_updmap} >/dev/null 2>&1 && \
194    echo "done."
195
196exit 0
197
198
199%postun
200if [ "$1" = 0 ]; then
201    %{exec_texhash}
202
203    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
204
205    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^Map cjhebrew.map" && \
206        echo -n "    " && \
207        echo -n "Running updmap: disable cjhebrew.map ... " && \
208        %{exec_updmap} --nomkmap --disable cjhebrew.map >/dev/null 2>&1 && \
209        echo "done."
210echo -n "    " && \
211    echo -n "Running updmap: recreate map files ... " && \
212    %{exec_updmap} >/dev/null 2>&1 && \
213    echo "done."
214
215fi
216
217exit 0
218
219%files -f filelist.full
220%defattr(-,root,root)
221
222%files -f filelist.doc doc
223%defattr(-,root,root)
224
225%changelog
226* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
227- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-langhebrew
228- removed arch dependent binaries (texlive-collection-latexextra)
229- fixed perl path
230- improved updmap process in %%post and %%postun
231
232* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
233- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-langhebrew
Note: See TracBrowser for help on using the repository browser.