source: projects/specs/branches/6/s/system-config-printer/system-config-printer-vl.spec @ 3659

Revision 3659, 31.7 KB checked in by daisuke, 13 years ago (diff)

s-c-printer: update ja.po

Line 
1%define pycups_version 1.9.55
2%define pysmbc_version 1.0.10
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
6
7Summary: A printer administration tool
8Summary(ja): プリンタ管理ツール
9Name: system-config-printer
10Version: 1.3.2
11Release: 3%{?_dist_release}
12License: GPLv2+
13URL: http://cyberelk.net/tim/software/system-config-printer/
14Group: System Environment/Base
15
16Source0: http://cyberelk.net/tim/data/system-config-printer/1.3/system-config-printer-%{version}.tar.xz
17Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
18Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
19
20Source10: %{name}-1.3.2-ja.po
21
22#Patch1: system-config-printer-no-applet-in-gnome.patch
23Patch2: system-config-printer-check-device-ids.patch
24Patch3: system-config-printer-self.printers.patch
25
26Patch20: %{name}-1.3.2-gettext.patch
27Patch21: %{name}-1.3.2-ppd-translation.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30
31BuildRequires: cups-devel >= 1.2
32BuildRequires: glib2-devel
33BuildRequires: python-devel >= 2.5
34BuildRequires: libsmbclient-devel >= 3.2
35BuildRequires: desktop-file-utils >= 0.2.92
36BuildRequires: gettext
37BuildRequires: intltool
38BuildRequires: xmlto
39BuildRequires: python-tools
40BuildRequires: libusb-devel, libudev-devel
41BuildRequires: epydoc
42
43Requires: pygtk2
44Requires: pygobject
45Requires: desktop-file-utils
46Requires: dbus-x11
47Requires: system-config-printer-libs = %{version}-%{release}
48Requires: gnome-icon-theme
49Requires: gnome-python
50Requires: gnome-python-gnomekeyring
51Requires: notification-daemon
52Requires: notify-python
53Requires: libxml2-python
54
55Obsoletes: system-config-printer-gui <= 0.6.152
56Provides: system-config-printer-gui = 0.6.152
57
58Obsoletes: desktop-printing <= 0.20-7.fc7
59Provides: desktop-printing = 0.20-7.fc7
60
61%description
62system-config-printer is a graphical user interface that allows
63the user to configure a CUPS print server.
64
65%package libs
66Summary: Libraries and shared code for printer administration tool
67Summary(ja): Libraries and shared code for printer administration tool
68Group: System Environment/Base
69Requires: python
70Requires: foomatic
71Provides: pycups = %{pycups_version}
72Provides: pysmbc = %{pysmbc_version}
73
74%description libs
75The common code used by both the graphical and non-graphical parts of
76the configuration tool.
77
78%package udev
79Summary: Rules for udev for automatic configuration of USB printers
80Group: System Environment/Base
81Requires: system-config-printer-libs = %{version}-%{release}
82Obsoletes: hal-cups-utils <= 0.6.20
83Provides: hal-cups-utils = 0.6.20
84
85%description udev
86The udev rules and helper programs for automatically configuring USB
87printers.
88
89%prep
90%setup -q -a 1 -a 2
91
92# Don't start the applet in GNOME.
93#%patch1 -p1 -b .no-applet-in-gnome
94
95# Improvements for check-device-ids from upstream.
96%patch2 -p1 -b .check-device-ids
97
98# Fixed traceback in newprinter.py (bug #680683).
99%patch3 -p1 -b .self.printers
100
101%patch20 -p1 -b .gettext
102%patch21 -p1 -b .ppd-translation
103
104cp -f %{SOURCE10} po/ja.po
105
106%build
107%configure --with-udev-rules
108
109pushd pycups-%{pycups_version}
110make
111make doc
112popd
113
114pushd pysmbc-%{pysmbc_version}
115make
116make doc
117popd
118
119%install
120rm -rf %buildroot
121make DESTDIR=%buildroot install \
122     udevrulesdir=/lib/udev/rules.d \
123     udevhelperdir=/lib/udev
124
125pushd pycups-%{pycups_version}
126make DESTDIR=%buildroot install
127popd
128
129pushd pysmbc-%{pysmbc_version}
130make DESTDIR=%buildroot install
131popd
132
133%{__mkdir_p} %buildroot%{_localstatedir}/run/udev-configure-printer
134touch %buildroot%{_localstatedir}/run/udev-configure-printer/usb-uris
135
136%find_lang system-config-printer
137
138%clean
139rm -rf %buildroot
140
141%post
142/bin/rm -f /var/cache/foomatic/foomatic.pickle
143exit 0
144
145%files libs -f system-config-printer.lang
146%defattr(-,root,root,-)
147%doc --parents pycups-%{pycups_version}/{ChangeLog,README,NEWS,TODO,examples,html}
148%doc --parents pysmbc-%{pysmbc_version}/{ChangeLog,README,NEWS,TODO,test.py,html}
149%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.NewPrinterNotification.conf
150%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.PrinterDriversInstaller.conf
151%dir %{_sysconfdir}/cupshelpers
152%config(noreplace) %{_sysconfdir}/cupshelpers/preferreddrivers.xml
153%{python_sitearch}/cups.so
154%{python_sitearch}/smbc.so
155%{python_sitearch}/*.egg-info
156%dir %{python_sitelib}/cupshelpers
157%{python_sitelib}/cupshelpers/*.py*
158%{python_sitelib}/*.egg-info
159%{_rpmconfigdir}/fileattrs/psdriver.attr
160%{_rpmconfigdir}/postscriptdriver.prov
161
162%files udev
163%defattr(-,root,root,-)
164/lib/udev/rules.d/*.rules
165/lib/udev/udev-*-printer
166%dir %{_localstatedir}/run/udev-configure-printer
167%verify(not md5 size mtime) %config(noreplace,missingok) %attr(0644,root,root) %{_localstatedir}/run/udev-configure-printer/usb-uris
168
169%files
170%defattr(-,root,root,-)
171%doc ChangeLog README
172%{_bindir}/%{name}
173%{_bindir}/%{name}-applet
174%{_bindir}/scp-dbus-service
175%{_datadir}/dbus-1/interfaces/*.xml
176%{_datadir}/dbus-1/services/*.service
177%dir %{_datadir}/%{name}
178%{_datadir}/%{name}/*.py*
179%{_datadir}/%{name}/troubleshoot
180%{_datadir}/%{name}/icons
181%dir %{_datadir}/%{name}/xml
182%{_datadir}/%{name}/xml/*.rng
183%{_datadir}/%{name}/xml/*.py*
184%dir %{_datadir}/%{name}/ui
185%{_datadir}/%{name}/ui/*.glade
186%{_datadir}/applications/system-config-printer.desktop
187%{_sysconfdir}/xdg/autostart/print-applet.desktop
188%{_mandir}/man1/*
189
190%changelog
191* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
192- update patch21 and ja.po
193
194* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-2
195- add BuildRequires: glib2-devel
196
197* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-1
198- new upstream release
199  - system-config-printer-1.3.2
200  - pycups-1.9.55
201  - pysmbc-1.0.10
202- drop old patches (1,2,10)
203- add Patch2,3 from fedora
204  - Patch2: Improvements for check-device-ids from upstream.
205  - Patch3: Fixed traceback in newprinter.py (bug #680683).
206- update ja.po
207- Patch21: add more ppd translation dictionary
208- add BR: epydoc
209
210* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.92-1
211- new development release (pre1.2)
212  - system-config-printer-1.1.92
213  - pycups-1.9.48
214- add Patch1,2 from fedora
215  - Patch1: build without epydoc, remove BR: epydoc
216  - Patch2: Convert MFG and MDL to lowercase before D-Bus call
217    to work around bug #566217.
218- add BR: python-tools, libudev-devel, libusb-devel
219- add R: libxml2-python
220
221* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
222- rebuilt with python-2.6.4
223
224* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.7-1
225- new upstream release
226  - Updated translations.
227  - Don't abort if the jobviewer couldn't show a notification.
228  - Don't use setlocale() for locale-independent case conversion.
229  - Don't assume the notification daemon can show action buttons.
230  - Use case-insensitive matching for model names.
231  - HPLIP compatibility fixes.
232  - Fixed typo in jobviewer keyring support (Ubuntu #343156).
233  - Added support for https device URIs (bug #478677).
234  - Prevent traceback in monitor when connection failed (Ubuntu #343387).
235- add Patch10: fix infinite loop on adding printer
236- add Patch11: do not probe hplip
237
238* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
239- new upstream release
240  - system-config-printer 1.1.6
241  - pycups 1.9.45
242
243* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-1
244- initial build for Vine Linux
245
246* Tue Oct 21 2008 Tim Waugh <twaugh@redhat.com> 1.0.9-1
247- Updated to 1.0.9 for translations.
248- Updated pysmbc to 1.0.6.  No longer need pysmbc-git patch.
249
250* Fri Oct 17 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-7
251- Added patch for pysmbc changes in git to prevent getdents crashing
252  (bug #465975).
253
254* Thu Oct 16 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-6
255- Updated patch for 1.0.x changes:
256  - Fixed SMB authentication dialog's cancel button (bug #467127).
257  - Work around samba bug #5805 by sending debug output to stderr
258    instead of stdout.
259
260* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-5
261- Updated patch for 1.0.x changes:
262  - Fixed SMB authentication (bug #464003).
263
264* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-4
265- Updated patch for 1.0.x changes:
266  - Removed unneeded debugging output.
267  - Don't show the applet in KDE (bug #466945).
268  - Auth/error dialog improvements for SMB as for IPP (bug #465407).
269
270* Mon Oct 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-3
271- Added patch for 1.0.x changes since 1.0.8:
272  - Don't use a LinkButton for the 'Problems?' button (bug #465407).
273  - Don't use a separator for the server settings dialog (bug
274    #465407).
275  - Don't set non-zero page size for SpinButtons.
276  - Don't show an error dialog if an IPP operation's authentication
277    dialog is cancelled by the user, but show an error dialog if the
278    password was incorrect (bug #465407).
279  - Set Server Settings... menu entry sensitive depending on whether
280    we are connected to a server (Ubuntu #280736).
281  - Lots of translations updated.
282
283* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-2
284- Removed patch (no longer needed).
285
286* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-1
287- 1.0.8:
288  - Use modelName from custom PPD to suggest name for new printer
289    (trac #97).
290  - Avoid display problem with installable options.
291  - Better matching for Lexmark printers.
292  - Catch exceptions from advanced server settings dialog (Ubuntu
293    #267557).
294  - Added some missing OpenPrinting query fields.
295  - Jockey support added.
296  - Lots of translations updated.
297
298* Sat Aug 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-2
299- Handle IPP_FORBIDDEN (bug #460670).
300
301* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-1
302- 1.0.7:
303  - Efficiency improvements.
304  - Small UI improvements for the New Printer dialog.
305  - Other small fixes.
306
307* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com>
308- Updated pysmbc to 1.0.5.
309- Updated pycups to 1.9.42.
310
311* Tue Aug 26 2008 Tim Waugh <twaugh@redhat.com> 1.0.6-1
312- Requires gnome-python2-gnome (bug #460021).
313- 1.0.6:
314  - More delete-event fixes.
315  - Fixed temporary file leak.
316  - Fixed dialog leaks.
317  - Small UI improvements for the New Printer dialog.
318  - Other small fixes.
319
320* Thu Aug 14 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-3
321- Include other fixes from upstream including:
322  - OpenPrinting API change (trac #74).
323  - libnotify API change for 'closed' signal.
324  - Notification for job authentication (trac #91).
325  - Glade delete-event fixes (trac #88).
326  - Pre-fill username in job authentication dialog (trac #87).
327
328* Wed Aug 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-2
329- Handle HTTP_FORBIDDEN.
330
331* Mon Aug 11 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-1
332- 1.0.5.
333- Updated pycups to 1.9.41.
334
335* Thu Jul 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.4-1
336- 1.0.4.
337- Applied upstream patch for pycups to fix getPrinterAttributes when
338  requested_attributes is specified.
339
340* Tue Jul  8 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-2
341- Better debugging for pysmbc.
342
343* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-1
344- Updated pycups to 1.9.40.
345- 1.0.3.
346
347* Fri Jun 20 2008 Tim Waugh <twaugh@redhat.com>
348- Updated pysmbc to 1.0.4.
349
350* Tue Jun 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.2-1
351- 1.0.2.
352
353* Mon Jun  9 2008 Tim Waugh <twaugh@redhat.com> 1.0.1-1
354- Updated pysmbc to 1.0.3.
355- 1.0.1 (bug #450119).
356
357* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com>
358- Requires notify-python (bug #450139).
359
360* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-3
361- Applied patches from upstream (bug #450120).
362
363* Tue Jun  3 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-2
364- Applied patches from upstream (bug #449753).
365
366* Thu May 29 2008 Tim Waugh <twaugh@redhat.com>
367- Updated pycups to 1.9.39.
368- Updated libs summary.
369
370* Tue May 27 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-1
371- 1.0.0.
372
373* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
374- Fixed small UI problem in SMB browser.
375
376* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
377- 0.9.93.
378
379* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.92-1
380- 0.9.92.
381
382* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-3
383- Sync to trunk.
384- Updated pysmbc to 1.0.2.
385
386* Sun May 18 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-2
387- Fixed icon search path.
388
389* Fri May 16 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-1
390- No longer requires system-install-packages (bug #444645).
391- Added pysmbc.  Build requires libsmbclient-devel.
392- Don't install consolehelper bits any more as they are no longer needed.
393- 0.9.91:
394  - User interface overhaul, part 2.
395
396* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.9.90-1
397- Updated pycups to 1.9.38.
398- 0.9.90:
399  - User interface overhaul, part 1.
400
401* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.2-1
402- 0.7.82.2:
403  - Various bug fixes.
404  - Translation updates.
405
406* Mon Mar 17 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-3
407- Updated pycups to 1.9.37.
408- More fixes from upstream.
409
410* Wed Mar  5 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-2
411- Updated pycups to 1.9.36.
412- Some fixes from upstream.
413
414* Mon Mar  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-1
415- Requires /usr/bin/system-install-packages not pirut (bug #435622).
416- 0.7.82.1:
417  - More trouble-shooting improvements.
418  - applet: notify user about failed jobs (bug #168370).
419
420* Tue Feb 19 2008 Tim Waugh <twaugh@redhat.com> 0.7.82-1
421- Updated to pycups-1.9.35.
422- 0.7.82:
423  - More trouble-shooting improvements.
424
425* Wed Feb 13 2008 Tim Waugh <twaugh@redhat.com> 0.7.81-1
426- 0.7.81:
427  - Trouble-shooting improvements and other minor fixes.
428
429* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-2
430- Rebuild for GCC 4.3.
431
432* Mon Feb  4 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-1
433- Updated to pycups-1.9.34.
434- 0.7.80:
435  - Trouble-shooting support.
436
437* Fri Jan 25 2008 Tim Waugh <twaugh@redhat.com> 0.7.79-1
438- 0.7.79.
439
440* Wed Jan 23 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-5
441- Updated to pycups-1.9.33.
442
443* Wed Jan 16 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-4
444- Use config-util from new usermode (bug #428406).
445
446* Thu Dec 20 2007 Tim Waugh <twaugh@redhat.com>
447- Requires notification-daemon (Ubuntu #176929).
448- Requires gnome-python2 for theme support (Ubuntu #176929).
449- Requires gnome-icon-theme for printer icon (Ubuntu #176929).
450
451* Mon Dec 17 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-3
452- Install Python egg-info file.
453- Updated pycups to 1.9.32.
454
455* Tue Nov 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-2
456- pycups: Applied patch from SVN to allow fetching printer attributes by URI.
457- Sync to SVN 1748.
458
459* Thu Nov 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-1
460- pycups: Fix job-sheets-default attribute.
461- Updated pycups to 1.9.31.
462- 0.7.78.
463
464* Wed Nov 21 2007 Tim Waugh <twaugh@redhat.com>
465- Applied patch to pycups to avoid reading uninitialised
466  memory (bug #390431).
467
468* Mon Nov 19 2007 Tim Waugh <twaugh@redhat.com>
469- Updated pycups to 1.9.30.
470
471* Tue Oct 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.77-1
472- 0.7.77:
473  - Tooltips for the button bar buttons (bug #335601).
474
475* Mon Oct 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.76-1
476- 0.7.76.
477
478* Thu Oct  4 2007 Tim Waugh <twaugh@redhat.com> 0.7.75-1
479- 0.7.75.
480
481* Wed Oct  3 2007 Tim Waugh <twaugh@redhat.com>
482- No need to run update-desktop-database because there are no MimeKey
483  lines in the desktop files.
484- Consistent macro style.
485
486* Tue Oct  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.4-1
487- Changed PreReq to Requires.
488- Mark console.apps file as a config file.
489- Mark pam file as a config file (not replaceable).
490- No need to ship empty NEWS file.
491- Give cupsd.py executable permissions to satisfy rpmlint.
492- Provides system-config-printer-gui.
493- Mark D-Bus configuration file as a config file.
494- Fixed libs summary.
495- Better buildroot tag.
496- Better defattr.
497- Preserve timestamps on explicitly install files.
498- Make example pycups program non-executable.
499- 0.7.74.4:
500  - Updated translations.
501  - Several small bugs fixed.
502
503* Thu Sep 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.3-1
504- 0.7.74.3:
505  - Updated translations.
506  - Other small bug fixes.
507
508* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
509- Pull in SVN patch from stable branch for foomatic recommended
510  drivers (bug #292021).
511
512* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
513- Pull in SVN patch from stable branch for 'Allow printing from
514  the Internet' check-box (bug #221003).
515
516* Wed Sep 19 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-1
517- Updated pycups to 1.9.27.
518- 0.7.74.2:
519  - When a class is removed on the server, remove it from the UI.
520  - When deleting a printer, select the default printer again.
521  - Select newly-copied printer.
522  - Updated translation (fi).
523  - Better --help message.
524  - Use strcoll to sort manufacturer names.
525  - Avoid duplicate 'recommended' marks.
526  - Remove duplicate device URIs.
527  - Handle IPP_TAG_NOVALUE attributes (for CUPS 1.3.x).
528
529* Wed Sep 12 2007 Tim Waugh <twaugh@redhat.com>
530- Updated pycups to 1.9.26.
531- Build requires epydoc.  Ship HTML documentation.
532
533* Fri Sep  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.1-1
534- 0.7.74.1:
535  - Updated Polish translation (bug #263001).
536  - Don't select the default printer after changes to another printer have
537    been made.
538  - Always construct URI from input fields when changing device (bug #281551).
539  - Avoid busy-cursor traceback when window is not yet displayed.
540
541* Thu Aug 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.74-1
542- Updated pycups to 1.9.25.
543- 0.7.74:
544  - Fixed New Class dialog.
545  - UI fixes.
546
547* Sat Aug 25 2007 Tim Waugh <twaugh@redhat.com>
548- More specific license tag.
549
550* Fri Aug 24 2007 Tim Waugh <twaugh@redhat.com> 0.7.73-1
551- 0.7.73.
552
553* Fri Aug 10 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-2
554- Ship the applet's desktop file.
555
556* Wed Aug  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-1
557- 0.7.72:
558  - Fixed my-default-printer traceback.
559  - Improvements to New Printer wizard (Till Kamppeter).
560
561* Fri Aug  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.71-1
562- 0.7.71:
563  - Don't discard make/model-matched devices when there are ID-matched
564    devices (Till Kamppeter).
565  - Fixed fallback if no text-only driver is available (Till Kamppeter).
566  - Initialise the make/model list when an ID match failed (Till Kamppeter).
567  - Better error-handling in default-print application (Ubuntu #129901).
568  - UI tweak in admin tool (Ubuntu #128263).
569  - Handle socket: URIs (Ubuntu #127074).
570
571* Mon Jul 23 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-2
572- Obsoletes/provides desktop-printing.
573
574* Mon Jul  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-1
575- Requires pirut for system-install-packages.
576- 0.7.70:
577  - Increased GetReady->NewPrinter timeout.
578  - More binary names mapped to package named.
579  - Run system-install-packages to install missing drivers (bug #246726).
580  - Less debug output.
581  - Desktop file fixes for KDE (bug #247299).
582
583* Thu Jun 28 2007 Tim Waugh <twaugh@redhat.com> 0.7.69-1
584- No longer requires PyXML (bug #233146).
585- Moved applet to main package.
586- 0.7.69:
587  - Use HardwareSettings category for my-default-printer desktop
588    file (bug #244935).
589  - Removed unused code.
590  - Filter PPDs by natural language (bug #244173).
591
592* Mon Jun 25 2007 Tim Waugh <twaugh@redhat.com>
593- The applet requires dbus-x11 (Ubuntu #119570).
594
595* Fri Jun 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.68-1
596- 0.7.68:
597  - Fixed the notification bubbles.
598  - Ship my-default-printer utility.
599
600* Fri Jun  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.67-1
601- Don't put TrayIcon or SystemSetup categories in the desktop file.
602- Updated pycups to 1.9.24.
603- 0.7.67:
604  - Fixed desktop files to have capital letters at the start of each
605    word in the Name field (bug #242859).
606  - Fixed crash when saving unapplied changes.
607  - Fixed Device ID parser to always split the CMD field at commas.
608  - New PPDs class means we no longer parse the foomatic XML database.
609
610* Wed May 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.66-1
611- 0.7.66:
612  - Allow job-hold-until to be set (bug #239776).
613  - Implement new printer notifications.
614
615* Tue May 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.65-1
616- Build requires xmlto.
617- Updated to pycups-1.9.22.
618- 0.7.65:
619  - Use urllib for quoting/unquoting (Val Henson, Ubuntu #105022).
620  - Added kn translation.
621  - Better permissions on non-scripts.
622  - Added man pages.
623  - Applet: status feedback.
624  - Applet: fixed relative time descriptions.
625  - Applet: limit refresh frequency.
626
627* Mon Apr 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.63.1-1
628- 0.7.63.1:
629  - Small applet fixes.
630
631* Thu Apr  5 2007 Tim Waugh <twaugh@redhat.com> 0.7.63-1
632- 0.7.63:
633  - Translation updates.
634  - Checked in missing file.
635
636* Wed Apr  4 2007 Tim Waugh <twaugh@redhat.com>
637- Updated to pycups-1.9.20 for printer-state-reasons fix.
638
639* Mon Apr  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.62-1
640- 0.7.62:
641  - Use standard icon for admin tool desktop file.
642  - Fixed env path in Python scripts.
643  - Applet: stop running when the session ends.
644  - Prevent a traceback in the SMB browser (bug #225351).
645  - 'Manage print jobs' desktop file.
646
647* Fri Mar 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.61-1
648- 0.7.61:
649  - Fixed retrieval of SMB authentication details (bug #203539).
650
651* Tue Mar 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.60-1
652- Updated to pycups-1.9.19.
653- Avoid %%makeinstall.
654- 0.7.60:
655  - Handle reconnection failure.
656  - New applet name.
657
658* Mon Mar 26 2007 Tim Waugh <twaugh@redhat.com> 0.7.59-1
659- 0.7.59:
660  - Fixed a translatable string.
661  - Set a window icon (bug #233899).
662  - Handle failure to start the D-Bus service.
663  - Ellipsize the document and printer named (bug #233899).
664  - Removed the status bar (bug #233899).
665  - Added an icon pop-up menu for 'Hide' (bug #233899).
666
667* Wed Mar 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.57-1
668- Added URL tag.
669- 0.7.57:
670  - Prevent traceback when removing temporary file (Ubuntu #92914).
671  - Added print applet.
672
673* Sun Mar 18 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-2
674- Updated to pycups-1.9.18.
675
676* Fri Mar 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-1
677- 0.7.56:
678  - Parse Boolean strings correctly in job options.
679  - Small command-set list/string fix (bug #230665).
680  - Handle hostname look-up failures.
681  - Updated filter-to-driver map.
682  - Don't parse printers.conf (bug #231826).
683
684* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.55-1
685- 0.7.55:
686  - Use converted value for job option widgets.
687
688* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.54-1
689- 0.7.54:
690  - Removed debugging code.
691
692* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.53-1
693- No longer requires rhpl (since 0.7.53).
694- 0.7.53:
695  - Use gettext instead of rhpl.translate.
696  - Better layout for PPD options.
697  - Added scrollbars to main printer list (bug #229453).
698  - Set maximum width of default printer label (bug #229453).
699  - Handle applying changes correctly when switching to another
700    printer (bug #229378).
701  - Don't crash when failing to fetch the PPD (bug #229406).
702  - Make the text entry boxes sensitive but not editable for remote
703    printers (bug #229381).
704  - Better job options screen layout (bug #222272).
705
706* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 0.7.52-1
707- 0.7.52:
708  - Sort models using cups.modelSort before scanning for a close
709    match (bug #228505).
710  - Fixed matching logic (bug #228505).
711
712* Fri Feb  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.51-1
713- 0.7.51:
714  - Prevent display glitch in job options list when clicking on a printer
715    repeatedly.
716  - List conflicting PPD options, and embolden the relevant tab
717    labels (bug #226368).
718  - Fixed typo in 'set default' handling that caused a traceback (bug #227936).
719  - Handle interactive search a little better (bug #227935).
720
721* Wed Feb  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.50-1
722- 0.7.50:
723  - Fixed hex digits list (bug #223770).
724  - Added bs translation.
725  - Don't put the ellipsis in the real device URI (bug #227643).
726  - Don't check for existing drivers for complex command lines (bug #225104).
727  - Allow floating point job options (bug #224651).
728  - Prevent shared/published confusion (bug #225081).
729  - Fixed PPD page size setting.
730  - Avoid os.remove exception (bug #226703).
731  - Handle unknown job options (bug #225538).
732
733* Tue Jan 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.49-1
734- 0.7.49:
735  - Fixed a traceback in the driver check code.
736  - Fixed a typo in the conflicts message.
737  - Handle InputSlot/ManualFeed specially because libcups does (bug #222490).
738
739* Mon Jan 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.48-1
740- 0.7.48:
741  - Updated translations.
742
743* Fri Jan 12 2007 Tim Waugh <twaugh@redhat.com> 0.7.47-1
744- 0.7.47:
745  - Fixed minor text bugs (bug #177433).
746  - Handle shell builtins in the driver check (bug #222413).
747
748* Mon Jan  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.46-1
749- 0.7.46:
750  - Fixed page size problem (bug #221702).
751  - Added 'ro' to ALL_LINGUAS.
752
753* Wed Jan  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.45-1
754- Updated to pycups-1.9.17.
755- 0.7.45:
756  - Fixed traceback in driver check.
757
758* Tue Jan  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.44-1
759- 0.7.44:
760  - Fixed traceback in error display (bug #220136).
761  - Preserve case in model string when dumping debug output.
762
763* Thu Dec 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.43-1
764- 0.7.43:
765  - Don't check against IEEE 1284 DES field at all.
766  - Merged device matching code (bug #219518).
767  - Catch non-fatal errors when auto-matching device.
768  - Fixed driver checking bug involving pipelines (bug #220347).
769  - Show PPD errors (bug #220136).
770
771* Mon Dec 11 2006 Tim Waugh <twaugh@redhat.com> 0.7.42-1
772- 0.7.42:
773  - Fixed typo in command set matching code.
774  - Case-insensitive matching when Device ID not known to database.
775
776* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.7.41-2
777- build against python 2.5
778
779* Thu Dec  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.41-1
780- Updated pycups to 1.9.16.
781- 0.7.41:
782  - Reconnect smoothly after uploading new configuration.
783  - Update lpoptions when setting default printer if it conflicts with
784    the new setting (bug #217395).
785  - Fixed typo in show_HTTP_Error (bug #217537).
786  - Don't pre-select make and model when not discoverable for chosen
787    device (bug #217518).
788  - Set Forward button sensitive on Device screen in new-printer
789    dialog (bug #217515).
790  - Keep Server Settings selected after applying changes if it was selected
791    before.
792  - Set Connecting dialog transient for main window.
793  - Center Connecting dialog on parent.
794  - Optional 'reason' argument for cupshelpers.Printer.setEnabled.
795  - Describe devices that have no optional parameters.
796
797* Thu Nov 30 2006 Tim Waugh <twaugh@redhat.com>
798- Provide pycups feature.
799
800* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.40-1
801- 0.7.40:
802  - Removed username:password from hint string because we add that in
803    afterwards.
804  - Don't set button widths in create-printer dialog (bug #217025).
805
806* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.39-1
807- 0.7.39:
808  - Busy cursor while loading foomatic and PPD list (bug #215527).
809  - Make PPD NickName selectable.
810  - Added SMB hint label on device screen (bug #212759).
811
812* Tue Nov 14 2006 Tim Waugh <twaugh@redhat.com> 0.7.38-1
813- Updated pycups to 1.9.15.
814- 0.7.38:
815  - Fixed a bug in the 'ieee1284'/'ppd-device-id' parsing code.
816
817* Mon Nov 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.37-1
818- 0.7.37:
819  - Allow cancellation of test pages (bug #215054).
820
821* Fri Nov 10 2006 Tim Waugh <twaugh@redhat.com> 0.7.36-1
822- 0.7.36:
823  - Match against commandset (bug #214181).
824  - Parse 'ieee1284' foomatic autodetect entries (bug #214761).
825  - Don't remove foomatic PPDs from the list (bug #197331).
826
827* Tue Nov  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.35-1
828- 0.7.35.
829
830* Thu Nov  2 2006 Tim Waugh <twaugh@redhat.com>
831- Updated to pycups-1.9.14 (bug #213136).
832
833* Tue Oct 31 2006 Tim Waugh <twaugh@redhat.com>
834- Update desktop database (bug #213249).
835
836* Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com>
837- Build requires Python 2.4.
838
839* Mon Oct  2 2006 Tim Waugh <twaugh@redhat.com> 0.7.32-1
840- Updated to pycups-1.9.13 for HTTP_FORBIDDEN.
841- 0.7.32:
842  - Handle HTTP errors during connection (bug #208824).
843  - Updated translations (bug #208873).
844
845* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.31-1
846- 0.7.31:
847  - Select recommended driver automatically (bug #208606).
848  - Better visibility of driver list (bug #203907).
849
850* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.30-1
851- 0.7.30:
852  - Translations fixed properly (bug #206622).
853  - Button widths corrected (bug #208556).
854
855* Tue Sep 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.28-1
856- 0.7.28.  Translations fixed (bug #206622).
857
858* Wed Aug 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.27-1
859- Build requires intltool.
860- 0.7.27.
861
862* Wed Aug 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.26-1
863- 0.7.26.  Fixes bug # 203149.
864
865* Mon Aug 14 2006 Florian Festi <ffesti@redhat.com> 0.7.25-1
866- 0.7.25. (bug #202060)
867
868* Fri Aug 11 2006 Tim Waugh <twaugh@redhat.com>
869- Fixed description (bug #202189).
870
871* Thu Aug  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.24-1
872- 0.7.24.
873
874* Mon Jul 24 2006 Tim Waugh <twaugh@redhat.com> 0.7.23-1
875- 0.7.23.  Fixes bug #197866.
876
877* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.22-1.1
878- rebuild
879
880* Fri Jul  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.22-1
881- 0.7.22.
882
883* Wed Jul  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.21-1
884- Updated to pycups-1.9.12.
885- 0.7.21.
886
887* Mon Jul  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.20-1
888- 0.7.20.
889
890* Fri Jun 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.19-1
891- 0.7.19.
892- Remove foomatic pickle file post-install.
893
894* Tue Jun 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.18-1
895- 0.7.18.
896- Ship translations with libs subpackage.
897
898* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.17-1
899- 0.7.17.
900
901* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.16-1
902- 0.7.16, now with SMB browser.
903
904* Wed Jun 22 2006 Tim Waugh <twaugh@redhat.com> 0.7.15-1
905- 0.7.15.
906- Build requires gettext-devel.
907- Ship translations.
908
909* Tue Jun 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.14-1
910- 0.7.14.
911
912* Mon Jun 19 2006 Tim Waugh <twaugh@redhat.com> 0.7.13-1
913- 0.7.13.
914
915* Fri Jun  9 2006 Tim Waugh <twaugh@redhat.com> 0.7.12-1
916- 0.7.12.
917
918* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-3
919- Fix libs dependency.
920
921* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-2
922- Moved the gtk_html2pango module to the libs package (needed by
923  foomatic.py).
924
925* Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-1
926- Split out system-config-printer-libs.
927- Updated to system-config-printer-0.7.11.
928
929* Sat May 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-2
930- Requires gobject2 (bug #192764).
931
932* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-1
933- Require foomatic (bug #192764).
934- Updated to system-config-printer-0.7.10.
935
936* Thu May 25 2006 Tim Waugh <twaugh@redhat.com> 0.7.9-1
937- Updated to pycups-1.9.11.
938- Updated to system-config-printer-0.7.9.
939
940* Mon May 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.8-1
941- Updated to pycups-1.9.10.
942- Updated to system-config-printer-0.7.8.
943
944* Fri May  5 2006 Tim Waugh <twaugh@redhat.com>
945- Fix pycups segfault.
946
947* Fri May  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-2
948- Ship PAM and userhelper files.
949- Requires usermode.
950- Added missing options.py file.
951- Fix getClasses() in pycups.
952
953* Thu May  4 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-1
954- Updated to system-config-printer-0.7.7.
955- Updated to pycups-1.9.9.
956- Desktop file.
957- Requires PyXML.
958
959* Fri Apr 28 2006 Tim Waugh <twaugh@redhat.com>
960- Make it actually run.
961
962* Fri Apr 21 2006 Tim Waugh <twaugh@redhat.com>
963- Build requires CUPS 1.2.
964
965* Thu Apr 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.5-1
966- Updated to pycups-1.9.8.  No longer need threads patch.
967- Updated to system-config-printer-0.7.5.
968
969* Sat Apr 15 2006 Tim Waugh <twaugh@redhat.com>
970- Updated to pycups-1.9.7.
971
972* Thu Apr 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-2
973- Obsoletes: system-config-printer-gui <= 0.6.152
974
975* Wed Apr 12 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-1
976- Updated to system-config-printer-0.7.4.
977
978* Fri Apr  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.3-1
979- Added threads patch from pycups CVS.
980- Updated to system-config-printer-0.7.3.
981
982* Tue Apr  4 2006 Tim Waugh <twaugh@redhat.com>
983- Updated to pycups-1.9.6.
984
985* Fri Mar 24 2006 Tim Waugh <twaugh@redhat.com>
986- Updated to pycups-1.9.5.
987
988* Fri Mar 17 2006 Tim Waugh <twaugh@redhat.com>
989- Package the actual system-config-printer command.
990
991* Thu Mar 16 2006 Tim Waugh <twaugh@redhat.com> 0.7.1-1
992- Include s-c-printer tarball.
993- Updated to pycups-1.9.4.
994
995* Wed Mar 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.0-1
996- Initial spec file.
Note: See TracBrowser for help on using the repository browser.