source: projects/specs/trunk/s/system-config-printer/system-config-printer-vl.spec @ 5701

Revision 5701, 31.8 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define pycups_version 1.9.55
2%define pysmbc_version 1.0.10
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
6
7Summary: A printer administration tool
8Summary(ja): プリンタ管理ツール
9Name: system-config-printer
10Version: 1.3.2
11Release: 4%{?_dist_release}
12License: GPLv2+
13URL: http://cyberelk.net/tim/software/system-config-printer/
14Group: System Environment/Base
15
16Source0: http://cyberelk.net/tim/data/system-config-printer/1.3/system-config-printer-%{version}.tar.xz
17Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
18Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
19
20Source10: %{name}-1.3.2-ja.po
21
22#Patch1: system-config-printer-no-applet-in-gnome.patch
23Patch2: system-config-printer-check-device-ids.patch
24Patch3: system-config-printer-self.printers.patch
25
26Patch20: %{name}-1.3.2-gettext.patch
27Patch21: %{name}-1.3.2-ppd-translation.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30
31BuildRequires: cups-devel >= 1.2
32BuildRequires: glib2-devel
33BuildRequires: python-devel >= 2.5
34BuildRequires: libsmbclient-devel >= 3.2
35BuildRequires: desktop-file-utils >= 0.2.92
36BuildRequires: gettext
37BuildRequires: intltool
38BuildRequires: xmlto
39BuildRequires: python-tools
40BuildRequires: libusb-devel, libudev-devel
41BuildRequires: epydoc
42
43Requires: pygtk2
44Requires: pygobject
45Requires: desktop-file-utils
46Requires: dbus-x11
47Requires: system-config-printer-libs = %{version}-%{release}
48Requires: gnome-icon-theme
49Requires: gnome-python
50Requires: gnome-python-gnomekeyring
51Requires: notification-daemon
52Requires: notify-python
53Requires: libxml2-python
54
55Obsoletes: system-config-printer-gui <= 0.6.152
56Provides: system-config-printer-gui = 0.6.152
57
58Obsoletes: desktop-printing <= 0.20-7.fc7
59Provides: desktop-printing = 0.20-7.fc7
60
61%description
62system-config-printer is a graphical user interface that allows
63the user to configure a CUPS print server.
64
65%package libs
66Summary: Libraries and shared code for printer administration tool
67Summary(ja): Libraries and shared code for printer administration tool
68Group: System Environment/Base
69Requires: python
70Requires: foomatic
71Provides: pycups = %{pycups_version}
72Provides: pysmbc = %{pysmbc_version}
73
74%description libs
75The common code used by both the graphical and non-graphical parts of
76the configuration tool.
77
78%package udev
79Summary: Rules for udev for automatic configuration of USB printers
80Group: System Environment/Base
81Requires: system-config-printer-libs = %{version}-%{release}
82Obsoletes: hal-cups-utils <= 0.6.20
83Provides: hal-cups-utils = 0.6.20
84
85%description udev
86The udev rules and helper programs for automatically configuring USB
87printers.
88
89%prep
90%setup -q -a 1 -a 2
91
92# Don't start the applet in GNOME.
93#%patch1 -p1 -b .no-applet-in-gnome
94
95# Improvements for check-device-ids from upstream.
96%patch2 -p1 -b .check-device-ids
97
98# Fixed traceback in newprinter.py (bug #680683).
99%patch3 -p1 -b .self.printers
100
101%patch20 -p1 -b .gettext
102%patch21 -p1 -b .ppd-translation
103
104cp -f %{SOURCE10} po/ja.po
105
106%build
107%configure --with-udev-rules
108
109pushd pycups-%{pycups_version}
110make
111make doc
112popd
113
114pushd pysmbc-%{pysmbc_version}
115make
116make doc
117popd
118
119%install
120rm -rf %buildroot
121make DESTDIR=%buildroot install \
122     udevrulesdir=/lib/udev/rules.d \
123     udevhelperdir=/lib/udev
124
125pushd pycups-%{pycups_version}
126make DESTDIR=%buildroot install
127popd
128
129pushd pysmbc-%{pysmbc_version}
130make DESTDIR=%buildroot install
131popd
132
133%{__mkdir_p} %buildroot%{_localstatedir}/run/udev-configure-printer
134touch %buildroot%{_localstatedir}/run/udev-configure-printer/usb-uris
135
136%find_lang system-config-printer
137
138%clean
139rm -rf %buildroot
140
141%post
142/bin/rm -f /var/cache/foomatic/foomatic.pickle
143exit 0
144
145%files libs -f system-config-printer.lang
146%defattr(-,root,root,-)
147%doc --parents pycups-%{pycups_version}/{ChangeLog,README,NEWS,TODO,examples,html}
148%doc --parents pysmbc-%{pysmbc_version}/{ChangeLog,README,NEWS,TODO,test.py,html}
149%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.NewPrinterNotification.conf
150%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.PrinterDriversInstaller.conf
151%dir %{_sysconfdir}/cupshelpers
152%config(noreplace) %{_sysconfdir}/cupshelpers/preferreddrivers.xml
153%{python_sitearch}/cups.so
154%{python_sitearch}/smbc.so
155%{python_sitearch}/*.egg-info
156%dir %{python_sitelib}/cupshelpers
157%{python_sitelib}/cupshelpers/*.py*
158%{python_sitelib}/*.egg-info
159%{_rpmconfigdir}/fileattrs/psdriver.attr
160%{_rpmconfigdir}/postscriptdriver.prov
161
162%files udev
163%defattr(-,root,root,-)
164/lib/udev/rules.d/*.rules
165/lib/udev/udev-*-printer
166%dir %{_localstatedir}/run/udev-configure-printer
167%verify(not md5 size mtime) %config(noreplace,missingok) %attr(0644,root,root) %{_localstatedir}/run/udev-configure-printer/usb-uris
168
169%files
170%defattr(-,root,root,-)
171%doc ChangeLog README
172%{_bindir}/%{name}
173%{_bindir}/%{name}-applet
174%{_bindir}/scp-dbus-service
175%{_datadir}/dbus-1/interfaces/*.xml
176%{_datadir}/dbus-1/services/*.service
177%dir %{_datadir}/%{name}
178%{_datadir}/%{name}/*.py*
179%{_datadir}/%{name}/troubleshoot
180%{_datadir}/%{name}/icons
181%dir %{_datadir}/%{name}/xml
182%{_datadir}/%{name}/xml/*.rng
183%{_datadir}/%{name}/xml/*.py*
184%dir %{_datadir}/%{name}/ui
185%{_datadir}/%{name}/ui/*.glade
186%{_datadir}/applications/system-config-printer.desktop
187%{_sysconfdir}/xdg/autostart/print-applet.desktop
188%{_mandir}/man1/*
189
190%changelog
191* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-4
192- rebuild with python-2.7.2
193
194* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
195- update patch21 and ja.po
196
197* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-2
198- add BuildRequires: glib2-devel
199
200* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-1
201- new upstream release
202  - system-config-printer-1.3.2
203  - pycups-1.9.55
204  - pysmbc-1.0.10
205- drop old patches (1,2,10)
206- add Patch2,3 from fedora
207  - Patch2: Improvements for check-device-ids from upstream.
208  - Patch3: Fixed traceback in newprinter.py (bug #680683).
209- update ja.po
210- Patch21: add more ppd translation dictionary
211- add BR: epydoc
212
213* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.92-1
214- new development release (pre1.2)
215  - system-config-printer-1.1.92
216  - pycups-1.9.48
217- add Patch1,2 from fedora
218  - Patch1: build without epydoc, remove BR: epydoc
219  - Patch2: Convert MFG and MDL to lowercase before D-Bus call
220    to work around bug #566217.
221- add BR: python-tools, libudev-devel, libusb-devel
222- add R: libxml2-python
223
224* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
225- rebuilt with python-2.6.4
226
227* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.7-1
228- new upstream release
229  - Updated translations.
230  - Don't abort if the jobviewer couldn't show a notification.
231  - Don't use setlocale() for locale-independent case conversion.
232  - Don't assume the notification daemon can show action buttons.
233  - Use case-insensitive matching for model names.
234  - HPLIP compatibility fixes.
235  - Fixed typo in jobviewer keyring support (Ubuntu #343156).
236  - Added support for https device URIs (bug #478677).
237  - Prevent traceback in monitor when connection failed (Ubuntu #343387).
238- add Patch10: fix infinite loop on adding printer
239- add Patch11: do not probe hplip
240
241* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
242- new upstream release
243  - system-config-printer 1.1.6
244  - pycups 1.9.45
245
246* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-1
247- initial build for Vine Linux
248
249* Tue Oct 21 2008 Tim Waugh <twaugh@redhat.com> 1.0.9-1
250- Updated to 1.0.9 for translations.
251- Updated pysmbc to 1.0.6.  No longer need pysmbc-git patch.
252
253* Fri Oct 17 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-7
254- Added patch for pysmbc changes in git to prevent getdents crashing
255  (bug #465975).
256
257* Thu Oct 16 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-6
258- Updated patch for 1.0.x changes:
259  - Fixed SMB authentication dialog's cancel button (bug #467127).
260  - Work around samba bug #5805 by sending debug output to stderr
261    instead of stdout.
262
263* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-5
264- Updated patch for 1.0.x changes:
265  - Fixed SMB authentication (bug #464003).
266
267* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-4
268- Updated patch for 1.0.x changes:
269  - Removed unneeded debugging output.
270  - Don't show the applet in KDE (bug #466945).
271  - Auth/error dialog improvements for SMB as for IPP (bug #465407).
272
273* Mon Oct 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-3
274- Added patch for 1.0.x changes since 1.0.8:
275  - Don't use a LinkButton for the 'Problems?' button (bug #465407).
276  - Don't use a separator for the server settings dialog (bug
277    #465407).
278  - Don't set non-zero page size for SpinButtons.
279  - Don't show an error dialog if an IPP operation's authentication
280    dialog is cancelled by the user, but show an error dialog if the
281    password was incorrect (bug #465407).
282  - Set Server Settings... menu entry sensitive depending on whether
283    we are connected to a server (Ubuntu #280736).
284  - Lots of translations updated.
285
286* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-2
287- Removed patch (no longer needed).
288
289* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-1
290- 1.0.8:
291  - Use modelName from custom PPD to suggest name for new printer
292    (trac #97).
293  - Avoid display problem with installable options.
294  - Better matching for Lexmark printers.
295  - Catch exceptions from advanced server settings dialog (Ubuntu
296    #267557).
297  - Added some missing OpenPrinting query fields.
298  - Jockey support added.
299  - Lots of translations updated.
300
301* Sat Aug 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-2
302- Handle IPP_FORBIDDEN (bug #460670).
303
304* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-1
305- 1.0.7:
306  - Efficiency improvements.
307  - Small UI improvements for the New Printer dialog.
308  - Other small fixes.
309
310* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com>
311- Updated pysmbc to 1.0.5.
312- Updated pycups to 1.9.42.
313
314* Tue Aug 26 2008 Tim Waugh <twaugh@redhat.com> 1.0.6-1
315- Requires gnome-python2-gnome (bug #460021).
316- 1.0.6:
317  - More delete-event fixes.
318  - Fixed temporary file leak.
319  - Fixed dialog leaks.
320  - Small UI improvements for the New Printer dialog.
321  - Other small fixes.
322
323* Thu Aug 14 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-3
324- Include other fixes from upstream including:
325  - OpenPrinting API change (trac #74).
326  - libnotify API change for 'closed' signal.
327  - Notification for job authentication (trac #91).
328  - Glade delete-event fixes (trac #88).
329  - Pre-fill username in job authentication dialog (trac #87).
330
331* Wed Aug 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-2
332- Handle HTTP_FORBIDDEN.
333
334* Mon Aug 11 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-1
335- 1.0.5.
336- Updated pycups to 1.9.41.
337
338* Thu Jul 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.4-1
339- 1.0.4.
340- Applied upstream patch for pycups to fix getPrinterAttributes when
341  requested_attributes is specified.
342
343* Tue Jul  8 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-2
344- Better debugging for pysmbc.
345
346* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-1
347- Updated pycups to 1.9.40.
348- 1.0.3.
349
350* Fri Jun 20 2008 Tim Waugh <twaugh@redhat.com>
351- Updated pysmbc to 1.0.4.
352
353* Tue Jun 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.2-1
354- 1.0.2.
355
356* Mon Jun  9 2008 Tim Waugh <twaugh@redhat.com> 1.0.1-1
357- Updated pysmbc to 1.0.3.
358- 1.0.1 (bug #450119).
359
360* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com>
361- Requires notify-python (bug #450139).
362
363* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-3
364- Applied patches from upstream (bug #450120).
365
366* Tue Jun  3 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-2
367- Applied patches from upstream (bug #449753).
368
369* Thu May 29 2008 Tim Waugh <twaugh@redhat.com>
370- Updated pycups to 1.9.39.
371- Updated libs summary.
372
373* Tue May 27 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-1
374- 1.0.0.
375
376* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
377- Fixed small UI problem in SMB browser.
378
379* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
380- 0.9.93.
381
382* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.92-1
383- 0.9.92.
384
385* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-3
386- Sync to trunk.
387- Updated pysmbc to 1.0.2.
388
389* Sun May 18 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-2
390- Fixed icon search path.
391
392* Fri May 16 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-1
393- No longer requires system-install-packages (bug #444645).
394- Added pysmbc.  Build requires libsmbclient-devel.
395- Don't install consolehelper bits any more as they are no longer needed.
396- 0.9.91:
397  - User interface overhaul, part 2.
398
399* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.9.90-1
400- Updated pycups to 1.9.38.
401- 0.9.90:
402  - User interface overhaul, part 1.
403
404* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.2-1
405- 0.7.82.2:
406  - Various bug fixes.
407  - Translation updates.
408
409* Mon Mar 17 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-3
410- Updated pycups to 1.9.37.
411- More fixes from upstream.
412
413* Wed Mar  5 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-2
414- Updated pycups to 1.9.36.
415- Some fixes from upstream.
416
417* Mon Mar  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-1
418- Requires /usr/bin/system-install-packages not pirut (bug #435622).
419- 0.7.82.1:
420  - More trouble-shooting improvements.
421  - applet: notify user about failed jobs (bug #168370).
422
423* Tue Feb 19 2008 Tim Waugh <twaugh@redhat.com> 0.7.82-1
424- Updated to pycups-1.9.35.
425- 0.7.82:
426  - More trouble-shooting improvements.
427
428* Wed Feb 13 2008 Tim Waugh <twaugh@redhat.com> 0.7.81-1
429- 0.7.81:
430  - Trouble-shooting improvements and other minor fixes.
431
432* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-2
433- Rebuild for GCC 4.3.
434
435* Mon Feb  4 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-1
436- Updated to pycups-1.9.34.
437- 0.7.80:
438  - Trouble-shooting support.
439
440* Fri Jan 25 2008 Tim Waugh <twaugh@redhat.com> 0.7.79-1
441- 0.7.79.
442
443* Wed Jan 23 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-5
444- Updated to pycups-1.9.33.
445
446* Wed Jan 16 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-4
447- Use config-util from new usermode (bug #428406).
448
449* Thu Dec 20 2007 Tim Waugh <twaugh@redhat.com>
450- Requires notification-daemon (Ubuntu #176929).
451- Requires gnome-python2 for theme support (Ubuntu #176929).
452- Requires gnome-icon-theme for printer icon (Ubuntu #176929).
453
454* Mon Dec 17 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-3
455- Install Python egg-info file.
456- Updated pycups to 1.9.32.
457
458* Tue Nov 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-2
459- pycups: Applied patch from SVN to allow fetching printer attributes by URI.
460- Sync to SVN 1748.
461
462* Thu Nov 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-1
463- pycups: Fix job-sheets-default attribute.
464- Updated pycups to 1.9.31.
465- 0.7.78.
466
467* Wed Nov 21 2007 Tim Waugh <twaugh@redhat.com>
468- Applied patch to pycups to avoid reading uninitialised
469  memory (bug #390431).
470
471* Mon Nov 19 2007 Tim Waugh <twaugh@redhat.com>
472- Updated pycups to 1.9.30.
473
474* Tue Oct 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.77-1
475- 0.7.77:
476  - Tooltips for the button bar buttons (bug #335601).
477
478* Mon Oct 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.76-1
479- 0.7.76.
480
481* Thu Oct  4 2007 Tim Waugh <twaugh@redhat.com> 0.7.75-1
482- 0.7.75.
483
484* Wed Oct  3 2007 Tim Waugh <twaugh@redhat.com>
485- No need to run update-desktop-database because there are no MimeKey
486  lines in the desktop files.
487- Consistent macro style.
488
489* Tue Oct  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.4-1
490- Changed PreReq to Requires.
491- Mark console.apps file as a config file.
492- Mark pam file as a config file (not replaceable).
493- No need to ship empty NEWS file.
494- Give cupsd.py executable permissions to satisfy rpmlint.
495- Provides system-config-printer-gui.
496- Mark D-Bus configuration file as a config file.
497- Fixed libs summary.
498- Better buildroot tag.
499- Better defattr.
500- Preserve timestamps on explicitly install files.
501- Make example pycups program non-executable.
502- 0.7.74.4:
503  - Updated translations.
504  - Several small bugs fixed.
505
506* Thu Sep 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.3-1
507- 0.7.74.3:
508  - Updated translations.
509  - Other small bug fixes.
510
511* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
512- Pull in SVN patch from stable branch for foomatic recommended
513  drivers (bug #292021).
514
515* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
516- Pull in SVN patch from stable branch for 'Allow printing from
517  the Internet' check-box (bug #221003).
518
519* Wed Sep 19 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-1
520- Updated pycups to 1.9.27.
521- 0.7.74.2:
522  - When a class is removed on the server, remove it from the UI.
523  - When deleting a printer, select the default printer again.
524  - Select newly-copied printer.
525  - Updated translation (fi).
526  - Better --help message.
527  - Use strcoll to sort manufacturer names.
528  - Avoid duplicate 'recommended' marks.
529  - Remove duplicate device URIs.
530  - Handle IPP_TAG_NOVALUE attributes (for CUPS 1.3.x).
531
532* Wed Sep 12 2007 Tim Waugh <twaugh@redhat.com>
533- Updated pycups to 1.9.26.
534- Build requires epydoc.  Ship HTML documentation.
535
536* Fri Sep  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.1-1
537- 0.7.74.1:
538  - Updated Polish translation (bug #263001).
539  - Don't select the default printer after changes to another printer have
540    been made.
541  - Always construct URI from input fields when changing device (bug #281551).
542  - Avoid busy-cursor traceback when window is not yet displayed.
543
544* Thu Aug 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.74-1
545- Updated pycups to 1.9.25.
546- 0.7.74:
547  - Fixed New Class dialog.
548  - UI fixes.
549
550* Sat Aug 25 2007 Tim Waugh <twaugh@redhat.com>
551- More specific license tag.
552
553* Fri Aug 24 2007 Tim Waugh <twaugh@redhat.com> 0.7.73-1
554- 0.7.73.
555
556* Fri Aug 10 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-2
557- Ship the applet's desktop file.
558
559* Wed Aug  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-1
560- 0.7.72:
561  - Fixed my-default-printer traceback.
562  - Improvements to New Printer wizard (Till Kamppeter).
563
564* Fri Aug  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.71-1
565- 0.7.71:
566  - Don't discard make/model-matched devices when there are ID-matched
567    devices (Till Kamppeter).
568  - Fixed fallback if no text-only driver is available (Till Kamppeter).
569  - Initialise the make/model list when an ID match failed (Till Kamppeter).
570  - Better error-handling in default-print application (Ubuntu #129901).
571  - UI tweak in admin tool (Ubuntu #128263).
572  - Handle socket: URIs (Ubuntu #127074).
573
574* Mon Jul 23 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-2
575- Obsoletes/provides desktop-printing.
576
577* Mon Jul  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-1
578- Requires pirut for system-install-packages.
579- 0.7.70:
580  - Increased GetReady->NewPrinter timeout.
581  - More binary names mapped to package named.
582  - Run system-install-packages to install missing drivers (bug #246726).
583  - Less debug output.
584  - Desktop file fixes for KDE (bug #247299).
585
586* Thu Jun 28 2007 Tim Waugh <twaugh@redhat.com> 0.7.69-1
587- No longer requires PyXML (bug #233146).
588- Moved applet to main package.
589- 0.7.69:
590  - Use HardwareSettings category for my-default-printer desktop
591    file (bug #244935).
592  - Removed unused code.
593  - Filter PPDs by natural language (bug #244173).
594
595* Mon Jun 25 2007 Tim Waugh <twaugh@redhat.com>
596- The applet requires dbus-x11 (Ubuntu #119570).
597
598* Fri Jun 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.68-1
599- 0.7.68:
600  - Fixed the notification bubbles.
601  - Ship my-default-printer utility.
602
603* Fri Jun  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.67-1
604- Don't put TrayIcon or SystemSetup categories in the desktop file.
605- Updated pycups to 1.9.24.
606- 0.7.67:
607  - Fixed desktop files to have capital letters at the start of each
608    word in the Name field (bug #242859).
609  - Fixed crash when saving unapplied changes.
610  - Fixed Device ID parser to always split the CMD field at commas.
611  - New PPDs class means we no longer parse the foomatic XML database.
612
613* Wed May 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.66-1
614- 0.7.66:
615  - Allow job-hold-until to be set (bug #239776).
616  - Implement new printer notifications.
617
618* Tue May 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.65-1
619- Build requires xmlto.
620- Updated to pycups-1.9.22.
621- 0.7.65:
622  - Use urllib for quoting/unquoting (Val Henson, Ubuntu #105022).
623  - Added kn translation.
624  - Better permissions on non-scripts.
625  - Added man pages.
626  - Applet: status feedback.
627  - Applet: fixed relative time descriptions.
628  - Applet: limit refresh frequency.
629
630* Mon Apr 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.63.1-1
631- 0.7.63.1:
632  - Small applet fixes.
633
634* Thu Apr  5 2007 Tim Waugh <twaugh@redhat.com> 0.7.63-1
635- 0.7.63:
636  - Translation updates.
637  - Checked in missing file.
638
639* Wed Apr  4 2007 Tim Waugh <twaugh@redhat.com>
640- Updated to pycups-1.9.20 for printer-state-reasons fix.
641
642* Mon Apr  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.62-1
643- 0.7.62:
644  - Use standard icon for admin tool desktop file.
645  - Fixed env path in Python scripts.
646  - Applet: stop running when the session ends.
647  - Prevent a traceback in the SMB browser (bug #225351).
648  - 'Manage print jobs' desktop file.
649
650* Fri Mar 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.61-1
651- 0.7.61:
652  - Fixed retrieval of SMB authentication details (bug #203539).
653
654* Tue Mar 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.60-1
655- Updated to pycups-1.9.19.
656- Avoid %%makeinstall.
657- 0.7.60:
658  - Handle reconnection failure.
659  - New applet name.
660
661* Mon Mar 26 2007 Tim Waugh <twaugh@redhat.com> 0.7.59-1
662- 0.7.59:
663  - Fixed a translatable string.
664  - Set a window icon (bug #233899).
665  - Handle failure to start the D-Bus service.
666  - Ellipsize the document and printer named (bug #233899).
667  - Removed the status bar (bug #233899).
668  - Added an icon pop-up menu for 'Hide' (bug #233899).
669
670* Wed Mar 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.57-1
671- Added URL tag.
672- 0.7.57:
673  - Prevent traceback when removing temporary file (Ubuntu #92914).
674  - Added print applet.
675
676* Sun Mar 18 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-2
677- Updated to pycups-1.9.18.
678
679* Fri Mar 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-1
680- 0.7.56:
681  - Parse Boolean strings correctly in job options.
682  - Small command-set list/string fix (bug #230665).
683  - Handle hostname look-up failures.
684  - Updated filter-to-driver map.
685  - Don't parse printers.conf (bug #231826).
686
687* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.55-1
688- 0.7.55:
689  - Use converted value for job option widgets.
690
691* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.54-1
692- 0.7.54:
693  - Removed debugging code.
694
695* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.53-1
696- No longer requires rhpl (since 0.7.53).
697- 0.7.53:
698  - Use gettext instead of rhpl.translate.
699  - Better layout for PPD options.
700  - Added scrollbars to main printer list (bug #229453).
701  - Set maximum width of default printer label (bug #229453).
702  - Handle applying changes correctly when switching to another
703    printer (bug #229378).
704  - Don't crash when failing to fetch the PPD (bug #229406).
705  - Make the text entry boxes sensitive but not editable for remote
706    printers (bug #229381).
707  - Better job options screen layout (bug #222272).
708
709* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 0.7.52-1
710- 0.7.52:
711  - Sort models using cups.modelSort before scanning for a close
712    match (bug #228505).
713  - Fixed matching logic (bug #228505).
714
715* Fri Feb  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.51-1
716- 0.7.51:
717  - Prevent display glitch in job options list when clicking on a printer
718    repeatedly.
719  - List conflicting PPD options, and embolden the relevant tab
720    labels (bug #226368).
721  - Fixed typo in 'set default' handling that caused a traceback (bug #227936).
722  - Handle interactive search a little better (bug #227935).
723
724* Wed Feb  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.50-1
725- 0.7.50:
726  - Fixed hex digits list (bug #223770).
727  - Added bs translation.
728  - Don't put the ellipsis in the real device URI (bug #227643).
729  - Don't check for existing drivers for complex command lines (bug #225104).
730  - Allow floating point job options (bug #224651).
731  - Prevent shared/published confusion (bug #225081).
732  - Fixed PPD page size setting.
733  - Avoid os.remove exception (bug #226703).
734  - Handle unknown job options (bug #225538).
735
736* Tue Jan 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.49-1
737- 0.7.49:
738  - Fixed a traceback in the driver check code.
739  - Fixed a typo in the conflicts message.
740  - Handle InputSlot/ManualFeed specially because libcups does (bug #222490).
741
742* Mon Jan 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.48-1
743- 0.7.48:
744  - Updated translations.
745
746* Fri Jan 12 2007 Tim Waugh <twaugh@redhat.com> 0.7.47-1
747- 0.7.47:
748  - Fixed minor text bugs (bug #177433).
749  - Handle shell builtins in the driver check (bug #222413).
750
751* Mon Jan  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.46-1
752- 0.7.46:
753  - Fixed page size problem (bug #221702).
754  - Added 'ro' to ALL_LINGUAS.
755
756* Wed Jan  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.45-1
757- Updated to pycups-1.9.17.
758- 0.7.45:
759  - Fixed traceback in driver check.
760
761* Tue Jan  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.44-1
762- 0.7.44:
763  - Fixed traceback in error display (bug #220136).
764  - Preserve case in model string when dumping debug output.
765
766* Thu Dec 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.43-1
767- 0.7.43:
768  - Don't check against IEEE 1284 DES field at all.
769  - Merged device matching code (bug #219518).
770  - Catch non-fatal errors when auto-matching device.
771  - Fixed driver checking bug involving pipelines (bug #220347).
772  - Show PPD errors (bug #220136).
773
774* Mon Dec 11 2006 Tim Waugh <twaugh@redhat.com> 0.7.42-1
775- 0.7.42:
776  - Fixed typo in command set matching code.
777  - Case-insensitive matching when Device ID not known to database.
778
779* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.7.41-2
780- build against python 2.5
781
782* Thu Dec  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.41-1
783- Updated pycups to 1.9.16.
784- 0.7.41:
785  - Reconnect smoothly after uploading new configuration.
786  - Update lpoptions when setting default printer if it conflicts with
787    the new setting (bug #217395).
788  - Fixed typo in show_HTTP_Error (bug #217537).
789  - Don't pre-select make and model when not discoverable for chosen
790    device (bug #217518).
791  - Set Forward button sensitive on Device screen in new-printer
792    dialog (bug #217515).
793  - Keep Server Settings selected after applying changes if it was selected
794    before.
795  - Set Connecting dialog transient for main window.
796  - Center Connecting dialog on parent.
797  - Optional 'reason' argument for cupshelpers.Printer.setEnabled.
798  - Describe devices that have no optional parameters.
799
800* Thu Nov 30 2006 Tim Waugh <twaugh@redhat.com>
801- Provide pycups feature.
802
803* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.40-1
804- 0.7.40:
805  - Removed username:password from hint string because we add that in
806    afterwards.
807  - Don't set button widths in create-printer dialog (bug #217025).
808
809* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.39-1
810- 0.7.39:
811  - Busy cursor while loading foomatic and PPD list (bug #215527).
812  - Make PPD NickName selectable.
813  - Added SMB hint label on device screen (bug #212759).
814
815* Tue Nov 14 2006 Tim Waugh <twaugh@redhat.com> 0.7.38-1
816- Updated pycups to 1.9.15.
817- 0.7.38:
818  - Fixed a bug in the 'ieee1284'/'ppd-device-id' parsing code.
819
820* Mon Nov 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.37-1
821- 0.7.37:
822  - Allow cancellation of test pages (bug #215054).
823
824* Fri Nov 10 2006 Tim Waugh <twaugh@redhat.com> 0.7.36-1
825- 0.7.36:
826  - Match against commandset (bug #214181).
827  - Parse 'ieee1284' foomatic autodetect entries (bug #214761).
828  - Don't remove foomatic PPDs from the list (bug #197331).
829
830* Tue Nov  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.35-1
831- 0.7.35.
832
833* Thu Nov  2 2006 Tim Waugh <twaugh@redhat.com>
834- Updated to pycups-1.9.14 (bug #213136).
835
836* Tue Oct 31 2006 Tim Waugh <twaugh@redhat.com>
837- Update desktop database (bug #213249).
838
839* Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com>
840- Build requires Python 2.4.
841
842* Mon Oct  2 2006 Tim Waugh <twaugh@redhat.com> 0.7.32-1
843- Updated to pycups-1.9.13 for HTTP_FORBIDDEN.
844- 0.7.32:
845  - Handle HTTP errors during connection (bug #208824).
846  - Updated translations (bug #208873).
847
848* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.31-1
849- 0.7.31:
850  - Select recommended driver automatically (bug #208606).
851  - Better visibility of driver list (bug #203907).
852
853* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.30-1
854- 0.7.30:
855  - Translations fixed properly (bug #206622).
856  - Button widths corrected (bug #208556).
857
858* Tue Sep 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.28-1
859- 0.7.28.  Translations fixed (bug #206622).
860
861* Wed Aug 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.27-1
862- Build requires intltool.
863- 0.7.27.
864
865* Wed Aug 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.26-1
866- 0.7.26.  Fixes bug # 203149.
867
868* Mon Aug 14 2006 Florian Festi <ffesti@redhat.com> 0.7.25-1
869- 0.7.25. (bug #202060)
870
871* Fri Aug 11 2006 Tim Waugh <twaugh@redhat.com>
872- Fixed description (bug #202189).
873
874* Thu Aug  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.24-1
875- 0.7.24.
876
877* Mon Jul 24 2006 Tim Waugh <twaugh@redhat.com> 0.7.23-1
878- 0.7.23.  Fixes bug #197866.
879
880* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.22-1.1
881- rebuild
882
883* Fri Jul  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.22-1
884- 0.7.22.
885
886* Wed Jul  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.21-1
887- Updated to pycups-1.9.12.
888- 0.7.21.
889
890* Mon Jul  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.20-1
891- 0.7.20.
892
893* Fri Jun 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.19-1
894- 0.7.19.
895- Remove foomatic pickle file post-install.
896
897* Tue Jun 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.18-1
898- 0.7.18.
899- Ship translations with libs subpackage.
900
901* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.17-1
902- 0.7.17.
903
904* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.16-1
905- 0.7.16, now with SMB browser.
906
907* Wed Jun 22 2006 Tim Waugh <twaugh@redhat.com> 0.7.15-1
908- 0.7.15.
909- Build requires gettext-devel.
910- Ship translations.
911
912* Tue Jun 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.14-1
913- 0.7.14.
914
915* Mon Jun 19 2006 Tim Waugh <twaugh@redhat.com> 0.7.13-1
916- 0.7.13.
917
918* Fri Jun  9 2006 Tim Waugh <twaugh@redhat.com> 0.7.12-1
919- 0.7.12.
920
921* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-3
922- Fix libs dependency.
923
924* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-2
925- Moved the gtk_html2pango module to the libs package (needed by
926  foomatic.py).
927
928* Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-1
929- Split out system-config-printer-libs.
930- Updated to system-config-printer-0.7.11.
931
932* Sat May 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-2
933- Requires gobject2 (bug #192764).
934
935* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-1
936- Require foomatic (bug #192764).
937- Updated to system-config-printer-0.7.10.
938
939* Thu May 25 2006 Tim Waugh <twaugh@redhat.com> 0.7.9-1
940- Updated to pycups-1.9.11.
941- Updated to system-config-printer-0.7.9.
942
943* Mon May 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.8-1
944- Updated to pycups-1.9.10.
945- Updated to system-config-printer-0.7.8.
946
947* Fri May  5 2006 Tim Waugh <twaugh@redhat.com>
948- Fix pycups segfault.
949
950* Fri May  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-2
951- Ship PAM and userhelper files.
952- Requires usermode.
953- Added missing options.py file.
954- Fix getClasses() in pycups.
955
956* Thu May  4 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-1
957- Updated to system-config-printer-0.7.7.
958- Updated to pycups-1.9.9.
959- Desktop file.
960- Requires PyXML.
961
962* Fri Apr 28 2006 Tim Waugh <twaugh@redhat.com>
963- Make it actually run.
964
965* Fri Apr 21 2006 Tim Waugh <twaugh@redhat.com>
966- Build requires CUPS 1.2.
967
968* Thu Apr 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.5-1
969- Updated to pycups-1.9.8.  No longer need threads patch.
970- Updated to system-config-printer-0.7.5.
971
972* Sat Apr 15 2006 Tim Waugh <twaugh@redhat.com>
973- Updated to pycups-1.9.7.
974
975* Thu Apr 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-2
976- Obsoletes: system-config-printer-gui <= 0.6.152
977
978* Wed Apr 12 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-1
979- Updated to system-config-printer-0.7.4.
980
981* Fri Apr  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.3-1
982- Added threads patch from pycups CVS.
983- Updated to system-config-printer-0.7.3.
984
985* Tue Apr  4 2006 Tim Waugh <twaugh@redhat.com>
986- Updated to pycups-1.9.6.
987
988* Fri Mar 24 2006 Tim Waugh <twaugh@redhat.com>
989- Updated to pycups-1.9.5.
990
991* Fri Mar 17 2006 Tim Waugh <twaugh@redhat.com>
992- Package the actual system-config-printer command.
993
994* Thu Mar 16 2006 Tim Waugh <twaugh@redhat.com> 0.7.1-1
995- Include s-c-printer tarball.
996- Updated to pycups-1.9.4.
997
998* Wed Mar 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.0-1
999- Initial spec file.
Note: See TracBrowser for help on using the repository browser.